Re: [PATCH v3 1/9] media: rcar-vin: Rename 'digital' to 'parallel'

2018-05-24 Thread jacopo mondi
Hi Niklas,

On Thu, May 24, 2018 at 12:42:25AM +0200, Niklas Söderlund wrote:
> Hi Jacopo,
>
> Thanks for your patch.
>
> On 2018-05-18 16:40:37 +0200, Jacopo Mondi wrote:
> > As the term 'digital' is used all over the rcar-vin code in place of
> > 'parallel', rename all the occurrencies.
> >
> > Signed-off-by: Jacopo Mondi 
> > ---
> >  drivers/media/platform/rcar-vin/rcar-core.c | 72 
> > ++---
> >  drivers/media/platform/rcar-vin/rcar-dma.c  |  4 +-
> >  drivers/media/platform/rcar-vin/rcar-v4l2.c | 12 ++---
> >  drivers/media/platform/rcar-vin/rcar-vin.h  |  6 +--
> >  4 files changed, 47 insertions(+), 47 deletions(-)
> >
> > diff --git a/drivers/media/platform/rcar-vin/rcar-core.c 
> > b/drivers/media/platform/rcar-vin/rcar-core.c
> > index d3072e1..6b80f98 100644
> > --- a/drivers/media/platform/rcar-vin/rcar-core.c
> > +++ b/drivers/media/platform/rcar-vin/rcar-core.c
> > @@ -376,12 +376,12 @@ static int rvin_find_pad(struct v4l2_subdev *sd, int 
> > direction)
> >  }
> >
> >  /* 
> > -
> > - * Digital async notifier
> > + * Parallel async notifier
> >   */
> >
> >  /* The vin lock should be held when calling the subdevice attach and 
> > detach */
> > -static int rvin_digital_subdevice_attach(struct rvin_dev *vin,
> > -struct v4l2_subdev *subdev)
> > +static int rvin_parallel_subdevice_attach(struct rvin_dev *vin,
> > + struct v4l2_subdev *subdev)
> >  {
> > struct v4l2_subdev_mbus_code_enum code = {
> > .which = V4L2_SUBDEV_FORMAT_ACTIVE,
> > @@ -392,15 +392,15 @@ static int rvin_digital_subdevice_attach(struct 
> > rvin_dev *vin,
> > ret = rvin_find_pad(subdev, MEDIA_PAD_FL_SOURCE);
> > if (ret < 0)
> > return ret;
> > -   vin->digital->source_pad = ret;
> > +   vin->parallel->source_pad = ret;
> >
> > ret = rvin_find_pad(subdev, MEDIA_PAD_FL_SINK);
> > -   vin->digital->sink_pad = ret < 0 ? 0 : ret;
> > +   vin->parallel->sink_pad = ret < 0 ? 0 : ret;
> >
> > /* Find compatible subdevices mbus format */
> > vin->mbus_code = 0;
> > code.index = 0;
> > -   code.pad = vin->digital->source_pad;
> > +   code.pad = vin->parallel->source_pad;
> > while (!vin->mbus_code &&
> >!v4l2_subdev_call(subdev, pad, enum_mbus_code, NULL, )) {
> > code.index++;
> > @@ -450,21 +450,21 @@ static int rvin_digital_subdevice_attach(struct 
> > rvin_dev *vin,
> >
> > vin->vdev.ctrl_handler = >ctrl_handler;
> >
> > -   vin->digital->subdev = subdev;
> > +   vin->parallel->subdev = subdev;
> >
> > return 0;
> >  }
> >
> > -static void rvin_digital_subdevice_detach(struct rvin_dev *vin)
> > +static void rvin_parallel_subdevice_detach(struct rvin_dev *vin)
> >  {
> > rvin_v4l2_unregister(vin);
> > v4l2_ctrl_handler_free(>ctrl_handler);
> >
> > vin->vdev.ctrl_handler = NULL;
> > -   vin->digital->subdev = NULL;
> > +   vin->parallel->subdev = NULL;
> >  }
> >
> > -static int rvin_digital_notify_complete(struct v4l2_async_notifier 
> > *notifier)
> > +static int rvin_parallel_notify_complete(struct v4l2_async_notifier 
> > *notifier)
> >  {
> > struct rvin_dev *vin = notifier_to_vin(notifier);
> > int ret;
> > @@ -478,28 +478,28 @@ static int rvin_digital_notify_complete(struct 
> > v4l2_async_notifier *notifier)
> > return rvin_v4l2_register(vin);
> >  }
> >
> > -static void rvin_digital_notify_unbind(struct v4l2_async_notifier 
> > *notifier,
> > -  struct v4l2_subdev *subdev,
> > -  struct v4l2_async_subdev *asd)
> > +static void rvin_parallel_notify_unbind(struct v4l2_async_notifier 
> > *notifier,
> > +   struct v4l2_subdev *subdev,
> > +   struct v4l2_async_subdev *asd)
>
> When I run my indentation script this indentation changes from spaces to
> all tabs. If possible I would like to keep that as I usually run it on
> these files before submitting any patches, but it's not a big deal.

Oh I didn't notice that we now have exactly 8 spaces there.
I'll change this for sure!

Thanks
   j

>
> Whit this fixed, thanks for clearing this up!
>
> Acked-by: Niklas Söderlund 
>
> >  {
> > struct rvin_dev *vin = notifier_to_vin(notifier);
> >
> > -   vin_dbg(vin, "unbind digital subdev %s\n", subdev->name);
> > +   vin_dbg(vin, "unbind parallel subdev %s\n", subdev->name);
> >
> > mutex_lock(>lock);
> > -   rvin_digital_subdevice_detach(vin);
> > +   rvin_parallel_subdevice_detach(vin);
> > mutex_unlock(>lock);
> >  }
> >
> > -static int rvin_digital_notify_bound(struct v4l2_async_notifier *notifier,
> > -struct v4l2_subdev *subdev,
> > -struct v4l2_async_subdev *asd)
> > +static int 

Re: [PATCH v3 1/9] media: rcar-vin: Rename 'digital' to 'parallel'

2018-05-23 Thread Niklas Söderlund
Hi Jacopo,

Thanks for your patch.

On 2018-05-18 16:40:37 +0200, Jacopo Mondi wrote:
> As the term 'digital' is used all over the rcar-vin code in place of
> 'parallel', rename all the occurrencies.
> 
> Signed-off-by: Jacopo Mondi 
> ---
>  drivers/media/platform/rcar-vin/rcar-core.c | 72 
> ++---
>  drivers/media/platform/rcar-vin/rcar-dma.c  |  4 +-
>  drivers/media/platform/rcar-vin/rcar-v4l2.c | 12 ++---
>  drivers/media/platform/rcar-vin/rcar-vin.h  |  6 +--
>  4 files changed, 47 insertions(+), 47 deletions(-)
> 
> diff --git a/drivers/media/platform/rcar-vin/rcar-core.c 
> b/drivers/media/platform/rcar-vin/rcar-core.c
> index d3072e1..6b80f98 100644
> --- a/drivers/media/platform/rcar-vin/rcar-core.c
> +++ b/drivers/media/platform/rcar-vin/rcar-core.c
> @@ -376,12 +376,12 @@ static int rvin_find_pad(struct v4l2_subdev *sd, int 
> direction)
>  }
>  
>  /* 
> -
> - * Digital async notifier
> + * Parallel async notifier
>   */
>  
>  /* The vin lock should be held when calling the subdevice attach and detach 
> */
> -static int rvin_digital_subdevice_attach(struct rvin_dev *vin,
> -  struct v4l2_subdev *subdev)
> +static int rvin_parallel_subdevice_attach(struct rvin_dev *vin,
> +   struct v4l2_subdev *subdev)
>  {
>   struct v4l2_subdev_mbus_code_enum code = {
>   .which = V4L2_SUBDEV_FORMAT_ACTIVE,
> @@ -392,15 +392,15 @@ static int rvin_digital_subdevice_attach(struct 
> rvin_dev *vin,
>   ret = rvin_find_pad(subdev, MEDIA_PAD_FL_SOURCE);
>   if (ret < 0)
>   return ret;
> - vin->digital->source_pad = ret;
> + vin->parallel->source_pad = ret;
>  
>   ret = rvin_find_pad(subdev, MEDIA_PAD_FL_SINK);
> - vin->digital->sink_pad = ret < 0 ? 0 : ret;
> + vin->parallel->sink_pad = ret < 0 ? 0 : ret;
>  
>   /* Find compatible subdevices mbus format */
>   vin->mbus_code = 0;
>   code.index = 0;
> - code.pad = vin->digital->source_pad;
> + code.pad = vin->parallel->source_pad;
>   while (!vin->mbus_code &&
>  !v4l2_subdev_call(subdev, pad, enum_mbus_code, NULL, )) {
>   code.index++;
> @@ -450,21 +450,21 @@ static int rvin_digital_subdevice_attach(struct 
> rvin_dev *vin,
>  
>   vin->vdev.ctrl_handler = >ctrl_handler;
>  
> - vin->digital->subdev = subdev;
> + vin->parallel->subdev = subdev;
>  
>   return 0;
>  }
>  
> -static void rvin_digital_subdevice_detach(struct rvin_dev *vin)
> +static void rvin_parallel_subdevice_detach(struct rvin_dev *vin)
>  {
>   rvin_v4l2_unregister(vin);
>   v4l2_ctrl_handler_free(>ctrl_handler);
>  
>   vin->vdev.ctrl_handler = NULL;
> - vin->digital->subdev = NULL;
> + vin->parallel->subdev = NULL;
>  }
>  
> -static int rvin_digital_notify_complete(struct v4l2_async_notifier *notifier)
> +static int rvin_parallel_notify_complete(struct v4l2_async_notifier 
> *notifier)
>  {
>   struct rvin_dev *vin = notifier_to_vin(notifier);
>   int ret;
> @@ -478,28 +478,28 @@ static int rvin_digital_notify_complete(struct 
> v4l2_async_notifier *notifier)
>   return rvin_v4l2_register(vin);
>  }
>  
> -static void rvin_digital_notify_unbind(struct v4l2_async_notifier *notifier,
> -struct v4l2_subdev *subdev,
> -struct v4l2_async_subdev *asd)
> +static void rvin_parallel_notify_unbind(struct v4l2_async_notifier *notifier,
> + struct v4l2_subdev *subdev,
> + struct v4l2_async_subdev *asd)

When I run my indentation script this indentation changes from spaces to 
all tabs. If possible I would like to keep that as I usually run it on 
these files before submitting any patches, but it's not a big deal.

Whit this fixed, thanks for clearing this up!

Acked-by: Niklas Söderlund 

>  {
>   struct rvin_dev *vin = notifier_to_vin(notifier);
>  
> - vin_dbg(vin, "unbind digital subdev %s\n", subdev->name);
> + vin_dbg(vin, "unbind parallel subdev %s\n", subdev->name);
>  
>   mutex_lock(>lock);
> - rvin_digital_subdevice_detach(vin);
> + rvin_parallel_subdevice_detach(vin);
>   mutex_unlock(>lock);
>  }
>  
> -static int rvin_digital_notify_bound(struct v4l2_async_notifier *notifier,
> -  struct v4l2_subdev *subdev,
> -  struct v4l2_async_subdev *asd)
> +static int rvin_parallel_notify_bound(struct v4l2_async_notifier *notifier,
> +   struct v4l2_subdev *subdev,
> +   struct v4l2_async_subdev *asd)
>  {
>   struct rvin_dev *vin = notifier_to_vin(notifier);
>   int ret;
>  
>   mutex_lock(>lock);
> -