Re: pull-request: wireless-drivers-next 2017-08-07

2017-08-07 Thread David Miller
From: Kalle Valo 
Date: Mon, 07 Aug 2017 17:55:40 +0300

> here's the first pull request to net-next for 4.14, more info in the
> signed tag below. This time there's a simple conflict in iwlwifi but
> you can fix it just like Stephen did:
> 
> https://lkml.kernel.org/r/20170804120408.0d147...@canb.auug.org.au
> 
> Please let me know if you have any problems.

Pulled, thanks Kalle.


pull-request: wireless-drivers-next 2017-08-07

2017-08-07 Thread Kalle Valo
Hi Dave,

here's the first pull request to net-next for 4.14, more info in the
signed tag below. This time there's a simple conflict in iwlwifi but
you can fix it just like Stephen did:

https://lkml.kernel.org/r/20170804120408.0d147...@canb.auug.org.au

Please let me know if you have any problems.

Kalle

The following changes since commit 53d56f79a0b2e4bc5bbc04988e5bfde768db604f:

  Merge branch 'qed-next' (2017-07-27 00:05:23 -0700)

are available in the git repository at:

  git://git.kernel.org/pub/scm/linux/kernel/git/kvalo/wireless-drivers-next.git 
tags/wireless-drivers-next-for-davem-2017-08-07

for you to fetch changes up to 9d546198705a79630cb29b1cc47a43e75b8afb89:

  rtlwifi: Replace hardcode value with macro (2017-08-03 13:20:43 +0300)


wireless-drivers-next patches for 4.14

The first wireless-drivers-next pull request for 4.14. I'm submitting
this unusally late in the cycle as my vacation postponed this. But
even if this is late there's not still that much new features, mostly
cleanup or fixes.

Major changes:

ath10k

* preparation for wcn3990 support

iwlwifi

* Reorganization of the code into separate directories continues

qtnfmac

* regulatory support updates

* add get_channel, dump_survey and channel_switch cfg80211 handlers


Amitkumar Karwar (5):
  rsi: use BUILD_BUG_ON check for fsm_state
  rsi: correct the logic of deriving queue number
  rsi: use macro for allocating USB buffer
  rsi: check length before USB read/write register
  rsi: fix static checker warning

Arvind Yadav (9):
  brcmfmac: constify pci_device_id
  rtlwifi: rtl8192de: constify pci_device_id.
  rtlwifi: rtl8192se: constify pci_device_id.
  rtlwifi: rtl8821ae: constify pci_device_id.
  rtlwifi: rtl8723ae: constify pci_device_id.
  rtlwifi: rtl8723be: constify pci_device_id.
  rtlwifi: rtl8188ee: constify pci_device_id.
  rtlwifi: rtl8192ee: constify pci_device_id.
  net: qtnfmac: constify pci_device_id.

Brian Norris (21):
  mwifiex: correct channel stat buffer overflows
  mwifiex: reunite copy-and-pasted remove/reset code
  mwifiex: reset interrupt status across device reset
  mwifiex: pcie: don't allow cmd buffer reuse after reset
  mwifiex: re-register wiphy across reset
  mwifiex: unregister wiphy before freeing resources
  mwifiex: don't short-circuit netdev notifiers on interface deletion
  mwifiex: fixup init_channel_scan_gap error case
  mwifiex: ensure "disable auto DS" struct is initialized
  mwifiex: fix misnomers in mwifiex_free_lock_list()
  mwifiex: make mwifiex_free_cmd_buffer() return void
  mwifiex: utilize netif_tx_{wake,stop}_all_queues()
  mwifiex: don't open-code ARRAY_SIZE()
  mwifiex: drop 'add_tail' param from mwifiex_insert_cmd_to_pending_q()
  mwifiex: pcie: remove unnecessary masks
  mwifiex: pcie: unify MSI-X / non-MSI-X interrupt process
  mwifiex: debugfs: allow card_reset() to cancel things
  mwifiex: pcie: disable device DMA before unmapping/freeing buffers
  mwifiex: pcie: remove unnecessary 'pdev' check
  mwifiex: keep mwifiex_cancel_pending_ioctl() static
  mwifiex: drop num CPU notice

Colin Ian King (5):
  rtlwifi: kfree entry until after entry->bssid has been accessed
  mwifiex: usb: fix spelling mistake: "aggreataon"-> "aggregation"
  mwifiex: fix spelling mistake: "Insuffient" -> "Insufficient"
  zd1211rw: fix spelling mistake 'hybernate' -> 'hibernate'
  wl3501_cs: fix spelling mistake: "Insupported" -> "Unsupported"

Cong Wang (1):
  wl1251: add a missing spin_lock_init()

Dan Carpenter (2):
  mwifiex: usb: unlock on error in mwifiex_usb_tx_aggr_tmo()
  rtlwifi: rtl8821ae: Fix HW_VAR_NAV_UPPER operation

Dan Williams (1):
  ipw2100: don't return positive values to PCI probe on error

Emmanuel Grumbach (3):
  iwlwifi: mvm: fix the FIFO numbers in A000 devices
  iwlwifi: pcie: fix A-MSDU on gen2 devices
  iwlwifi: mvm: don't retake the pointer to skb's CB

Florian Fainelli (1):
  bcma: gpio: Correct number of GPIOs for BCM53573

Govind Singh (2):
  ath10k: make CE layer bus agnostic
  ath10k: add copy engine register MAP for wcn3990 target

Jeffy Chen (1):
  mwifiex: uninit wakeup info in the error handling

Johannes Berg (13):
  iwlwifi: refactor out paging code
  iwlwifi: refactor shared mem parsing
  iwlwifi: track current firmware image in common code
  iwlwifi: refactor firmware debug code
  iwlwifi: reorganize firmware API
  iwlwifi: fw api: fix various kernel-doc warnings
  iwlwifi: mvm: add and use iwl_mvm_has_unified_ucode()
  iwlwifi: mvm: check family instead of new TX API for workarounds
  iwlwifi: mvm: byte-swap constant instead of variable
  iwlwifi: pcie: rename iwl_trans_check_hw_rf_kill() to