Re: [PATCH V2 01/68] powerpc/cxl: Use REGION_ID instead of opencoding

2016-04-20 Thread Aneesh Kumar K.V
Michael Ellerman  writes:

> On Wed, 2016-04-13 at 08:12 +0530, Aneesh Kumar K.V wrote:
>> "Aneesh Kumar K.V"  writes:
>> > Also note that the `~` operation is wrong.
>> > 
>> > Cc: Frederic Barrat 
>> > Cc: Andrew Donnellan 
>> > Acked-by: Ian Munsie 
>> > Signed-off-by: Aneesh Kumar K.V 
>> > ---
>> >  drivers/misc/cxl/fault.c | 2 +-
>> >  1 file changed, 1 insertion(+), 1 deletion(-)
>> > 
>> > diff --git a/drivers/misc/cxl/fault.c b/drivers/misc/cxl/fault.c
>> > index 9a8650bcb042..9a236543da23 100644
>> > --- a/drivers/misc/cxl/fault.c
>> > +++ b/drivers/misc/cxl/fault.c
>> > @@ -152,7 +152,7 @@ static void cxl_handle_page_fault(struct cxl_context 
>> > *ctx,
>> >access = _PAGE_PRESENT;
>> >if (dsisr & CXL_PSL_DSISR_An_S)
>> >access |= _PAGE_RW;
>> > -  if ((!ctx->kernel) || ~(dar & (1ULL << 63)))
>> > +  if ((!ctx->kernel) || (REGION_ID(dar) == USER_REGION_ID))
>> >access |= _PAGE_USER;
>> > 
>> >if (dsisr & DSISR_NOHPTE)
>> 
>> Posted an updated version of this patch alone with improved commit
>> message here
>> 
>> http://mid.gmane.org/1460482475-20782-1-git-send-email-aneesh.ku...@linux.vnet.ibm.com
>
> I never saw it. And that link is empty?
>

Interesting . I will send this again.

-aneesh

___
Linuxppc-dev mailing list
Linuxppc-dev@lists.ozlabs.org
https://lists.ozlabs.org/listinfo/linuxppc-dev

Re: [PATCH V2 01/68] powerpc/cxl: Use REGION_ID instead of opencoding

2016-04-19 Thread Michael Ellerman
On Wed, 2016-04-13 at 08:12 +0530, Aneesh Kumar K.V wrote:
> "Aneesh Kumar K.V"  writes:
> > Also note that the `~` operation is wrong.
> > 
> > Cc: Frederic Barrat 
> > Cc: Andrew Donnellan 
> > Acked-by: Ian Munsie 
> > Signed-off-by: Aneesh Kumar K.V 
> > ---
> >  drivers/misc/cxl/fault.c | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> > 
> > diff --git a/drivers/misc/cxl/fault.c b/drivers/misc/cxl/fault.c
> > index 9a8650bcb042..9a236543da23 100644
> > --- a/drivers/misc/cxl/fault.c
> > +++ b/drivers/misc/cxl/fault.c
> > @@ -152,7 +152,7 @@ static void cxl_handle_page_fault(struct cxl_context 
> > *ctx,
> > access = _PAGE_PRESENT;
> > if (dsisr & CXL_PSL_DSISR_An_S)
> > access |= _PAGE_RW;
> > -   if ((!ctx->kernel) || ~(dar & (1ULL << 63)))
> > +   if ((!ctx->kernel) || (REGION_ID(dar) == USER_REGION_ID))
> > access |= _PAGE_USER;
> > 
> > if (dsisr & DSISR_NOHPTE)
> 
> Posted an updated version of this patch alone with improved commit
> message here
> 
> http://mid.gmane.org/1460482475-20782-1-git-send-email-aneesh.ku...@linux.vnet.ibm.com

I never saw it. And that link is empty?

cheers

___
Linuxppc-dev mailing list
Linuxppc-dev@lists.ozlabs.org
https://lists.ozlabs.org/listinfo/linuxppc-dev

Re: [PATCH V2 01/68] powerpc/cxl: Use REGION_ID instead of opencoding

2016-04-12 Thread Aneesh Kumar K.V
"Aneesh Kumar K.V"  writes:

> Also note that the `~` operation is wrong.
>
> Cc: Frederic Barrat 
> Cc: Andrew Donnellan 
> Acked-by: Ian Munsie 
> Signed-off-by: Aneesh Kumar K.V 
> ---
>  drivers/misc/cxl/fault.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/misc/cxl/fault.c b/drivers/misc/cxl/fault.c
> index 9a8650bcb042..9a236543da23 100644
> --- a/drivers/misc/cxl/fault.c
> +++ b/drivers/misc/cxl/fault.c
> @@ -152,7 +152,7 @@ static void cxl_handle_page_fault(struct cxl_context *ctx,
>   access = _PAGE_PRESENT;
>   if (dsisr & CXL_PSL_DSISR_An_S)
>   access |= _PAGE_RW;
> - if ((!ctx->kernel) || ~(dar & (1ULL << 63)))
> + if ((!ctx->kernel) || (REGION_ID(dar) == USER_REGION_ID))
>   access |= _PAGE_USER;
>
>   if (dsisr & DSISR_NOHPTE)
> -- 
> 2.5.0

Posted an updated version of this patch alone with improved commit
message here

http://mid.gmane.org/1460482475-20782-1-git-send-email-aneesh.ku...@linux.vnet.ibm.com

-aneesh

___
Linuxppc-dev mailing list
Linuxppc-dev@lists.ozlabs.org
https://lists.ozlabs.org/listinfo/linuxppc-dev

Re: [PATCH V2 01/68] powerpc/cxl: Use REGION_ID instead of opencoding

2016-04-10 Thread Andrew Donnellan

On 09/04/16 16:12, Aneesh Kumar K.V wrote:

Also note that the `~` operation is wrong.

Cc: Frederic Barrat 
Cc: Andrew Donnellan 
Acked-by: Ian Munsie 
Signed-off-by: Aneesh Kumar K.V 


Reviewed-by: Andrew Donnellan 

--
Andrew Donnellan  OzLabs, ADL Canberra
andrew.donnel...@au1.ibm.com  IBM Australia Limited

___
Linuxppc-dev mailing list
Linuxppc-dev@lists.ozlabs.org
https://lists.ozlabs.org/listinfo/linuxppc-dev

[PATCH V2 01/68] powerpc/cxl: Use REGION_ID instead of opencoding

2016-04-09 Thread Aneesh Kumar K.V
Also note that the `~` operation is wrong.

Cc: Frederic Barrat 
Cc: Andrew Donnellan 
Acked-by: Ian Munsie 
Signed-off-by: Aneesh Kumar K.V 
---
 drivers/misc/cxl/fault.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/misc/cxl/fault.c b/drivers/misc/cxl/fault.c
index 9a8650bcb042..9a236543da23 100644
--- a/drivers/misc/cxl/fault.c
+++ b/drivers/misc/cxl/fault.c
@@ -152,7 +152,7 @@ static void cxl_handle_page_fault(struct cxl_context *ctx,
access = _PAGE_PRESENT;
if (dsisr & CXL_PSL_DSISR_An_S)
access |= _PAGE_RW;
-   if ((!ctx->kernel) || ~(dar & (1ULL << 63)))
+   if ((!ctx->kernel) || (REGION_ID(dar) == USER_REGION_ID))
access |= _PAGE_USER;
 
if (dsisr & DSISR_NOHPTE)
-- 
2.5.0

___
Linuxppc-dev mailing list
Linuxppc-dev@lists.ozlabs.org
https://lists.ozlabs.org/listinfo/linuxppc-dev