Re: [Linuxwacom-devel] [PATCH] xsetwacom: Recognize 'AltGr' key as synonym for 'ISO_Level3_Shift'

2017-09-14 Thread Peter Hutterer
On Thu, Sep 14, 2017 at 07:38:39AM -0700, Jason Gerecke wrote:
> The table of keysyms does not include an obvious synonym for the "AltGr"
> key that is found on some international keyboard layouts. It seems that
> "ISO_Level3_Shift" is the magic name that should typically be used.
> 
> https://sourceforge.net/p/linuxwacom/bugs/344/
> 
> Signed-off-by: Jason Gerecke 

Reviewed-by: Peter Hutterer 

Cheers,
   Peter
> ---
>  tools/xsetwacom.c | 2 ++
>  1 file changed, 2 insertions(+)
> 
> diff --git a/tools/xsetwacom.c b/tools/xsetwacom.c
> index 834ebde..1051868 100644
> --- a/tools/xsetwacom.c
> +++ b/tools/xsetwacom.c
> @@ -581,6 +581,8 @@ static struct modifier modifiers[] = {
>   {"lhyper", "Hyper_L"},
>   {"rhyper", "Hyper_R"},
>  
> + {"altgr", "ISO_Level3_Shift"},
> +
>   { NULL, NULL }
>  };
>  
> -- 
> 2.14.1
> 

--
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
___
Linuxwacom-devel mailing list
Linuxwacom-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/linuxwacom-devel


Re: [Linuxwacom-devel] [PATCH] xsetwacom: Recognize 'AltGr' key as synonym for 'ISO_Level3_Shift'

2017-09-14 Thread Ping Cheng
On Thursday, September 14, 2017, Jason Gerecke  wrote:

> The table of keysyms does not include an obvious synonym for the "AltGr"
> key that is found on some international keyboard layouts. It seems that
> "ISO_Level3_Shift" is the magic name that should typically be used.
>
> https://sourceforge.net/p/linuxwacom/bugs/344/


> Signed-off-by: Jason Gerecke >


xsetwacom forces us to get familiar with international keys and ISO keysyms
;).

Reviewed-by: Ping Cheng 

Cheers,
Ping


> ---
>  tools/xsetwacom.c | 2 ++
>  1 file changed, 2 insertions(+)
>
> diff --git a/tools/xsetwacom.c b/tools/xsetwacom.c
> index 834ebde..1051868 100644
> --- a/tools/xsetwacom.c
> +++ b/tools/xsetwacom.c
> @@ -581,6 +581,8 @@ static struct modifier modifiers[] = {
> {"lhyper", "Hyper_L"},
> {"rhyper", "Hyper_R"},
>
> +   {"altgr", "ISO_Level3_Shift"},
> +
> { NULL, NULL }
>  };
>
> --
> 2.14.1
>
>
--
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot___
Linuxwacom-devel mailing list
Linuxwacom-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/linuxwacom-devel


Re: [Linuxwacom-devel] [PATCH input-wacom] Remove duplicated "Wacom" prefix from some devices

2017-09-14 Thread Jason Gerecke
Thanks. Pushed.


Jason
---
Now instead of four in the eights place /
you’ve got three, ‘Cause you added one  /
(That is to say, eight) to the two, /
But you can’t take seven from three,/
So you look at the sixty-fours


On Wed, Sep 13, 2017 at 9:59 PM, Peter Hutterer 
wrote:

> On Wed, Sep 13, 2017 at 08:05:11AM -0700, Jason Gerecke wrote:
> > Fixes: 38c795d ("backport: HID: wacom: Improve generic name generation")
> > Signed-off-by: Jason Gerecke 
>
> so simple, even I can add my
> Reviewed-by: Peter Hutterer  :)
>
> Cheers,
>Peter
>
> > ---
> >  2.6.30/wacom_wac.c | 2 +-
> >  2.6.38/wacom_wac.c | 4 ++--
> >  2 files changed, 3 insertions(+), 3 deletions(-)
> >
> > diff --git a/2.6.30/wacom_wac.c b/2.6.30/wacom_wac.c
> > index cab65cf..91b464e 100644
> > --- a/2.6.30/wacom_wac.c
> > +++ b/2.6.30/wacom_wac.c
> > @@ -2563,7 +2563,7 @@ static const struct wacom_features
> wacom_features_0x354 =
> >  static const struct wacom_features wacom_features_0x357 =
> >   { "Wacom Intuos Pro M", WACOM_PKGLEN_INTUOSP2, 44800, 29600, 8191,
> 63, INTUOSP2, 9 };
> >  static const struct wacom_features wacom_features_0x358 =
> > - { "Wacom Wacom Intuos Pro L", WACOM_PKGLEN_INTUOSP2, 62200, 43200,
> 8191, 63, INTUOSP2, 9 };
> > + { "Wacom Intuos Pro L", WACOM_PKGLEN_INTUOSP2, 62200, 43200, 8191,
> 63, INTUOSP2, 9 };
> >  static const struct wacom_features wacom_features_0x35A =
> >   { "Wacom DTH-1152", WACOM_PKGLEN_DTH1152, 22320, 12555, 1024,
> > 0, DTH1152, .oVid = USB_VENDOR_ID_WACOM, .oPid = 0x368 };
> > diff --git a/2.6.38/wacom_wac.c b/2.6.38/wacom_wac.c
> > index cf94c0f..46c1d4c 100644
> > --- a/2.6.38/wacom_wac.c
> > +++ b/2.6.38/wacom_wac.c
> > @@ -3244,10 +3244,10 @@ static const struct wacom_features
> wacom_features_0x354 =
> >   { "Wacom Cintiq Pro 16UHD Touch", WACOM_PKGLEN_MSPROT, .type =
> WACOM_MSPROT,
> > .oVid = USB_VENDOR_ID_WACOM, .oPid = 0x350 }; /* Touch */
> >  static const struct wacom_features wacom_features_0x357 =
> > - { "Wacom Wacom Intuos Pro M", WACOM_PKGLEN_INTUOSP2, 44800, 29600,
> 8191,
> > + { "Wacom Intuos Pro M", WACOM_PKGLEN_INTUOSP2, 44800, 29600, 8191,
> > 63, INTUOSP2, WACOM_INTUOS3_RES, WACOM_INTUOS3_RES, 9,
> .touch_max = 10 };
> >  static const struct wacom_features wacom_features_0x358 =
> > - { "Wacom Wacom Intuos Pro L", WACOM_PKGLEN_INTUOSP2, 62200, 43200,
> 8191,
> > + { "Wacom Intuos Pro L", WACOM_PKGLEN_INTUOSP2, 62200, 43200, 8191,
> > 63, INTUOSP2, WACOM_INTUOS3_RES, WACOM_INTUOS3_RES, 9,
> .touch_max = 10 };
> >  static const struct wacom_features wacom_features_0x35A =
> >   { "Wacom DTH-1152", WACOM_PKGLEN_DTH1152, 22320, 12555, 1024,
> > --
> > 2.14.1
>
--
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot___
Linuxwacom-devel mailing list
Linuxwacom-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/linuxwacom-devel


[Linuxwacom-devel] [PATCH] xsetwacom: Recognize 'AltGr' key as synonym for 'ISO_Level3_Shift'

2017-09-14 Thread Jason Gerecke
The table of keysyms does not include an obvious synonym for the "AltGr"
key that is found on some international keyboard layouts. It seems that
"ISO_Level3_Shift" is the magic name that should typically be used.

https://sourceforge.net/p/linuxwacom/bugs/344/

Signed-off-by: Jason Gerecke 
---
 tools/xsetwacom.c | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/tools/xsetwacom.c b/tools/xsetwacom.c
index 834ebde..1051868 100644
--- a/tools/xsetwacom.c
+++ b/tools/xsetwacom.c
@@ -581,6 +581,8 @@ static struct modifier modifiers[] = {
{"lhyper", "Hyper_L"},
{"rhyper", "Hyper_R"},
 
+   {"altgr", "ISO_Level3_Shift"},
+
{ NULL, NULL }
 };
 
-- 
2.14.1


--
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
___
Linuxwacom-devel mailing list
Linuxwacom-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/linuxwacom-devel