Aaron Schulz has uploaded a new change for review.

  https://gerrit.wikimedia.org/r/325516

Change subject: Remove broken apcu_set() calls
......................................................................

Remove broken apcu_set() calls

The method call was misnamed (bogus) and not needed anyway,
since the other BagOStuff classes fail if no key is present.

Change-Id: I726965e665c2d0c5843d8dd33504810d130b9e98
---
M includes/libs/objectcache/APCUBagOStuff.php
1 file changed, 2 insertions(+), 2 deletions(-)


  git pull ssh://gerrit.wikimedia.org:29418/mediawiki/core 
refs/changes/16/325516/1

diff --git a/includes/libs/objectcache/APCUBagOStuff.php 
b/includes/libs/objectcache/APCUBagOStuff.php
index 02b3c92..6e6a3ad 100644
--- a/includes/libs/objectcache/APCUBagOStuff.php
+++ b/includes/libs/objectcache/APCUBagOStuff.php
@@ -72,7 +72,7 @@
                if ( apcu_exists( $key . self::KEY_SUFFIX ) ) {
                        return apcu_inc( $key . self::KEY_SUFFIX, $value );
                } else {
-                       return apcu_set( $key . self::KEY_SUFFIX, $value );
+                       return false;
                }
        }
 
@@ -85,7 +85,7 @@
                if ( apcu_exists( $key . self::KEY_SUFFIX ) ) {
                        return apcu_dec( $key . self::KEY_SUFFIX, $value );
                } else {
-                       return apcu_set( $key . self::KEY_SUFFIX, -$value );
+                       return false;
                }
        }
 }

-- 
To view, visit https://gerrit.wikimedia.org/r/325516
To unsubscribe, visit https://gerrit.wikimedia.org/r/settings

Gerrit-MessageType: newchange
Gerrit-Change-Id: I726965e665c2d0c5843d8dd33504810d130b9e98
Gerrit-PatchSet: 1
Gerrit-Project: mediawiki/core
Gerrit-Branch: master
Gerrit-Owner: Aaron Schulz <asch...@wikimedia.org>

_______________________________________________
MediaWiki-commits mailing list
MediaWiki-commits@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/mediawiki-commits

Reply via email to