Re: [Mesa-dev] [PATCH 2/2] i965: Shorten the name of the workaround BO.

2018-02-27 Thread Kenneth Graunke
On Tuesday, February 27, 2018 2:04:36 AM PST Chris Wilson wrote:
> Quoting Kenneth Graunke (2018-02-26 23:55:00)
> > This makes the name shorter in debug printouts.  If "workaround_bo"
> > is good enough for the code, it's probably good enough for debugging.
> 
> brw->wa_bo and "w/a"? :)
> -Chris

Heh, that would be shorter :) "workaround" is already roughly the same
size as the name for most of our other buffers, and I was mostly trying
to make things fit in my %-15s format specifier.

I'll keep "workaround" as it's more descriptive.


signature.asc
Description: This is a digitally signed message part.
___
mesa-dev mailing list
mesa-dev@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/mesa-dev


Re: [Mesa-dev] [PATCH 2/2] i965: Shorten the name of the workaround BO.

2018-02-27 Thread Chris Wilson
Quoting Kenneth Graunke (2018-02-26 23:55:00)
> This makes the name shorter in debug printouts.  If "workaround_bo"
> is good enough for the code, it's probably good enough for debugging.

brw->wa_bo and "w/a"? :)
-Chris
___
mesa-dev mailing list
mesa-dev@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/mesa-dev


[Mesa-dev] [PATCH 2/2] i965: Shorten the name of the workaround BO.

2018-02-26 Thread Kenneth Graunke
This makes the name shorter in debug printouts.  If "workaround_bo"
is good enough for the code, it's probably good enough for debugging.
---
 src/mesa/drivers/dri/i965/brw_pipe_control.c | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

diff --git a/src/mesa/drivers/dri/i965/brw_pipe_control.c 
b/src/mesa/drivers/dri/i965/brw_pipe_control.c
index e5b3ffe640c..2350a6148f3 100644
--- a/src/mesa/drivers/dri/i965/brw_pipe_control.c
+++ b/src/mesa/drivers/dri/i965/brw_pipe_control.c
@@ -572,9 +572,7 @@ brw_init_pipe_control(struct brw_context *brw,
 * the gen6 workaround because it involves actually writing to
 * the buffer, and the kernel doesn't let us write to the batch.
 */
-   brw->workaround_bo = brw_bo_alloc(brw->bufmgr,
- "pipe_control workaround",
- 4096, 4096);
+   brw->workaround_bo = brw_bo_alloc(brw->bufmgr, "workaround", 4096, 4096);
if (brw->workaround_bo == NULL)
   return -ENOMEM;
 
-- 
2.16.1

___
mesa-dev mailing list
mesa-dev@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/mesa-dev