Re: Need suggestions for a module name

2011-06-18 Thread Bob Parker


-Original Message-
From: Robert Rothenberg r...@fastmail.net
Reply-To: Robert Rothenberg at CPAN r...@cpan.org
Date: Thu, 16 Jun 2011 21:23:50 +0100
To: Perl Module Authors List module-authors@perl.org
Subject: Need suggestions for a module name

While debugging a project that generated a lot of temporary files, I came
upon a nifty idea: rather than name the temporary files the usual random
strings, why not have the files named by the method/function that created
them, e.g. instead of something like /tmp/Hf6254d85.txt, why not call it
/tmp/Some_Package_Name/text_analysing_function-Hf6254d85.txt.

Anyhow, I think this might be something worth uploading to CPAN.

So what should it be called?

I was thinking of something like File::Temp::Smart, for lack of a better
name. But I am open to better ideas.

Suggestions?

Rob

Rob, rather than creating a brand new module for this, perhaps you could
work with Tim Jenness to add this functionality to the existing File::Temp
module as a non-default exported function and/or OO interface method? It
seems like it would be useful enough that it would be fairly common for
folks to use, once they realize what it is, so why make them install yet
another module (assuming he agrees, of course).

Obviously it could be done using the existing template functions, but to
do it automatically with an option to use directories or just the file
name would certainly save a lot of time  code rewriting, at least IMHO. I
know I've done it at least 3 or 4 times, as recently as 3 weeks ago.

Just a thought,

Bob




Re: Need suggestions for a module name

2011-06-18 Thread Robert Rothenberg
The module makes use of File::Temp, but the interface is different,
and I don't think it makes sense to add specialised high-level
functionality to a low-level module.


On Sat, Jun 18, 2011 at 4:42 PM, Bob Parker b...@perldevgeek.com wrote:


 -Original Message-
 From: Robert Rothenberg r...@fastmail.net
 Reply-To: Robert Rothenberg at CPAN r...@cpan.org
 Date: Thu, 16 Jun 2011 21:23:50 +0100
 To: Perl Module Authors List module-authors@perl.org
 Subject: Need suggestions for a module name

While debugging a project that generated a lot of temporary files, I came
upon a nifty idea: rather than name the temporary files the usual random
strings, why not have the files named by the method/function that created
them, e.g. instead of something like /tmp/Hf6254d85.txt, why not call it
/tmp/Some_Package_Name/text_analysing_function-Hf6254d85.txt.

Anyhow, I think this might be something worth uploading to CPAN.

So what should it be called?

I was thinking of something like File::Temp::Smart, for lack of a better
name. But I am open to better ideas.

Suggestions?

Rob

 Rob, rather than creating a brand new module for this, perhaps you could
 work with Tim Jenness to add this functionality to the existing File::Temp
 module as a non-default exported function and/or OO interface method? It
 seems like it would be useful enough that it would be fairly common for
 folks to use, once they realize what it is, so why make them install yet
 another module (assuming he agrees, of course).

 Obviously it could be done using the existing template functions, but to
 do it automatically with an option to use directories or just the file
 name would certainly save a lot of time  code rewriting, at least IMHO. I
 know I've done it at least 3 or 4 times, as recently as 3 weeks ago.

 Just a thought,

 Bob





Re: Need suggestions for a module name

2011-06-18 Thread Bill Ward
It's not really that high level or specialized. It's just a matter of
updating how the file name is generated. I could easily see it going either
way. If you do go with a separate module, the interface should be the same
(with whatever added options needed to add the new features) as File::Temp,
for reduced confusion.

On Sat, Jun 18, 2011 at 5:36 PM, Robert Rothenberg r...@cpan.org wrote:

 The module makes use of File::Temp, but the interface is different,
 and I don't think it makes sense to add specialised high-level
 functionality to a low-level module.


 On Sat, Jun 18, 2011 at 4:42 PM, Bob Parker b...@perldevgeek.com wrote:
 
 
  -Original Message-
  From: Robert Rothenberg r...@fastmail.net
  Reply-To: Robert Rothenberg at CPAN r...@cpan.org
  Date: Thu, 16 Jun 2011 21:23:50 +0100
  To: Perl Module Authors List module-authors@perl.org
  Subject: Need suggestions for a module name
 
 While debugging a project that generated a lot of temporary files, I came
 upon a nifty idea: rather than name the temporary files the usual random
 strings, why not have the files named by the method/function that created
 them, e.g. instead of something like /tmp/Hf6254d85.txt, why not call it
 /tmp/Some_Package_Name/text_analysing_function-Hf6254d85.txt.
 
 Anyhow, I think this might be something worth uploading to CPAN.
 
 So what should it be called?
 
 I was thinking of something like File::Temp::Smart, for lack of a better
 name. But I am open to better ideas.
 
 Suggestions?
 
 Rob
 
  Rob, rather than creating a brand new module for this, perhaps you could
  work with Tim Jenness to add this functionality to the existing
 File::Temp
  module as a non-default exported function and/or OO interface method? It
  seems like it would be useful enough that it would be fairly common for
  folks to use, once they realize what it is, so why make them install yet
  another module (assuming he agrees, of course).
 
  Obviously it could be done using the existing template functions, but to
  do it automatically with an option to use directories or just the file
  name would certainly save a lot of time  code rewriting, at least IMHO.
 I
  know I've done it at least 3 or 4 times, as recently as 3 weeks ago.
 
  Just a thought,
 
  Bob
 
 
 




-- 
Check out my LEGO blog at http://www.brickpile.com/
View my photos at http://flickr.com/photos/billward/
Follow me at http://twitter.com/williamward


Re: Need suggestions for a module name

2011-06-18 Thread Robert Rothenberg
It has a different interface, necessarily. File::Temp only manages single
temp files or directories in isolation, whereas my module manages a set of
them with logs about how they were created.
On 18 Jun 2011 23:44, Bill Ward b...@wards.net wrote:
 It's not really that high level or specialized. It's just a matter of
 updating how the file name is generated. I could easily see it going
either
 way. If you do go with a separate module, the interface should be the same
 (with whatever added options needed to add the new features) as
File::Temp,
 for reduced confusion.

 On Sat, Jun 18, 2011 at 5:36 PM, Robert Rothenberg r...@cpan.org wrote:

 The module makes use of File::Temp, but the interface is different,
 and I don't think it makes sense to add specialised high-level
 functionality to a low-level module.


 On Sat, Jun 18, 2011 at 4:42 PM, Bob Parker b...@perldevgeek.com wrote:
 
 
  -Original Message-
  From: Robert Rothenberg r...@fastmail.net
  Reply-To: Robert Rothenberg at CPAN r...@cpan.org
  Date: Thu, 16 Jun 2011 21:23:50 +0100
  To: Perl Module Authors List module-authors@perl.org
  Subject: Need suggestions for a module name
 
 While debugging a project that generated a lot of temporary files, I
came
 upon a nifty idea: rather than name the temporary files the usual
random
 strings, why not have the files named by the method/function that
created
 them, e.g. instead of something like /tmp/Hf6254d85.txt, why not call
it
 /tmp/Some_Package_Name/text_analysing_function-Hf6254d85.txt.
 
 Anyhow, I think this might be something worth uploading to CPAN.
 
 So what should it be called?
 
 I was thinking of something like File::Temp::Smart, for lack of a
better
 name. But I am open to better ideas.
 
 Suggestions?
 
 Rob
 
  Rob, rather than creating a brand new module for this, perhaps you
could
  work with Tim Jenness to add this functionality to the existing
 File::Temp
  module as a non-default exported function and/or OO interface method?
It
  seems like it would be useful enough that it would be fairly common for
  folks to use, once they realize what it is, so why make them install
yet
  another module (assuming he agrees, of course).
 
  Obviously it could be done using the existing template functions, but
to
  do it automatically with an option to use directories or just the file
  name would certainly save a lot of time  code rewriting, at least
IMHO.
 I
  know I've done it at least 3 or 4 times, as recently as 3 weeks ago.
 
  Just a thought,
 
  Bob
 
 
 




 --
 Check out my LEGO blog at http://www.brickpile.com/
 View my photos at http://flickr.com/photos/billward/
 Follow me at http://twitter.com/williamward


Re: Need suggestions for a module name

2011-06-18 Thread Bill Ward
Oh, I thought it was just about generating the filename using the
module/subroutine name. *that* should be in File::Temp, and maybe the other
features you describe should be in a new module?

On Sat, Jun 18, 2011 at 6:44 PM, Robert Rothenberg r...@cpan.org wrote:

 It has a different interface, necessarily. File::Temp only manages single
 temp files or directories in isolation, whereas my module manages a set of
 them with logs about how they were created.
 On 18 Jun 2011 23:44, Bill Ward b...@wards.net wrote:
  It's not really that high level or specialized. It's just a matter of
  updating how the file name is generated. I could easily see it going
 either
  way. If you do go with a separate module, the interface should be the
 same
  (with whatever added options needed to add the new features) as
 File::Temp,
  for reduced confusion.
 
  On Sat, Jun 18, 2011 at 5:36 PM, Robert Rothenberg r...@cpan.org
 wrote:
 
  The module makes use of File::Temp, but the interface is different,
  and I don't think it makes sense to add specialised high-level
  functionality to a low-level module.
 
 
  On Sat, Jun 18, 2011 at 4:42 PM, Bob Parker b...@perldevgeek.com
 wrote:
  
  
   -Original Message-
   From: Robert Rothenberg r...@fastmail.net
   Reply-To: Robert Rothenberg at CPAN r...@cpan.org
   Date: Thu, 16 Jun 2011 21:23:50 +0100
   To: Perl Module Authors List module-authors@perl.org
   Subject: Need suggestions for a module name
  
  While debugging a project that generated a lot of temporary files, I
 came
  upon a nifty idea: rather than name the temporary files the usual
 random
  strings, why not have the files named by the method/function that
 created
  them, e.g. instead of something like /tmp/Hf6254d85.txt, why not call
 it
  /tmp/Some_Package_Name/text_analysing_function-Hf6254d85.txt.
  
  Anyhow, I think this might be something worth uploading to CPAN.
  
  So what should it be called?
  
  I was thinking of something like File::Temp::Smart, for lack of a
 better
  name. But I am open to better ideas.
  
  Suggestions?
  
  Rob
  
   Rob, rather than creating a brand new module for this, perhaps you
 could
   work with Tim Jenness to add this functionality to the existing
  File::Temp
   module as a non-default exported function and/or OO interface method?
 It
   seems like it would be useful enough that it would be fairly common
 for
   folks to use, once they realize what it is, so why make them install
 yet
   another module (assuming he agrees, of course).
  
   Obviously it could be done using the existing template functions, but
 to
   do it automatically with an option to use directories or just the file
   name would certainly save a lot of time  code rewriting, at least
 IMHO.
  I
   know I've done it at least 3 or 4 times, as recently as 3 weeks ago.
  
   Just a thought,
  
   Bob
  
  
  
 
 
 
 
  --
  Check out my LEGO blog at http://www.brickpile.com/
  View my photos at http://flickr.com/photos/billward/
  Follow me at http://twitter.com/williamward




-- 
Check out my LEGO blog at http://www.brickpile.com/
View my photos at http://flickr.com/photos/billward/
Follow me at http://twitter.com/williamward


IO still maintained?

2011-06-18 Thread Lyle
IO, including IO:File, IO::Handle, etc, hasn't been updated since 2009. 
However the bug list is still growing. Are these modules no longer 
maintained? Are they no longer recommended?



Lyle