Re: [PATCH] mISDN: l1oip_core: replace _manual_ swap with swap macro

2017-11-05 Thread David Miller
From: "Gustavo A. R. Silva" 
Date: Fri, 3 Nov 2017 11:52:45 -0500

> Make use of the swap macro and remove unnecessary variables skb and cnt.
> This makes the code easier to read and maintain.
> 
> This code was detected with the help of Coccinelle.
> 
> Signed-off-by: Gustavo A. R. Silva 

Applied, thank you.


[PATCH] mISDN: l1oip_core: replace _manual_ swap with swap macro

2017-11-03 Thread Gustavo A. R. Silva
Make use of the swap macro and remove unnecessary variables skb and cnt.
This makes the code easier to read and maintain.

This code was detected with the help of Coccinelle.

Signed-off-by: Gustavo A. R. Silva 
---
 drivers/isdn/mISDN/l1oip_core.c | 10 ++
 1 file changed, 2 insertions(+), 8 deletions(-)

diff --git a/drivers/isdn/mISDN/l1oip_core.c b/drivers/isdn/mISDN/l1oip_core.c
index b5d590e..e365478 100644
--- a/drivers/isdn/mISDN/l1oip_core.c
+++ b/drivers/isdn/mISDN/l1oip_core.c
@@ -440,14 +440,8 @@ l1oip_socket_recv(struct l1oip *hc, u8 remotecodec, u8 
channel, u16 timebase,
 
 #ifdef REORDER_DEBUG
if (hc->chan[channel].disorder_flag) {
-   struct sk_buff *skb;
-   int cnt;
-   skb = hc->chan[channel].disorder_skb;
-   hc->chan[channel].disorder_skb = nskb;
-   nskb = skb;
-   cnt = hc->chan[channel].disorder_cnt;
-   hc->chan[channel].disorder_cnt = rx_counter;
-   rx_counter = cnt;
+   swap(hc->chan[channel].disorder_skb, nskb);
+   swap(hc->chan[channel].disorder_cnt, rx_counter);
}
hc->chan[channel].disorder_flag ^= 1;
if (nskb)
-- 
2.7.4