Re: [PATCH v4 03/11] net: mvmdio: use GENMASK for masks

2017-06-19 Thread David Miller
From: David Laight 
Date: Mon, 19 Jun 2017 11:57:51 +

> From: Antoine Tenart
>> Sent: 14 June 2017 16:49
>> Cosmetic patch to use the GENMASK helper for masks.
> ...
>> -ret = val & 0x;
>> +ret = val & GENMASK(15, 0);
> 
> My 2c: It isn't at all clear to me that changes like this in anyway
> improve the code readability.
> In some sense the '15' should be a named constant - but that just makes
> it even less obvious what is going on.

I agree, a hexidecimal mask of 0x is 100 times more readable and
understandable to me than "SOME_MACRO(x, y)".


RE: [PATCH v4 03/11] net: mvmdio: use GENMASK for masks

2017-06-19 Thread David Laight
From: Antoine Tenart
> Sent: 14 June 2017 16:49
> Cosmetic patch to use the GENMASK helper for masks.
...
> - ret = val & 0x;
> + ret = val & GENMASK(15, 0);

My 2c: It isn't at all clear to me that changes like this in anyway
improve the code readability.
In some sense the '15' should be a named constant - but that just makes
it even less obvious what is going on.

David