Re: [PATCH 3/5] ucc_geth: eliminate max-speed, change interface-type to phy-connection-type

2007-05-23 Thread Kumar Gala


On May 18, 2007, at 10:33 AM, Kim Phillips wrote:


On Fri, 18 May 2007 09:07:42 -0500
Kumar Gala [EMAIL PROTECTED] wrote:



On May 17, 2007, at 8:53 PM, Jeff Garzik wrote:


Kim Phillips wrote:

On Tue, 15 May 2007 17:45:19 -0400
Jeff Garzik [EMAIL PROTECTED] wrote:

Kim Phillips wrote:

It was agreed that phy-connection-type was a better name for
the interface-type property, so this patch renames it.

Also, the max-speed property name was determined too generic,
and is therefore eliminated in favour of phy-connection-type
derivation logic.

includes corrections to copyright text.

Signed-off-by: Kim Phillips [EMAIL PROTECTED]
---
 drivers/net/ucc_geth.c |   40 +++
+
 drivers/net/ucc_geth_mii.c |9 +
 drivers/net/ucc_geth_mii.h |   10 +-
 3 files changed, 26 insertions(+), 33 deletions(-)

applied to #upstream


just to be clear; only the mpc8323e-mds board works on your
current #upstream-{fixes,linus}.
The mpc8323e-rdb and mpc8360e-mds require
phylib: add the ICPlus IP175C PHY driver
and phylib: enable RGMII-ID on the Marvell m88e PHY
respectively in order to work.
I'm ok with the SGMII patches:
phylib: m88e: enable SGMII mode
gianfar: add support for SGMII
staying on #upstream, but 2 out of 3 boards are currently broken
for #upstream-{fixes,linus}.


New hardware support is always broken until merged.  Nonetheless
it is still new and outside the merge window.


I think new is a little relative here.  The MPC8232-RDB  MPC8360E-
MDS boards worked with 2.6.21 and the UCC. They had support for the
PHYs that Kim's listed built directly into the ucc driver and not as
part of the phy lib.  Since we've moved to using the phy lib in
2.6.22 we've broken these boards since their PHY drivers aren't
currently in linus's tree.

Kim, correct me if I'm wrong.



thanks for clarifying that - it is indeed the case.


Jeff, any comments?

While I can see the view that the ICPlus  m88e in RGMII may be  
new Kim did post these patches before the release of 2.6.21.


http://marc.info/?l=linux-netdevm=117624199831578w=2
http://marc.info/?l=linux-netdevm=117624199831578w=2

And I believe its our normal stance to not introduce regressions  
between kernel versions when possible.  It would be appreciated if  
you could push the two patches Kim has referenced to linus for 2.6.22  
otherwise we've created a regression in supporting the MPC8323 RDB   
MPC8360 MDS boards.


thanks

- k

-
To unsubscribe from this list: send the line unsubscribe netdev in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 3/5] ucc_geth: eliminate max-speed, change interface-type to phy-connection-type

2007-05-18 Thread Kumar Gala


On May 17, 2007, at 8:53 PM, Jeff Garzik wrote:


Kim Phillips wrote:

On Tue, 15 May 2007 17:45:19 -0400
Jeff Garzik [EMAIL PROTECTED] wrote:

Kim Phillips wrote:

It was agreed that phy-connection-type was a better name for
the interface-type property, so this patch renames it.

Also, the max-speed property name was determined too generic,
and is therefore eliminated in favour of phy-connection-type
derivation logic.

includes corrections to copyright text.

Signed-off-by: Kim Phillips [EMAIL PROTECTED]
---
 drivers/net/ucc_geth.c |   40 +++ 
+

 drivers/net/ucc_geth_mii.c |9 +
 drivers/net/ucc_geth_mii.h |   10 +-
 3 files changed, 26 insertions(+), 33 deletions(-)

applied to #upstream

just to be clear; only the mpc8323e-mds board works on your  
current #upstream-{fixes,linus}.

The mpc8323e-rdb and mpc8360e-mds require
phylib: add the ICPlus IP175C PHY driver
and phylib: enable RGMII-ID on the Marvell m88e PHY
respectively in order to work.
I'm ok with the SGMII patches:
phylib: m88e: enable SGMII mode
gianfar: add support for SGMII
staying on #upstream, but 2 out of 3 boards are currently broken  
for #upstream-{fixes,linus}.


New hardware support is always broken until merged.  Nonetheless  
it is still new and outside the merge window.


I think new is a little relative here.  The MPC8232-RDB  MPC8360E- 
MDS boards worked with 2.6.21 and the UCC. They had support for the  
PHYs that Kim's listed built directly into the ucc driver and not as  
part of the phy lib.  Since we've moved to using the phy lib in  
2.6.22 we've broken these boards since their PHY drivers aren't  
currently in linus's tree.


Kim, correct me if I'm wrong.

- k
-
To unsubscribe from this list: send the line unsubscribe netdev in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 3/5] ucc_geth: eliminate max-speed, change interface-type to phy-connection-type

2007-05-18 Thread Kim Phillips
On Fri, 18 May 2007 09:07:42 -0500
Kumar Gala [EMAIL PROTECTED] wrote:

 
 On May 17, 2007, at 8:53 PM, Jeff Garzik wrote:
 
  Kim Phillips wrote:
  On Tue, 15 May 2007 17:45:19 -0400
  Jeff Garzik [EMAIL PROTECTED] wrote:
  Kim Phillips wrote:
  It was agreed that phy-connection-type was a better name for
  the interface-type property, so this patch renames it.
 
  Also, the max-speed property name was determined too generic,
  and is therefore eliminated in favour of phy-connection-type
  derivation logic.
 
  includes corrections to copyright text.
 
  Signed-off-by: Kim Phillips [EMAIL PROTECTED]
  ---
   drivers/net/ucc_geth.c |   40 +++ 
  +
   drivers/net/ucc_geth_mii.c |9 +
   drivers/net/ucc_geth_mii.h |   10 +-
   3 files changed, 26 insertions(+), 33 deletions(-)
  applied to #upstream
 
  just to be clear; only the mpc8323e-mds board works on your  
  current #upstream-{fixes,linus}.
  The mpc8323e-rdb and mpc8360e-mds require
  phylib: add the ICPlus IP175C PHY driver
  and phylib: enable RGMII-ID on the Marvell m88e PHY
  respectively in order to work.
  I'm ok with the SGMII patches:
  phylib: m88e: enable SGMII mode
  gianfar: add support for SGMII
  staying on #upstream, but 2 out of 3 boards are currently broken  
  for #upstream-{fixes,linus}.
 
  New hardware support is always broken until merged.  Nonetheless  
  it is still new and outside the merge window.
 
 I think new is a little relative here.  The MPC8232-RDB  MPC8360E- 
 MDS boards worked with 2.6.21 and the UCC. They had support for the  
 PHYs that Kim's listed built directly into the ucc driver and not as  
 part of the phy lib.  Since we've moved to using the phy lib in  
 2.6.22 we've broken these boards since their PHY drivers aren't  
 currently in linus's tree.
 
 Kim, correct me if I'm wrong.
 

thanks for clarifying that - it is indeed the case.

Kim
-
To unsubscribe from this list: send the line unsubscribe netdev in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 3/5] ucc_geth: eliminate max-speed, change interface-type to phy-connection-type

2007-05-17 Thread Jeff Garzik

Kim Phillips wrote:

On Tue, 15 May 2007 17:45:19 -0400
Jeff Garzik [EMAIL PROTECTED] wrote:


Kim Phillips wrote:

It was agreed that phy-connection-type was a better name for
the interface-type property, so this patch renames it.

Also, the max-speed property name was determined too generic,
and is therefore eliminated in favour of phy-connection-type
derivation logic.

includes corrections to copyright text.

Signed-off-by: Kim Phillips [EMAIL PROTECTED]
---
 drivers/net/ucc_geth.c |   40 
 drivers/net/ucc_geth_mii.c |9 +
 drivers/net/ucc_geth_mii.h |   10 +-
 3 files changed, 26 insertions(+), 33 deletions(-)

applied to #upstream


just to be clear; only the mpc8323e-mds board works on your current 
#upstream-{fixes,linus}.

The mpc8323e-rdb and mpc8360e-mds require

phylib: add the ICPlus IP175C PHY driver

and 


phylib: enable RGMII-ID on the Marvell m88e PHY

respectively in order to work.

I'm ok with the SGMII patches:

phylib: m88e: enable SGMII mode
gianfar: add support for SGMII

staying on #upstream, but 2 out of 3 boards are currently broken for 
#upstream-{fixes,linus}.


New hardware support is always broken until merged.  Nonetheless it is 
still new and outside the merge window.


Jeff



-
To unsubscribe from this list: send the line unsubscribe netdev in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 3/5] ucc_geth: eliminate max-speed, change interface-type to phy-connection-type

2007-05-15 Thread Jeff Garzik

Kim Phillips wrote:

It was agreed that phy-connection-type was a better name for
the interface-type property, so this patch renames it.

Also, the max-speed property name was determined too generic,
and is therefore eliminated in favour of phy-connection-type
derivation logic.

includes corrections to copyright text.

Signed-off-by: Kim Phillips [EMAIL PROTECTED]
---
 drivers/net/ucc_geth.c |   40 
 drivers/net/ucc_geth_mii.c |9 +
 drivers/net/ucc_geth_mii.h |   10 +-
 3 files changed, 26 insertions(+), 33 deletions(-)


applied to #upstream


-
To unsubscribe from this list: send the line unsubscribe netdev in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html