Re: [PATCH net-2.6.25 0/4] Convert IP4 address class macros to inline functions

2007-11-20 Thread David Miller
From: Joe Perches [EMAIL PROTECTED]
Date: Mon, 19 Nov 2007 23:18:44 -0800

 On Tue, 2007-11-20 at 16:06 +0900, Simon Horman wrote:
  Also, as the function names are longer than the macro name
  you are creating lines that are  80 columns wide that used
  not to be in that state. For my eyes that reduced readability
  (substantially).
 
 David? You want a patch for that too?

These patches are just clumsy and awkward, this much I will
say.

BTW, these seemingly odd macro names come from BSD.
Terefore they are quite readable for many of us :-)

I don't know what to do with these patches, they feel like
just plain noise to me even though I like the type checking.

I'm going to defer for now, sorry.
-
To unsubscribe from this list: send the line unsubscribe netdev in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH net-2.6.25 0/4] Convert IP4 address class macros to inline functions

2007-11-19 Thread Simon Horman
On Mon, Nov 19, 2007 at 10:40:12PM -0800, Joe Perches wrote:
 Change LOOPBACK MULTICAST LOCAL_MCAST BADCLASS and ZERONET
 macros to inline functions ipv4_is_type(__be32 addr)
 
 Adds some type safety and arguably some readability
 
 No change in compiled image size
 
 Signed-off-by: Joe Perches [EMAIL PROTECTED]

I can understand the motivation for moving the functionality into
inline functions in order to get some type safety. But what is
the motivation for changing all the macro calls to function calls,
when you have set up the marcos to call the appropriate functions?
Surely if you want to do that you should just ditch the marcos all
together. Perhaps I am missing a patch?

Also, as the function names are longer than the macro name
you are creating lines that are  80 columns wide that used
not to be in that state. For my eyes that reduced readability
(substantially).

-- 
Horms

-
To unsubscribe from this list: send the line unsubscribe netdev in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH net-2.6.25 0/4] Convert IP4 address class macros to inline functions

2007-11-19 Thread Joe Perches
On Tue, 2007-11-20 at 16:06 +0900, Simon Horman wrote:
 On Mon, Nov 19, 2007 at 10:40:12PM -0800, Joe Perches wrote:
  Change LOOPBACK MULTICAST LOCAL_MCAST BADCLASS and ZERONET
  macros to inline functions ipv4_is_type(__be32 addr)
  Adds some type safety and arguably some readability
  No change in compiled image size
  Signed-off-by: Joe Perches [EMAIL PROTECTED]
 I can understand the motivation for moving the functionality into
 inline functions in order to get some type safety. But what is
 the motivation for changing all the macro calls to function calls,
 when you have set up the marcos to call the appropriate functions?

It's just a sequence that allows the kernel to compile.

I expect to remove the macros when the other callsites,
drivers/infiniband and drivers/parisc, are converted.

 Surely if you want to do that you should just ditch the marcos all
 together. Perhaps I am missing a patch?

That's what I'd like to do but in sequence.

David Miller can reasonably accept the net changes, but
I'm not too sure he can accept the drivers changes.

If/when this change is accepted and patches for drivers are
accepted, I'll submit a patch to remove the macros.

 Also, as the function names are longer than the macro name
 you are creating lines that are  80 columns wide that used
 not to be in that state. For my eyes that reduced readability
 (substantially).

David? You want a patch for that too?

-
To unsubscribe from this list: send the line unsubscribe netdev in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH net-2.6.25 0/4] Convert IP4 address class macros to inline functions

2007-11-19 Thread Simon Horman
On Mon, Nov 19, 2007 at 11:18:44PM -0800, Joe Perches wrote:
 On Tue, 2007-11-20 at 16:06 +0900, Simon Horman wrote:
  On Mon, Nov 19, 2007 at 10:40:12PM -0800, Joe Perches wrote:
   Change LOOPBACK MULTICAST LOCAL_MCAST BADCLASS and ZERONET
   macros to inline functions ipv4_is_type(__be32 addr)
   Adds some type safety and arguably some readability
   No change in compiled image size
   Signed-off-by: Joe Perches [EMAIL PROTECTED]
  I can understand the motivation for moving the functionality into
  inline functions in order to get some type safety. But what is
  the motivation for changing all the macro calls to function calls,
  when you have set up the marcos to call the appropriate functions?
 
 It's just a sequence that allows the kernel to compile.
 
 I expect to remove the macros when the other callsites,
 drivers/infiniband and drivers/parisc, are converted.
 
  Surely if you want to do that you should just ditch the marcos all
  together. Perhaps I am missing a patch?
 
 That's what I'd like to do but in sequence.
 
 David Miller can reasonably accept the net changes, but
 I'm not too sure he can accept the drivers changes.
 
 If/when this change is accepted and patches for drivers are
 accepted, I'll submit a patch to remove the macros.

Thanks for the clarification. I realised after I sent my
mail that you were probably having to cope with other callers.

  Also, as the function names are longer than the macro name
  you are creating lines that are  80 columns wide that used
  not to be in that state. For my eyes that reduced readability
  (substantially).
 
 David? You want a patch for that too?

-- 
Horms

-
To unsubscribe from this list: send the line unsubscribe netdev in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html