Re: [Nouveau] [PATCH 14/15] drm/amd: cleanup: drm_modeset_lock_all() --> DRM_MODESET_LOCK_ALL_BEGIN()

2021-09-18 Thread Fernando Ramos
On 21/09/18 01:17AM, Fernando Ramos wrote:

> > > +#include 
> > 
> > Top-level headers generally come above the driver headers. Also, now that I 
> > think
> > about this a bit more, all of the new includes in this set should probably 
> > be
> > for 'drm_modeset_lock.h' instead of 'drm_drv.h'.
> 
> Ok. Let me try that.

Turns out that the DRM_MODESET_LOCK_ALL_*() macros expansion includes a call
to drm_drv_uses_atomic_modeset() which is defined in "drm_drv.h".

Thus, #include'ing  cannot be avoided.

This makes me wonder...

  1. "drm_drv.h" includes "drm_device.h", which includes "drm_mode_config.h",
 which includes "drm_modeset_lock.h"

  2. "drm_modeset_lock.h" defines DRM_MODESET_LOCK_ALL_*() which expands into
 drm_drv_uses_atomic_modeset()

  3. drm_drv_uses_atomic_modeset() is declared in "drm_drv.h"

There seems to be a circular dependency here.

We can try to fix this, but I suggest to do it in a different patch series.



Re: [Nouveau] [PATCH 14/15] drm/amd: cleanup: drm_modeset_lock_all() --> DRM_MODESET_LOCK_ALL_BEGIN()

2021-09-18 Thread Fernando Ramos
> > +   struct drm_modeset_acquire_ctx ctx;
> > int r;
> > +   int ret;
> 
> Relocate ret with r please

Done!

> > -   drm_modeset_unlock_all(dev);
> > +   DRM_MODESET_LOCK_ALL_END(dev, ctx, ret);
> 
> You should check ret here

Done!


> > int r;
> > +   int ret;
> 
> Relocate ret with r

Done!


> > -   drm_modeset_unlock_all(dev);
> > +   DRM_MODESET_LOCK_ALL_END(dev, ctx, ret);
> >  
> > return 0;
> 
> Return ret

Done!


> > diff --git a/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c 
> > b/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c
> > index 9b1fc54555ee..5196c1d26f87 100644
> > @@ -2661,13 +2657,18 @@ static void handle_hpd_irq(void *param)
> >  
> > amdgpu_dm_update_connector_after_detect(aconnector);
> >  
> > -   drm_modeset_lock_all(dev);
> > -   dm_restore_drm_connector_state(dev, connector);
> > -   drm_modeset_unlock_all(dev);
> > -
> > -   if (aconnector->base.force == DRM_FORCE_UNSPECIFIED)
> > -   drm_kms_helper_hotplug_event(dev);
> > +   } else {
> > +   goto out;
> > }
> > +
> > +   DRM_MODESET_LOCK_ALL_BEGIN(dev, ctx, 0, ret);
> > +   dm_restore_drm_connector_state(dev, connector);
> > +   DRM_MODESET_LOCK_ALL_END(dev, ctx, ret);
> 
> Check ret here please

This function ("handle_hpd_irq") returns void. What would the appropriate way of
checking the error be?


> > @@ -2841,14 +2838,17 @@ static void handle_hpd_rx_irq(void *param)
> >  
> > amdgpu_dm_update_connector_after_detect(aconnector);
> >  
> > +   } else {
> > +   goto finish;
> 
> You used 'out' above and 'finish' here. It would be nice to be consistent with
> naming, I see 'out' a lot more than 'finish', so my vote would be to change 
> this
> label to 'out'.

I originally used "out", but turns out there is already an "out" label in this
function :)

I then searched for other "go to end" labels and found "finish" being used in 
this same file.

But I can rename it to somehitng else ("out2" maybe?) to make it less confusing.

 
> > +   }
> >  
> > -   drm_modeset_lock_all(dev);
> > -   dm_restore_drm_connector_state(dev, connector);
> > -   drm_modeset_unlock_all(dev);
> > +   DRM_MODESET_LOCK_ALL_BEGIN(dev, ctx, 0, ret);
> > +   dm_restore_drm_connector_state(dev, connector);
> > +   DRM_MODESET_LOCK_ALL_END(dev, ctx, ret);
> 
> Check ret here?

This is another irq-like function returning void.

What can we do here after having checked the error?


> > +#include 
> 
> Top-level headers generally come above the driver headers. Also, now that I 
> think
> about this a bit more, all of the new includes in this set should probably be
> for 'drm_modeset_lock.h' instead of 'drm_drv.h'.

Ok. Let me try that.


> > @@ -1259,13 +1257,16 @@ static ssize_t trigger_hotplug(struct file *f, 
> > const char __user *buf,
> > +   DRM_MODESET_LOCK_ALL_BEGIN(dev, ctx, 0, ret);
> > +   dm_restore_drm_connector_state(dev, connector);
> > +   DRM_MODESET_LOCK_ALL_END(dev, ctx, ret);
> 
> Check ret here?

This is a .write file_operations function expected to return a "size". Is it ok
for it to return an error? I guess so, right?



Re: [Nouveau] [PATCH 14/15] drm/amd: cleanup: drm_modeset_lock_all() --> DRM_MODESET_LOCK_ALL_BEGIN()

2021-09-17 Thread Sean Paul
On Thu, Sep 16, 2021 at 11:15:51PM +0200, Fernando Ramos wrote:
> As requested in Documentation/gpu/todo.rst, replace driver calls to
> drm_modeset_lock_all() with DRM_MODESET_LOCK_ALL_BEGIN() and
> DRM_MODESET_LOCK_ALL_END()
> 
> Signed-off-by: Fernando Ramos 
> ---
>  drivers/gpu/drm/amd/amdgpu/amdgpu_display.c   | 13 +++--
>  .../gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c | 50 +--
>  .../amd/display/amdgpu_dm/amdgpu_dm_debugfs.c | 23 +
>  3 files changed, 46 insertions(+), 40 deletions(-)
> 
> diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_display.c 
> b/drivers/gpu/drm/amd/amdgpu/amdgpu_display.c
> index 7a7316731911..55ecc4aa859f 100644
> --- a/drivers/gpu/drm/amd/amdgpu/amdgpu_display.c
> +++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_display.c
> @@ -40,6 +40,7 @@
>  #include 
>  #include 
>  #include 
> +#include 
>  
>  static void amdgpu_display_flip_callback(struct dma_fence *f,
>struct dma_fence_cb *cb)
> @@ -1543,16 +1544,18 @@ int amdgpu_display_suspend_helper(struct 
> amdgpu_device *adev)
>   struct drm_crtc *crtc;
>   struct drm_connector *connector;
>   struct drm_connector_list_iter iter;
> + struct drm_modeset_acquire_ctx ctx;
>   int r;
> + int ret;

Relocate ret with r please

>  
>   /* turn off display hw */
> - drm_modeset_lock_all(dev);
> + DRM_MODESET_LOCK_ALL_BEGIN(dev, ctx, 0, ret);
>   drm_connector_list_iter_begin(dev, );
>   drm_for_each_connector_iter(connector, )
>   drm_helper_connector_dpms(connector,
> DRM_MODE_DPMS_OFF);
>   drm_connector_list_iter_end();
> - drm_modeset_unlock_all(dev);
> + DRM_MODESET_LOCK_ALL_END(dev, ctx, ret);


You should check ret here

>   /* unpin the front buffers and cursors */
>   list_for_each_entry(crtc, >mode_config.crtc_list, head) {
>   struct amdgpu_crtc *amdgpu_crtc = to_amdgpu_crtc(crtc);
> @@ -1590,7 +1593,9 @@ int amdgpu_display_resume_helper(struct amdgpu_device 
> *adev)
>   struct drm_connector *connector;
>   struct drm_connector_list_iter iter;
>   struct drm_crtc *crtc;
> + struct drm_modeset_acquire_ctx ctx;
>   int r;
> + int ret;

Relocate ret with r

>  
>   /* pin cursors */
>   list_for_each_entry(crtc, >mode_config.crtc_list, head) {
> @@ -1612,7 +1617,7 @@ int amdgpu_display_resume_helper(struct amdgpu_device 
> *adev)
>   drm_helper_resume_force_mode(dev);
>  
>   /* turn on display hw */
> - drm_modeset_lock_all(dev);
> + DRM_MODESET_LOCK_ALL_BEGIN(dev, ctx, 0, ret);
>  
>   drm_connector_list_iter_begin(dev, );
>   drm_for_each_connector_iter(connector, )
> @@ -1620,7 +1625,7 @@ int amdgpu_display_resume_helper(struct amdgpu_device 
> *adev)
> DRM_MODE_DPMS_ON);
>   drm_connector_list_iter_end();
>  
> - drm_modeset_unlock_all(dev);
> + DRM_MODESET_LOCK_ALL_END(dev, ctx, ret);
>  
>   return 0;

Return ret

>  }
> diff --git a/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c 
> b/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c
> index 9b1fc54555ee..5196c1d26f87 100644
> --- a/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c
> +++ b/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c
> @@ -80,6 +80,7 @@
>  #include 
>  #include 
>  #include 
> +#include 
>  
>  #if defined(CONFIG_DRM_AMD_DC_DCN)
>  #include "ivsrcid/dcn/irqsrcs_dcn_1_0.h"
> @@ -2621,6 +2622,9 @@ static void handle_hpd_irq(void *param)
>  #ifdef CONFIG_DRM_AMD_DC_HDCP
>   struct dm_connector_state *dm_con_state = 
> to_dm_connector_state(connector->state);
>  #endif
> + struct drm_modeset_acquire_ctx ctx;
> + int ret;
> +
>  
>   if (adev->dm.disable_hpd_irq)
>   return;
> @@ -2646,14 +2650,6 @@ static void handle_hpd_irq(void *param)
>   if (aconnector->base.force && new_connection_type == 
> dc_connection_none) {
>   emulated_link_detect(aconnector->dc_link);
>  
> -
> - drm_modeset_lock_all(dev);
> - dm_restore_drm_connector_state(dev, connector);
> - drm_modeset_unlock_all(dev);
> -
> - if (aconnector->base.force == DRM_FORCE_UNSPECIFIED)
> - drm_kms_helper_hotplug_event(dev);
> -
>   } else if (dc_link_detect(aconnector->dc_link, DETECT_REASON_HPD)) {
>   if (new_connection_type == dc_connection_none &&
>   aconnector->dc_link->type == dc_connection_none)
> @@ -2661,13 +2657,18 @@ static void handle_hpd_irq(void *param)
>  
>   amdgpu_dm_update_connector_after_detect(aconnector);
>  
> - drm_modeset_lock_all(dev);
> - dm_restore_drm_connector_state(dev, connector);
> - drm_modeset_unlock_all(dev);
> -
> - if (aconnector->base.force == DRM_FORCE_UNSPECIFIED)
> - drm_kms_helper_hotplug_event(dev);
> + } else {
> + goto