Re: [gisi-notify-fix PATCH 2/4] gisi: simplify handling of pending

2011-01-18 Thread Pekka Pessi
Hi,

2011/1/18 Aki Niemi :
>> -void g_isi_pending_remove(GIsiPending *operation);
>> +void g_isi_pending_own(GIsiPending *op, gpointer owner);
>> +void g_isi_remove_all_my_pending(GIsiModem *modem, uint8_t resource,
>> +                                       gpointer owner);
>
> Overall, I like the idea.
>
> But how about naming these a bit better? Something like
> g_isi_pending_set_owner() and g_isi_pending_remove_by_owner()?

Sounds better. I'll do that, and I think I also leave the
g_isi_pending_remove() as an added bonus. Just in case.

-- 
Pekka.Pessi mail at nokia.com
___
ofono mailing list
ofono@ofono.org
http://lists.ofono.org/listinfo/ofono


Re: [gisi-notify-fix PATCH 2/4] gisi: simplify handling of pending

2011-01-18 Thread Aki Niemi
Hi Pekka,

2011/1/12  :
> diff --git a/gisi/modem.h b/gisi/modem.h
> index fff1338..91fe3d0 100644
> --- a/gisi/modem.h
> +++ b/gisi/modem.h
> @@ -109,7 +109,9 @@ int g_isi_response_vsend(GIsiModem *modem, const 
> GIsiMessage *req,
>
>  GIsiPending *g_isi_pending_from_msg(const GIsiMessage *msg);
>
> -void g_isi_pending_remove(GIsiPending *operation);
> +void g_isi_pending_own(GIsiPending *op, gpointer owner);
> +void g_isi_remove_all_my_pending(GIsiModem *modem, uint8_t resource,
> +                                       gpointer owner);

Overall, I like the idea.

But how about naming these a bit better? Something like
g_isi_pending_set_owner() and g_isi_pending_remove_by_owner()?

Cheers,
Aki
___
ofono mailing list
ofono@ofono.org
http://lists.ofono.org/listinfo/ofono