Re: [OpenWrt-Devel] [PATCH 3/6] bcm53xx: bcm_nand: add support for overriding partition probe through device tree

2015-05-18 Thread Rafał Miłecki
On 16 May 2015 at 12:53, Álvaro Fernández Rojas nolt...@gmail.com wrote:
 Signed-off-by: Álvaro Fernández Rojas nolt...@gmail.com

So I'll give a nack to this one too. The feature you proposed is
really nice, but should be implemented as some generic solution, see
Hauke's recent patch:
https://patchwork.ozlabs.org/patch/473208/
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] [PATCH 4/6] bcm53xx: bcm47xxpart: add support for parsing device tree partitions

2015-05-18 Thread Rafał Miłecki
On 16 May 2015 at 15:28, Rafał Miłecki zaj...@gmail.com wrote:
 On 16 May 2015 at 13:53, Álvaro Fernández Rojas nolt...@gmail.com wrote:
 This patch splits firmware partition based on TRX header, while ofpart won't 
 be able to split firmware partition into kernel (linux) + rootfs.
 It's very similar to bcm63xx code, where bcmtag contains the information 
 needed to split linux partition into kernel + rootfs.

 Let me think about this, but I guess it's not the way we want to
 handle it. We probably should use TRX MTD splitter.

OK, let me share my thoughts. There is a chain of problems ;) but we
can handle it with a bit of time.

It seems the main reason for you hacking bcm47xxpart is its support
for creating firmware partition subpartitions. This is not a way to
go. We should allow any driver (bcm47xxpart, ofpart) to just create
firmware and then have separated splitter handling firmware
partition.

There already is a driver for that, see MTD_SPLIT_TRX_FW.
Unfortunately, we can't enable it for bcm53xx as it will conflict with
bcm47xxpart.

So we should drop support for TRX parsing from bcm47xxpart and then
enable MTD_SPLIT_TRX_FW. Unfortunately bcm47xxpart is already
upstreamed (and I want to use upstream version). There is no reason to
drop TRX parting from bcm47xpart mainline, since MTD_SPLIT_TRX_FW
exists in OpenWrt only.

So we should add MTD_SPLIT_TRX_FW to the mainline kernel.
Unfortunately this also isn't possible, because mainline kernel
doesn't support mtdsplit.

So there is a good news. I've just sent patch to linux-mtd ML adding
support for splitting parsers:
https://patchwork.ozlabs.org/patch/473363/

Once we got my patch accepted we can work on every step from the above
chain one by one.

-- 
Rafał
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] [PATCH 4/6] bcm53xx: bcm47xxpart: add support for parsing device tree partitions

2015-05-18 Thread Rafał Miłecki
On 16 May 2015 at 12:53, Álvaro Fernández Rojas nolt...@gmail.com wrote:
 Signed-off-by: Álvaro Fernández Rojas nolt...@gmail.com

After discussion in this topic, I'll give a nack to this patch. We
should use different approach and we should probably focus on mainline
Broadcom NAND driver.

-- 
Rafał
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] [PATCH 5/6] bcm53xx: add ASUS RT-AC87U partitions

2015-05-18 Thread Rafał Miłecki
On 16 May 2015 at 12:53, Álvaro Fernández Rojas nolt...@gmail.com wrote:
 Signed-off-by: Álvaro Fernández Rojas nolt...@gmail.com

With the previous patches nacked/rejected, it doesn't make sense to
apply this one.

I've commited workaround for RT-AC87U just to make it usable with the
upcoming CC release, see:
https://dev.openwrt.org/changeset/45694/

For the long term development we should focus on:
1) Mainline parsers splitters
2) Broadcom's NAND mainlined driver
3) Upstreaming TRX parser
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] How to track IO usage of internal flash mtd partitions?

2015-05-18 Thread valent.turko...@gmail.com
Looks like iostat only tracks block devices so I can see change for
usb flash device but no change for internal flash partitions :(

# iostat
Linux 3.10.49 (Demo36_Muc (Base9)) 05/18/15 _mips_ (1 CPU)

avg-cpu:  %user   %nice %system %iowait  %steal   %idle
   5.340.001.470.000.00   93.19

Device:tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn
mtdblock0 0.00 0.00 0.00208  0
mtdblock1 0.00 0.00 0.00208  0
mtdblock2 0.00 0.00 0.00208  0
mtdblock3 0.00 0.00 0.00208  0
mtdblock4 0.00 0.04 0.00  12240  0
mtdblock5 0.00 0.00 0.00208  0
mtdblock6 0.00 0.00 0.00208  0
mmcblk0   0.02 0.03 0.21   9786  69721


Any ideas?

On 18 May 2015 at 11:45, José Vázquez ppvazquez...@gmail.com wrote:
 Try iostat (selectable in busybox). Maybe is what are you looking for.

 2015-05-17 0:40 GMT+02:00, valent.turko...@gmail.com
 valent.turko...@gmail.com:
 Here is some interesting info I found using mtdinfo tool:

 # mtdinfo /dev/mtd5
 mtd5
 Name:   rootfs_data
 Type:   nor
 Eraseblock size:65536 bytes, 64.0 KiB
 Amount of eraseblocks:  104 (6815744 bytes, 6.5 MiB)
 Minimum input/output unit size: 1 byte
 Sub-page size:  1 byte
 Character device major/minor:   90:10
 Bad blocks are allowed: false
 Device is writable: true

 So I see there are 104 eraseblocks on this partition. Interesting so
 see finaly some numbers. Now how to see how many times these
 eraseblock were issued erase eraseblock command?
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] [BB 14.07] No automatic buildbot anymore ???

2015-05-18 Thread Hannu Nyman
To my knowledge theer has never been automatic building for the relase 
branches. Developers have selectively built core packages (like openssl) 
after security updates, but otherwise the updated package sources have been 
compiled only for the .1 maintenance releases (like 10.03.1). But so far 
there has been no .1 release BB14.07. (and most likely none will be ever 
released, as the CC15.05 release will get the focus)


People building private BB14.07 builds do get the updates, naturally.


On 17.5.2015 15:51, Christian Schoenebeck wrote:

Hi,
I fixed some LuCI language files about 3 weeks ago, but downloads.openwrt.org 
is still on 29.09.2014.
Are there no updates build for BB 14.07 ?
Christian


___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] [PATCH] [PATCH] wpa-supplicant: add 802.11r client support

2015-05-18 Thread Stefan Hellermann
Add 802.11r client support to wpa_supplicant. It's only enabled in
wpa_supplicant-full. hostapd gained 802.11r support in commit r45051.

Tested on a TP-Link TL-WR710N sta psk client with two 802.11r enabled
openwrt accesspoints (TP-Link TL-WDR3600).

Signed-off-by: Stefan Hellermann ste...@the2masters.de
---
 package/network/services/hostapd/files/netifd.sh  | 7 ++-
 package/network/services/hostapd/files/wpa_supplicant-full.config | 2 +-
 2 files changed, 7 insertions(+), 2 deletions(-)

diff --git a/package/network/services/hostapd/files/netifd.sh 
b/package/network/services/hostapd/files/netifd.sh
index 23d2e7e..a3ffd93 100644
--- a/package/network/services/hostapd/files/netifd.sh
+++ b/package/network/services/hostapd/files/netifd.sh
@@ -538,7 +538,9 @@ wpa_supplicant_add_network() {
json_get_vars \
ssid bssid key \
basic_rate mcast_rate \
-   ieee80211w
+   ieee80211w ieee80211r
+
+   set_default ieee80211r 0
 
local key_mgmt='NONE'
local enc_str=
@@ -549,6 +551,8 @@ wpa_supplicant_add_network() {
local scan_ssid=scan_ssid=1
local freq
 
+   [ $ieee80211r -gt 0 ]  wpa_key_mgmt=FT-PSK $wpa_key_mgmt
+
[[ $_w_mode = adhoc ]]  {
append network_data mode=1 $N$T
[ -n $channel ]  {
@@ -594,6 +598,7 @@ wpa_supplicant_add_network() {
;;
eap)
key_mgmt='WPA-EAP'
+   [ $ieee80211r -gt 0 ]  key_mgmt=FT-EAP $key_mgmt
 
json_get_vars eap_type identity ca_cert
[ -n $ca_cert ]  append network_data 
ca_cert=\$ca_cert\ $N$T
diff --git a/package/network/services/hostapd/files/wpa_supplicant-full.config 
b/package/network/services/hostapd/files/wpa_supplicant-full.config
index a9d04ab..26e3c80 100644
--- a/package/network/services/hostapd/files/wpa_supplicant-full.config
+++ b/package/network/services/hostapd/files/wpa_supplicant-full.config
@@ -367,7 +367,7 @@ CONFIG_INTERNAL_LIBTOMMATH_FAST=y
 #CONFIG_DYNAMIC_EAP_METHODS=y
 
 # IEEE Std 802.11r-2008 (Fast BSS Transition)
-#CONFIG_IEEE80211R=y
+CONFIG_IEEE80211R=y
 
 # Add support for writing debug log to a file (/tmp/wpa_supplicant-log-#.txt)
 #CONFIG_DEBUG_FILE=y
-- 
1.9.1
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] Managed WiFi and IPv4/IPv6

2015-05-18 Thread Cristian Morales Vega
On 15 May 2015 at 20:25, Felix Fietkau n...@openwrt.org wrote:
 On 2015-05-15 17:28, Cristian Morales Vega wrote:
 Since a wifi-iface can only have one network, how are you supposed
 to link it to both the wan and wan6 interfaces?
 It can have multiple networks. Use 'list' instead of 'option'.

And it's actually documented in the wiki, my bad.
Thanks.
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] [PATCH] [brcm63xx] Add support for Plusnet 2704N

2015-05-18 Thread Matt Goring
Hello, this is my first submission, please excuse me if I have the wrong 
mailing list, or missed a mailing rule.



This patch is to add support for the Plusnet 2704N Router (BCM6318), on 
the current trunk.
This will most possibly add support for the Sagem 2704N (Ver 1) and the 
TP-Link-TD-W8960N (Ver 5) due to the same hardware, but unconfirmed.
ADSL does not work (same with all Broadcom devices) and the Fibre (via 
copper) is purposely not configured.  Otherwise you will loose a 
Ethernet port.


The openwrt image will not work out-the-box for this Plusnet router.  So 
I will create a wiki page if this patch is accepted.


Signed-off-by: Matt Goring matt.goring at googlemail.com

diff --git 
a/build_dir/target-mips_mips32_uClibc-0.9.33.2/linux-brcm63xx_generic/linux-3.18.11/arch/mips/bcm63xx/boards/board_bcm963xx.c
 
b/build_dir/target-mips_mips32_uClibc-0.9.33.2/linux-brcm63xx_generic/linux-3.18.11/arch/mips/bcm63xx/boards/board_bcm963xx.c
index 6b6cfc0..a0ef569 100644
--- 
a/build_dir/target-mips_mips32_uClibc-0.9.33.2/linux-brcm63xx_generic/linux-3.18.11/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ 
b/build_dir/target-mips_mips32_uClibc-0.9.33.2/linux-brcm63xx_generic/linux-3.18.11/arch/mips/bcm63xx/boards/board_bcm963xx.c
@@ -2401,6 +2401,7 @@ static struct of_device_id const bcm963xx_boards_dt[] = {
{ .compatible = brcm,bcm96318ref, .data = board_96318ref, },
{ .compatible = brcm,bcm96318ref_p300, .data = board_96318ref_p300, 
},
{ .compatible = d-link,dsl-275xb-d, .data = board_dsl_2751b_d1, },
+   { .compatible = plusnet,f@st2704n, .data = board_96318ref, },
 #endif
 #ifdef CONFIG_BCM63XX_CPU_6328
{ .compatible = adb,a4001n, .data = board_A4001N, },
diff --git a/target/linux/brcm63xx/base-files/etc/diag.sh 
b/target/linux/brcm63xx/base-files/etc/diag.sh
index 03d98b9..e97547a 100644
--- a/target/linux/brcm63xx/base-files/etc/diag.sh
+++ b/target/linux/brcm63xx/base-files/etc/diag.sh
@@ -69,6 +69,9 @@ set_state() {
fast2504n)
status_led=fast2504n:green:ok
;;
+   fast2704n)
+   status_led2=F@ST2704N:red:power
+   ;;
fast2704v2)
status_led=F@ST2704V2:green:power
;;
diff --git a/target/linux/brcm63xx/base-files/etc/uci-defaults/01_leds 
b/target/linux/brcm63xx/base-files/etc/uci-defaults/01_leds
index 58404a1..c40a94f 100644
--- a/target/linux/brcm63xx/base-files/etc/uci-defaults/01_leds
+++ b/target/linux/brcm63xx/base-files/etc/uci-defaults/01_leds
@@ -22,6 +22,9 @@ dgnd3700v1_dgnd3800b)
ucidef_set_led_usbdev usb1 USB1 DGND3700v1_3800B:green:usb-back 
1-1
ucidef_set_led_usbdev usb2 USB2 DGND3700v1_3800B:green:usb-front 
1-2
;;
+fast2704n)
+   ucidef_set_led_netdev lan LAN F@ST2704N:green:lan1 eth0.1
+   ;;
 fast2704v2)
ucidef_set_led_usbdev usb USB F@ST2704V2:green:usb 1-1
;;
diff --git a/target/linux/brcm63xx/base-files/etc/uci-defaults/02_network 
b/target/linux/brcm63xx/base-files/etc/uci-defaults/02_network
index 814e100..c31373a 100644
--- a/target/linux/brcm63xx/base-files/etc/uci-defaults/02_network
+++ b/target/linux/brcm63xx/base-files/etc/uci-defaults/02_network
@@ -91,6 +91,13 @@ bcm96368mvngr |\
 dsl-274xb-f |\
 dsl-275xb-d |\
 fast2504n |\
+fast2704n)
+   ucidef_set_interfaces_lan_wan eth0.1 eth0.2
+   ucidef_add_switch eth0 1 1
+   ucidef_add_switch_vlan eth0 1 0 1 2 3 8t
+   ;;
+
 fast2704v2 |\
 p870hw-51a_v2 |\
 vr-3025un |\
diff --git a/target/linux/brcm63xx/base-files/lib/brcm63xx.sh 
b/target/linux/brcm63xx/base-files/lib/brcm63xx.sh
index 5cb390f..e09478e 100755
--- a/target/linux/brcm63xx/base-files/lib/brcm63xx.sh
+++ b/target/linux/brcm63xx/base-files/lib/brcm63xx.sh
@@ -186,6 +186,9 @@ brcm63xx_dt_detect() {
Pirelli Alice Gate AGPF-S0)
board_name=agpf-s0
;;
+   Plusnet F@ST2704N)
+   board_name=fast2704n
+   ;;
Sagem F@ST2404)
board_name=fast2404
;;
diff --git a/target/linux/brcm63xx/dts/fast2704n.dts 
b/target/linux/brcm63xx/dts/fast2704n.dts
new file mode 100755
index 000..08bc58b
--- /dev/null
+++ b/target/linux/brcm63xx/dts/fast2704n.dts
@@ -0,0 +1,70 @@
+/dts-v1/;
+
+/include/ bcm6318.dtsi
+
+/ {
+   model = Plusnet F@ST2704N;
+   compatible = plusnet,f@st2704n, brcm,bcm6318;
+
+   gpio-keys-polled {
+   compatible = gpio-keys-polled;
+   #address-cells = 1;
+   #size-cells = 0;
+   poll-interval = 20;
+   debounce-interval = 60;
+
+   reset {
+   label = reset;
+   gpios = gpio1 2 1;
+   linux,code = 0x198;
+   };
+   wps {
+   label = wps;
+   gpios = gpio1 1 1;
+   linux,code = 0x211;
+   };
+   };
+
+   /* 

[OpenWrt-Devel] (no subject)

2015-05-18 Thread Alison C.
Hey everybody,

I'm trying to build a Barrier Breaker image with OpenVswitch 2.3.1. However,
it fails with

{standard input}:1116: Error: unknown pseudo-op: `.tprelword'

error. I found [a Stack Overflow
thread](http://stackoverflow.com/questions/8872517)
that suggests this is due to a too old binutils or a version mismatch
between gcc and g++. However, I know i'm using the gcc, g++, binutils in the
buildroot environment, whose versions are as follows:

[11:42:40] 
erinacity:~/Code/openwrt/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc-0.9.33.2/bin
alisonc $ ./mips-openwrt-linux-uclibc-gcc --version | head -1
mips-openwrt-linux-uclibc-gcc (OpenWrt/Linaro GCC 4.8-2014.04 r45620) 4.8.3

alisonc $ ./mips-openwrt-linux-uclibc-g++ --version | head -1
mips-openwrt-linux-uclibc-g++ (OpenWrt/Linaro GCC 4.8-2014.04 r45620) 4.8.3

alisonc $ ./mips-openwrt-linux-uclibc-as --version | head -1
GNU assembler (GNU Binutils) 2.22

The relevant snippet of the build log is below the fold, full build log is
[here](http://sprunge.us/aNKc), and i can pass along any other info that's
necessary.

How do i go about fixing this? Should i switch to a different OVS version? a
different OpenWrt version? I was able to build successfully a while ago with
Attitude Adjustment and OVS 1.9.0. Thanks in advance.

Cheers,
Alison



make[6]: Entering directory
`/home/alisonc/Code/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/openvswitch-2.3.1'
depbase=`echo lib/coverage.lo | sed 's|[^/]*$|.deps/|;s|\.lo$||'`;\
/bin/bash ./libtool  --tag=CC   --mode=compile
mips-openwrt-linux-uclibc-gcc -DHAVE_CONFIG_H -I.-I ./include -I
./lib -I ./lib 
-I/home/alisonc/Code/openwrt/staging_dir/target-mips_34kc_uClibc-0.9.33.2/usr/include
  
-I/home/alisonc/Code/openwrt/staging_dir/target-mips_34kc_uClibc-0.9.33.2/usr/include
-I/home/alisonc/Code/openwrt/staging_dir/target-mips_34kc_uClibc-0.9.33.2/include
-I/home/alisonc/Code/openwrt/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc-0.9.33.2/usr/include
-I/home/alisonc/Code/openwrt/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc-0.9.33.2/include
 -Wstrict-prototypes -Wall -Wextra -Wno-sign-compare -Wpointer-arith
-Wdeclaration-after-statement -Wno-format-zero-length -Wswitch-enum
-Wunused-parameter -Wstrict-aliasing -Wbad-function-cast -Wcast-align
-Wmissing-prototypes -Wmissing-field-initializers
-I/home/alisonc/Code/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/openvswitch-2.3.1/lib
-Os -pipe -mno-branch-likely -mips32r2 -mtune=34kc -fno-caller-saves
-fhonour-copts -Wno-error=unused-but-set-variable -msoft-float -mips16
-minterlink-mips16 -std=gnu99 -MT lib/coverage.lo -MD -MP -MF
$depbase.Tpo -c -o lib/coverage.lo lib/coverage.c \
mv -f $depbase.Tpo $depbase.Plo
OpenWrt-libtool: compile:  mips-openwrt-linux-uclibc-gcc
-DHAVE_CONFIG_H -I. -I ./include -I ./lib -I ./lib
-I/home/alisonc/Code/openwrt/staging_dir/target-mips_34kc_uClibc-0.9.33.2/usr/include
-I/home/alisonc/Code/openwrt/staging_dir/target-mips_34kc_uClibc-0.9.33.2/usr/include
-I/home/alisonc/Code/openwrt/staging_dir/target-mips_34kc_uClibc-0.9.33.2/include
-I/home/alisonc/Code/openwrt/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc-0.9.33.2/usr/include
-I/home/alisonc/Code/openwrt/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc-0.9.33.2/include
-Wstrict-prototypes -Wall -Wextra -Wno-sign-compare -Wpointer-arith
-Wdeclaration-after-statement -Wno-format-zero-length -Wswitch-enum
-Wunused-parameter -Wstrict-aliasing -Wbad-function-cast -Wcast-align
-Wmissing-prototypes -Wmissing-field-initializers
-I/home/alisonc/Code/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/openvswitch-2.3.1/lib
-Os -pipe -mno-branch-likely -mips32r2 -mtune=34kc -fno-caller-saves
-fhonour-copts -Wno-error=unused-but-set-variable -msoft-float -mips16
-minterlink-mips16 -std=gnu99 -MT lib/coverage.lo -MD -MP -MF
lib/.deps/coverage.Tpo -c lib/coverage.c -o lib/coverage.o
{standard input}: Assembler messages:
{standard input}:1116: Error: unknown pseudo-op: `.tprelword'
make[6]: *** [lib/coverage.lo] Error 1
make[6]: Leaving directory
`/home/alisonc/Code/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/openvswitch-2.3.1'
make[5]: *** [all-recursive] Error 1
make[5]: Leaving directory
`/home/alisonc/Code/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/openvswitch-2.3.1'
make[4]: *** [all] Error 2
make[4]: Leaving directory
`/home/alisonc/Code/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/openvswitch-2.3.1'
make[3]: ***
[/home/alisonc/Code/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/openvswitch-2.3.1/.built]
Error 2
make[3]: Leaving directory
`/home/alisonc/Code/openwrt/feeds/openvswitch/openvswitch'
make[2]: *** [package/feeds/openvswitch/openvswitch/compile] Error 2
make[2]: Leaving directory `/home/alisonc/Code/openwrt'
make[1]: ***

[OpenWrt-Devel] [PATCH 2/5] argp-standalone: import package from packages.git

2015-05-18 Thread Mathieu Olivari
argp-standalone is required by elfutils, itself required by perf. So
we'll move this package from packages.git and make it part of the core
distribution.

Signed-off-by: Mathieu Olivari math...@codeaurora.org
---
 package/libs/argp-standalone/Makefile  | 48 +
 .../patches/001-throw-in-funcdef.patch | 79 ++
 2 files changed, 127 insertions(+)
 create mode 100644 package/libs/argp-standalone/Makefile
 create mode 100644 
package/libs/argp-standalone/patches/001-throw-in-funcdef.patch

diff --git a/package/libs/argp-standalone/Makefile 
b/package/libs/argp-standalone/Makefile
new file mode 100644
index 000..8cf23fe
--- /dev/null
+++ b/package/libs/argp-standalone/Makefile
@@ -0,0 +1,48 @@
+#
+# Copyright (C) 2007-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=argp-standalone
+PKG_VERSION:=1.3
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.lysator.liu.se/~nisse/misc/
+PKG_MD5SUM:=720704bac078d067111b32444e24ba69
+PKG_MAINTAINER:=Ted Hess th...@kitschensync.net
+
+PKG_LICENSE:=LGPL-2.1
+PKG_LICENSE:=Makefile.am
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/argp-standalone
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=Hierarchial argument parsing broken out from glibc
+  URL:=http://www.lysator.liu.se/~nisse/misc/
+endef
+
+define Package/argp-standalone/description
+  GNU libc hierarchial argument parsing library broken out from glibc.
+endef
+
+MAKE_FLAGS += \
+   CFLAGS=$(TARGET_CFLAGS) $(FPIC)
+
+
+define Build/InstallDev
+   $(INSTALL_DIR) $(1)/usr/include
+   $(CP)   $(PKG_BUILD_DIR)/argp.h \
+   $(1)/usr/include/
+   $(INSTALL_DIR) $(1)/usr/lib
+   $(CP)   $(PKG_BUILD_DIR)/libargp.a \
+   $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,argp-standalone))
diff --git a/package/libs/argp-standalone/patches/001-throw-in-funcdef.patch 
b/package/libs/argp-standalone/patches/001-throw-in-funcdef.patch
new file mode 100644
index 000..4a90751
--- /dev/null
+++ b/package/libs/argp-standalone/patches/001-throw-in-funcdef.patch
@@ -0,0 +1,79 @@
+# --- T2-COPYRIGHT-NOTE-BEGIN ---
+# This copyright note is auto-generated by ./scripts/Create-CopyPatch.
+# 
+# T2 SDE: package/.../rng-tools/throw-in-funcdef.patch.argp-standalone
+# Copyright (C) 2006 The T2 SDE Project
+# 
+# More information can be found in the files COPYING and README.
+# 
+# This patch file is dual-licensed. It is available under the license the
+# patched project is licensed under, as long as it is an OpenSource license
+# as defined at http://www.opensource.org/ (e.g. BSD, X11) or under the terms
+# of the GNU General Public License as published by the Free Software
+# Foundation; either version 2 of the License, or (at your option) any later
+# version.
+# --- T2-COPYRIGHT-NOTE-END ---
+
+
+No __THROW in function implementation.
+   --jsaw
+
+--- argp-standalone-1.4-test2/argp.h.orig  2006-01-06 02:29:59.0 
+0100
 argp-standalone-1.4-test2/argp.h   2006-01-06 02:41:10.0 +0100
+@@ -560,17 +560,17 @@
+ # endif
+ 
+ # ifndef ARGP_EI
+-#  define ARGP_EI extern __inline__
++#  define ARGP_EI extern inline
+ # endif
+ 
+ ARGP_EI void
+-__argp_usage (__const struct argp_state *__state) __THROW
++__argp_usage (__const struct argp_state *__state)
+ {
+   __argp_state_help (__state, stderr, ARGP_HELP_STD_USAGE);
+ }
+ 
+ ARGP_EI int
+-__option_is_short (__const struct argp_option *__opt) __THROW
++__option_is_short (__const struct argp_option *__opt)
+ {
+   if (__opt-flags  OPTION_DOC)
+ return 0;
+@@ -582,7 +582,7 @@
+ }
+ 
+ ARGP_EI int
+-__option_is_end (__const struct argp_option *__opt) __THROW
++__option_is_end (__const struct argp_option *__opt)
+ {
+   return !__opt-key  !__opt-name  !__opt-doc  !__opt-group;
+ }
+--- argp-standalone-1.4-test2/argp-parse.c.orig2006-01-06 
02:47:48.0 +0100
 argp-standalone-1.4-test2/argp-parse.c 2006-01-06 02:48:16.0 
+0100
+@@ -1290,13 +1290,13 @@
+ /* Defined here, in case a user is not inlining the definitions in
+  * argp.h */
+ void
+-__argp_usage (__const struct argp_state *__state) __THROW
++__argp_usage (__const struct argp_state *__state)
+ {
+   __argp_state_help (__state, stderr, ARGP_HELP_STD_USAGE);
+ }
+ 
+ int
+-__option_is_short (__const struct argp_option *__opt) __THROW
++__option_is_short (__const struct argp_option *__opt) 
+ {
+   if (__opt-flags  OPTION_DOC)
+ return 0;
+@@ -1310,7 +1310,7 @@
+ }
+ 
+ int
+-__option_is_end (__const struct argp_option *__opt) __THROW
++__option_is_end (__const struct argp_option *__opt) 
+ {
+   return !__opt-key  !__opt-name  !__opt-doc  !__opt-group;
+ }
-- 
2.1.4
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org

[OpenWrt-Devel] [PATCH 1/5] uClibc: elf: Add STT_GNU_IFUNC from glibc

2015-05-18 Thread Mathieu Olivari
perf in upstream Linux kernel 3.17 onwards expects STT_GNU_IFUNC
replicate it from glibc

Patch cherry-picked from:
http://lists.busybox.net/pipermail/uclibc/2015-February/048825.html

Signed-off-by: Mathieu Olivari math...@codeaurora.org
---
 .../012-elf-Add-STT_GNU_IFUNC-from-glibc.patch | 37 ++
 1 file changed, 37 insertions(+)
 create mode 100644 
toolchain/uClibc/patches-0.9.33.2/012-elf-Add-STT_GNU_IFUNC-from-glibc.patch

diff --git 
a/toolchain/uClibc/patches-0.9.33.2/012-elf-Add-STT_GNU_IFUNC-from-glibc.patch 
b/toolchain/uClibc/patches-0.9.33.2/012-elf-Add-STT_GNU_IFUNC-from-glibc.patch
new file mode 100644
index 000..6cecfaa
--- /dev/null
+++ 
b/toolchain/uClibc/patches-0.9.33.2/012-elf-Add-STT_GNU_IFUNC-from-glibc.patch
@@ -0,0 +1,37 @@
+From be58779614b2fe9aa57a9315be9dc004dfd77b3b Mon Sep 17 00:00:00 2001
+From: Vineet Gupta vgu...@synopsys.com
+Date: Fri, 20 Feb 2015 15:27:08 +0530
+Subject: [PATCH] elf: Add STT_GNU_IFUNC from glibc
+
+perf in upstream Linux kernel 3.17 onwards expects STT_GNU_IFUNC
+replicate it from glibc
+
+Signed-off-by: Vineet Gupta vgu...@synopsys.com
+Signed-off-by: Bernhard Reutner-Fischer rep.dot@gmail.com
+---
+ include/elf.h | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/include/elf.h b/include/elf.h
+index facf09c..917930b 100644
+--- a/include/elf.h
 b/include/elf.h
+@@ -566,6 +566,7 @@ typedef struct
+ #define STB_WEAK  2   /* Weak symbol */
+ #define   STB_NUM 3   /* Number of defined types.  */
+ #define STB_LOOS  10  /* Start of OS-specific */
++#define STB_GNU_UNIQUE10  /* Unique symbol.  */
+ #define STB_HIOS  12  /* End of OS-specific */
+ #define STB_LOPROC13  /* Start of processor-specific */
+ #define STB_HIPROC15  /* End of processor-specific */
+@@ -581,6 +582,7 @@ typedef struct
+ #define STT_TLS   6   /* Symbol is thread-local data 
object*/
+ #define   STT_NUM 7   /* Number of defined types.  */
+ #define STT_LOOS  10  /* Start of OS-specific */
++#define STT_GNU_IFUNC 10  /* Symbol is indirect code object */
+ #define STT_HIOS  12  /* End of OS-specific */
+ #define STT_LOPROC13  /* Start of processor-specific */
+ #define STT_HIPROC15  /* End of processor-specific */
+-- 
+2.1.4
+
-- 
2.1.4
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] [PATCH 4/5] bzip2: import package from packages.git

2015-05-18 Thread Mathieu Olivari
bzip2 is required by elfutils, itself required by perf. So we'll move
this package from packages.git and make it part of the core
distribution.

Signed-off-by: Mathieu Olivari math...@codeaurora.org
---
 package/utils/bzip2/Makefile | 87 
 1 file changed, 87 insertions(+)
 create mode 100644 package/utils/bzip2/Makefile

diff --git a/package/utils/bzip2/Makefile b/package/utils/bzip2/Makefile
new file mode 100644
index 000..493ccc9
--- /dev/null
+++ b/package/utils/bzip2/Makefile
@@ -0,0 +1,87 @@
+#
+# Copyright (C) 2007-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bzip2
+PKG_VERSION:=1.0.6
+PKG_RELEASE:=2
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.bzip.org/$(PKG_VERSION)
+PKG_MD5SUM:=00b516f4704d4a7cb50a1d97e6e8e15b
+PKG_MAINTAINER:=Steven Barth cy...@openwrt.org
+
+PKG_LICENSE:=BZIP2
+PKG_LICENSE_FILES:=LICENSE
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/bzip2/Default
+  SUBMENU:=Compression
+  URL:=http://www.bzip.org/
+endef
+
+define Package/libbz2
+$(call Package/bzip2/Default)
+  SECTION:=libs
+  CATEGORY:=Libraries
+  DEPENDS:=
+  TITLE:=bzip2 library.
+endef
+
+define Package/libbz2/description
+   bzip2 is a freely available, patent free, high-quality
+   data compressor. This packages provides libbz2 library.
+endef
+
+define Package/bzip2
+$(call Package/bzip2/Default)
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=+libbz2
+  TITLE:=bzip2 is a compression utility.
+endef
+
+define Package/bzip2/description
+   bzip2 is a freely available, patent free, high-quality
+   data compressor. This package provides the binary.
+endef
+
+TARGET_CFLAGS += \
+   $(FPIC) \
+   $(TARGET_LDFLAGS)
+
+CONFIGURE_ARGS += --prefix=/usr
+
+MAKE_FLAGS += \
+   -f Makefile-libbz2_so \
+   CFLAGS=$(TARGET_CFLAGS) \
+   all
+
+define Build/InstallDev
+   $(INSTALL_DIR) $(1)/usr/include
+   $(CP) $(PKG_BUILD_DIR)/bzlib.h $(1)/usr/include/
+   $(INSTALL_DIR) $(1)/usr/lib
+   $(CP) $(PKG_BUILD_DIR)/libbz2.so.$(PKG_VERSION) $(1)/usr/lib/
+   $(LN) libbz2.so.$(PKG_VERSION) $(1)/usr/lib/libbz2.so.1.0
+   $(LN) libbz2.so.$(PKG_VERSION) $(1)/usr/lib/libbz2.so
+endef
+
+define Package/libbz2/install
+   $(INSTALL_DIR) $(1)/usr/lib/
+   $(CP) $(PKG_BUILD_DIR)/libbz2.so.$(PKG_VERSION) $(1)/usr/lib/
+   $(LN) libbz2.so.$(PKG_VERSION) $(1)/usr/lib/libbz2.so.1.0
+endef
+
+define Package/bzip2/install
+   $(INSTALL_DIR) $(1)/usr/bin/
+   $(INSTALL_BIN) $(PKG_BUILD_DIR)/bzip2-shared $(1)/usr/bin/bzip2
+endef
+
+$(eval $(call BuildPackage,libbz2))
+$(eval $(call BuildPackage,bzip2))
-- 
2.1.4
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] Patch file for QCA8334 eth switch chip

2015-05-18 Thread nam228

Hi all,

I have a board with a qca8334 eth switch chip.The chip is found by the 
ar8216 phy as an ar8337.


My board can not ping unless I remove the AR8337_PAD_MAC06_EXCHANGE_EN 
with a path file.


The patch file is:

--- a/drivers/net/phy/ar8327.c
+++ b/drivers/net/phy/ar8327.c
@@ -508,8 +508,8 @@ ar8327_hw_config_pdata(struct ar8xxx_pri
 data-port6_status = 
ar8327_get_port_init_status(pdata-port6_cfg);


 t = ar8327_get_pad_cfg(pdata-pad0_cfg);
-   if (chip_is_ar8337(priv))
-   t |= AR8337_PAD_MAC06_EXCHANGE_EN;
+   //if (chip_is_ar8337(priv))
+   //  t |= AR8337_PAD_MAC06_EXCHANGE_EN;

 ar8xxx_write(priv, AR8327_REG_PAD0_MODE, t);
 t = ar8327_get_pad_cfg(pdata-pad5_cfg);


Does anyone know if the qca8334 is different from the ar8337 ?

Thanks,

Nam.

P/S: my OpenWRT version is Chaos Calmer.
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] Patch file for QCA8334 eth switch chip

2015-05-18 Thread Heiner Kallweit
Am 19.05.2015 um 05:45 schrieb nam228:
 Hi all,
 
 I have a board with a qca8334 eth switch chip.The chip is found by the ar8216 
 phy as an ar8337.
 
 My board can not ping unless I remove the AR8337_PAD_MAC06_EXCHANGE_EN with a 
 path file.
 
 The patch file is:
 
 --- a/drivers/net/phy/ar8327.c
 +++ b/drivers/net/phy/ar8327.c
 @@ -508,8 +508,8 @@ ar8327_hw_config_pdata(struct ar8xxx_pri
  data-port6_status = ar8327_get_port_init_status(pdata-port6_cfg);
 
  t = ar8327_get_pad_cfg(pdata-pad0_cfg);
 -   if (chip_is_ar8337(priv))
 -   t |= AR8337_PAD_MAC06_EXCHANGE_EN;
 +   //if (chip_is_ar8337(priv))
 +   //  t |= AR8337_PAD_MAC06_EXCHANGE_EN;
 
  ar8xxx_write(priv, AR8327_REG_PAD0_MODE, t);
  t = ar8327_get_pad_cfg(pdata-pad5_cfg);
 
 
 Does anyone know if the qca8334 is different from the ar8337 ?
 
 Thanks,
 
 Nam.
 
 P/S: my OpenWRT version is Chaos Calmer.
 ___
 openwrt-devel mailing list
 openwrt-devel@lists.openwrt.org
 https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
 
With this patch you would break several AR8337-based devices.
A solution that covers both chips is waiting to be applied:
http://patchwork.ozlabs.org/patch/466209/

Heiner
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] [PATCH 0/5] perf: fix dependencies restore uClibc compatibility

2015-05-18 Thread Mathieu Olivari
Commit 9cddeba3a4eb00e85233f0b8ac84b8e8492822ef was removing uClibc
support from perf because it didn't build anymore.
The root cause of this failure was multiple:
*perf needs a uClibc patch to define STT_GNU_IFUNC. Patch has been done
 already to the uClibc project, and just needs to be cherry-picked to
 OpenWrt.
*perf was moved to openwrt.git, but libelf1 (in its dependencies) is
 still located in packages.git. So it ends-up compiling without libelf
 support.

This change set fixes these issues by adding the patch and importing the
missing packages, which allows us to remove the dependency perf has on
eglibc.

Mathieu Olivari (5):
  uClibc: elf: Add STT_GNU_IFUNC from glibc
  argp-standalone: import package from packages.git
  elfutils: import package from packages.git
  bzip2: import package from packages.git
  perf: remove EGLIBC dependency

 package/devel/perf/Makefile|2 +-
 package/libs/argp-standalone/Makefile  |   48 +
 .../patches/001-throw-in-funcdef.patch |   79 +
 package/libs/elfutils/Makefile |   97 +
 .../patches/001-elfutils-portability.patch | 1871 
 .../elfutils/patches/002-argp_standalone.patch |   14 +
 .../libs/elfutils/patches/003-libint-stub.patch|   49 +
 .../elfutils/patches/004-maybe-uninitialized.patch |   11 +
 package/libs/elfutils/patches/004-memcpy_def.patch |   14 +
 .../elfutils/patches/005-build_only_libs.patch |   24 +
 package/libs/elfutils/patches/006-libdw_LIBS.patch |   11 +
 .../libs/elfutils/patches/100-musl-compat.patch|  788 +
 package/libs/elfutils/patches/101-no-fts.patch |  109 ++
 package/utils/bzip2/Makefile   |   87 +
 .../012-elf-Add-STT_GNU_IFUNC-from-glibc.patch |   37 +
 15 files changed, 3240 insertions(+), 1 deletion(-)
 create mode 100644 package/libs/argp-standalone/Makefile
 create mode 100644 
package/libs/argp-standalone/patches/001-throw-in-funcdef.patch
 create mode 100644 package/libs/elfutils/Makefile
 create mode 100644 package/libs/elfutils/patches/001-elfutils-portability.patch
 create mode 100644 package/libs/elfutils/patches/002-argp_standalone.patch
 create mode 100644 package/libs/elfutils/patches/003-libint-stub.patch
 create mode 100644 package/libs/elfutils/patches/004-maybe-uninitialized.patch
 create mode 100644 package/libs/elfutils/patches/004-memcpy_def.patch
 create mode 100644 package/libs/elfutils/patches/005-build_only_libs.patch
 create mode 100644 package/libs/elfutils/patches/006-libdw_LIBS.patch
 create mode 100644 package/libs/elfutils/patches/100-musl-compat.patch
 create mode 100644 package/libs/elfutils/patches/101-no-fts.patch
 create mode 100644 package/utils/bzip2/Makefile
 create mode 100644 
toolchain/uClibc/patches-0.9.33.2/012-elf-Add-STT_GNU_IFUNC-from-glibc.patch

-- 
2.1.4
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] [PATCH 5/5] perf: remove EGLIBC dependency

2015-05-18 Thread Mathieu Olivari
EGLIBC dependency was required as libelf was not found. But we now fixed
the root cause, so we can remove it. perf works with uClibc again.

Signed-off-by: Mathieu Olivari math...@codeaurora.org
---
 package/devel/perf/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/package/devel/perf/Makefile b/package/devel/perf/Makefile
index b77e29a..86363ee 100644
--- a/package/devel/perf/Makefile
+++ b/package/devel/perf/Makefile
@@ -19,7 +19,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/perf
   SECTION:=devel
   CATEGORY:=Development
-  DEPENDS:= @USE_GLIBC +libelf1 +libdw +libpthread +librt +binutils
+  DEPENDS:= +libelf1 +libdw +libpthread +librt +binutils
   TITLE:=Linux performance monitoring tool
   VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
   URL:=http://www.kernel.org
-- 
2.1.4
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] [PATCH 3/5] elfutils: import package from packages.git

2015-05-18 Thread Mathieu Olivari
I just realized I only replied to part of the question. They should also 
probably be deleted from packages.git.
OpenWrt will ignore them anyway unless the override mechanism is used when 
installing the feeds. 

-Original Message-
From: openwrt-devel [mailto:openwrt-devel-boun...@lists.openwrt.org] On Behalf 
Of Mathieu Olivari
Sent: Monday, May 18, 2015 7:32 PM
To: 'Luiz Angelo Daros de Luca'; blo...@openwrt.org
Cc: mmccl...@codeaurora.org; openwrt-devel@lists.openwrt.org
Subject: Re: [OpenWrt-Devel] [PATCH 3/5] elfutils: import package from 
packages.git

Yeah; I actually wondered the same question. I’m not sure what we should happen 
in this case.
I’ll let blogic replied as he’s the one who moved perf into openwrt.git.
If these packages are required by the OpenWrt core, then one of the openwrt.git 
maintainer would probably own it. I’m not sure :s
Thanks,
Mathieu


From: Luiz Angelo Daros de Luca [mailto:luizl...@gmail.com] 
Sent: Monday, May 18, 2015 6:43 PM
To: Mathieu Olivari; blo...@openwrt.org
Cc: mmccl...@codeaurora.org; openwrt-devel@lists.openwrt.org
Subject: Re: [OpenWrt-Devel] [PATCH 3/5] elfutils: import package from 
packages.git

I'm curious, as current elfutils packager, how I should play in this import?
Should this package be removed from package.git (but there is no PR for it)?
Or will it be periodically synchronized with packages.git?
Also, as I'm not a core developer, maybe it would be better to a core developer 
to take its maintainance.
Regards,

Em seg, 18 de mai de 2015 20:45, Mathieu Olivari math...@codeaurora.org 
escreveu:
elfutils is required by perf. So we'll move this package from
packages.git and make it part of the core distribution.

Signed-off-by: Mathieu Olivari math...@codeaurora.org
---
 package/libs/elfutils/Makefile |   97 +
 .../patches/001-elfutils-portability.patch | 1871 
 .../elfutils/patches/002-argp_standalone.patch |   14 +
 .../libs/elfutils/patches/003-libint-stub.patch|   49 +
 .../elfutils/patches/004-maybe-uninitialized.patch |   11 +
 package/libs/elfutils/patches/004-memcpy_def.patch |   14 +
 .../elfutils/patches/005-build_only_libs.patch |   24 +
 package/libs/elfutils/patches/006-libdw_LIBS.patch |   11 +
 .../libs/elfutils/patches/100-musl-compat.patch|  788 +
 package/libs/elfutils/patches/101-no-fts.patch |  109 ++
 10 files changed, 2988 insertions(+)
 create mode 100644 package/libs/elfutils/Makefile
 create mode 100644 package/libs/elfutils/patches/001-elfutils-portability.patch
 create mode 100644 package/libs/elfutils/patches/002-argp_standalone.patch
 create mode 100644 package/libs/elfutils/patches/003-libint-stub.patch
 create mode 100644 package/libs/elfutils/patches/004-maybe-uninitialized.patch
 create mode 100644 package/libs/elfutils/patches/004-memcpy_def.patch
 create mode 100644 package/libs/elfutils/patches/005-build_only_libs.patch
 create mode 100644 package/libs/elfutils/patches/006-libdw_LIBS.patch
 create mode 100644 package/libs/elfutils/patches/100-musl-compat.patch
 create mode 100644 package/libs/elfutils/patches/101-no-fts.patch

diff --git a/package/libs/elfutils/Makefile b/package/libs/elfutils/Makefile
new file mode 100644
index 000..d3e1552
--- /dev/null
+++ b/package/libs/elfutils/Makefile
@@ -0,0 +1,97 @@
+#
+# Copyright (C) 2010-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=elfutils
+PKG_VERSION:=0.161
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://fedorahosted.org/releases/e/l/$(PKG_NAME)/$(PKG_VERSION)
+PKG_MD5SUM:=e1b9847c9a6a1ad340de8d47a863ec52
+PKG_MAINTAINER:=Luiz Angelo Daros de Luca luizl...@gmail.com
+PKG_LICENSE:=GPL-3.0+
+PKG_LICENSE_FILES:=COPYING COPYING-GPLV2 COPYING-LGPLV3
+
+PKG_INSTALL:=1
+PKG_USE_MIPS16:=0
+
+PKG_BUILD_DEPENDS:=USE_UCLIBC:argp-standalone USE_MUSL:argp-standalone
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
+
+define Package/elfutils/Default
+  SECTION:=libs
+  CATEGORY:=Libraries
+  DEPENDS:=$(INTL_DEPENDS)
+  TITLE:=ELF manipulation libraries
+  URL:=https://fedorahosted.org/elfutils/
+endef
+
+define Package/libasm
+  $(call Package/elfutils/Default)
+  TITLE+= (libasm)
+  DEPENDS:=libelf1
+endef
+
+define Package/libdw
+  $(call Package/elfutils/Default)
+  DEPENDS:=libelf1 +zlib +libbz2
+  TITLE+= (libdw)
+endef
+
+define Package/libelf1
+  $(call Package/elfutils/Default)
+  TITLE+= (libelf)
+endef
+
+ifeq ($(CONFIG_BUILD_NLS),y)
+TARGET_LDFLAGS += -lintl
+endif
+
+ifdef CONFIG_USE_UCLIBC
+CONFIGURE_VARS += \
+   LIBS=-largp
+endif
+
+ifdef CONFIG_USE_MUSL
+CONFIGURE_VARS += \
+   LIBS=-largp
+endif
+
+CONFIGURE_ARGS += \
+   --disable-werror \
+   --without-lzma
+
+define Build/InstallDev
+   $(INSTALL_DIR) $(1)/usr/include
+   $(CP) $(PKG_INSTALL_DIR)/usr/include/* 

Re: [OpenWrt-Devel] [PATCH 3/5] elfutils: import package from packages.git

2015-05-18 Thread Mathieu Olivari
Yeah; I actually wondered the same question. I’m not sure what we should happen 
in this case.
I’ll let blogic replied as he’s the one who moved perf into openwrt.git.
If these packages are required by the OpenWrt core, then one of the openwrt.git 
maintainer would probably own it. I’m not sure :s
Thanks,
Mathieu


From: Luiz Angelo Daros de Luca [mailto:luizl...@gmail.com] 
Sent: Monday, May 18, 2015 6:43 PM
To: Mathieu Olivari; blo...@openwrt.org
Cc: mmccl...@codeaurora.org; openwrt-devel@lists.openwrt.org
Subject: Re: [OpenWrt-Devel] [PATCH 3/5] elfutils: import package from 
packages.git

I'm curious, as current elfutils packager, how I should play in this import?
Should this package be removed from package.git (but there is no PR for it)?
Or will it be periodically synchronized with packages.git?
Also, as I'm not a core developer, maybe it would be better to a core developer 
to take its maintainance.
Regards,

Em seg, 18 de mai de 2015 20:45, Mathieu Olivari math...@codeaurora.org 
escreveu:
elfutils is required by perf. So we'll move this package from
packages.git and make it part of the core distribution.

Signed-off-by: Mathieu Olivari math...@codeaurora.org
---
 package/libs/elfutils/Makefile |   97 +
 .../patches/001-elfutils-portability.patch | 1871 
 .../elfutils/patches/002-argp_standalone.patch |   14 +
 .../libs/elfutils/patches/003-libint-stub.patch|   49 +
 .../elfutils/patches/004-maybe-uninitialized.patch |   11 +
 package/libs/elfutils/patches/004-memcpy_def.patch |   14 +
 .../elfutils/patches/005-build_only_libs.patch |   24 +
 package/libs/elfutils/patches/006-libdw_LIBS.patch |   11 +
 .../libs/elfutils/patches/100-musl-compat.patch|  788 +
 package/libs/elfutils/patches/101-no-fts.patch |  109 ++
 10 files changed, 2988 insertions(+)
 create mode 100644 package/libs/elfutils/Makefile
 create mode 100644 package/libs/elfutils/patches/001-elfutils-portability.patch
 create mode 100644 package/libs/elfutils/patches/002-argp_standalone.patch
 create mode 100644 package/libs/elfutils/patches/003-libint-stub.patch
 create mode 100644 package/libs/elfutils/patches/004-maybe-uninitialized.patch
 create mode 100644 package/libs/elfutils/patches/004-memcpy_def.patch
 create mode 100644 package/libs/elfutils/patches/005-build_only_libs.patch
 create mode 100644 package/libs/elfutils/patches/006-libdw_LIBS.patch
 create mode 100644 package/libs/elfutils/patches/100-musl-compat.patch
 create mode 100644 package/libs/elfutils/patches/101-no-fts.patch

diff --git a/package/libs/elfutils/Makefile b/package/libs/elfutils/Makefile
new file mode 100644
index 000..d3e1552
--- /dev/null
+++ b/package/libs/elfutils/Makefile
@@ -0,0 +1,97 @@
+#
+# Copyright (C) 2010-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=elfutils
+PKG_VERSION:=0.161
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://fedorahosted.org/releases/e/l/$(PKG_NAME)/$(PKG_VERSION)
+PKG_MD5SUM:=e1b9847c9a6a1ad340de8d47a863ec52
+PKG_MAINTAINER:=Luiz Angelo Daros de Luca luizl...@gmail.com
+PKG_LICENSE:=GPL-3.0+
+PKG_LICENSE_FILES:=COPYING COPYING-GPLV2 COPYING-LGPLV3
+
+PKG_INSTALL:=1
+PKG_USE_MIPS16:=0
+
+PKG_BUILD_DEPENDS:=USE_UCLIBC:argp-standalone USE_MUSL:argp-standalone
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
+
+define Package/elfutils/Default
+  SECTION:=libs
+  CATEGORY:=Libraries
+  DEPENDS:=$(INTL_DEPENDS)
+  TITLE:=ELF manipulation libraries
+  URL:=https://fedorahosted.org/elfutils/
+endef
+
+define Package/libasm
+  $(call Package/elfutils/Default)
+  TITLE+= (libasm)
+  DEPENDS:=libelf1
+endef
+
+define Package/libdw
+  $(call Package/elfutils/Default)
+  DEPENDS:=libelf1 +zlib +libbz2
+  TITLE+= (libdw)
+endef
+
+define Package/libelf1
+  $(call Package/elfutils/Default)
+  TITLE+= (libelf)
+endef
+
+ifeq ($(CONFIG_BUILD_NLS),y)
+TARGET_LDFLAGS += -lintl
+endif
+
+ifdef CONFIG_USE_UCLIBC
+CONFIGURE_VARS += \
+   LIBS=-largp
+endif
+
+ifdef CONFIG_USE_MUSL
+CONFIGURE_VARS += \
+   LIBS=-largp
+endif
+
+CONFIGURE_ARGS += \
+   --disable-werror \
+   --without-lzma
+
+define Build/InstallDev
+   $(INSTALL_DIR) $(1)/usr/include
+   $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
+   $(INSTALL_DIR) $(1)/usr/lib
+   $(CP) $(PKG_BUILD_DIR)/libasm/libasm.{a,so*} $(1)/usr/lib/
+   $(CP) $(PKG_BUILD_DIR)/libdw/libdw.{a,so*} $(1)/usr/lib/
+   $(CP) $(PKG_BUILD_DIR)/libelf/libelf.{a,so*} $(1)/usr/lib/
+endef
+
+define Package/libasm/install
+   $(INSTALL_DIR) $(1)/usr/lib
+   $(CP) $(PKG_BUILD_DIR)/libasm/libasm.so* $(1)/usr/lib/
+endef
+
+define Package/libdw/install
+   $(INSTALL_DIR) $(1)/usr/lib
+   $(CP) $(PKG_BUILD_DIR)/libdw/libdw.so* $(1)/usr/lib/
+endef
+
+define Package/libelf1/install
+   

[OpenWrt-Devel] [PATCH 3/5] elfutils: import package from packages.git

2015-05-18 Thread Mathieu Olivari
elfutils is required by perf. So we'll move this package from
packages.git and make it part of the core distribution.

Signed-off-by: Mathieu Olivari math...@codeaurora.org
---
 package/libs/elfutils/Makefile |   97 +
 .../patches/001-elfutils-portability.patch | 1871 
 .../elfutils/patches/002-argp_standalone.patch |   14 +
 .../libs/elfutils/patches/003-libint-stub.patch|   49 +
 .../elfutils/patches/004-maybe-uninitialized.patch |   11 +
 package/libs/elfutils/patches/004-memcpy_def.patch |   14 +
 .../elfutils/patches/005-build_only_libs.patch |   24 +
 package/libs/elfutils/patches/006-libdw_LIBS.patch |   11 +
 .../libs/elfutils/patches/100-musl-compat.patch|  788 +
 package/libs/elfutils/patches/101-no-fts.patch |  109 ++
 10 files changed, 2988 insertions(+)
 create mode 100644 package/libs/elfutils/Makefile
 create mode 100644 package/libs/elfutils/patches/001-elfutils-portability.patch
 create mode 100644 package/libs/elfutils/patches/002-argp_standalone.patch
 create mode 100644 package/libs/elfutils/patches/003-libint-stub.patch
 create mode 100644 package/libs/elfutils/patches/004-maybe-uninitialized.patch
 create mode 100644 package/libs/elfutils/patches/004-memcpy_def.patch
 create mode 100644 package/libs/elfutils/patches/005-build_only_libs.patch
 create mode 100644 package/libs/elfutils/patches/006-libdw_LIBS.patch
 create mode 100644 package/libs/elfutils/patches/100-musl-compat.patch
 create mode 100644 package/libs/elfutils/patches/101-no-fts.patch

diff --git a/package/libs/elfutils/Makefile b/package/libs/elfutils/Makefile
new file mode 100644
index 000..d3e1552
--- /dev/null
+++ b/package/libs/elfutils/Makefile
@@ -0,0 +1,97 @@
+#
+# Copyright (C) 2010-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=elfutils
+PKG_VERSION:=0.161
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://fedorahosted.org/releases/e/l/$(PKG_NAME)/$(PKG_VERSION)
+PKG_MD5SUM:=e1b9847c9a6a1ad340de8d47a863ec52
+PKG_MAINTAINER:=Luiz Angelo Daros de Luca luizl...@gmail.com
+PKG_LICENSE:=GPL-3.0+
+PKG_LICENSE_FILES:=COPYING COPYING-GPLV2 COPYING-LGPLV3
+
+PKG_INSTALL:=1
+PKG_USE_MIPS16:=0
+
+PKG_BUILD_DEPENDS:=USE_UCLIBC:argp-standalone USE_MUSL:argp-standalone
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
+
+define Package/elfutils/Default
+  SECTION:=libs
+  CATEGORY:=Libraries
+  DEPENDS:=$(INTL_DEPENDS)
+  TITLE:=ELF manipulation libraries
+  URL:=https://fedorahosted.org/elfutils/
+endef
+
+define Package/libasm
+  $(call Package/elfutils/Default)
+  TITLE+= (libasm)
+  DEPENDS:=libelf1
+endef
+
+define Package/libdw
+  $(call Package/elfutils/Default)
+  DEPENDS:=libelf1 +zlib +libbz2
+  TITLE+= (libdw)
+endef
+
+define Package/libelf1
+  $(call Package/elfutils/Default)
+  TITLE+= (libelf)
+endef
+
+ifeq ($(CONFIG_BUILD_NLS),y)
+TARGET_LDFLAGS += -lintl
+endif
+
+ifdef CONFIG_USE_UCLIBC
+CONFIGURE_VARS += \
+   LIBS=-largp
+endif
+
+ifdef CONFIG_USE_MUSL
+CONFIGURE_VARS += \
+   LIBS=-largp
+endif
+
+CONFIGURE_ARGS += \
+   --disable-werror \
+   --without-lzma
+
+define Build/InstallDev
+   $(INSTALL_DIR) $(1)/usr/include
+   $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
+   $(INSTALL_DIR) $(1)/usr/lib
+   $(CP) $(PKG_BUILD_DIR)/libasm/libasm.{a,so*} $(1)/usr/lib/
+   $(CP) $(PKG_BUILD_DIR)/libdw/libdw.{a,so*} $(1)/usr/lib/
+   $(CP) $(PKG_BUILD_DIR)/libelf/libelf.{a,so*} $(1)/usr/lib/
+endef
+
+define Package/libasm/install
+   $(INSTALL_DIR) $(1)/usr/lib
+   $(CP) $(PKG_BUILD_DIR)/libasm/libasm.so* $(1)/usr/lib/
+endef
+
+define Package/libdw/install
+   $(INSTALL_DIR) $(1)/usr/lib
+   $(CP) $(PKG_BUILD_DIR)/libdw/libdw.so* $(1)/usr/lib/
+endef
+
+define Package/libelf1/install
+   $(INSTALL_DIR) $(1)/usr/lib
+   $(CP) $(PKG_BUILD_DIR)/libelf/libelf.so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libasm))
+$(eval $(call BuildPackage,libdw))
+$(eval $(call BuildPackage,libelf1))
diff --git a/package/libs/elfutils/patches/001-elfutils-portability.patch 
b/package/libs/elfutils/patches/001-elfutils-portability.patch
new file mode 100644
index 000..7539f8b
--- /dev/null
+++ b/package/libs/elfutils/patches/001-elfutils-portability.patch
@@ -0,0 +1,1871 @@
+--- elfutils/backends/ChangeLog
 elfutils/backends/ChangeLog
+@@ -433,6 +433,10 @@
+   * ppc_attrs.c (ppc_check_object_attribute): Handle tag
+   GNU_Power_ABI_Struct_Return.
+ 
++2009-01-23  Roland McGrath  rol...@redhat.com
++
++  * Makefile.am (libebl_%.so): Use $(LD_AS_NEEDED).
++
+ 2008-10-04  Ulrich Drepper  drep...@redhat.com
+ 
+   * i386_reloc.def: Fix entries for TLS_GOTDESC, TLS_DESC_CALL, and
+@@ -760,6 +764,11 @@
+   * sparc_init.c: Likewise.
+   * x86_64_init.c: 

Re: [OpenWrt-Devel] openwrt-devel Digest, Vol 113, Issue 43

2015-05-18 Thread Angelo Corsaro

Hi Lars,
here's my conf:

/etc/config/firewall

config redirect
option target 'DNAT'
option src 'wan'
option dest 'lan'
option proto 'tcp'
option src_dport '22'
option dest_port '22'
option name 'ssh'
option dest_ip '192.168.100.200'
option reflection_src 'external'
option reflection '0'

config redirect
option target 'DNAT'
option src 'wan'
option dest 'lan'
option dest_ip '192.168.100.200'
option dest_port '80'
option name 'Photo'
option src_dport '10080'
option proto 'tcp'
option reflection '0'

config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
option drop_invalid '1'

config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option masq '1'
option network 'lan'

config zone
option name 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option mtu_fix '1'
option network 'wan wan6'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config include
option path '/etc/firewall.user'

config rule
option target 'ACCEPT'
option src 'wan'
option dest_port '1022'
option name 'ssh_modem'
option proto 'tcp'

config forwarding
option dest 'wan'
option src 'lan'


/etc/firewall.user

# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.

# Internal uci firewall chains are flushed and recreated on reload, so
# put custom rules into the root chains e.g. INPUT or FORWARD or into the
# special user chains, e.g. input_wan_rule or postrouting_lan_rule.

iptables -t nat -D zone_lan_postrouting -j MASQUERADE
iptables -t nat -A zone_lan_postrouting -j MASQUERADE -o pppoa-wan


On 16/05/2015 12:00, openwrt-devel-requ...@lists.openwrt.org wrote:

--

Message: 5
Date: Sat, 16 May 2015 01:27:38 +0200
From: Lars Kruseli...@sumpfralle.de
To:openwrt-devel@lists.openwrt.org
Subject: Re: [OpenWrt-Devel] External (public) IP forwarded to
internal LAN [SOLVED]
Message-ID:20150516012738.7c28d...@erker.lan
Content-Type: text/plain; charset=US-ASCII

Hi Angelo,


[..]
Doest this is an error or normal behaviour  of fw3 ?

Could you add the network and the firewall configuration files?

Lars


--

___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] How to track IO usage of internal flash mtd partitions?

2015-05-18 Thread José Vázquez
Try iostat (selectable in busybox). Maybe is what are you looking for.

2015-05-17 0:40 GMT+02:00, valent.turko...@gmail.com
valent.turko...@gmail.com:
 Here is some interesting info I found using mtdinfo tool:

 # mtdinfo /dev/mtd5
 mtd5
 Name:   rootfs_data
 Type:   nor
 Eraseblock size:65536 bytes, 64.0 KiB
 Amount of eraseblocks:  104 (6815744 bytes, 6.5 MiB)
 Minimum input/output unit size: 1 byte
 Sub-page size:  1 byte
 Character device major/minor:   90:10
 Bad blocks are allowed: false
 Device is writable: true

 So I see there are 104 eraseblocks on this partition. Interesting so
 see finaly some numbers. Now how to see how many times these
 eraseblock were issued erase eraseblock command?
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] [PATCH] Vlan configuration, limit the used ports

2015-05-18 Thread Rafał Miłecki
On 18 May 2015 at 12:12, Hante Meuleman meule...@broadcom.com wrote:
 Tested a clean checkout this morning and booted it. It is booting, but no
 packets are received. At least the ifconfig shows no RX packets, could be
 that the packets miss the vlan tag.

Can you see swconfig forcing port 8 state?
swconfig dev switch0 show | grep link

Can you debug what else is missing in b53 to support switch port 8? I
think we have all the other stuff already in place.
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel