Re: [PATCH] iproute2: update to 5.9

2020-11-13 Thread Hauke Mehrtens

On 11/12/20 6:18 PM, Hans Dedecker wrote:

Update iproute2 to latest stable 5.9; for the changes see 
https://lwn.net/Articles/834755/

Refresh patches

Signed-off-by: Hans Dedecker 


Acked-by: Hauke Mehrtens 


---
  package/network/utils/iproute2/Makefile | 4 ++--
  .../utils/iproute2/patches/115-add-config-xtlibdir.patch| 2 +-
  .../utils/iproute2/patches/175-reduce-dynamic-syms.patch| 6 +++---
  3 files changed, 6 insertions(+), 6 deletions(-)

diff --git a/package/network/utils/iproute2/Makefile 
b/package/network/utils/iproute2/Makefile
index 90f8b59a02..237f84736b 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -8,12 +8,12 @@
  include $(TOPDIR)/rules.mk
  
  PKG_NAME:=iproute2

-PKG_VERSION:=5.8.0
+PKG_VERSION:=5.9.0
  PKG_RELEASE:=1
  
  PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz

  PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
-PKG_HASH:=cfcd1f890290f8c8afcc91d9444ad929b9252c16f9ab3f286c50dd3c59dc646e
+PKG_HASH:=a25dac94bcdcf2f73316c7f812115ea7a5710580bad892b08a83d00c6b33dacf
  PKG_BUILD_PARALLEL:=1
  PKG_BUILD_DEPENDS:=iptables
  PKG_LICENSE:=GPL-2.0
diff --git 
a/package/network/utils/iproute2/patches/115-add-config-xtlibdir.patch 
b/package/network/utils/iproute2/patches/115-add-config-xtlibdir.patch
index 03df7809f7..8702d5fd2d 100644
--- a/package/network/utils/iproute2/patches/115-add-config-xtlibdir.patch
+++ b/package/network/utils/iproute2/patches/115-add-config-xtlibdir.patch
@@ -1,6 +1,6 @@
  --- a/tc/Makefile
  +++ b/tc/Makefile
-@@ -127,6 +127,9 @@ CFLAGS += -DCONFIG_GACT -DCONFIG_GACT_PR
+@@ -128,6 +128,9 @@ CFLAGS += -DCONFIG_GACT -DCONFIG_GACT_PR
   ifneq ($(IPT_LIB_DIR),)
CFLAGS += -DIPT_LIB_DIR=\"$(IPT_LIB_DIR)\"
   endif
diff --git 
a/package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch 
b/package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch
index e5d5492a35..da961a183b 100644
--- a/package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch
+++ b/package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch
@@ -9,7 +9,7 @@
   endif
   
   TCLIB := tc_core.o

-@@ -143,7 +143,7 @@ MODDESTDIR := $(DESTDIR)$(LIBDIR)/tc
+@@ -144,7 +144,7 @@ MODDESTDIR := $(DESTDIR)$(LIBDIR)/tc
   all: tc $(TCSO)
   
   tc: $(TCOBJ) $(LIBNETLINK) libtc.a

@@ -18,7 +18,7 @@
   
   libtc.a: $(TCLIB)

$(QUIET_AR)$(AR) rcs $@ $^
-@@ -165,6 +165,7 @@ install: all
+@@ -166,6 +166,7 @@ install: all
   clean:
rm -f $(TCOBJ) $(TCLIB) libtc.a tc *.so emp_ematch.tab.h; \
rm -f emp_ematch.tab.*
@@ -26,7 +26,7 @@
   
   q_atm.so: q_atm.c

$(QUIET_CC)$(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -shared -fpic -o 
q_atm.so q_atm.c -latm
-@@ -204,4 +205,15 @@ static-syms.h: $(wildcard *.c)
+@@ -205,4 +206,15 @@ static-syms.h: $(wildcard *.c)
sed -n '/'$$s'[^ ]* =/{s:.* \([^ ]*'$$s'[^ ]*\) .*:extern char \1[] 
__attribute__((weak)); if (!strcmp(sym, "\1")) return \1;:;p}' $$files ; \
done > $@
   




___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


[PATCH v2 2/2] mvebu: LS421DE: improve the HDD leds

2020-11-13 Thread Daniel González Cabanelas
Improve the HDD LEDs used for disk activity:
 - Use the trigger activity per ata channel

Signed-off-by: Daniel González Cabanelas 
---
changes in V2: deleted label modification

 .../files/arch/arm/boot/dts/armada-370-buffalo-ls421de.dts| 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git 
a/target/linux/mvebu/files/arch/arm/boot/dts/armada-370-buffalo-ls421de.dts 
b/target/linux/mvebu/files/arch/arm/boot/dts/armada-370-buffalo-ls421de.dts
index 7e070f49dc..9a62669e4c 100644
--- a/target/linux/mvebu/files/arch/arm/boot/dts/armada-370-buffalo-ls421de.dts
+++ b/target/linux/mvebu/files/arch/arm/boot/dts/armada-370-buffalo-ls421de.dts
@@ -153,14 +153,14 @@
label = "ls421de:red:hdd1";
gpios = < 29 GPIO_ACTIVE_HIGH>;
default-state = "off";
-   linux,default-trigger = "disk-activity";
+   linux,default-trigger = "ata1";
};
 
hdd2_red {
label = "ls421de:red:hdd2";
gpios = < 30 GPIO_ACTIVE_HIGH>;
default-state = "off";
-   linux,default-trigger = "disk-activity";
+   linux,default-trigger = "ata2";
};
};
 
-- 
2.29.2





___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


[PATCH v2 1/2] mvebu: LS421DE: fix low performance issue

2020-11-13 Thread Daniel González Cabanelas
The Buffalo Linkstation LS421DE isn't able to enable the Level 2 cache
(AKA Aurora cache). As of result of this, the throughput is about half of
the expected, e.g when doing network data transfers.

Fix it by adding the broken-idle property in the coherency fabric node.

Signed-off-by: Daniel González Cabanelas 
---
changes in V2: fixed typo in commit log 

 .../files/arch/arm/boot/dts/armada-370-buffalo-ls421de.dts| 4 
 1 file changed, 4 insertions(+)

diff --git 
a/target/linux/mvebu/files/arch/arm/boot/dts/armada-370-buffalo-ls421de.dts 
b/target/linux/mvebu/files/arch/arm/boot/dts/armada-370-buffalo-ls421de.dts
index 4589886190..7e070f49dc 100644
--- a/target/linux/mvebu/files/arch/arm/boot/dts/armada-370-buffalo-ls421de.dts
+++ b/target/linux/mvebu/files/arch/arm/boot/dts/armada-370-buffalo-ls421de.dts
@@ -211,6 +211,10 @@
};
 };
 
+ {
+   broken-idle;
+};
+
  {
pinctrl-0 = <_rgmii_pins>;
pinctrl-names = "default";
-- 
2.29.2





___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


Re: [PATCH 19.07] kernel: Update kernel 4.14 to version 4.14.206

2020-11-13 Thread Koen Vandeputte



On 13.11.20 13:35, Adrian Schmutzler wrote:

-Original Message-
From: openwrt-devel [mailto:openwrt-devel-boun...@lists.openwrt.org]
On Behalf Of Josef Schlehofer
Sent: Freitag, 13. November 2020 09:33
To: openwrt-devel@lists.openwrt.org
Cc: Hauke Mehrtens 
Subject: [PATCH 19.07] kernel: Update kernel 4.14 to version 4.14.206

From: Hauke Mehrtens 

This is a security update as currently in OpenWrt 19.07, there is version
4.14.202 it means that it is vulnerable against vulnerability known as Sad DNS
(DNS cache poisoning). Since kernel 4.14.203, there is present mitigation to
this attack by randomizing ICMP global rate limit.

More details can be found here: https://www.saddns.net/

Compile and runtime tested on x86/64.
Also compile and run tested on all Turris devices (Turris 1.x - powerpc 8540,
Turris Omnia - mvebu/cortex-a9_vfpv3-d16, Turris MOX -
mvebu/aarch64_cortex-a53)

Signed-off-by: Hauke Mehrtens  (cherry picked from
commit 9cdc02be88d5c25791664b1baaf9a7c1a4382c95)
Signed-off-by: Josef Schlehofer  [added
commit message about run testing on Turris devices, added mention about
Sad DNS]


Did you just pick the patch or properly refresh patches again?

Best

Adrian



fwiw,

I took my .205 patch and bumped it again with .206
It's already in my staging tree and compile tests already executed.

Regards,

Koen


___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


RE: [PATCH 19.07] kernel: Update kernel 4.14 to version 4.14.206

2020-11-13 Thread Adrian Schmutzler
> -Original Message-
> From: openwrt-devel [mailto:openwrt-devel-boun...@lists.openwrt.org]
> On Behalf Of Josef Schlehofer
> Sent: Freitag, 13. November 2020 09:33
> To: openwrt-devel@lists.openwrt.org
> Cc: Hauke Mehrtens 
> Subject: [PATCH 19.07] kernel: Update kernel 4.14 to version 4.14.206
> 
> From: Hauke Mehrtens 
> 
> This is a security update as currently in OpenWrt 19.07, there is version
> 4.14.202 it means that it is vulnerable against vulnerability known as Sad DNS
> (DNS cache poisoning). Since kernel 4.14.203, there is present mitigation to
> this attack by randomizing ICMP global rate limit.
> 
> More details can be found here: https://www.saddns.net/
> 
> Compile and runtime tested on x86/64.
> Also compile and run tested on all Turris devices (Turris 1.x - powerpc 8540,
> Turris Omnia - mvebu/cortex-a9_vfpv3-d16, Turris MOX -
> mvebu/aarch64_cortex-a53)
> 
> Signed-off-by: Hauke Mehrtens  (cherry picked from
> commit 9cdc02be88d5c25791664b1baaf9a7c1a4382c95)
> Signed-off-by: Josef Schlehofer  [added
> commit message about run testing on Turris devices, added mention about
> Sad DNS]


Did you just pick the patch or properly refresh patches again?

Best

Adrian

> ---
>  include/kernel-version.mk | 4 ++--
>  target/linux/cns3xxx/patches-4.14/210-dwc2_defaults.patch | 2 +-
>  ...030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch | 2 +-
>  target/linux/generic/hack-4.14/204-module_strip.patch | 2 +-
>  target/linux/generic/hack-4.14/930-crashlog.patch | 2 +-
>  .../generic/pending-4.14/203-kallsyms_uncompressed.patch  | 2 +-
>  target/linux/generic/pending-4.14/920-mangle_bootargs.patch   | 2 +-
>  .../0067-generic-Mangle-bootloader-s-kernel-arguments.patch   | 2 +-
>  target/linux/mediatek/patches-4.14/0064-dts.patch | 2 +-
>  ...arm64-mediatek-cleanup-message-for-platform-selectio.patch | 2 +-
>  .../006-mvebu-Mangle-bootloader-s-kernel-arguments.patch  | 2 +-
>  .../linux/mvebu/patches-4.14/411-sfp-add-sfp-compatible.patch | 2 +-
> ...arm64-dts-armada-3720-espressobin-set-max-link-to-ge.patch | 2 +-
> .../octeon/patches-4.14/110-er200-ethernet_probe_order.patch  | 4 ++--
>  .../996-generic-Mangle-bootloader-s-kernel-arguments.patch| 2 +-
>  15 files changed, 17 insertions(+), 17 deletions(-)
> 
> diff --git a/include/kernel-version.mk b/include/kernel-version.mk index
> a58b17fbf4..e581897dc1 100644
> --- a/include/kernel-version.mk
> +++ b/include/kernel-version.mk
> @@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
>KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
>  endif
> 
> -LINUX_VERSION-4.14 = .202
> +LINUX_VERSION-4.14 = .206
> 
> -LINUX_KERNEL_HASH-4.14.202 =
> 95c717ab5b0bdd2333e829f0507385fbe3424ceee810727f3a8551a0c74be328
> +LINUX_KERNEL_HASH-4.14.206 =
> +1c233efaa5063983293a02d4692acc9ced9c03e18857364855d4f612347086ac
> 
>  remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1
> sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -
> ,_,$(subst /,_,$(1))) diff --git a/target/linux/cns3xxx/patches-4.14/210-
> dwc2_defaults.patch b/target/linux/cns3xxx/patches-4.14/210-
> dwc2_defaults.patch
> index 67f152f43d..0cc4dd1830 100644
> --- a/target/linux/cns3xxx/patches-4.14/210-dwc2_defaults.patch
> +++ b/target/linux/cns3xxx/patches-4.14/210-dwc2_defaults.patch
> @@ -43,7 +43,7 @@
>   {
>  +/*
>   const struct of_device_id *match;
> - void (*set_params)(void *data);
> + void (*set_params)(struct dwc2_hsotg *data);
>  +*/
> 
>   dwc2_set_default_params(hsotg);
> diff --git a/target/linux/generic/backport-4.14/030-USB-serial-option-fix-
> dwm-158-3g-modem-interface.patch b/target/linux/generic/backport-
> 4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch
> index ebd90a8ef2..4ad22b3de1 100644
> --- a/target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-
> 3g-modem-interface.patch
> +++ b/target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-1
> +++ 58-3g-modem-interface.patch
> @@ -30,7 +30,7 @@ Signed-off-by: Johan Hovold 
> 
>  --- a/drivers/usb/serial/option.c
>  +++ b/drivers/usb/serial/option.c
> -@@ -2001,7 +2001,8 @@ static const struct usb_device_id option
> +@@ -2011,7 +2011,8 @@ static const struct usb_device_id option
>   { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d01, 0xff) },
>   /* D-Link DWM-156 (variant) */
>   { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d02, 0xff) },
>   { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d03, 0xff) }, diff --git
> a/target/linux/generic/hack-4.14/204-module_strip.patch
> b/target/linux/generic/hack-4.14/204-module_strip.patch
> index c53963c530..d93b545b7c 100644
> --- a/target/linux/generic/hack-4.14/204-module_strip.patch
> +++ b/target/linux/generic/hack-4.14/204-module_strip.patch
> @@ -98,7 +98,7 @@ Signed-off-by: Felix Fietkau 
> 
>  --- a/init/Kconfig
>  +++ b/init/Kconfig
> -@@ -1903,6 +1903,13 @@ config TRIM_UNUSED_KSYMS
> 

Re: [PATCH] Revert "netifd: update to the latest version"

2020-11-13 Thread e9hack
Am 13.11.2020 um 11:19 schrieb Rui Salvaterra:
> This broke the switch VLAN configuration on at least Archer C6 v2 EU and 
> Archer
> C7 (both switchdev-based one-armed routers).

Which Archer C7 version is mentioned here? I'm using an Archer C7 v2 and didn't 
see any issues. 

Regards,
Hartmut


___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


Re: [PATCH] Revert "netifd: update to the latest version"

2020-11-13 Thread Rui Salvaterra
On Fri, 13 Nov 2020 at 10:35, Felix Fietkau  wrote:
>
> Please show me the full /etc/config/network so I can test with it as-is.

Here it goes (WG keys redacted):

config interface 'loopback'
option ifname 'lo'
option proto 'static'
list ipaddr '127.0.0.1/8'

config interface 'lan'
option ifname 'eth0.1'
option ipv6 '0'
option proto 'static'
option type 'bridge'
list ipaddr '192.168.16.1/24'

config interface 'tor'
option ipv6 '0'
option proto 'static'
option type 'bridge'
list ipaddr '192.168.17.1/24'

config interface 'gst'
option ipv6 '0'
option proto 'static'
option type 'bridge'
list ipaddr '192.168.18.1/24'

config interface 'pub'
option ipv6 '0'
option proto 'static'
option type 'bridge'
list ipaddr '192.168.19.1/24'

config interface 'wgl'
option ipv6 '0'
option listen_port '995'
option proto 'wireguard'
list addresses '10.0.0.1/29'

config wireguard_wgl
option route_allowed_ips '1'
list allowed_ips '192.168.240.0/24'

config wireguard_wgl
list allowed_ips '10.0.0.4/32'

config wireguard_wgl
list allowed_ips '10.0.0.5/32'

config interface 'wgt'
option ipv6 '0'
option listen_port '443'
option proto 'wireguard'
list addresses '10.0.1.1/30'

config wireguard_wgt
list allowed_ips '10.0.1.2/32'

config interface 'wgk'
option ipv6 '0'
option listen_port '80'
option proto 'wireguard'
list addresses '10.0.2.2/30'

config wireguard_wgk
option endpoint_host '62.28.38.138'
option endpoint_port '443'
option route_allowed_ips '1'
list allowed_ips '192.168.1.0/24'

config interface 'wan'
option ifname 'eth0.2'
option ipv6 '0'
option proto 'dhcp'

config switch
option enable_vlan '1'
option name 'switch0'
option reset '1'

config switch_vlan
option device 'switch0'
option ports '2 3 4 5 0t'
option vlan '1'

config switch_vlan
option device 'switch0'
option ports '1 0t'
option vlan '2'

Thanks,
Rui

___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


Re: [PATCH] Revert "netifd: update to the latest version"

2020-11-13 Thread Felix Fietkau


On 2020-11-13 11:34, Rui Salvaterra wrote:
> Hi, Felix,
> 
> On Fri, 13 Nov 2020 at 10:25, Felix Fietkau  wrote:
>>
>> Please git-bisect this and show me the config that doesn't work anymore,
>> so that I can fix it properly.
> 
> I can't bisect this now, as I'm using the router. The config (in
> /etc/config/network), however, is trivial:
> 
> config switch
> option enable_vlan '1'
> option name 'switch0'
> option reset '1'
> 
> config switch_vlan
> option device 'switch0'
> option ports '2 3 4 5 0t'
> option vlan '1'
> 
> config switch_vlan
> option device 'switch0'
> option ports '1 0t'
> option vlan '2'
> 
> Symptom: with the netifd update, only the VLAN 1 (eth0.1@eth0)
> interface exists, VLAN 2 (eth0.2@eth0) doesn't.
Please show me the full /etc/config/network so I can test with it as-is.

Thanks,

- Felix

___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


Re: [PATCH] Revert "netifd: update to the latest version"

2020-11-13 Thread Rui Salvaterra
Hi, Felix,

On Fri, 13 Nov 2020 at 10:25, Felix Fietkau  wrote:
>
> Please git-bisect this and show me the config that doesn't work anymore,
> so that I can fix it properly.

I can't bisect this now, as I'm using the router. The config (in
/etc/config/network), however, is trivial:

config switch
option enable_vlan '1'
option name 'switch0'
option reset '1'

config switch_vlan
option device 'switch0'
option ports '2 3 4 5 0t'
option vlan '1'

config switch_vlan
option device 'switch0'
option ports '1 0t'
option vlan '2'

Symptom: with the netifd update, only the VLAN 1 (eth0.1@eth0)
interface exists, VLAN 2 (eth0.2@eth0) doesn't.

Thanks,
Rui

___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


Re: [PATCH] Revert "netifd: update to the latest version"

2020-11-13 Thread Felix Fietkau


On 2020-11-13 11:19, Rui Salvaterra wrote:
> This broke the switch VLAN configuration on at least Archer C6 v2 EU and 
> Archer
> C7 (both switchdev-based one-armed routers).
> 
> Signed-off-by: Rui Salvaterra 
Please git-bisect this and show me the config that doesn't work anymore,
so that I can fix it properly.

Thanks,

- Felix

___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


[PATCH] Revert "netifd: update to the latest version"

2020-11-13 Thread Rui Salvaterra
This broke the switch VLAN configuration on at least Archer C6 v2 EU and Archer
C7 (both switchdev-based one-armed routers).

Signed-off-by: Rui Salvaterra 
---
 package/network/config/netifd/Makefile | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/package/network/config/netifd/Makefile 
b/package/network/config/netifd/Makefile
index 92bdb34fc8..2c26517f44 100644
--- a/package/network/config/netifd/Makefile
+++ b/package/network/config/netifd/Makefile
@@ -5,9 +5,9 @@ PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/netifd.git
-PKG_SOURCE_DATE:=2020-11-05
-PKG_SOURCE_VERSION:=ed11f0c0ffe4fdacfe3f8223049ef8a61d9c53e9
-PKG_MIRROR_HASH:=0abd8aaa3818147b6a550a054d97c6cd21d22e806195d863aa87b6b2c808d409
+PKG_SOURCE_DATE:=2020-10-22
+PKG_SOURCE_VERSION:=24ce1eab4910869576406bafd0489daf0d3e6e28
+PKG_MIRROR_HASH:=aa73b4e470e81165baba0262144f410bb05a3ff141cf72ad451914f033868ea1
 PKG_MAINTAINER:=Felix Fietkau 
 
 PKG_LICENSE:=GPL-2.0
-- 
2.29.2


___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


[PATCH 19.07] kernel: Update kernel 4.14 to version 4.14.206

2020-11-13 Thread Josef Schlehofer
From: Hauke Mehrtens 

This is a security update as currently in OpenWrt 19.07, there is
version 4.14.202 it means that it is vulnerable against vulnerability
known as Sad DNS (DNS cache poisoning). Since kernel 4.14.203, there is
present mitigation to this attack by randomizing ICMP global rate limit.

More details can be found here: https://www.saddns.net/

Compile and runtime tested on x86/64.
Also compile and run tested on all Turris devices
(Turris 1.x - powerpc 8540, Turris Omnia - mvebu/cortex-a9_vfpv3-d16,
Turris MOX - mvebu/aarch64_cortex-a53)

Signed-off-by: Hauke Mehrtens 
(cherry picked from commit 9cdc02be88d5c25791664b1baaf9a7c1a4382c95)
Signed-off-by: Josef Schlehofer 
[added commit message about run testing on Turris devices, added mention
about Sad DNS]
---
 include/kernel-version.mk | 4 ++--
 target/linux/cns3xxx/patches-4.14/210-dwc2_defaults.patch | 2 +-
 ...030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch | 2 +-
 target/linux/generic/hack-4.14/204-module_strip.patch | 2 +-
 target/linux/generic/hack-4.14/930-crashlog.patch | 2 +-
 .../generic/pending-4.14/203-kallsyms_uncompressed.patch  | 2 +-
 target/linux/generic/pending-4.14/920-mangle_bootargs.patch   | 2 +-
 .../0067-generic-Mangle-bootloader-s-kernel-arguments.patch   | 2 +-
 target/linux/mediatek/patches-4.14/0064-dts.patch | 2 +-
 ...arm64-mediatek-cleanup-message-for-platform-selectio.patch | 2 +-
 .../006-mvebu-Mangle-bootloader-s-kernel-arguments.patch  | 2 +-
 .../linux/mvebu/patches-4.14/411-sfp-add-sfp-compatible.patch | 2 +-
 ...arm64-dts-armada-3720-espressobin-set-max-link-to-ge.patch | 2 +-
 .../octeon/patches-4.14/110-er200-ethernet_probe_order.patch  | 4 ++--
 .../996-generic-Mangle-bootloader-s-kernel-arguments.patch| 2 +-
 15 files changed, 17 insertions(+), 17 deletions(-)

diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index a58b17fbf4..e581897dc1 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-4.14 = .202
+LINUX_VERSION-4.14 = .206
 
-LINUX_KERNEL_HASH-4.14.202 = 
95c717ab5b0bdd2333e829f0507385fbe3424ceee810727f3a8551a0c74be328
+LINUX_KERNEL_HASH-4.14.206 = 
1c233efaa5063983293a02d4692acc9ced9c03e18857364855d4f612347086ac
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst 
-,_,$(subst /,_,$(1)))
diff --git a/target/linux/cns3xxx/patches-4.14/210-dwc2_defaults.patch 
b/target/linux/cns3xxx/patches-4.14/210-dwc2_defaults.patch
index 67f152f43d..0cc4dd1830 100644
--- a/target/linux/cns3xxx/patches-4.14/210-dwc2_defaults.patch
+++ b/target/linux/cns3xxx/patches-4.14/210-dwc2_defaults.patch
@@ -43,7 +43,7 @@
  {
 +  /*
const struct of_device_id *match;
-   void (*set_params)(void *data);
+   void (*set_params)(struct dwc2_hsotg *data);
 +  */
  
dwc2_set_default_params(hsotg);
diff --git 
a/target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch
 
b/target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch
index ebd90a8ef2..4ad22b3de1 100644
--- 
a/target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch
+++ 
b/target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch
@@ -30,7 +30,7 @@ Signed-off-by: Johan Hovold 
 
 --- a/drivers/usb/serial/option.c
 +++ b/drivers/usb/serial/option.c
-@@ -2001,7 +2001,8 @@ static const struct usb_device_id option
+@@ -2011,7 +2011,8 @@ static const struct usb_device_id option
{ USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d01, 0xff) },   
/* D-Link DWM-156 (variant) */
{ USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d02, 0xff) },
{ USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d03, 0xff) },
diff --git a/target/linux/generic/hack-4.14/204-module_strip.patch 
b/target/linux/generic/hack-4.14/204-module_strip.patch
index c53963c530..d93b545b7c 100644
--- a/target/linux/generic/hack-4.14/204-module_strip.patch
+++ b/target/linux/generic/hack-4.14/204-module_strip.patch
@@ -98,7 +98,7 @@ Signed-off-by: Felix Fietkau 
  
 --- a/init/Kconfig
 +++ b/init/Kconfig
-@@ -1903,6 +1903,13 @@ config TRIM_UNUSED_KSYMS
+@@ -1904,6 +1904,13 @@ config TRIM_UNUSED_KSYMS
  
  If unsure, or if you need to build out-of-tree modules, say N.
  
diff --git a/target/linux/generic/hack-4.14/930-crashlog.patch 
b/target/linux/generic/hack-4.14/930-crashlog.patch
index 9d09dbd760..2da51fb406 100644
--- a/target/linux/generic/hack-4.14/930-crashlog.patch
+++ b/target/linux/generic/hack-4.14/930-crashlog.patch
@@ -41,7 +41,7 @@ Signed-off-by: Felix Fietkau 
 +#endif
 --- a/init/Kconfig
 +++ b/init/Kconfig
-@@ -1009,6 +1009,10 @@ config RELAY
+@@ -1010,6