Re: [ovs-discuss] OVS 2.8.1 changes the rates of data packets!

2017-12-09 Thread Dawood Sajjadi
I didn't make any conclusion. I just stated whatever I have experienced and
as I mentioned before since by removing the wireless interfaces from the
bridge, there is no rate limitation problem, then (at least) OVS plays a
role in this problem. Ben: may I know what do you suggest to deal with this
problem?

On Fri, Dec 8, 2017 at 7:44 PM, Ben Pfaff  wrote:

> It seems like you're just jumping to conclusions here.  What have you
> done to understand the situation?
>
> On Fri, Dec 08, 2017 at 05:59:57PM -0800, Dawood Sajjadi wrote:
> > when I remove the wireless interfaces from the bridge, there is no
> problem.
> > However, as soon as adding the wireless interfaces to the bridge, the
> > problem shows up. So, it seems OVS (at least) is a part of the problem.
> >
> > On Fri, Dec 8, 2017 at 5:55 PM, Ben Pfaff  wrote:
> >
> > > On December 8, 2017 5:53:44 PM PST, Dawood Sajjadi <
> s.d.sajj...@gmail.com>
> > > wrote:
> > >>
> > >> I created a bridge using OVS 2.8.1 in Ubuntu 14.04. The bridge
> contains 4
> > >> physical ports including one ethernet and three wireless ports. The
> > >> ethernet port is connected to a laptop that generated dummy traffic
> using
> > >> Iperf. So, the ethernet port is used as the incoming port and the
> generated
> > >> traffic leaves the bridge through the wireless (as the outgoing)
> ports. I
> > >> used tcpdump to capture the traffic at the incoming and outgoing
> ports of
> > >> the bridge and I noticed that the volume of the outgoing traffic (at
> the
> > >> wireless ports) is by far lower than the amount of the incoming
> traffic
> > >> (from the ethernet port). It seems the OVS bridge drops/limits the
> rate of
> > >> outgoing packets. For instance, if the size of the captured traffic
> using
> > >> tcpdump at eth0 is 15 MB, the total size of the captured traffic on
> > >> wireless ports is 3 MB!
> > >>
> > >> I didn't make any change in the default configuration of the OVS.
> Also,
> > >> to ensure that there is no predefined Queue/QoS policy at the bridge,
> I
> > >> used "ovs-vsctl --all destroy qos && ovs-vsctl --all destroy queue"
> > >> command. However, the problem persists! Has anyone encountered such an
> > >> issue before? I really appreciate having your feedback. Thanks.
> > >>
> > >
> > > OVS doesn't change data rates. You should try to figure out what's
> going
> > > on without making that assumption.
> > >
>
___
discuss mailing list
disc...@openvswitch.org
https://mail.openvswitch.org/mailman/listinfo/ovs-discuss


Re: [ovs-discuss] Ubuntu 16.04 Openvswitch bridge on bond

2017-12-09 Thread Raymond Burkholder
> I am attempting to setup a linux bond and create a openvswitch bridge that
> uses this bond0 on Ubuntu 16.04.03 using a cisco 2960 switch with
> openvswitch version 255.2.

Take a look at 

https://github.com/openvswitch/ovs/blob/master/debian/openvswitch-switch.REA
DME.Debian

It has a number of examples.

In addition, I have found that I need to create manual entries for bond
members to ensure that they come up (do this only if you find they don't
come up)



> 
> On the Ubuntu server I have configured
> 
> # /etc/modprobe.d/bonding.conf
> alias bond0 bonding
> options bonding mode=4 miimon=100 lacp_rate=1
> 
> # /etc/network/interfaces
> auto eno1
> iface eno1 inet manual
>   bond-master bond0
> 
> auto eno2
> iface eno2 inet manual
>   bond-master bond0
> 
> auto bond0
> allow-br0 bond0
> iface bond0 inet manual
>   bond-slaves eno1 eno2
>   ovs_bridge br0
>   ovs_type OVSPort
> 
> auto br0
> allow-ovs br0
> iface br0 inet static
>   address 192.168.0.8
>   netmask 255.255.255.0
>   gateway 192.168.0.1
>   dns-nameservers 192.168.0.1
>   ovs_type OVSBridge
>   ovs_ports br0
> 
> On the Cisco switch I have my LAN 192.168.0.1 connect to port G0/1 on
access
> port and created ether-channel and connected ports G0/7 and G0/8 to my
> Ubuntu server.  Vlan 1 to make things simple.
> 
> # show run
> interface Port-channel1
>  switchport mode access
> 
> interface GigabitEthernet0/7
>  switchport mode access
>  channel-protocol lacp
>  channel-group 1 mode active
> !
> interface GigabitEthernet0/8
>  switchport mode access
>  channel-protocol lacp
>  channel-group 1 mode active
> 
> From the switch I can see the LACP neighbours
> 
> Switch#show lacp neighbor
>   LACP portAdmin  Oper   Port
Port
> Port  Flags   Priority  Dev ID  AgekeyKeyNumber
> State
> Gi0/7 SA  255   a01d.48c7.7618  26s0x00x90x2
0x3D
> Gi0/8 SA  255   a01d.48c7.7618  25s0x00x90x1
0x3D
> 
> However, I am unable to get my Ubuntu server to be able to ping any
devices
> on my local network.  From my switch I can ping other devices my network
> apart from the Ubuntu server.
> 
> Could someone explain to me what I have missed with regards to this setup?
> 
> Thanks
> 
> Densha
> 
> ___
> discuss mailing list
> disc...@openvswitch.org
> https://mail.openvswitch.org/mailman/listinfo/ovs-discuss
> 
> --
> This message has been scanned for viruses and dangerous content by
> MailScanner, and is believed to be clean.



-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

___
discuss mailing list
disc...@openvswitch.org
https://mail.openvswitch.org/mailman/listinfo/ovs-discuss


Re: [ovs-discuss] OVSDB connection keep-alive vs. echo RPC

2017-12-09 Thread Matt Layher via discuss
Thank you both for the information.  I've implemented an optional 
client-initiated echo option, and the ability to echo when prompted by 
the server.


- Matt


On 12/07/2017 03:43 PM, Ben Pfaff wrote:

On Thu, Dec 07, 2017 at 01:59:45PM -0500, Matt Layher via discuss wrote:

But that leads me to another question: does ovsdb-server send echo RPCs to
its clients at all?  If so, I can implement something to reply in my receive
loop.  If not, I won't bother.

Yes, it does (unless configured not to do that).


___
discuss mailing list
disc...@openvswitch.org
https://mail.openvswitch.org/mailman/listinfo/ovs-discuss


[ovs-discuss] Ubuntu 16.04 Openvswitch bridge on bond

2017-12-09 Thread densha
Hi Forum,

I am attempting to setup a linux bond and create a openvswitch bridge that
uses this bond0 on Ubuntu 16.04.03 using a cisco 2960 switch with
openvswitch version 255.2.

On the Ubuntu server I have configured

# /etc/modprobe.d/bonding.conf
alias bond0 bonding
options bonding mode=4 miimon=100 lacp_rate=1

# /etc/network/interfaces
auto eno1
iface eno1 inet manual
  bond-master bond0

auto eno2
iface eno2 inet manual
  bond-master bond0

auto bond0
allow-br0 bond0
iface bond0 inet manual
  bond-slaves eno1 eno2
  ovs_bridge br0
  ovs_type OVSPort

auto br0
allow-ovs br0
iface br0 inet static
  address 192.168.0.8
  netmask 255.255.255.0
  gateway 192.168.0.1
  dns-nameservers 192.168.0.1
  ovs_type OVSBridge
  ovs_ports br0

On the Cisco switch I have my LAN 192.168.0.1 connect to port G0/1 on
access port and created ether-channel and connected ports G0/7 and G0/8 to
my Ubuntu server.  Vlan 1 to make things simple.

# show run
interface Port-channel1
 switchport mode access

interface GigabitEthernet0/7
 switchport mode access
 channel-protocol lacp
 channel-group 1 mode active
!
interface GigabitEthernet0/8
 switchport mode access
 channel-protocol lacp
 channel-group 1 mode active

>From the switch I can see the LACP neighbours

Switch#show lacp neighbor
  LACP portAdmin  Oper   PortPort
Port  Flags   Priority  Dev ID  AgekeyKeyNumber 
State
Gi0/7 SA  255   a01d.48c7.7618  26s0x00x90x2 0x3D
Gi0/8 SA  255   a01d.48c7.7618  25s0x00x90x1 0x3D

However, I am unable to get my Ubuntu server to be able to ping any
devices on my local network.  From my switch I can ping other devices my
network apart from the Ubuntu server.

Could someone explain to me what I have missed with regards to this setup?

Thanks

Densha

___
discuss mailing list
disc...@openvswitch.org
https://mail.openvswitch.org/mailman/listinfo/ovs-discuss