Re: [pass] ***UNCHECKED*** Re: [Feature Request] Add a `--raw` option to `pass ls`

2016-11-10 Thread Kenny Evitt
Alternatively, Pass could simply commit to its current implementation of
using the filesystem as it does and that would resolve any potential future
incompatibility issues just as well. If we were voting, that's what I would
vote for.

The Pass website  currently seems to
support such an interpretation:

> Password management should be simple and follow Unix philosophy
. With pass, each password
lives inside of a gpg encrypted file whose filename is the title of the
website or resource that requires the password. These encrypted files may
be organized into meaningful folder hierarchies, copied from computer to
computer, and, in general, manipulated using standard command line file
management utilities.

Every program that uses the filesystem doesn't need to provide an API with
its own abstraction over the filesystem. Anything that wants to can just
use the filesystem directly!



Even assuming that the existing patches are complete and without bugs,
there's documentation too both in Pass itself, the Pass man page, and the
Pass website, all of which might need or warrant being updated. But then of
course there's the cost of maintaining that feature indefinitely too.
Please be considerate in *expecting *someone else to commit to doing that
work for you. I'm not claiming you are, but you certainly seem to be
minimizing the amount of potential work that needs to be done.

If we're properly accounting for all of the effort involved by everyone
anywhere, the easiest thing for you to do would be to just maintain your
own private fork of Pass with whatever patches you want to incorporate. I'm
considering doing that myself precisely because writing long commands or
maintaining separate scripts is a 'hassle'. Tho of course maintaining a
fork is a 'hassle' too. Trade-offs abound!

On Thu, Nov 10, 2016 at 2:45 AM, Linden Krouse  wrote:

> While you could read the password directory directly, wouldn't it be
> better for future compatibly to have pass print the raw key names? If pass
> ever changes the way it stores it's passwords, every script relying on the
> current layout will break. Also, `{ cd 
> ${PASSWORD_STORE_DIR:-$HOME/.password-store};
> find -type f -name '*.gpg' -printf "%P\n" | sed 's/\.gpg$//'; }` is much
> longer and more difficult to read than `pass ls --raw` which
> describes exactly what is being done. Having to do this repeatedly, or
> create and store a script specifically to do this just adds more hassle to
> pass.
>
> Lastly, at least one other person has written a patch to add this feature
> so it wouldn't take any additional effort to implement, as the work as
> already been done.
>
> On Wed, Nov 9, 2016 at 3:43 PM, Lenz Weber  wrote:
>
>> Actually, if you want to write a software to use that ouput this should
>> be quite intuitive for you, yes.
>>
>> Even simpler would be
>>
>> { cd ${PASSWORD_STORE_DIR:-$HOME/.password-store}; find -type f -name
>> '*.gpg' -printf "%P\n" | sed 's/\.gpg$//'; }
>>
>> just don't forget the braces.
>>
>> Am 09.11.2016 um 21:22 schrieb Tobias Girstmair:
>> >> TL;DR We don't need `pass ls --raw` because we have `ls -1`
>> >
>> > well, `ls -1` doesn't exactly provide a recursive output. this could be
>> done with a convoluted tree statement (see my patch) or this find one
>> (which isn't simpler, and I haven't checked for symlinks or other strange
>> things):
>> >
>> >
>> > find ${PASSWORD_STORE_DIR:-$HOME/.password-store} -type f -name
>> '*.gpg'|sed 's|^${PASSWORD_STORE_DIR:-$HOME/.password-store}/||'|sed
>> 's/\.gpg$//'
>> >
>> >
>> > intuitive, isn't it? ;-)
>> >
>> > Another use case is an interactive user, who wants to copy-paste a line
>> of the `pass ls` output into `pass show`.
>> >
>> > -- Tobias
>> > ___
>> > Password-Store mailing list
>> > Password-Store@lists.zx2c4.com
>> > http://lists.zx2c4.com/mailman/listinfo/password-store
>>
>>
>>
>> ___
>> Password-Store mailing list
>> Password-Store@lists.zx2c4.com
>> http://lists.zx2c4.com/mailman/listinfo/password-store
>>
>
>
>
> --
> - Sent from my microwave oven
>
> ___
> Password-Store mailing list
> Password-Store@lists.zx2c4.com
> http://lists.zx2c4.com/mailman/listinfo/password-store
>
>
___
Password-Store mailing list
Password-Store@lists.zx2c4.com
http://lists.zx2c4.com/mailman/listinfo/password-store


Re: [pass] ***UNCHECKED*** Re: [Feature Request] Add a `--raw` option to `pass ls`

2016-11-10 Thread Tobias Girstmair
On Thu, Nov 10, 2016 at 02:45:34AM -0500, Linden Krouse wrote:
>Having to do this repeatedly, or create and store a script
>specifically to
>do this just adds more hassle to pass.
exactly.

>Lastly, at least one other person has written a patch to add this
>feature
>so it wouldn't take any additional effort to implement, as the work
>as
>already been done.
if you are talking about my patch: I'm open to suggestions for
simplyfication / changes. I went with modifying the 'pretty
print'-`tree` statement to avoid introducing errors (and the fact that
`tree` is mentioned as a dependency in the readme).

>On Wed, Nov 9, 2016 at 3:43 PM, Lenz Weber  wrote:
>
>>  Actually, if you want to write a software to use that ouput this
>>  should
>>  be quite intuitive for you, yes.
To my defense: I was getting a bit tired after a rather long day.
yes, intuitive might not have been the best word to use - Linden
Krouse's quote above is what I meant.
___
Password-Store mailing list
Password-Store@lists.zx2c4.com
http://lists.zx2c4.com/mailman/listinfo/password-store