[PHP-DEV] Re: [PHP-CVS] cvs: php4 /ext/vpopmail .cvsignore CREDITS Makefile.in config.m4 php_vpopmail.c php_vpopmail.h

2001-03-01 Thread Boian Bonev

hi,

[i move this to php-dev where is the right place IMHO]

indeed the library is used by me, you and perhapse two more people (two have
asked how to get/make/use it). my code is not problematic to change - i am
using different servers for test and production and i can change it with not
more than a minute downtime. not to mention that i can build version with
aliases, change the code live and reinstall version without the aliases...

tell us how hard it is to change your code... now is the most appropriate
time to agree on a certain naming convention. there is a huge discussion
about this on php-dev and my opinion is that once released things must not
be changed. it is better two or four of us change our code and achieve
consistency than release this and tomorrow make aliases and stuff...

both ways look ok to me - vpopmail_name from lib and vpopmail_name from
lib made readable with _
the api is not something like isalpha and noone is stuck to a name so both
conventions are acceptable now.

btw. i have started an xml doc - would you help me with language stuff -
english is not native for me and i do not feel confident when writing
non-code...

b.

- Original Message -
From: "David Croft" [EMAIL PROTECTED]
To: "Andrei Zmievski" [EMAIL PROTECTED]
Cc: [EMAIL PROTECTED]
Sent: Thursday, March 01, 2001 11:02 PM
Subject: Re: [PHP-CVS] cvs: php4 /ext/vpopmail .cvsignore CREDITS
Makefile.in config.m4 php_vpopmail.c php_vpopmail.h



 On Tue, 16 Jan 2001, Andrei Zmievski wrote:

   PHP_FE(vpopmail_passwd, NULL)
   PHP_FE(vpopmail_setuserquota, NULL)
 [snip]
  Didn't we agree to put underscores between words in function names, i.e.
  vpopmail_del_user?

 At the expense of losing compatability with the library's existing naming
 convention?

 David


 --
 PHP CVS Mailing List (http://www.php.net/)
 To unsubscribe, e-mail: [EMAIL PROTECTED]
 For additional commands, e-mail: [EMAIL PROTECTED]
 To contact the list administrators, e-mail: [EMAIL PROTECTED]




-- 
PHP Development Mailing List http://www.php.net/
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]




[PHP-DEV] Re: [PHP-CVS] cvs: php4 /ext/vpopmail .cvsignore CREDITS Makefile.in config.m4 php_vpopmail.c php_vpopmail.h

2001-01-17 Thread Boian Bonev

hi,

i do not like this too but this are the names exported by vpopmail api.
this can be changed very easy. i am currently waiting for reply from David
about what the php api support, what not and how...

b.
- Original Message -
From: "Andrei Zmievski" [EMAIL PROTECTED]
To: "David Croft" [EMAIL PROTECTED]
Cc: [EMAIL PROTECTED]
Sent: Tuesday, January 16, 2001 4:42 PM
Subject: Re: [PHP-CVS] cvs: php4 /ext/vpopmail .cvsignore CREDITS
Makefile.in config.m4 php_vpopmail.c php_vpopmail.h


 On Sun, 14 Jan 2001, David Croft wrote:
  function_entry vpopmail_functions[] = {
  PHP_FE(vpopmail_auth_user, NULL)
  PHP_FE(vpopmail_adddomain, NULL)
  PHP_FE(vpopmail_deldomain, NULL)
  PHP_FE(vpopmail_adduser, NULL)
  PHP_FE(vpopmail_deluser, NULL)
  PHP_FE(vpopmail_passwd, NULL)
  PHP_FE(vpopmail_setuserquota, NULL)
  {NULL, NULL, NULL}
  };

 Didn't we agree to put underscores between words in function names, i.e.
 vpopmail_del_user?

 -Andrei
 * Life may be expensive, but it includes an annual free trip around the
sun. *

 --
 PHP CVS Mailing List (http://www.php.net/)
 To unsubscribe, e-mail: [EMAIL PROTECTED]
 For additional commands, e-mail: [EMAIL PROTECTED]
 To contact the list administrators, e-mail: [EMAIL PROTECTED]




-- 
PHP Development Mailing List http://www.php.net/
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]




Re: [PHP-DEV] Re: [PHP-CVS] cvs: php4 /ext/vpopmail .cvsignore CREDITS Makefile.in config.m4 php_vpopmail.c php_vpopmail.h

2001-01-17 Thread Boian Bonev

sorry for broken english.

I just wanted to say that vpopmail's api uses function naming convention
which is incomatible with php style. This is the reason to name php
functions after vpopmail api, prefixing them with vpopmail_. We can fix this
easy.

b.

- Original Message -
From: "Boian Bonev" [EMAIL PROTECTED]
To: "Andrei Zmievski" [EMAIL PROTECTED]; "PHP Development"
[EMAIL PROTECTED]; "David Croft" [EMAIL PROTECTED]
Sent: Wednesday, January 17, 2001 5:03 PM
Subject: [PHP-DEV] Re: [PHP-CVS] cvs: php4 /ext/vpopmail .cvsignore CREDITS
Makefile.in config.m4 php_vpopmail.c php_vpopmail.h


 hi,

 i do not like this too but this are the names exported by vpopmail api.
 this can be changed very easy. i am currently waiting for reply from David
 about what the php api support, what not and how...

 b.
 - Original Message -
 From: "Andrei Zmievski" [EMAIL PROTECTED]
 To: "David Croft" [EMAIL PROTECTED]
 Cc: [EMAIL PROTECTED]
 Sent: Tuesday, January 16, 2001 4:42 PM
 Subject: Re: [PHP-CVS] cvs: php4 /ext/vpopmail .cvsignore CREDITS
 Makefile.in config.m4 php_vpopmail.c php_vpopmail.h


  On Sun, 14 Jan 2001, David Croft wrote:
   function_entry vpopmail_functions[] = {
   PHP_FE(vpopmail_auth_user, NULL)
   PHP_FE(vpopmail_adddomain, NULL)
   PHP_FE(vpopmail_deldomain, NULL)
   PHP_FE(vpopmail_adduser, NULL)
   PHP_FE(vpopmail_deluser, NULL)
   PHP_FE(vpopmail_passwd, NULL)
   PHP_FE(vpopmail_setuserquota, NULL)
   {NULL, NULL, NULL}
   };
 
  Didn't we agree to put underscores between words in function names, i.e.
  vpopmail_del_user?
 
  -Andrei
  * Life may be expensive, but it includes an annual free trip around the
 sun. *



-- 
PHP Development Mailing List http://www.php.net/
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]




Re: [PHP-DEV] Re: [PHP-CVS] cvs: php4 /ext/vpopmail .cvsignore CREDITS Makefile.in config.m4 php_vpopmail.c php_vpopmail.h

2001-01-17 Thread Andrei Zmievski

On Wed, 17 Jan 2001, Boian Bonev wrote:
 sorry for broken english.
 
 I just wanted to say that vpopmail's api uses function naming convention
 which is incomatible with php style. This is the reason to name php
 functions after vpopmail api, prefixing them with vpopmail_. We can fix this
 easy.

The PHP interface to vpopmail does not have to depend on the naming
conventions used by the vpopmail library.

-Andrei
* If Bill Gates had a nickel for every time Windows crashed.. Oh, wait.. *

-- 
PHP Development Mailing List http://www.php.net/
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]




Re: [PHP-DEV] Re: [PHP-CVS] cvs: php4 /ext/vpopmail .cvsignore CREDITS Makefile.in config.m4 php_vpopmail.c php_vpopmail.h

2001-01-17 Thread Boian Bonev

hi,

sure.

can i ask you another style question?

snips form a config.m4 file:
---
AC_MSG_RESULT(found in $VPOPMAIL_LIB_DIR)
---

---
AC_MSG_CHECKING(for vpopmail install directory)
... code follows...
AC_MSG_RESULT($VPOPMAIL_DIR)
---

i wonder which one is preferable to use.

b.

- Original Message -
  I just wanted to say that vpopmail's api uses function naming convention
  which is incomatible with php style. This is the reason to name php
  functions after vpopmail api, prefixing them with vpopmail_. We can fix
this
  easy.

 The PHP interface to vpopmail does not have to depend on the naming
 conventions used by the vpopmail library.



-- 
PHP Development Mailing List http://www.php.net/
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]




Re: [PHP-DEV] Re: [PHP-CVS] cvs: php4 /ext/vpopmail .cvsignore CREDITS Makefile.in config.m4 php_vpopmail.c php_vpopmail.h

2001-01-17 Thread Andrei Zmievski

On Wed, 17 Jan 2001, Boian Bonev wrote:
 hi,
 
 sure.
 
 can i ask you another style question?
 
 snips form a config.m4 file:
 ---
 AC_MSG_RESULT(found in $VPOPMAIL_LIB_DIR)
 ---
 
 ---
 AC_MSG_CHECKING(for vpopmail install directory)
 ... code follows...
 AC_MSG_RESULT($VPOPMAIL_DIR)
 ---
 
 i wonder which one is preferable to use.

I like the second one.

-Andrei
* Change is the only constant. *

-- 
PHP Development Mailing List http://www.php.net/
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]