Re: cmod.vim (Re: New pike.vim)

2018-01-18 Thread Stephen R. van den Berg
Stephen R. van den Berg wrote:
>https://vim.sourceforge.io/scripts/script.php?script_id=5645

Added a boatload of identifiers which are used in cmod files.
-- 
Stephen.


Protocols.HTTP.Server.SSLPort()->create([...], void|int share)

2018-01-18 Thread Peter Bortas @ Pike developers forum
Of those two, reuse_port is more descriptive, so it has my vote.


Protocols.HTTP.Server.SSLPort()->create([...], void|int share)

2018-01-18 Thread Henrik Grubbstr�m (Lysator) @ Pike (-) developers forum
> I'm trying to figure out what the "void|int share" argument of
> Protocols.HTTP.Server.SSLPort()->create() really does.  The
> documentation is less than helpful:
>
> > Parameter share
> >
> > If true, the connection will be shared if possible. See
> > Stdio.Port.bind for more information
>
> (Source:
> )
>
> But the Stdio.Port.bind documentation does not mention "share".
> Looking at the source code I see that my suspicion is correct: "share"
> corresponds to the "reuse_port" argument.
>
> I think "share" should be renamed "reuse_port", so that it is easier
> to read the documentation.  Any objections?  If not, I'll commit such
> a change to the 8.1 branch tomorrow.

Seems like it.

The argument "share" is passed as "share" to SSL.Port::bind(),
which in turn is passed as "shared" to Stdio.Port::bind(),
which in turn is passed as "reuse_port" to _Stdio._port::bind().

The argument names probably ought to be updated to be consistent.


Protocols.HTTP.Server.SSLPort()->create([...], void|int share)

2018-01-18 Thread ceder (-) Per Cederqvist @ Pike (-) developers forum
I'm trying to figure out what the "void|int share" argument of
Protocols.HTTP.Server.SSLPort()->create() really does.  The
documentation is less than helpful:

> Parameter share
>
> If true, the connection will be shared if possible. See
> Stdio.Port.bind for more information

(Source:
)

But the Stdio.Port.bind documentation does not mention "share".
Looking at the source code I see that my suspicion is correct: "share"
corresponds to the "reuse_port" argument.

I think "share" should be renamed "reuse_port", so that it is easier
to read the documentation.  Any objections?  If not, I'll commit such
a change to the 8.1 branch tomorrow.