D17652: Fix logic error in kioclient noninteractive argument handling

2018-12-19 Thread David Edmundson
davidedmundson added a comment.


  There's a new twist!
  
  Even in non interactive mode we still got dialogs for file conflicts. See 
https://phabricator.kde.org/D17703
  
  Because of this the current state isn't non-interactive. It's a horrible mess 
of both.
  Whatever we do will result in a behavioural change for users.

REPOSITORY
  R126 KDE CLI Utilities

REVISION DETAIL
  https://phabricator.kde.org/D17652

To: davidedmundson, #plasma, nerdopolist, dfaure
Cc: broulik, plasma-devel, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, 
ali-mohamed, jensreuterberg, abetts, sebas, apol, mart


D17703: Fix KIOClient non-interactive mode handling renamed prompts

2018-12-19 Thread David Edmundson
davidedmundson created this revision.
davidedmundson added a reviewer: Plasma.
Herald added a project: Plasma.
Herald added a subscriber: plasma-devel.
davidedmundson requested review of this revision.

REVISION SUMMARY
  In the kdelibs to KF5 transition a factory class was adding for loading
  rename prompts to make KIO gui-less.
  
  In jobs "if (isInteractive)" was changed everywhere into "if
  (uiDelegateExtension)".
  
  The former was false if we called KJob::setUiDelegate(nullptr). The
  latter is only false if the calling code explicitly calls the new
  KIO::Job::setUiDelegateExtension(nullptr) as well.
  
  This left kioclient5 in the very weird state of non-interactive mode
  still having rename dialogs but not error messages.
  
  Now non-interactive mode will simply error if it hits a conflict and
  stop.

TEST PLAN
  Copied a conflict

REPOSITORY
  R126 KDE CLI Utilities

BRANCH
  master

REVISION DETAIL
  https://phabricator.kde.org/D17703

AFFECTED FILES
  kioclient/kioclient.cpp

To: davidedmundson, #plasma
Cc: plasma-devel, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, ali-mohamed, 
jensreuterberg, abetts, sebas, apol, mart


D17677: Add workaround for gtk file chooser filter patterns

2018-12-19 Thread David Edmundson
davidedmundson added inline comments.

INLINE COMMENTS

> jgrulich wrote in filechooser.cpp:287
> This can be done of course, but it will not fix this problem. It's reasonable 
> to use it directly and maybe add support for regular expressions in filters 
> to KIO, but this is something what will need more work and require changes on 
> two places. I would like to have now a workaround that can be pushed to 
> stable Plasma release now.

KFileWidget::setFilter exists and takes regular expressions already.

REPOSITORY
  R838 Flatpak Support: KDE Portal for XDG Desktop

REVISION DETAIL
  https://phabricator.kde.org/D17677

To: jgrulich, broulik
Cc: ngraham, davidedmundson, plasma-devel, GB_2, ragreen, Pitel, ZrenBot, 
lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas, apol, mart


D17592: Introduce a DelegateRecycler attached object

2018-12-19 Thread Albert Astals Cid
aacid added a comment.


  @apol you broke the build

REPOSITORY
  R169 Kirigami

REVISION DETAIL
  https://phabricator.kde.org/D17592

To: apol, #kirigami, mart
Cc: aacid, plasma-devel, dkardarakos, apol, davidedmundson, mart, hein


D17218: Fix removing first item in languages list

2018-12-19 Thread Eike Hein
hein added reviewers: davidedmundson, broulik.
hein added a comment.


  Ping?

REPOSITORY
  R119 Plasma Desktop

REVISION DETAIL
  https://phabricator.kde.org/D17218

To: hein, #plasma, davidedmundson, broulik
Cc: plasma-devel, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, ali-mohamed, 
jensreuterberg, abetts, sebas, apol, mart


D17658: Redraw the slider if modes have changed

2018-12-19 Thread Andras Mantia
amantia abandoned this revision.
amantia added a comment.


  Abandoned in favor of https://phabricator.kde.org/D17686

REPOSITORY
  R104 KScreen

REVISION DETAIL
  https://phabricator.kde.org/D17658

To: amantia, dvratil
Cc: davidedmundson, plasma-devel, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, 
ali-mohamed, jensreuterberg, abetts, sebas, apol, mart


D17659: Set parent window for dialogs

2018-12-19 Thread Martin Flöser
graesslin added a comment.


  In D17659#379007 , @apol wrote:
  
  > LGTM, I also missed this!
  >
  > Maybe it would make sense to add a TODO about implementing it for Wayland?
  
  
  Even better would be to just implement it for Wayland. 
https://api.kde.org/frameworks/kwayland/html/classKWayland_1_1Client_1_1XdgExporter.html
 and 
https://api.kde.org/frameworks/kwayland/html/classKWayland_1_1Client_1_1XdgImporter.html
 are the relevant classes.

REPOSITORY
  R838 Flatpak Support: KDE Portal for XDG Desktop

BRANCH
  Plasma/5.14

REVISION DETAIL
  https://phabricator.kde.org/D17659

To: volkov, jgrulich, apol
Cc: graesslin, broulik, apol, plasma-devel, GB_2, ragreen, Pitel, ZrenBot, 
lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas, mart


D17686: Redraw the slider if modes have changed

2018-12-19 Thread Andras Mantia
amantia closed this revision.

REPOSITORY
  R104 KScreen

REVISION DETAIL
  https://phabricator.kde.org/D17686

To: amantia, #plasma, dvratil
Cc: plasma-devel, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, ali-mohamed, 
jensreuterberg, abetts, sebas, apol, mart


D17694: Support a tooltip on a MouseArea

2018-12-19 Thread Aleix Pol Gonzalez
apol created this revision.
apol added reviewers: Kirigami, mart.
Herald added a project: Plasma.
Herald added a subscriber: plasma-devel.
apol requested review of this revision.

REVISION SUMMARY
  MouseArea doesn't have hovered but it has containsMouse

REPOSITORY
  R858 Qt Quick Controls 2: Desktop Style

BRANCH
  master

REVISION DETAIL
  https://phabricator.kde.org/D17694

AFFECTED FILES
  org.kde.desktop/ToolTip.qml

To: apol, #kirigami, mart
Cc: plasma-devel, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, ali-mohamed, 
jensreuterberg, abetts, sebas, apol, mart


D17685: Notify also if modes have changed

2018-12-19 Thread Andras Mantia
amantia closed this revision.

REPOSITORY
  R110 KScreen Library

REVISION DETAIL
  https://phabricator.kde.org/D17685

To: amantia, #plasma, dvratil
Cc: davidedmundson, plasma-devel, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, 
ali-mohamed, jensreuterberg, abetts, sebas, apol, mart


D17686: Redraw the slider if modes have changed

2018-12-19 Thread Daniel Vrátil
dvratil accepted this revision.
dvratil added a comment.
This revision is now accepted and ready to land.


  Looks good to me. This whole thing could probably use some cleanup, but 
that's for another day :-)

REPOSITORY
  R104 KScreen

BRANCH
  Plasma/5.12

REVISION DETAIL
  https://phabricator.kde.org/D17686

To: amantia, #plasma, dvratil
Cc: plasma-devel, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, ali-mohamed, 
jensreuterberg, abetts, sebas, apol, mart


D17657: Notify also if modes have changed

2018-12-19 Thread Andras Mantia
amantia abandoned this revision.
amantia added a comment.


  Will fix first in 5.12 and merge to master, as per 
https://phabricator.kde.org/D17685

REPOSITORY
  R110 KScreen Library

REVISION DETAIL
  https://phabricator.kde.org/D17657

To: amantia, dvratil
Cc: davidedmundson, plasma-devel, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, 
ali-mohamed, jensreuterberg, abetts, sebas, apol, mart


D17657: Notify also if modes have changed

2018-12-19 Thread Daniel Vrátil
dvratil added inline comments.

INLINE COMMENTS

> amantia wrote in output.cpp:583-585
> Good point, missed it. @dvratil any reason why it emits outputChanged and not 
> modesChanged? Actually setModes emits both, so maybe indeed it is easier to 
> just put modesChnaged there as well. I'm still curious why we need both.

There are properties that are related to the overall output state and will 
never change individually (e.g. id, type, name). Technically modes /may/ change 
independently of the output (it is possible to add modes in XRandR), but 
historically we did not support that, so modes were always coupled with the 
output state as well. I think this is the correct approach to fix a bug, but 
longterm someone should probably look into what happens when the 
`outputChanged()` signal is removed from here and from `setModes()` as there 
might be some code listening to it instead of `modesChanged()`.

REPOSITORY
  R110 KScreen Library

REVISION DETAIL
  https://phabricator.kde.org/D17657

To: amantia, dvratil
Cc: davidedmundson, plasma-devel, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, 
ali-mohamed, jensreuterberg, abetts, sebas, apol, mart


D17592: Introduce a DelegateRecycler attached object

2018-12-19 Thread Aleix Pol Gonzalez
apol closed this revision.

REPOSITORY
  R169 Kirigami

REVISION DETAIL
  https://phabricator.kde.org/D17592

To: apol, #kirigami, mart
Cc: plasma-devel, dkardarakos, apol, davidedmundson, mart, hein


D17685: Notify also if modes have changed

2018-12-19 Thread Daniel Vrátil
dvratil accepted this revision.
dvratil added a comment.
This revision is now accepted and ready to land.


  You can close the review for master and commit this to the stable branch, 
then merge stable to master.

REPOSITORY
  R110 KScreen Library

BRANCH
  Plasma/5.12

REVISION DETAIL
  https://phabricator.kde.org/D17685

To: amantia, #plasma, dvratil
Cc: davidedmundson, plasma-devel, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, 
ali-mohamed, jensreuterberg, abetts, sebas, apol, mart


D17689: [RFC] Positioner: call initMaps even if m_enabled == false

2018-12-19 Thread Eike Hein
hein added a comment.


  Can you provide a description for this patch? What does it fix, why does it 
fix it?

REPOSITORY
  R119 Plasma Desktop

REVISION DETAIL
  https://phabricator.kde.org/D17689

To: McPain, #plasma, hein, davidedmundson
Cc: plasma-devel, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, ali-mohamed, 
jensreuterberg, abetts, sebas, apol, mart


D17677: Add workaround for gtk file chooser filter patterns

2018-12-19 Thread Nathaniel Graham
ngraham added a comment.


  The fixed bug is actually 399889

REPOSITORY
  R838 Flatpak Support: KDE Portal for XDG Desktop

REVISION DETAIL
  https://phabricator.kde.org/D17677

To: jgrulich, broulik
Cc: ngraham, davidedmundson, plasma-devel, GB_2, ragreen, Pitel, ZrenBot, 
lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas, apol, mart


D17689: Positioner: call initMaps even if m_enabled == false

2018-12-19 Thread Oleg Solovyov
McPain created this revision.
Herald added a project: Plasma.
Herald added a subscriber: plasma-devel.
McPain requested review of this revision.

REVISION SUMMARY
  see BUG: 401023

REPOSITORY
  R119 Plasma Desktop

REVISION DETAIL
  https://phabricator.kde.org/D17689

AFFECTED FILES
  plasma-desktop/containments/desktop/plugins/folder/positioner.cpp

To: McPain
Cc: plasma-devel, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, ali-mohamed, 
jensreuterberg, abetts, sebas, apol, mart


D17685: Notify also if modes have changed

2018-12-19 Thread Andras Mantia
amantia added a comment.


  I have on for master and one for Plasma 5.12, as we want this in 5.12 as 
well, if approved. Should I keep only one of them?

REPOSITORY
  R110 KScreen Library

REVISION DETAIL
  https://phabricator.kde.org/D17685

To: amantia, #plasma, dvratil
Cc: davidedmundson, plasma-devel, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, 
ali-mohamed, jensreuterberg, abetts, sebas, apol, mart


D17685: Notify also if modes have changed

2018-12-19 Thread David Edmundson
davidedmundson added a comment.


  You seem to have multiple reviews open for the same thing. Can you close the 
outdated ones please.

REPOSITORY
  R110 KScreen Library

REVISION DETAIL
  https://phabricator.kde.org/D17685

To: amantia, #plasma, dvratil
Cc: davidedmundson, plasma-devel, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, 
ali-mohamed, jensreuterberg, abetts, sebas, apol, mart


D17677: Add workaround for gtk file chooser filter patterns

2018-12-19 Thread Jan Grulich
jgrulich added inline comments.

INLINE COMMENTS

> davidedmundson wrote in filechooser.cpp:287
> Given this is the plasma portal, it might be a good case to use the 
> KFileWidget directly rather than have a proxy layer in the way which converts 
> filter strings back again.
> 
> KFileWidget::setFilter takes an expression directly - and if it doesn't match 
> perfectly we can change KIO to come up with something that does.

This can be done of course, but it will not fix this problem. It's reasonable 
to use it directly and maybe add support for regular expressions in filters to 
KIO, but this is something what will need more work and require changes on two 
places. I would like to have now a workaround that can be pushed to stable 
Plasma release now.

REPOSITORY
  R838 Flatpak Support: KDE Portal for XDG Desktop

REVISION DETAIL
  https://phabricator.kde.org/D17677

To: jgrulich, broulik
Cc: davidedmundson, plasma-devel, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, 
ali-mohamed, jensreuterberg, abetts, sebas, apol, mart


D17686: Redraw the slider if modes have changed

2018-12-19 Thread Andras Mantia
amantia created this revision.
amantia added a project: Plasma.
amantia requested review of this revision.

REVISION SUMMARY
  This can happen if a monitor was not configured at all, the KCM is shown
  when it first plugged in and the user selects to not configure it.
  In the UI it will appear with no Resolution/Refresh rate and wrong size in
  the QML view.
  
  Backport of D17658 
  Depends on D17685 

REPOSITORY
  R104 KScreen

BRANCH
  Plasma/5.12

REVISION DETAIL
  https://phabricator.kde.org/D17686

AFFECTED FILES
  kcm/src/resolutionslider.cpp
  kcm/src/resolutionslider.h

To: amantia
Cc: plasma-devel, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, ali-mohamed, 
jensreuterberg, abetts, sebas, apol, mart


D17685: Notify also if modes have changedBackport for D17657Depends on D17657

2018-12-19 Thread Andras Mantia
amantia created this revision.
amantia added a project: Plasma.
amantia requested review of this revision.

REVISION SUMMARY
  Will be needed in the KCM to correctly update the UI

REPOSITORY
  R110 KScreen Library

BRANCH
  Plasma/5.12

REVISION DETAIL
  https://phabricator.kde.org/D17685

AFFECTED FILES
  src/output.cpp

To: amantia
Cc: plasma-devel, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, ali-mohamed, 
jensreuterberg, abetts, sebas, apol, mart


D17677: Add workaround for gtk file chooser filter patterns

2018-12-19 Thread David Edmundson
davidedmundson added inline comments.

INLINE COMMENTS

> filechooser.cpp:287
>  
>  QFileDialog *fileDialog = new QFileDialog();
>  fileDialog->setWindowTitle(title);

Given this is the plasma portal, it might be a good case to use the KFileWidget 
directly rather than have a proxy layer in the way which converts filter 
strings back again.

KFileWidget::setFilter takes an expression directly - and if it doesn't match 
perfectly we can change KIO to come up with something that does.

REPOSITORY
  R838 Flatpak Support: KDE Portal for XDG Desktop

REVISION DETAIL
  https://phabricator.kde.org/D17677

To: jgrulich, broulik
Cc: davidedmundson, plasma-devel, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, 
ali-mohamed, jensreuterberg, abetts, sebas, apol, mart


D17642: remove binding loop in KickoffItem

2018-12-19 Thread David Edmundson
This revision was automatically updated to reflect the committed changes.
Closed by commit R119:be189b0ce2b7: remove binding loop in KickoffItem 
(authored by davidedmundson).

REPOSITORY
  R119 Plasma Desktop

CHANGES SINCE LAST UPDATE
  https://phabricator.kde.org/D17642?vs=47730=47837

REVISION DETAIL
  https://phabricator.kde.org/D17642

AFFECTED FILES
  applets/kickoff/package/contents/ui/KickoffItem.qml

To: davidedmundson, #plasma, broulik
Cc: plasma-devel, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, ali-mohamed, 
jensreuterberg, abetts, sebas, apol, mart


D17677: Add workaround for gtk file chooser filter patterns

2018-12-19 Thread Jan Grulich
jgrulich updated this revision to Diff 47833.
jgrulich added a comment.


  Allow also patterns like '*.ab[cC]de[fF]'

REPOSITORY
  R838 Flatpak Support: KDE Portal for XDG Desktop

CHANGES SINCE LAST UPDATE
  https://phabricator.kde.org/D17677?vs=47829=47833

BRANCH
  Plasma/5.14

REVISION DETAIL
  https://phabricator.kde.org/D17677

AFFECTED FILES
  src/filechooser.cpp

To: jgrulich, broulik
Cc: plasma-devel, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, ali-mohamed, 
jensreuterberg, abetts, sebas, apol, mart


D17658: Redraw the slider if modes have changed

2018-12-19 Thread Andras Mantia
amantia updated this revision to Diff 47831.
amantia added a comment.


  Undo last change

REPOSITORY
  R104 KScreen

CHANGES SINCE LAST UPDATE
  https://phabricator.kde.org/D17658?vs=47830=47831

BRANCH
  fix_null_size

REVISION DETAIL
  https://phabricator.kde.org/D17658

AFFECTED FILES
  kcm/src/resolutionslider.cpp
  kcm/src/resolutionslider.h

To: amantia, dvratil
Cc: davidedmundson, plasma-devel, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, 
ali-mohamed, jensreuterberg, abetts, sebas, apol, mart


D17658: Redraw the slider if modes have changed

2018-12-19 Thread Andras Mantia
amantia updated this revision to Diff 47830.
amantia added a comment.


  - Show unconnected displayed at the left

REPOSITORY
  R104 KScreen

CHANGES SINCE LAST UPDATE
  https://phabricator.kde.org/D17658?vs=47779=47830

BRANCH
  rework_qml_part

REVISION DETAIL
  https://phabricator.kde.org/D17658

AFFECTED FILES
  kcm/src/declarative/qmlscreen.cpp
  kcm/src/resolutionslider.cpp
  kcm/src/resolutionslider.h

To: amantia, dvratil
Cc: davidedmundson, plasma-devel, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, 
ali-mohamed, jensreuterberg, abetts, sebas, apol, mart


D17677: Add workaround for gtk file chooser filter patterns

2018-12-19 Thread Jan Grulich
jgrulich updated this revision to Diff 47829.
jgrulich added a comment.


  Be more specific about the pattern

REPOSITORY
  R838 Flatpak Support: KDE Portal for XDG Desktop

CHANGES SINCE LAST UPDATE
  https://phabricator.kde.org/D17677?vs=47825=47829

BRANCH
  Plasma/5.14

REVISION DETAIL
  https://phabricator.kde.org/D17677

AFFECTED FILES
  src/filechooser.cpp

To: jgrulich, broulik
Cc: plasma-devel, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, ali-mohamed, 
jensreuterberg, abetts, sebas, apol, mart


D17677: Add workaround for gtk file chooser filter patterns

2018-12-19 Thread Jan Grulich
jgrulich created this revision.
Herald added a project: Plasma.
Herald added a subscriber: plasma-devel.
jgrulich requested review of this revision.

REVISION SUMMARY
  Gtk can use filter patterns, looking like "*.[Pp][Nn][Gg]" to handle all 
possible lowercase/uppercase
  variants. This is unfortunately not supported by KDE/Qt dialogs so we should 
try to convert it to
  just "*.png" instead. There are other possible patterns, but this is probably 
the most common one.

REPOSITORY
  R838 Flatpak Support: KDE Portal for XDG Desktop

BRANCH
  Plasma/5.14

REVISION DETAIL
  https://phabricator.kde.org/D17677

AFFECTED FILES
  src/filechooser.cpp

To: jgrulich
Cc: plasma-devel, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, ali-mohamed, 
jensreuterberg, abetts, sebas, apol, mart


D17659: Set parent window for dialogs

2018-12-19 Thread Kai Uwe Broulik
broulik added a comment.


  +1

INLINE COMMENTS

> utils.h:24
> +
> +class Utils
> +{

This might as well be a `namespace`?

REPOSITORY
  R838 Flatpak Support: KDE Portal for XDG Desktop

BRANCH
  Plasma/5.14

REVISION DETAIL
  https://phabricator.kde.org/D17659

To: volkov, jgrulich, apol
Cc: broulik, apol, plasma-devel, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, 
ali-mohamed, jensreuterberg, abetts, sebas, mart