Re: [Qemu-block] [Qemu-devel] [PATCH v8 18/26] block: Add sgfnt_runtime_opts to BlockDriver

2018-02-20 Thread Eric Blake

On 02/20/2018 08:51 AM, Max Reitz wrote:

On 2018-02-06 20:43, Eric Blake wrote:

On 02/05/2018 09:18 AM, Max Reitz wrote:

This new field can be set by block drivers to list the runtime options
they accept that may influence the contents of the respective BDS. As of
a follow-up patch, this list will be used by the common
bdrv_refresh_filename() implementation to decide which options to put
into BDS.full_open_options (and consequently whether a JSON filename has
to be created), thus freeing the drivers of having to implement that
logic themselves.

Additionally, this patch adds the field to all of the block drivers that
need it and sets it accordingly.

Signed-off-by: Max Reitz 
---



+    /* Pointer to a NULL-terminated array of names of significant
options that
+ * can be specified for bdrv_open(). A significant option is one
that
+ * changes the data of a BDS.
+ * If this pointer is NULL, the array is considered empty.
+ * "filename" and "driver" are always considered significant. */
+    const char *const *sgfnt_runtime_opts;


Warning: Bikeshedding follows:

s/sgfnt/vital/

might read easier (same number of letters, but has some vowels rthr thn
bng crptc bbrvtn).


So, did we reach any verdict on this? :-)

To sum up IRC (as far as I've understood), I don't quite like "vital" or
"needed" because they sound like those options would be required; but
they usually have defaults so they are not.

I preferred "strong", but you said that might mean something else
(although I still don't know what exactly :-)).

So...?


major?  apt?

(the thesaurus mentions other words like meaningful or influential, but 
those don't buy you any length reduction or easier abbreviations)


I don't recall what (if anything) I said against strong, so I'm also 
fine if that's what you choose.


At the end of the day, it's all bikeshedding - pick a term, and I'll 
live with it ;)


--
Eric Blake, Principal Software Engineer
Red Hat, Inc.   +1-919-301-3266
Virtualization:  qemu.org | libvirt.org



Re: [Qemu-block] [Qemu-devel] [PATCH v8 18/26] block: Add sgfnt_runtime_opts to BlockDriver

2018-02-20 Thread Max Reitz
On 2018-02-06 20:43, Eric Blake wrote:
> On 02/05/2018 09:18 AM, Max Reitz wrote:
>> This new field can be set by block drivers to list the runtime options
>> they accept that may influence the contents of the respective BDS. As of
>> a follow-up patch, this list will be used by the common
>> bdrv_refresh_filename() implementation to decide which options to put
>> into BDS.full_open_options (and consequently whether a JSON filename has
>> to be created), thus freeing the drivers of having to implement that
>> logic themselves.
>>
>> Additionally, this patch adds the field to all of the block drivers that
>> need it and sets it accordingly.
>>
>> Signed-off-by: Max Reitz 
>> ---
> 
>> +    /* Pointer to a NULL-terminated array of names of significant
>> options that
>> + * can be specified for bdrv_open(). A significant option is one
>> that
>> + * changes the data of a BDS.
>> + * If this pointer is NULL, the array is considered empty.
>> + * "filename" and "driver" are always considered significant. */
>> +    const char *const *sgfnt_runtime_opts;
> 
> Warning: Bikeshedding follows:
> 
> s/sgfnt/vital/
> 
> might read easier (same number of letters, but has some vowels rthr thn
> bng crptc bbrvtn).

So, did we reach any verdict on this? :-)

To sum up IRC (as far as I've understood), I don't quite like "vital" or
"needed" because they sound like those options would be required; but
they usually have defaults so they are not.

I preferred "strong", but you said that might mean something else
(although I still don't know what exactly :-)).

So...?

Max



signature.asc
Description: OpenPGP digital signature


Re: [Qemu-block] [Qemu-devel] [PATCH v8 18/26] block: Add sgfnt_runtime_opts to BlockDriver

2018-02-06 Thread Eric Blake

On 02/05/2018 09:18 AM, Max Reitz wrote:

This new field can be set by block drivers to list the runtime options
they accept that may influence the contents of the respective BDS. As of
a follow-up patch, this list will be used by the common
bdrv_refresh_filename() implementation to decide which options to put
into BDS.full_open_options (and consequently whether a JSON filename has
to be created), thus freeing the drivers of having to implement that
logic themselves.

Additionally, this patch adds the field to all of the block drivers that
need it and sets it accordingly.

Signed-off-by: Max Reitz 
---



+/* Pointer to a NULL-terminated array of names of significant options that
+ * can be specified for bdrv_open(). A significant option is one that
+ * changes the data of a BDS.
+ * If this pointer is NULL, the array is considered empty.
+ * "filename" and "driver" are always considered significant. */
+const char *const *sgfnt_runtime_opts;


Warning: Bikeshedding follows:

s/sgfnt/vital/

might read easier (same number of letters, but has some vowels rthr thn 
bng crptc bbrvtn).


--
Eric Blake, Principal Software Engineer
Red Hat, Inc.   +1-919-301-3266
Virtualization:  qemu.org | libvirt.org