Re: [Qemu-devel] [PATCH 1/1] qdev: rename qdev_create() argument to sync with qdev_try_create()

2019-01-08 Thread Markus Armbruster
Dongli Zhang  writes:

> The second argument used by qdev_create() is typename and 'name' is very
> confusing. Rename it from 'name' to 'type', which is the same used by
> qdev_try_create().
>
> Signed-off-by: Dongli Zhang 
> ---
>  hw/core/qdev.c | 8 
>  1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/hw/core/qdev.c b/hw/core/qdev.c
> index 6b3cc55..1d65e8f 100644
> --- a/hw/core/qdev.c
> +++ b/hw/core/qdev.c
> @@ -113,17 +113,17 @@ void qdev_set_parent_bus(DeviceState *dev, BusState 
> *bus)
>  /* Create a new device.  This only initializes the device state
> structure and allows properties to be set.  The device still needs
> to be realized.  See qdev-core.h.  */
> -DeviceState *qdev_create(BusState *bus, const char *name)
> +DeviceState *qdev_create(BusState *bus, const char *type)
>  {
>  DeviceState *dev;
>  
> -dev = qdev_try_create(bus, name);
> +dev = qdev_try_create(bus, type);
>  if (!dev) {
>  if (bus) {
> -error_report("Unknown device '%s' for bus '%s'", name,
> +error_report("Unknown device '%s' for bus '%s'", type,
>   object_get_typename(OBJECT(bus)));
>  } else {
> -error_report("Unknown device '%s' for default sysbus", name);
> +error_report("Unknown device '%s' for default sysbus", type);
>  }
>  abort();
>  }

Yes, @name is rather generic.  The sub-par function comment doesn't
really help.

You rename the parameter in the definition, but not in the declaration
(qdev-core.h).  Better keep them consistent.

Note that qdev_create() is just one instance of the "variables
containing type names are confusingly named" pattern.  Let's start with
just qdev-core.h:

* qdev_create() parameter @name.

* qdev_try_create() parameter @name.  The definition in qdev.c calls it
  @type.

* qbus_create_inplace() parameter @typename.

* qbus_create() parameter @typename.  The definition in bus.c calls it
  @name.

Let's pick a single identifier and use it consistently.  Picking
@typename would minimize churn, and be consistent with object_new() &
friends.  Philippe, Paolo, what do you think?



[Qemu-devel] [PATCH 1/1] qdev: rename qdev_create() argument to sync with qdev_try_create()

2018-12-23 Thread Dongli Zhang
The second argument used by qdev_create() is typename and 'name' is very
confusing. Rename it from 'name' to 'type', which is the same used by
qdev_try_create().

Signed-off-by: Dongli Zhang 
---
 hw/core/qdev.c | 8 
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/hw/core/qdev.c b/hw/core/qdev.c
index 6b3cc55..1d65e8f 100644
--- a/hw/core/qdev.c
+++ b/hw/core/qdev.c
@@ -113,17 +113,17 @@ void qdev_set_parent_bus(DeviceState *dev, BusState *bus)
 /* Create a new device.  This only initializes the device state
structure and allows properties to be set.  The device still needs
to be realized.  See qdev-core.h.  */
-DeviceState *qdev_create(BusState *bus, const char *name)
+DeviceState *qdev_create(BusState *bus, const char *type)
 {
 DeviceState *dev;
 
-dev = qdev_try_create(bus, name);
+dev = qdev_try_create(bus, type);
 if (!dev) {
 if (bus) {
-error_report("Unknown device '%s' for bus '%s'", name,
+error_report("Unknown device '%s' for bus '%s'", type,
  object_get_typename(OBJECT(bus)));
 } else {
-error_report("Unknown device '%s' for default sysbus", name);
+error_report("Unknown device '%s' for default sysbus", type);
 }
 abort();
 }
-- 
2.7.4