Re: [Qemu-devel] [PATCH v2 00/20] monitor: Wean core off QError, and other cleanups

2015-05-29 Thread Markus Armbruster
Luiz Capitulino  writes:

> On Tue, 26 May 2015 17:20:35 +0200
> Markus Armbruster  wrote:
>
>> Command handlers still use QError.  Left for another day.
>
> Great work! I've found one bug that has to be addressed before merging.
> Also, for the error conversions you're doing you're going from
> qerror_report() to error_set() but I'd recommend going directly to
> error_setg() as that's our final goal. It's totally fine with me
> if you're saving this work for a later series, but I think it will
> you save work if you do it in this series. Your call.

Saving for later, not least because this series has been fully reviewed
now.

> Can you take this through your tree?

Sure!

>  Feel free to add this once
> you fix the bug:
>
> Reviewed-by: Luiz Capitulino 

Thanks!



Re: [Qemu-devel] [PATCH v2 00/20] monitor: Wean core off QError, and other cleanups

2015-05-28 Thread Luiz Capitulino
On Tue, 26 May 2015 17:20:35 +0200
Markus Armbruster  wrote:

> Command handlers still use QError.  Left for another day.

Great work! I've found one bug that has to be addressed before merging.
Also, for the error conversions you're doing you're going from
qerror_report() to error_set() but I'd recommend going directly to
error_setg() as that's our final goal. It's totally fine with me
if you're saving this work for a later series, but I think it will
you save work if you do it in this series. Your call.

Can you take this through your tree? Feel free to add this once
you fix the bug:

Reviewed-by: Luiz Capitulino 

> 
> v2:
> * Trivially rebased
> * PATCH 01: Drop another async remnant [Eric]
> * PATCH 01+02+18: Improve commit messages
> * PATCH 03+04: client_migrate_info still hasn't been implemented VNC,
>   de-document [Eric, Gerd]
> * PATCH 16+19: Don't inline monitor_ctrl_mode() into monitor_init() [Eric]
> * PATCH 20: Use false instead of 0 [Eric]
> 
> Markus Armbruster (20):
>   monitor: Drop broken, unused asynchronous command interface
>   monitor: Clean up after previous commit
>   monitor: Improve and document client_migrate_info protocol error
>   monitor: Convert client_migrate_info to QAPI
>   monitor: Use traditional command interface for HMP drive_del
>   monitor: Use traditional command interface for HMP device_add
>   monitor: Use trad. command interface for HMP pcie_aer_inject_error
>   monitor: Drop unused "new" HMP command interface
>   monitor: Propagate errors through qmp_check_client_args()
>   monitor: Propagate errors through qmp_check_input_obj()
>   monitor: Wean monitor_protocol_emitter() off mon->error
>   monitor: Inline monitor_has_error() into its only caller
>   monitor: Limit QError use to command handlers
>   monitor: Rename handle_user_command() to handle_hmp_command()
>   monitor: Rename monitor_control_read(), monitor_control_event()
>   monitor: Unbox Monitor member mc and rename to qmp
>   monitor: Drop do_qmp_capabilities()'s superfluous QMP check
>   monitor: Turn int command_mode into bool in_command_mode
>   monitor: Rename monitor_ctrl_mode() to monitor_is_qmp()
>   monitor: Change return type of monitor_cur_is_qmp() to bool
> 
>  blockdev.c|   9 +-
>  hmp-commands.hx   |  20 +--
>  hmp.c |  23 +++
>  hmp.h |   2 +
>  hw/pci/pci-stub.c |  14 +-
>  hw/pci/pcie_aer.c |  39 ++---
>  include/monitor/monitor.h |   7 +-
>  include/sysemu/blockdev.h |   2 +-
>  include/sysemu/sysemu.h   |   4 +-
>  monitor.c | 380 
> --
>  qapi-schema.json  |  19 +++
>  qmp-commands.hx   |  16 +-
>  stubs/mon-is-qmp.c|   4 +-
>  13 files changed, 222 insertions(+), 317 deletions(-)
> 




[Qemu-devel] [PATCH v2 00/20] monitor: Wean core off QError, and other cleanups

2015-05-26 Thread Markus Armbruster
Command handlers still use QError.  Left for another day.

v2:
* Trivially rebased
* PATCH 01: Drop another async remnant [Eric]
* PATCH 01+02+18: Improve commit messages
* PATCH 03+04: client_migrate_info still hasn't been implemented VNC,
  de-document [Eric, Gerd]
* PATCH 16+19: Don't inline monitor_ctrl_mode() into monitor_init() [Eric]
* PATCH 20: Use false instead of 0 [Eric]

Markus Armbruster (20):
  monitor: Drop broken, unused asynchronous command interface
  monitor: Clean up after previous commit
  monitor: Improve and document client_migrate_info protocol error
  monitor: Convert client_migrate_info to QAPI
  monitor: Use traditional command interface for HMP drive_del
  monitor: Use traditional command interface for HMP device_add
  monitor: Use trad. command interface for HMP pcie_aer_inject_error
  monitor: Drop unused "new" HMP command interface
  monitor: Propagate errors through qmp_check_client_args()
  monitor: Propagate errors through qmp_check_input_obj()
  monitor: Wean monitor_protocol_emitter() off mon->error
  monitor: Inline monitor_has_error() into its only caller
  monitor: Limit QError use to command handlers
  monitor: Rename handle_user_command() to handle_hmp_command()
  monitor: Rename monitor_control_read(), monitor_control_event()
  monitor: Unbox Monitor member mc and rename to qmp
  monitor: Drop do_qmp_capabilities()'s superfluous QMP check
  monitor: Turn int command_mode into bool in_command_mode
  monitor: Rename monitor_ctrl_mode() to monitor_is_qmp()
  monitor: Change return type of monitor_cur_is_qmp() to bool

 blockdev.c|   9 +-
 hmp-commands.hx   |  20 +--
 hmp.c |  23 +++
 hmp.h |   2 +
 hw/pci/pci-stub.c |  14 +-
 hw/pci/pcie_aer.c |  39 ++---
 include/monitor/monitor.h |   7 +-
 include/sysemu/blockdev.h |   2 +-
 include/sysemu/sysemu.h   |   4 +-
 monitor.c | 380 --
 qapi-schema.json  |  19 +++
 qmp-commands.hx   |  16 +-
 stubs/mon-is-qmp.c|   4 +-
 13 files changed, 222 insertions(+), 317 deletions(-)

-- 
1.9.3