Re: [Qemu-devel] [RFC v3 1/3] util/qemu-error: Rename error_print_loc() to be more generic

2017-07-05 Thread Thomas Huth
On 05.07.2017 19:36, Alistair Francis wrote:
> Rename the error_print_loc() function in preparation for using it to
> print warnings as well.
> 
> Signed-off-by: Alistair Francis 
> Reviewed-by: Philippe Mathieu-Daudé 
> ---
> 
>  util/qemu-error.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/util/qemu-error.c b/util/qemu-error.c
> index b331f8f4a4..1c5e35ecdb 100644
> --- a/util/qemu-error.c
> +++ b/util/qemu-error.c
> @@ -146,7 +146,7 @@ const char *error_get_progname(void)
>  /*
>   * Print current location to current monitor if we have one, else to stderr.
>   */
> -static void error_print_loc(void)
> +static void print_loc(void)
>  {
>  const char *sep = "";
>  int i;
> @@ -197,7 +197,7 @@ void error_vreport(const char *fmt, va_list ap)
>  g_free(timestr);
>  }
>  
> -error_print_loc();
> +print_loc();
>  error_vprintf(fmt, ap);
>  error_printf("\n");
>  }

Reviewed-by: Thomas Huth 





[Qemu-devel] [RFC v3 1/3] util/qemu-error: Rename error_print_loc() to be more generic

2017-07-05 Thread Alistair Francis
Rename the error_print_loc() function in preparation for using it to
print warnings as well.

Signed-off-by: Alistair Francis 
Reviewed-by: Philippe Mathieu-Daudé 
---

 util/qemu-error.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/util/qemu-error.c b/util/qemu-error.c
index b331f8f4a4..1c5e35ecdb 100644
--- a/util/qemu-error.c
+++ b/util/qemu-error.c
@@ -146,7 +146,7 @@ const char *error_get_progname(void)
 /*
  * Print current location to current monitor if we have one, else to stderr.
  */
-static void error_print_loc(void)
+static void print_loc(void)
 {
 const char *sep = "";
 int i;
@@ -197,7 +197,7 @@ void error_vreport(const char *fmt, va_list ap)
 g_free(timestr);
 }
 
-error_print_loc();
+print_loc();
 error_vprintf(fmt, ap);
 error_printf("\n");
 }
-- 
2.11.0