Re: [Qemu-devel] [PATCH] sheepdog: pass vdi_id to sheep daemon for sd_close()

2013-01-29 Thread MORITA Kazutaka
At Tue, 29 Jan 2013 16:22:49 +0800,
Liu Yuan wrote:
 
 From: Liu Yuan tailai...@taobao.com
 
 Sheep daemon needs vdi_id to identify which vdi is closed to release resources
 such as object cache.
 
 Cc: MORITA Kazutaka morita.kazut...@lab.ntt.co.jp
 Cc: Kevin Wolf kw...@redhat.com
 Cc: Stefan Hajnoczi stefa...@redhat.com
 Signed-off-by: Liu Yuan tailai...@taobao.com
 ---
  block/sheepdog.c |1 +
  1 file changed, 1 insertion(+)
 
 diff --git a/block/sheepdog.c b/block/sheepdog.c
 index 3e49bb8..97c76f5 100644
 --- a/block/sheepdog.c
 +++ b/block/sheepdog.c
 @@ -1384,6 +1384,7 @@ static void sd_close(BlockDriverState *bs)
  memset(hdr, 0, sizeof(hdr));
  
  hdr.opcode = SD_OP_RELEASE_VDI;
 +hdr.base_vdi_id = s-inode.vdi_id;

How about renaming base_vdi_id to vdi_id?  What you want to send here
is not a base vdi id.  I think it's better to generalize the field
name so that we can use it here without confusion.

Thanks,

Kazutaka




Re: [Qemu-devel] [PATCH] sheepdog: pass vdi_id to sheep daemon for sd_close()

2013-01-29 Thread Liu Yuan
On 01/29/2013 04:51 PM, MORITA Kazutaka wrote:
 At Tue, 29 Jan 2013 16:22:49 +0800,
 Liu Yuan wrote:

 From: Liu Yuan tailai...@taobao.com

 Sheep daemon needs vdi_id to identify which vdi is closed to release 
 resources
 such as object cache.

 Cc: MORITA Kazutaka morita.kazut...@lab.ntt.co.jp
 Cc: Kevin Wolf kw...@redhat.com
 Cc: Stefan Hajnoczi stefa...@redhat.com
 Signed-off-by: Liu Yuan tailai...@taobao.com
 ---
  block/sheepdog.c |1 +
  1 file changed, 1 insertion(+)

 diff --git a/block/sheepdog.c b/block/sheepdog.c
 index 3e49bb8..97c76f5 100644
 --- a/block/sheepdog.c
 +++ b/block/sheepdog.c
 @@ -1384,6 +1384,7 @@ static void sd_close(BlockDriverState *bs)
  memset(hdr, 0, sizeof(hdr));
  
  hdr.opcode = SD_OP_RELEASE_VDI;
 +hdr.base_vdi_id = s-inode.vdi_id;
 
 How about renaming base_vdi_id to vdi_id?  What you want to send here
 is not a base vdi id.  I think it's better to generalize the field
 name so that we can use it here without confusion.
 

Okay. I'll send v2

Thanks,
Yuan