RE: [qmailadmin] Max forwards per account

2005-05-23 Thread Samir Noshy

 -Original Message-
 From: Tom Collins [mailto:[EMAIL PROTECTED] 
 Sent: Monday, May 23, 2005 4:06 AM
 To: qmailadmin@inter7.com
 Subject: Re: [qmailadmin] Max forwards per account
 
 On May 22, 2005, at 8:35 AM, Samir Noshy wrote:
  MAX_FORWARD_PER_USER not exists in that file , shall I 
 define it there 
  as a new variable?
 
 No, upgrade to 1.2.7.  Or, look in user.c for code that reads 
 `while( tmpstr != NULL  count  5)` and change the 5 to 
 whatever you want.
 

Thanks a lot Tom , it works fine.
 

Best Regards.
 
Samir Noshy
 




[qmailadmin] Max forwards per account

2005-05-22 Thread Samir Noshy
Hi everyone,

 
Why the MAX  Forward To addresses per account that can I set by qmailadmin
is 5 forwards ?
 
Can I change it to (for ex. 20 forward addresses) ??
 
 
 
 
Thanks in Advance.
 
 
Best Regards.
 
Samir Noshy




Re: [qmailadmin] Max forwards per account

2005-05-22 Thread Tom Collins

On May 22, 2005, at 7:01 AM, Samir Noshy wrote:
Why the MAX  Forward To addresses per account that can I set by 
qmailadmin

is 5 forwards ?

Can I change it to (for ex. 20 forward addresses) ??


Modify MAX_FORWARD_PER_USER in qmailadmin.h.  Keep in mind that the 
list has to fit in 500 characters for other reasons.


If you're forwarding to that many addresses, consider using an alias 
instead.  It will be easier to manage.  Or think about setting up a 
mailing list.


--
Tom Collins  -  [EMAIL PROTECTED]
QmailAdmin: http://qmailadmin.sf.net/  Vpopmail: http://vpopmail.sf.net/
You don't need a laptop to troubleshoot high-speed Internet: 
sniffter.com




RE: [qmailadmin] Max forwards per account

2005-05-22 Thread Samir Noshy



 -Original Message-
 From: Tom Collins [mailto:[EMAIL PROTECTED] 
 Sent: Sunday, May 22, 2005 6:12 PM
 To: qmailadmin@inter7.com
 Subject: Re: [qmailadmin] Max forwards per account
 
 On May 22, 2005, at 7:01 AM, Samir Noshy wrote:
  Why the MAX  Forward To addresses per account that can I set by 
  qmailadmin is 5 forwards ?
 
  Can I change it to (for ex. 20 forward addresses) ??
 
 Modify MAX_FORWARD_PER_USER in qmailadmin.h.  Keep in mind 
 that the list has to fit in 500 characters for other reasons.


 
MAX_FORWARD_PER_USER not exists in that file , shall I define it there as a
new variable?

For ex.  #define MAX_FORWARD_PER_USER 10.



Thanks a lot and Best Regards.
 
Samir Noshy
 




[qmailadmin] max forwards

2004-06-12 Thread qmailadmin user
Hi all,
I think this is for Tom or Jeremy.
I agree that using a mailing list when the number of alii/forwards 
exceeds some arbitrary number is a good thing; nonetheless, I've seen 
questions about the maximum number of alii/forwards on this list several 
times over the years.  May I offer a suggestion?

The line numbers below refer to qmailadmin-1.2.0 (tarball is misnamed 
qmailadmin-2.2.0.tar.gz)

In qmailadmin.h add this line:
#define MAX_FORWARDS 5
In user.c #916
change
while( tmpstr != NULL  count  5) {
to
while( tmpstr != NULL  count  MAX_FORWARDS) {
IMHO this should make that constant easier for do-it-yourselfers to find 
and modify.

Thanks again for a great product!
Mike Wright


Re: [qmailadmin] max forwards

2004-06-12 Thread Ken Jones
On Saturday 12 June 2004 12:05 pm, qmailadmin user wrote:
 Hi all,

 I think this is for Tom or Jeremy.

 I agree that using a mailing list when the number of alii/forwards
 exceeds some arbitrary number is a good thing; nonetheless, I've seen
 questions about the maximum number of alii/forwards on this list several
 times over the years.  May I offer a suggestion?

 The line numbers below refer to qmailadmin-1.2.0 (tarball is misnamed
 qmailadmin-2.2.0.tar.gz)

 In qmailadmin.h add this line:
 #define MAX_FORWARDS 5

 In user.c #916
 change
  while( tmpstr != NULL  count  5) {
 to
  while( tmpstr != NULL  count  MAX_FORWARDS) {


 IMHO this should make that constant easier for do-it-yourselfers to find
 and modify.

I agree. 
What about using the .qmailadmin-limits values for max forwards?

Ken Jones


Re: [qmailadmin] max forwards

2004-06-12 Thread Rick Widmer

Ken Jones wrote:
IMHO this should make that constant easier for do-it-yourselfers to find
and modify.

I agree. 
What about using the .qmailadmin-limits values for max forwards?
  +1
Rick



Re: [qmailadmin] max forwards

2004-06-12 Thread Tom Collins
On Jun 12, 2004, at 10:05 AM, qmailadmin user wrote:
In user.c #916
change
while( tmpstr != NULL  count  5) {
to
while( tmpstr != NULL  count  MAX_FORWARDS) {
IMHO this should make that constant easier for do-it-yourselfers to 
find and modify.
This is a good idea, but we would need to watch out for buffer 
overflows.  I think that the code assumes it can fit the entire lists 
of forwards into an arbitrarily-sized buffer.  It would be better to 
have the size of the buffer based on MAX_FORWARDS * (MAX_ADDRESS_SIZE + 
1).

--
Tom Collins  -  [EMAIL PROTECTED]
QmailAdmin: http://qmailadmin.sf.net/  Vpopmail: http://vpopmail.sf.net/
Info on the Sniffter hand-held Network Tester: http://sniffter.com/


Re: [qmailadmin] max forwards

2004-06-12 Thread qmailadmin user
Tom Collins wrote:
On Jun 12, 2004, at 10:05 AM, qmailadmin user wrote:
In user.c #916
change
while( tmpstr != NULL  count  5) {
to
while( tmpstr != NULL  count  MAX_FORWARDS) {
IMHO this should make that constant easier for do-it-yourselfers to 
find and modify.

This is a good idea, but we would need to watch out for buffer 
overflows.  I think that the code assumes it can fit the entire lists of 
forwards into an arbitrarily-sized buffer.  It would be better to have 
the size of the buffer based on MAX_FORWARDS * (MAX_ADDRESS_SIZE + 1).
Here are the lines that I think need to be changed to do that.  (I'm not 
a c prog'er so check my work ;)

The MAX_ADDRESS_SIZE was picked arbitrarily.  I added 2 to it instead of 
1 to accomodate the  and the \n when calculating the NewBuf size.

These changes are against qmailadmin-1.2.0
qmailadmin.h
38a39,41
 #define MAX_ADDRESS_SIZE 80
 #define MAX_FORWARDS  5

user.c
367c367
  static char NewBuf[156];
---
  static char NewBuf[MAX_FORWARDS * (MAX_ADDRESS_SIZE + 2)];
744c744
  static char NewBuf[156];
---
  static char NewBuf[MAX_FORWARDS * (MAX_ADDRESS_SIZE + 2)];
916c916
 while( tmpstr != NULL  count  5) {
---
 while( tmpstr != NULL  count  MAX_FORWARDS) {
Hope that's helpful.
Mike Wright
--
Tom Collins  -  [EMAIL PROTECTED]
QmailAdmin: http://qmailadmin.sf.net/  Vpopmail: http://vpopmail.sf.net/
Info on the Sniffter hand-held Network Tester: http://sniffter.com/