Re: Review Request 38161: Replaced a hard-coded number for registration backoff with a proper constant and extended comments.

2015-09-30 Thread Alexander Rukletsov


> On Sept. 29, 2015, 7:12 p.m., Ben Mahler wrote:
> > Thanks Alex, didn't realize I was on the reviewers here, so apologies for 
> > the delay! Why don't we just name the constant with DEFAULT to avoid the 
> > need for this and to make the meaning of the constant more clear?

Sure, I'll rename it.


> On Sept. 29, 2015, 7:12 p.m., Ben Mahler wrote:
> > src/tests/fault_tolerance_tests.cpp, lines 620-621
> > 
> >
> > Don't think you need these comments, we should just 
> > s/REGISTRATION_BACKOFF_FACTOR/DEFAULT_REGISTRATION_BACKOFF_FACTOR/ to be 
> > more explicit about it. We've started doing this for some of our constants 
> > already, but need to continue! :)

Yep, makes sense.


> On Sept. 29, 2015, 7:12 p.m., Ben Mahler wrote:
> > src/tests/fault_tolerance_tests.cpp, lines 1547-1551
> > 
> >
> > Ditto here, it seems like if we use DEFAULT in the name, we don't have 
> > to bother setting it here, thoughts?

Default `CreateSlaveFlags()` may tinker with this flag (and it actually does), 
therefore I would like to restore the default value anyway to ensure we advance 
the clock for the correct value.


- Alexander


---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/38161/#review100993
---


On Sept. 28, 2015, 5:08 p.m., Alexander Rukletsov wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/38161/
> ---
> 
> (Updated Sept. 28, 2015, 5:08 p.m.)
> 
> 
> Review request for mesos and Ben Mahler.
> 
> 
> Repository: mesos
> 
> 
> Description
> ---
> 
> See summary.
> 
> 
> Diffs
> -
> 
>   src/tests/fault_tolerance_tests.cpp 
> c97bc4691f9bac4a8677e6d2247be96ee9674b57 
> 
> Diff: https://reviews.apache.org/r/38161/diff/
> 
> 
> Testing
> ---
> 
> make check (Mac OS 10.10.4)
> 
> 
> Thanks,
> 
> Alexander Rukletsov
> 
>



Re: Review Request 38161: Replaced a hard-coded number for registration backoff with a proper constant and extended comments.

2015-09-28 Thread haosdent huang

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/38161/#review100821
---

Ship it!


Ship It!

- haosdent huang


On Sept. 28, 2015, 5:08 p.m., Alexander Rukletsov wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/38161/
> ---
> 
> (Updated Sept. 28, 2015, 5:08 p.m.)
> 
> 
> Review request for mesos and Ben Mahler.
> 
> 
> Repository: mesos
> 
> 
> Description
> ---
> 
> See summary.
> 
> 
> Diffs
> -
> 
>   src/tests/fault_tolerance_tests.cpp 
> c97bc4691f9bac4a8677e6d2247be96ee9674b57 
> 
> Diff: https://reviews.apache.org/r/38161/diff/
> 
> 
> Testing
> ---
> 
> make check (Mac OS 10.10.4)
> 
> 
> Thanks,
> 
> Alexander Rukletsov
> 
>



Re: Review Request 38161: Replaced a hard-coded number for registration backoff with a proper constant and extended comments.

2015-09-28 Thread Alexander Rukletsov

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/38161/
---

(Updated Sept. 28, 2015, 5:08 p.m.)


Review request for mesos and Ben Mahler.


Changes
---

Rebased.


Repository: mesos


Description
---

See summary.


Diffs (updated)
-

  src/tests/fault_tolerance_tests.cpp c97bc4691f9bac4a8677e6d2247be96ee9674b57 

Diff: https://reviews.apache.org/r/38161/diff/


Testing
---

make check (Mac OS 10.10.4)


Thanks,

Alexander Rukletsov



Re: Review Request 38161: Replaced a hard-coded number for registration backoff with a proper constant and extended comments.

2015-09-09 Thread Alexander Rukletsov

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/38161/
---

(Updated Sept. 9, 2015, 2:27 p.m.)


Review request for mesos and Ben Mahler.


Changes
---

Bernd's comments.


Repository: mesos


Description
---

See summary.


Diffs (updated)
-

  src/tests/fault_tolerance_tests.cpp 89cb18be96cd60fb77fbcc4acd08cebdcf1ba075 

Diff: https://reviews.apache.org/r/38161/diff/


Testing
---

make check (Mac OS 10.10.4)


Thanks,

Alexander Rukletsov



Re: Review Request 38161: Replaced a hard-coded number for registration backoff with a proper constant and extended comments.

2015-09-09 Thread Alexander Rukletsov


> On Sept. 8, 2015, 2:30 p.m., Bernd Mathiske wrote:
> > src/tests/fault_tolerance_tests.cpp, line 705
> > 
> >
> > s/re-/
> > s/retry/

Let's keep "retry" for clarity (we send a second registration request).


- Alexander


---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/38161/#review98004
---


On Sept. 7, 2015, 4:04 p.m., Alexander Rukletsov wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/38161/
> ---
> 
> (Updated Sept. 7, 2015, 4:04 p.m.)
> 
> 
> Review request for mesos and Ben Mahler.
> 
> 
> Repository: mesos
> 
> 
> Description
> ---
> 
> See summary.
> 
> 
> Diffs
> -
> 
>   src/tests/fault_tolerance_tests.cpp 
> 89cb18be96cd60fb77fbcc4acd08cebdcf1ba075 
> 
> Diff: https://reviews.apache.org/r/38161/diff/
> 
> 
> Testing
> ---
> 
> make check (Mac OS 10.10.4)
> 
> 
> Thanks,
> 
> Alexander Rukletsov
> 
>



Re: Review Request 38161: Replaced a hard-coded number for registration backoff with a proper constant and extended comments.

2015-09-09 Thread Guangya Liu

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/38161/#review98191
---

Ship it!


Ship It!

- Guangya Liu


On 九月 9, 2015, 2:27 p.m., Alexander Rukletsov wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/38161/
> ---
> 
> (Updated 九月 9, 2015, 2:27 p.m.)
> 
> 
> Review request for mesos and Ben Mahler.
> 
> 
> Repository: mesos
> 
> 
> Description
> ---
> 
> See summary.
> 
> 
> Diffs
> -
> 
>   src/tests/fault_tolerance_tests.cpp 
> 89cb18be96cd60fb77fbcc4acd08cebdcf1ba075 
> 
> Diff: https://reviews.apache.org/r/38161/diff/
> 
> 
> Testing
> ---
> 
> make check (Mac OS 10.10.4)
> 
> 
> Thanks,
> 
> Alexander Rukletsov
> 
>



Re: Review Request 38161: Replaced a hard-coded number for registration backoff with a proper constant and extended comments.

2015-09-08 Thread Bernd Mathiske

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/38161/#review98004
---



src/tests/fault_tolerance_tests.cpp (line 675)


Please clarify that this is a side effect of the following statement.

"As a side-effect of the following, ..."



src/tests/fault_tolerance_tests.cpp (line 705)


s/re-/
s/retry/



src/tests/fault_tolerance_tests.cpp (line 1545)


s/a default/a known value instead of what CreateSlaveFlags() or 
parameterless StartSlave() would assign.



src/tests/fault_tolerance_tests.cpp (line 1572)


s/re-/
s/retry/


- Bernd Mathiske


On Sept. 7, 2015, 9:04 a.m., Alexander Rukletsov wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/38161/
> ---
> 
> (Updated Sept. 7, 2015, 9:04 a.m.)
> 
> 
> Review request for mesos and Ben Mahler.
> 
> 
> Repository: mesos
> 
> 
> Description
> ---
> 
> See summary.
> 
> 
> Diffs
> -
> 
>   src/tests/fault_tolerance_tests.cpp 
> 89cb18be96cd60fb77fbcc4acd08cebdcf1ba075 
> 
> Diff: https://reviews.apache.org/r/38161/diff/
> 
> 
> Testing
> ---
> 
> make check (Mac OS 10.10.4)
> 
> 
> Thanks,
> 
> Alexander Rukletsov
> 
>



Review Request 38161: Replaced a hard-coded number for registration backoff with a proper constant and extended comments.

2015-09-07 Thread Alexander Rukletsov

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/38161/
---

Review request for mesos and Ben Mahler.


Repository: mesos


Description
---

See summary.


Diffs
-

  src/tests/fault_tolerance_tests.cpp 89cb18be96cd60fb77fbcc4acd08cebdcf1ba075 

Diff: https://reviews.apache.org/r/38161/diff/


Testing
---

make check (Mac OS 10.10.4)


Thanks,

Alexander Rukletsov