Re: Review Request 67387: Updated Mesos code to use `io::prepare_async`.

2018-06-25 Thread Benjamin Mahler

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/67387/#review205333
---




src/files/files.cpp
Lines 714-717 (original), 714-717 (patched)


`prepare_async` doesn't seem accurate to me, why not call it something more 
like what the error message here says? We're "making" something (a handle) 
async rather than "preparing".

E.g. `io::set_async` and `io::unset_async`? (Don't know if the latter works 
on windows).


- Benjamin Mahler


On May 30, 2018, 6:56 p.m., Akash Gupta wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/67387/
> ---
> 
> (Updated May 30, 2018, 6:56 p.m.)
> 
> 
> Review request for mesos, Andrew Schwartzmeyer, Benjamin Mahler, Eric Mumau, 
> John Kordich, Joseph Wu, and Radhika Jandhyala.
> 
> 
> Bugs: MESOS-5371 and MESOS-8668
> https://issues.apache.org/jira/browse/MESOS-5371
> https://issues.apache.org/jira/browse/MESOS-8668
> 
> 
> Repository: mesos
> 
> 
> Description
> ---
> 
> Due to the previous patch, instances that use `os::nonblock` before
> sending the file descriptor to the async IO functions now need to use
> `io::prepare_async`.
> 
> 
> Diffs
> -
> 
>   src/files/files.cpp 8d896ed59e88de86149e00ba80806b61aba15c86 
>   src/slave/container_loggers/logrotate.cpp 
> bd41912fdf9faa70957a768ea5541e60824864ba 
> 
> 
> Diff: https://reviews.apache.org/r/67387/diff/2/
> 
> 
> Testing
> ---
> 
> 
> Thanks,
> 
> Akash Gupta
> 
>



Re: Review Request 67387: Updated Mesos code to use `io::prepare_async`.

2018-06-25 Thread Joseph Wu

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/67387/#review205311
---


Ship it!




Ship It!

- Joseph Wu


On May 30, 2018, 11:56 a.m., Akash Gupta wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/67387/
> ---
> 
> (Updated May 30, 2018, 11:56 a.m.)
> 
> 
> Review request for mesos, Andrew Schwartzmeyer, Benjamin Mahler, Eric Mumau, 
> John Kordich, Joseph Wu, and Radhika Jandhyala.
> 
> 
> Bugs: MESOS-5371 and MESOS-8668
> https://issues.apache.org/jira/browse/MESOS-5371
> https://issues.apache.org/jira/browse/MESOS-8668
> 
> 
> Repository: mesos
> 
> 
> Description
> ---
> 
> Due to the previous patch, instances that use `os::nonblock` before
> sending the file descriptor to the async IO functions now need to use
> `io::prepare_async`.
> 
> 
> Diffs
> -
> 
>   src/files/files.cpp 8d896ed59e88de86149e00ba80806b61aba15c86 
>   src/slave/container_loggers/logrotate.cpp 
> bd41912fdf9faa70957a768ea5541e60824864ba 
> 
> 
> Diff: https://reviews.apache.org/r/67387/diff/2/
> 
> 
> Testing
> ---
> 
> 
> Thanks,
> 
> Akash Gupta
> 
>



Re: Review Request 67387: Updated Mesos code to use `io::prepare_async`.

2018-06-08 Thread Andrew Schwartzmeyer

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/67387/#review204499
---


Ship it!




Ship It!

- Andrew Schwartzmeyer


On May 30, 2018, 11:56 a.m., Akash Gupta wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/67387/
> ---
> 
> (Updated May 30, 2018, 11:56 a.m.)
> 
> 
> Review request for mesos, Andrew Schwartzmeyer, Benjamin Mahler, Eric Mumau, 
> John Kordich, Joseph Wu, and Radhika Jandhyala.
> 
> 
> Bugs: MESOS-5371 and MESOS-8668
> https://issues.apache.org/jira/browse/MESOS-5371
> https://issues.apache.org/jira/browse/MESOS-8668
> 
> 
> Repository: mesos
> 
> 
> Description
> ---
> 
> Due to the previous patch, instances that use `os::nonblock` before
> sending the file descriptor to the async IO functions now need to use
> `io::prepare_async`.
> 
> 
> Diffs
> -
> 
>   src/files/files.cpp 8d896ed59e88de86149e00ba80806b61aba15c86 
>   src/slave/container_loggers/logrotate.cpp 
> bd41912fdf9faa70957a768ea5541e60824864ba 
> 
> 
> Diff: https://reviews.apache.org/r/67387/diff/1/
> 
> 
> Testing
> ---
> 
> 
> Thanks,
> 
> Akash Gupta
> 
>



Review Request 67387: Updated Mesos code to use `io::prepare_async`.

2018-05-30 Thread Akash Gupta

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/67387/
---

Review request for mesos, Andrew Schwartzmeyer, Benjamin Mahler, Eric Mumau, 
John Kordich, Joseph Wu, and Radhika Jandhyala.


Bugs: MESOS-5371 and MESOS-8668
https://issues.apache.org/jira/browse/MESOS-5371
https://issues.apache.org/jira/browse/MESOS-8668


Repository: mesos


Description
---

Due to the previous patch, instances that use `os::nonblock` before
sending the file descriptor to the async IO functions now need to use
`io::prepare_async`.


Diffs
-

  src/files/files.cpp 8d896ed59e88de86149e00ba80806b61aba15c86 
  src/slave/container_loggers/logrotate.cpp 
bd41912fdf9faa70957a768ea5541e60824864ba 


Diff: https://reviews.apache.org/r/67387/diff/1/


Testing
---


Thanks,

Akash Gupta