Re: RFR: 8285516: clearPassword should be called in a finally try block [v3]

2022-05-05 Thread Sean Mullan
On Thu, 5 May 2022 06:02:14 GMT, Xue-Lei Andrew Fan  wrote:

>> Hi,
>> 
>> Could I have the simple update reviewed?
>> 
>> In the PKCS12 key store implementation, the PBEKeySpec.clearPassword() 
>> should be called in a finally try block.  Otherwise, the password cleanup 
>> could be interrupted by exceptions.
>> 
>> Thanks,
>> Xuelei
>
> Xue-Lei Andrew Fan has updated the pull request with a new target base due to 
> a merge or a rebase. The incremental webrev excludes the unrelated changes 
> brought in by the merge/rebase. The pull request contains three additional 
> commits since the last revision:
> 
>  - Merge
>  - an extra whitespace added
>  - 8285516: clearPassword should be called in a finally try block

Even though this looks like a very low risk change, I would advise not 
integrating until next week as the Loom integration into 19 is planned for this 
weekend and it would be better to have as few disruptions as possible. Thanks!

-

PR: https://git.openjdk.java.net/jdk/pull/8377


Re: RFR: 8285516: clearPassword should be called in a finally try block [v3]

2022-05-05 Thread Weijun Wang
On Thu, 5 May 2022 06:02:14 GMT, Xue-Lei Andrew Fan  wrote:

>> Hi,
>> 
>> Could I have the simple update reviewed?
>> 
>> In the PKCS12 key store implementation, the PBEKeySpec.clearPassword() 
>> should be called in a finally try block.  Otherwise, the password cleanup 
>> could be interrupted by exceptions.
>> 
>> Thanks,
>> Xuelei
>
> Xue-Lei Andrew Fan has updated the pull request with a new target base due to 
> a merge or a rebase. The incremental webrev excludes the unrelated changes 
> brought in by the merge/rebase. The pull request contains three additional 
> commits since the last revision:
> 
>  - Merge
>  - an extra whitespace added
>  - 8285516: clearPassword should be called in a finally try block

Tests run fine. No unexpected failure.

-

PR: https://git.openjdk.java.net/jdk/pull/8377


Re: RFR: 8285516: clearPassword should be called in a finally try block [v3]

2022-05-05 Thread Weijun Wang
On Thu, 5 May 2022 06:02:14 GMT, Xue-Lei Andrew Fan  wrote:

>> Hi,
>> 
>> Could I have the simple update reviewed?
>> 
>> In the PKCS12 key store implementation, the PBEKeySpec.clearPassword() 
>> should be called in a finally try block.  Otherwise, the password cleanup 
>> could be interrupted by exceptions.
>> 
>> Thanks,
>> Xuelei
>
> Xue-Lei Andrew Fan has updated the pull request with a new target base due to 
> a merge or a rebase. The incremental webrev excludes the unrelated changes 
> brought in by the merge/rebase. The pull request contains three additional 
> commits since the last revision:
> 
>  - Merge
>  - an extra whitespace added
>  - 8285516: clearPassword should be called in a finally try block

Running now...

-

PR: https://git.openjdk.java.net/jdk/pull/8377


Re: RFR: 8285516: clearPassword should be called in a finally try block [v3]

2022-05-05 Thread Xue-Lei Andrew Fan
> Hi,
> 
> Could I have the simple update reviewed?
> 
> In the PKCS12 key store implementation, the PBEKeySpec.clearPassword() should 
> be called in a finally try block.  Otherwise, the password cleanup could be 
> interrupted by exceptions.
> 
> Thanks,
> Xuelei

Xue-Lei Andrew Fan has updated the pull request with a new target base due to a 
merge or a rebase. The incremental webrev excludes the unrelated changes 
brought in by the merge/rebase. The pull request contains three additional 
commits since the last revision:

 - Merge
 - an extra whitespace added
 - 8285516: clearPassword should be called in a finally try block

-

Changes:
  - all: https://git.openjdk.java.net/jdk/pull/8377/files
  - new: https://git.openjdk.java.net/jdk/pull/8377/files/99079d30..1df828df

Webrevs:
 - full: https://webrevs.openjdk.java.net/?repo=jdk=8377=02
 - incr: https://webrevs.openjdk.java.net/?repo=jdk=8377=01-02

  Stats: 32346 lines in 832 files changed: 22171 ins; 4511 del; 5664 mod
  Patch: https://git.openjdk.java.net/jdk/pull/8377.diff
  Fetch: git fetch https://git.openjdk.java.net/jdk pull/8377/head:pull/8377

PR: https://git.openjdk.java.net/jdk/pull/8377