Re: RFR: 8284161: Implementation of Virtual Threads (Preview) [v8]

2022-04-27 Thread Brian Burkhalter
On Wed, 27 Apr 2022 14:24:20 GMT, Alan Bateman  wrote:

>> This is the implementation of JEP 425: Virtual Threads (Preview); TBD which 
>> JDK version to target.
>> 
>> We will refresh this PR periodically to pick up changes and fixes from the 
>> loom repo.
>> 
>> Most of the new mechanisms in the HotSpot VM are disabled by default and 
>> require running with `--enable-preview` to enable.
>> 
>> The patch has support for x64 and aarch64 on the usual operating systems 
>> (Linux, macOS, and Windows). There are stubs (calling Unimplemented) for 
>> zero and some of the other ports. Additional ports can be contributed via 
>> PRs against the fibers branch in the loom repo.
>> 
>> There are changes in many areas. To reduce notifications/mails, the labels 
>> have been trimmed down for now to hotspot, serviceability and core-libs. 
>> We'll add the complete set of labels when the PR is further along.
>> 
>> The changes include a refresh of java.util.concurrent and ForkJoinPool from 
>> Doug Lea's CVS. These changes will probably be proposed and integrated in 
>> advance of this PR.
>> 
>> The changes include some non-exposed and low-level infrastructure to support 
>> the (in draft) JEPs for Structured Concurrency and Scope Locals. This is to 
>> make life a bit easier and avoid having to separate VM changes and juggle 
>> branches at this time.
>
> Alan Bateman has updated the pull request incrementally with one additional 
> commit since the last revision:
> 
>   Refresh 7965cc6b168e567ac2596f2fbc3b00a7d99b7e1e

The changes to the `java.io` package and related files in `libjava`, and the 
changes to the non-networking parts of the `java.nio.channels`, `sun.nio.ch`, 
and `sun.nio.fs` packages and related files in `libnio` all look fine to me.

-

Marked as reviewed by bpb (Reviewer).

PR: https://git.openjdk.java.net/jdk/pull/8166


Re: RFR: 8284853: Fix varios 'expected' typo

2022-04-13 Thread Brian Burkhalter
On Wed, 13 Apr 2022 20:36:48 GMT, Andrey Turbanov  wrote:

> Found various typos of expected: `exepected`, `exept`, `epectedly`, 
> `expeced`, `Unexpeted`, etc.

Expect the Unexpeted.

-

Marked as reviewed by bpb (Reviewer).

PR: https://git.openjdk.java.net/jdk/pull/8231


Re: Integrated: 8284015: ProblemList containers/docker/TestJcmd.java on linux-x64

2022-03-30 Thread Brian Burkhalter
On Wed, 30 Mar 2022 15:09:08 GMT, Daniel D. Daugherty  
wrote:

> A trivial fix to ProblemList containers/docker/TestJcmd.java on linux-x64.

Marked as reviewed by bpb (Reviewer).

-

PR: https://git.openjdk.java.net/jdk/pull/8042


Re: RFR: 8283800: Simplify String.indexOf/lastIndexOf calls

2022-03-28 Thread Brian Burkhalter
On Sun, 20 Mar 2022 12:45:34 GMT, Andrey Turbanov  wrote:

> In a few places String.indexOf/lastIndexOf methods are called with default 
> parameter for index: `0` for `indexOf`, length() for `lastIndexOf`.
> I propose to cleanup such calls. It makes code a bit easier to read. In case 
> of `indexOf` it even could be faster, as there is separate intrinsic for 
> `indexOf` call without index argument.

Marked as reviewed by bpb (Reviewer).

-

PR: https://git.openjdk.java.net/jdk/pull/7877


Re: [jdk18] Integrated: 8278521: ProblemList java/lang/management/ThreadMXBean/ThreadLists.java

2021-12-09 Thread Brian Burkhalter
On Thu, 9 Dec 2021 21:57:13 GMT, Daniel D. Daugherty  wrote:

> A trivial fix to ProblemList 
> java/lang/management/ThreadMXBean/ThreadLists.java on all configs.

Marked as reviewed by bpb (Reviewer).

-

PR: https://git.openjdk.java.net/jdk18/pull/3


Re: RFR: 8277346: ProblemList 7 serviceability/sa tests on macosx-x64

2021-11-17 Thread Brian Burkhalter
On Wed, 17 Nov 2021 20:43:46 GMT, Daniel D. Daugherty  
wrote:

> A trivial fix to ProblemList 7 serviceability/sa tests on macosx-x64.

Marked as reviewed by bpb (Reviewer).

-

PR: https://git.openjdk.java.net/jdk/pull/6438


Re: Integrated: 8276367: ProblemList vmTestbase/nsk/jvmti/RedefineClasses/StressRedefineWithoutBytecodeCorruption/TestDescription.java

2021-11-02 Thread Brian Burkhalter
On Tue, 2 Nov 2021 16:34:26 GMT, Daniel D. Daugherty  wrote:

> A trivial fix to ProblemList 
> vmTestbase/nsk/jvmti/RedefineClasses/StressRedefineWithoutBytecodeCorruption/TestDescription.java

Marked as reviewed by bpb (Reviewer).

-

PR: https://git.openjdk.java.net/jdk/pull/6214


Re: RFR: 8253497: Core Libs Terminology Refresh [v3]

2020-12-15 Thread Brian Burkhalter
On Tue, 15 Dec 2020 22:21:12 GMT, Brent Christian  wrote:

>> This is part of an effort in the JDK to replace archaic/non-inclusive words 
>> with more neutral terms (see JDK-8253315 for details).
>> 
>> Here are the changes covering core libraries code and tests.  Terms were 
>> changed as follows:
>> 1. grandfathered -> legacy
>> 2. blacklist -> filter or reject
>> 3. whitelist -> allow or accept
>> 4. master -> coordinator
>> 5. slave -> worker
>> 
>> Addressing similar issues in upstream 3rd party code is out of scope of this 
>> PR.  Such changes will be picked up from their upstream sources.
>
> Brent Christian has updated the pull request incrementally with three 
> additional commits since the last revision:
> 
>  - This is the controller
>  - use 'controller' in Assert.java
>  - use 'peer' in CloseRegisteredChannel.java

Marked as reviewed by bpb (Reviewer).

-

PR: https://git.openjdk.java.net/jdk/pull/1771


Re: RFR: 8253497: Core Libs Terminology Refresh [v2]

2020-12-15 Thread Brian Burkhalter
On Tue, 15 Dec 2020 01:46:08 GMT, Brent Christian  wrote:

>> This is part of an effort in the JDK to replace archaic/non-inclusive words 
>> with more neutral terms (see JDK-8253315 for details).
>> 
>> Here are the changes covering core libraries code and tests.  Terms were 
>> changed as follows:
>> 1. grandfathered -> legacy
>> 2. blacklist -> filter or reject
>> 3. whitelist -> allow or accept
>> 4. master -> coordinator
>> 5. slave -> worker
>> 
>> Addressing similar issues in upstream 3rd party code is out of scope of this 
>> PR.  Such changes will be picked up from their upstream sources.
>
> Brent Christian has updated the pull request incrementally with one 
> additional commit since the last revision:
> 
>   updates, per code review

test/jdk/java/lang/ClassLoader/Assert.java line 65:

> 63: 
> 64: int switchSource = 0;
> 65: if (args.length == 0) { // This is the coordinator version

Perhaps s/coordinator/controller/?

-

PR: https://git.openjdk.java.net/jdk/pull/1771


Re: RFR(S) : 8183040 : update jdk/test/lib/Platform.java to use NIO file API

2020-06-09 Thread Brian Burkhalter
Hi Igor,

> On Jun 9, 2020, at 4:47 PM, Igor Ignatyev  wrote:
> 
> could you please review this small clean up of testlibrary classes which 
> updates j.t.lib.Platform and j.t.l.SA.SATestUtils (as it now contains the 
> methods which 8183040 was about) to use NIO file API?
> 
> testing: test/hotspot/jtreg/serviceability 
> webrev: http://cr.openjdk.java.net/~iignatyev//8183040/webrev.00 
> 
> JBS: https://bugs.openjdk.java.net/browse/JDK-8183040 
> 
The NIO changes look all right to me.

Brian

6504660: HPI panic callback is dead code

2019-03-08 Thread Brian Burkhalter
Looping in serviceability-dev@openjdk.java.net.

Thanks,

Brian

> Begin forwarded message:
> 
> From: Claes Redestad 
> Subject: Re: 6504660: HPI panic callback is dead code
> Date: March 7, 2019 at 9:43:45 AM GMT
> To: Brian Burkhalter , core-libs-dev 
> 
> 
> Hi Brian,
> 
> looks fine!
> 
> Thanks!
> 
> /Claes
> 
> On 2019-03-07 10:39, Brian Burkhalter wrote:
>> Please review this fix [1] to remove dead code [2].
>> Thanks,
>> Brian
>> [1] http://cr.openjdk.java.net/~bpb/6504660/webrev.00/
>> [2] https://bugs.openjdk.java.net/browse/JDK-6504660



Re: JDK 9 RFR of 8038163: Build failure on Mac OS 10.9.2 (Mavericks) due to warning treated as error

2014-03-21 Thread Brian Burkhalter

On Mar 21, 2014, at 12:44 PM, Staffan Larsen staffan.lar...@oracle.com wrote:

 Looks good to me. 

Thanks.

 The version with JNI_TRUE/JNI_FALSE is more correct, but I’m fine with either 
 one.

Updated to this form:

http://cr.openjdk.java.net/~bpb/8038163/webrev.01/

 (note: this review request should have been sent to serviceability-dev).

I had no clue to which comp/sub-comp it belongs.

What test would I run to verify this change (other than that if fixes the 
build)?

Brian

hg: jdk8/tl/jdk: 2 new changesets

2013-12-05 Thread brian . burkhalter
Changeset: d3c4e8fe98c3
Author:bpb
Date:  2013-12-05 07:44 -0800
URL:   http://hg.openjdk.java.net/jdk8/tl/jdk/rev/d3c4e8fe98c3

8029514: java/math/BigInteger/BigIntegerTest.java failing since thresholds 
adjusted in 8022181
Summary: Ensure the value returned by getLower() is unsigned.
Reviewed-by: darcy

! src/share/classes/java/math/BigInteger.java
! test/java/math/BigInteger/BigIntegerTest.java

Changeset: 303f4bccfca2
Author:bpb
Date:  2013-12-05 07:45 -0800
URL:   http://hg.openjdk.java.net/jdk8/tl/jdk/rev/303f4bccfca2

8029501: BigInteger division algorithm selection heuristic is incorrect
Summary: Change Burnikel-Ziegler division heuristic to require that the 
dividend int-length exceed that of the divisor by a minimum amount.
Reviewed-by: darcy

! src/share/classes/java/math/BigInteger.java
! src/share/classes/java/math/MutableBigInteger.java



hg: jdk8/tl/jdk: 8022181: Tune algorithm crossover thresholds in BigInteger

2013-12-03 Thread brian . burkhalter
Changeset: c138b0d33980
Author:bpb
Date:  2013-12-03 12:25 -0800
URL:   http://hg.openjdk.java.net/jdk8/tl/jdk/rev/c138b0d33980

8022181: Tune algorithm crossover thresholds in BigInteger
Summary: Change multiplication, squaring, division, and base conversion 
thresholds to values which retain performance improvement in most cases but 
with a a lower overall risk of regression.
Reviewed-by: darcy

! src/share/classes/java/math/BigInteger.java



hg: jdk8/tl/jdk: 8027625: test/java/math/BigInteger/ExtremeShiftingTests.java needs @run tag to specify heap size

2013-11-04 Thread brian . burkhalter
Changeset: 92fb6baaebc4
Author:bpb
Date:  2013-11-04 08:05 -0800
URL:   http://hg.openjdk.java.net/jdk8/tl/jdk/rev/92fb6baaebc4

8027625: test/java/math/BigInteger/ExtremeShiftingTests.java needs @run tag to 
specify heap size
Summary: Add @run tag to specify heap size
Reviewed-by: alanb, dxu

! test/java/math/BigInteger/ExtremeShiftingTests.java



hg: jdk8/tl/jdk: 6910473: java.math.BigInteger.bitLength() may return negative int on large numbers; ...

2013-10-30 Thread brian . burkhalter
Changeset: 0734e1584d9d
Author:bpb
Date:  2013-10-30 17:45 -0700
URL:   http://hg.openjdk.java.net/jdk8/tl/jdk/rev/0734e1584d9d

6910473: java.math.BigInteger.bitLength() may return negative int on large 
numbers
8021203: BigInteger.doubleValue/floatValue returns 0.0 instead of Infinity
8021204: Constructor BigInteger(String val, int radix) doesn't detect overflow
8022780: Incorrect BigInteger division because of MutableBigInteger.bitLength() 
overflow
Summary: Prevent construction of overflowed BigIntegers.
Reviewed-by: bpb, darcy, psandoz
Contributed-by: Dmitry Nadezhin dmitry.nadez...@oracle.com

! src/share/classes/java/math/BigInteger.java
! src/share/classes/java/math/MutableBigInteger.java
+ test/java/math/BigInteger/BitLengthOverflow.java
+ test/java/math/BigInteger/DivisionOverflow.java
+ test/java/math/BigInteger/DoubleValueOverflow.java
! test/java/math/BigInteger/ExtremeShiftingTests.java
+ test/java/math/BigInteger/StringConstructorOverflow.java
+ test/java/math/BigInteger/SymmetricRangeTests.java



hg: jdk8/tl/jdk: 7179567: JCK8 tests: api/java_net/URLClassLoader/index.html#Ctor3 failed with NPE; ...

2013-10-22 Thread brian . burkhalter
Changeset: 2be08cdd1ced
Author:bpb
Date:  2013-10-22 11:25 -0700
URL:   http://hg.openjdk.java.net/jdk8/tl/jdk/rev/2be08cdd1ced

7179567: JCK8 tests: api/java_net/URLClassLoader/index.html#Ctor3 failed with 
NPE
6445180: URLClassLoader does not describe the behavior of several methods with 
respect to null arguments
Summary: Document when a NPE will be thrown by URLClassLoader constructors, 
newInstance(), findClass(), and getPermissions().
Reviewed-by: alanb, mduigou, chegar, dholmes, jrose

! src/share/classes/java/net/URLClassLoader.java
! src/share/classes/javax/management/remote/rmi/NoCallStackClassLoader.java
! src/share/classes/sun/applet/AppletClassLoader.java
+ test/java/net/URLClassLoader/NullURLTest.java



hg: jdk8/tl/jdk: 8026832: Clean up straggling doclint warnings in java.math

2013-10-17 Thread brian . burkhalter
Changeset: e76bb2436b04
Author:bpb
Date:  2013-10-17 15:05 -0700
URL:   http://hg.openjdk.java.net/jdk8/tl/jdk/rev/e76bb2436b04

8026832: Clean up straggling doclint warnings in java.math
Summary: Fix empty paragraph tag warnings.
Reviewed-by: lancea

! src/share/classes/java/math/BigDecimal.java
! src/share/classes/java/math/RoundingMode.java



hg: jdk8/tl/jdk: 8010371: getaddrinfo can fail with EAI_SYSTEM/EAGAIN, causes UnknownHostException to be thrown

2013-10-15 Thread brian . burkhalter
Changeset: 3676f04e6553
Author:bpb
Date:  2013-10-15 16:45 -0700
URL:   http://hg.openjdk.java.net/jdk8/tl/jdk/rev/3676f04e6553

8010371: getaddrinfo can fail with EAI_SYSTEM/EAGAIN, causes 
UnknownHostException to be thrown
Summary: Modify UHE exception message for EAI_AGAIN failures.
Reviewed-by: alanb, chegar, michaelm, dsamersoff
Contributed-by: Brian Burkhalter brian.burkhal...@oracle.com

! src/solaris/native/java/net/Inet4AddressImpl.c
! src/windows/native/java/net/Inet4AddressImpl.c
! src/windows/native/java/net/Inet6AddressImpl.c



hg: jdk8/tl/jdk: 8016252: More defensive HashSet.readObject

2013-10-09 Thread brian . burkhalter
Changeset: b86e6700266e
Author:bpb
Date:  2013-10-09 11:47 -0700
URL:   http://hg.openjdk.java.net/jdk8/tl/jdk/rev/b86e6700266e

8016252: More defensive HashSet.readObject
Summary: Add data validation checks in readObject().
Reviewed-by: alanb, mduigou, chegar
Contributed-by: Brian Burkhalter brian.burkhal...@oracle.com

! src/share/classes/java/util/HashSet.java
+ test/java/util/HashSet/Serialization.java



hg: jdk8/tl/jdk: 7189139: BigInteger's staticRandom field can be a source of bottlenecks.

2013-10-09 Thread brian . burkhalter
Changeset: 673f8045311e
Author:bpb
Date:  2013-10-09 17:22 -0700
URL:   http://hg.openjdk.java.net/jdk8/tl/jdk/rev/673f8045311e

7189139: BigInteger's staticRandom field can be a source of bottlenecks.
Summary: Use ThreadLocalRandom instead of SecureRandom.
Reviewed-by: shade, psandoz
Contributed-by: Brian Burkhalter brian.burkhal...@oracle.com

! src/share/classes/java/math/BigInteger.java



hg: jdk8/tl/jdk: 8010430: Math.round has surprising behavior for odd values of ulp 1

2013-09-20 Thread brian . burkhalter
Changeset: 917fffe971c8
Author:bpb
Date:  2013-09-11 17:07 -0700
URL:   http://hg.openjdk.java.net/jdk8/tl/jdk/rev/917fffe971c8

8010430: Math.round has surprising behavior for odd values of ulp 1
Summary: If the effective floating point exponent is zero return the 
significand including the implicit 1-bit.
Reviewed-by: bpb, darcy, gls
Contributed-by: Dmitry Nadezhin dmitry.nadez...@oracle.com

! src/share/classes/java/lang/Math.java
! src/share/classes/java/lang/StrictMath.java
! test/java/lang/Math/RoundTests.java



hg: jdk8/tl/jdk: 8024331: j.u.Map.computeIfPresent() default/nondefault implementations don't throw NPE if the remappingFunction is null and the key is absent

2013-09-20 Thread brian . burkhalter
Changeset: 2552cd270350
Author:bpb
Date:  2013-09-20 15:12 -0700
URL:   http://hg.openjdk.java.net/jdk8/tl/jdk/rev/2552cd270350

8024331: j.u.Map.computeIfPresent() default/nondefault implementations don't 
throw NPE if the remappingFunction is null and the key is absent
Summary: Explicitly check for null remappingFunction parameter.
Reviewed-by: mduigou, forax, psandoz
Contributed-by: Brian Burkhalter brian.burkhal...@oracle.com

! src/share/classes/java/util/HashMap.java
! src/share/classes/java/util/Map.java
! test/java/util/Map/Defaults.java