CVS: cvs.openbsd.org: src

2021-11-14 Thread Theo Buehler
CVSROOT:/cvs
Module name:src
Changes by: t...@cvs.openbsd.org2021/11/14 15:31:29

Modified files:
lib/libssl : ssl_lib.c 

Log message:
Fix a strange check in the auto DH codepath

The code assumes that the server certificate has an RSA key and bases
the calculation of the size of the ephemeral DH key on this assumption.
So instead of checking whether we have any key by inspecting the dh
part of the union, let's check that we actually have an RSA key.
While here, make sure that its length is non-negative.

ok jsing



CVS: cvs.openbsd.org: src

2021-11-14 Thread Philip Guenther
CVSROOT:/cvs
Module name:src
Changes by: guent...@cvs.openbsd.org2021/11/14 15:07:39

Modified files:
libexec/ld.so/hppa: boot_md.c archdep.h 
libexec/ld.so/aarch64: archdep.h 
libexec/ld.so/alpha: archdep.h 
libexec/ld.so/amd64: archdep.h 
libexec/ld.so/arm: archdep.h 
libexec/ld.so/i386: archdep.h 
libexec/ld.so/m88k: archdep.h 
libexec/ld.so/mips64: archdep.h 
libexec/ld.so/powerpc: archdep.h 
libexec/ld.so/powerpc64: archdep.h 
libexec/ld.so/riscv64: archdep.h 
libexec/ld.so/sh: archdep.h 
libexec/ld.so/sparc64: archdep.h 

Log message:
Delete all the no-op RELOC_GOT() macros and their uses.
Annotate RELOC_DYN() on non-hppa as only used in lib/csu.
Delete some inconsistent comments, adjust whitespace, and reorder
mips64's archdep.h so that the ld.so/*/archdep.h files look
(almost) the same.

ok visa@ kettenis@



CVS: cvs.openbsd.org: src

2021-11-14 Thread Philip Guenther
CVSROOT:/cvs
Module name:src
Changes by: guent...@cvs.openbsd.org2021/11/14 14:51:48

Modified files:
sys/arch/amd64/stand/efiboot: Makefile.common 
sys/arch/arm64/stand/efiboot: Makefile 
sys/arch/armv7/stand/efiboot: Makefile 
sys/arch/riscv64/stand/efiboot: Makefile 

Log message:
Make sure efiboot is built with RELA/REL relocations and not RELR,
as self_reloc.c only handles the former.

ok deraadt@ kettenis@



CVS: cvs.openbsd.org: xenocara

2021-11-14 Thread Robert Nagy
CVSROOT:/cvs
Module name:xenocara
Changes by: rob...@cvs.openbsd.org  2021/11/14 14:46:38

Modified files:
lib/fontconfig/conf.d: Makefile 

Log message:
do not disable bitmap fonts by default;
if you already have /etc/fonts/conf.d/70-no-bitmaps.conf, you might
want to delete it

ok matthieu@



CVS: cvs.openbsd.org: src

2021-11-14 Thread Theo de Raadt
CVSROOT:/cvs
Module name:src
Changes by: dera...@cvs.openbsd.org 2021/11/14 11:47:44

Modified files:
usr.bin/ssh: sshd.c 

Log message:
use ppoll() instead of pselect()
with djm



CVS: cvs.openbsd.org: src

2021-11-14 Thread Florian Obser
CVSROOT:/cvs
Module name:src
Changes by: flor...@cvs.openbsd.org 2021/11/14 11:13:19

Modified files:
sbin/dhcpleased: engine.c 

Log message:
When we transition from RENEWING to REBINDING state we have to
calculate the next timeout based on the rebinding time (T2), not
renewal time (T1). At this point T1 already expired and we would wait
way too long, past the lease lifetime.

Spotted while investigating a problem reported by Zack Newman on misc@



CVS: cvs.openbsd.org: src

2021-11-14 Thread Kenneth R Westerback
CVSROOT:/cvs
Module name:src
Changes by: k...@cvs.openbsd.org2021/11/14 10:28:29

Modified files:
sbin/fdisk : mbr.c 

Log message:
Calculate initial OpenBSD partition start/size using LBA values
instead of CHS values. Shorter, easier to follow.

No intentional functional change.



CVS: cvs.openbsd.org: src

2021-11-14 Thread Ingo Schwarze
CVSROOT:/cvs
Module name:src
Changes by: schwa...@cvs.openbsd.org2021/11/14 06:40:16

Modified files:
lib/libcrypto/man: BIO_read.3 

Log message:
the last argument of BIO_gets(3) is called "size", not "len"



CVS: cvs.openbsd.org: src

2021-11-14 Thread Ingo Schwarze
CVSROOT:/cvs
Module name:src
Changes by: schwa...@cvs.openbsd.org2021/11/14 04:22:36

Modified files:
lib/libcrypto/man: ASN1_STRING_length.3 

Log message:
fix a typo; diff from Matthias Schmidt  on tech@



CVS: cvs.openbsd.org: src

2021-11-14 Thread Antoine Jacoutot
CVSROOT:/cvs
Module name:src
Changes by: ajacou...@cvs.openbsd.org   2021/11/14 02:31:44

Modified files:
etc/rc.d   : rc.subr 

Log message:
Improve and simplify timer handling in "stop" and "reload".
Rename _rc_wait to _rc_wait_for_start since only "start" uses this now (to
handle rc_bg daemons).
In any situation, none of these actions should be able to hang boot or shutdown.

We should now be able to manage most corner cases out there ("most" because it's
unreasonable to assume we can cope with all the non-default
rc_{start,stop,reload} crazyness).

Several tests have been made and no obvious regression has been found.
But that doesn't mean there isn't; if some behavior changed for the worst, talk
to me.

ok robert@ sthen@



CVS: cvs.openbsd.org: src

2021-11-14 Thread Joel Sing
CVSROOT:/cvs
Module name:src
Changes by: js...@cvs.openbsd.org   2021/11/14 01:21:47

Modified files:
lib/libcrypto/x509: x509_verify.c 

Log message:
Put curly brace on the correct line.