Re: [SSSD] [PATCH] BUILD: Rename whitespace tests

2015-10-02 Thread Nikolai Kondrashov

On 10/02/2015 03:22 PM, Lukas Slebodnik wrote:

ehlo,

attached patch should fix valgrind issues with whitespace_test


Ah, I figured it out finally. Unfortunately that doesn't work on RHEL6 [1],
where Automake doesn't support LOG_COMPILER and such and we have to use
AUX_TEST_ENVIRONMENT instead. See contrib/ci/make-check-wrap.

Nick

[1] http://sssd-ci.duckdns.org/logs/job/28/61/summary.html
___
sssd-devel mailing list
sssd-devel@lists.fedorahosted.org
https://lists.fedorahosted.org/mailman/listinfo/sssd-devel


Re: [SSSD] [PATCH] BUILD: Rename whitespace tests

2015-10-02 Thread Nikolai Kondrashov

On 10/02/2015 04:49 PM, Lukas Slebodnik wrote:

On (02/10/15 16:09), Nikolai Kondrashov wrote:

On 10/02/2015 03:22 PM, Lukas Slebodnik wrote:

attached patch should fix valgrind issues with whitespace_test


Thank you, Lukas. This seems fine. I have also made another patch which
excludes whitespace_test from Valgrind run instead of renaming it.

I'm not sure which is better and actually don't quite understand how your
version works, but here it is :)

Nick



From 72533b05c2b2bcb90771bf9c91e9dade6e94b579 Mon Sep 17 00:00:00 2001
From: Nikolai Kondrashov 
Date: Fri, 2 Oct 2015 15:54:23 +0300
Subject: [PATCH] CI: Exclude whitespace_test from Valgrind checks

Exclude whitespace_test from Valgrind checks in contrib/ci/run to
prevent it from failing the tests due to Bash bugs.
---
contrib/ci/run | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/contrib/ci/run b/contrib/ci/run
index 5f668ff..4d89c8a 100755
--- a/contrib/ci/run
+++ b/contrib/ci/run
@@ -206,7 +206,7 @@ function build_debug()
 make-check-wrap -j $CPU_NUM check -- \
 libtool --mode=execute \
 valgrind-condense 99 \
-'!(*.py|*dlopen-tests)' -- \
+'!(*.py|*dlopen-tests|*/whitespace_test)' 
-- \

This patch is simpler. So it would be better to use this way.


Alright.


I have never understood what is the purpose of this regex.


Yeah, it is only expained in contrib/ci/valgrind-condense.


Would make sense to move it into separate variable
with meaningful name?


Yeah, I'll remake the patch to also do that. It's getting longish anyway.

Nick
___
sssd-devel mailing list
sssd-devel@lists.fedorahosted.org
https://lists.fedorahosted.org/mailman/listinfo/sssd-devel


Re: [SSSD] [PATCH] BUILD: Rename whitespace tests

2015-10-02 Thread Nikolai Kondrashov

On 10/02/2015 04:54 PM, Nikolai Kondrashov wrote:

On 10/02/2015 04:49 PM, Lukas Slebodnik wrote:

On (02/10/15 16:09), Nikolai Kondrashov wrote:

On 10/02/2015 03:22 PM, Lukas Slebodnik wrote:

attached patch should fix valgrind issues with whitespace_test


Thank you, Lukas. This seems fine. I have also made another patch which
excludes whitespace_test from Valgrind run instead of renaming it.

I'm not sure which is better and actually don't quite understand how your
version works, but here it is :)

Nick



From 72533b05c2b2bcb90771bf9c91e9dade6e94b579 Mon Sep 17 00:00:00 2001
From: Nikolai Kondrashov 
Date: Fri, 2 Oct 2015 15:54:23 +0300
Subject: [PATCH] CI: Exclude whitespace_test from Valgrind checks

Exclude whitespace_test from Valgrind checks in contrib/ci/run to
prevent it from failing the tests due to Bash bugs.
---
contrib/ci/run | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/contrib/ci/run b/contrib/ci/run
index 5f668ff..4d89c8a 100755
--- a/contrib/ci/run
+++ b/contrib/ci/run
@@ -206,7 +206,7 @@ function build_debug()
 make-check-wrap -j $CPU_NUM check -- \
 libtool --mode=execute \
 valgrind-condense 99 \
-'!(*.py|*dlopen-tests)' -- \
+'!(*.py|*dlopen-tests|*/whitespace_test)' 
-- \

This patch is simpler. So it would be better to use this way.


Alright.


I have never understood what is the purpose of this regex.


Yeah, it is only expained in contrib/ci/valgrind-condense.


Would make sense to move it into separate variable
with meaningful name?


Yeah, I'll remake the patch to also do that. It's getting longish anyway.


OMG, I just realized that due to a logic overlook on my part the filtered-out
tests weren't actually running at all, instead of running without Valgrind.

Will send a separate patch.

Nick
___
sssd-devel mailing list
sssd-devel@lists.fedorahosted.org
https://lists.fedorahosted.org/mailman/listinfo/sssd-devel


Re: [SSSD] [PATCH] BUILD: Rename whitespace tests

2015-10-02 Thread Lukas Slebodnik
On (02/10/15 16:09), Nikolai Kondrashov wrote:
>On 10/02/2015 03:22 PM, Lukas Slebodnik wrote:
>>attached patch should fix valgrind issues with whitespace_test
>
>Thank you, Lukas. This seems fine. I have also made another patch which
>excludes whitespace_test from Valgrind run instead of renaming it.
>
>I'm not sure which is better and actually don't quite understand how your
>version works, but here it is :)
>
>Nick

>From 72533b05c2b2bcb90771bf9c91e9dade6e94b579 Mon Sep 17 00:00:00 2001
>From: Nikolai Kondrashov 
>Date: Fri, 2 Oct 2015 15:54:23 +0300
>Subject: [PATCH] CI: Exclude whitespace_test from Valgrind checks
>
>Exclude whitespace_test from Valgrind checks in contrib/ci/run to
>prevent it from failing the tests due to Bash bugs.
>---
> contrib/ci/run | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
>diff --git a/contrib/ci/run b/contrib/ci/run
>index 5f668ff..4d89c8a 100755
>--- a/contrib/ci/run
>+++ b/contrib/ci/run
>@@ -206,7 +206,7 @@ function build_debug()
> make-check-wrap -j $CPU_NUM check -- \
> libtool --mode=execute \
> valgrind-condense 99 \
>-'!(*.py|*dlopen-tests)' -- \
>+'!(*.py|*dlopen-tests|*/whitespace_test)' 
>-- \
This patch is simpler. So it would be better to use this way.
I have never understood what is the purpose of this regex.
Would make sense to move it into separate variable
with meaningful name?

LS
___
sssd-devel mailing list
sssd-devel@lists.fedorahosted.org
https://lists.fedorahosted.org/mailman/listinfo/sssd-devel