Re: [tipc-discussion] [net-next 1/2] tipc: fix lockdep warning when reinitilaizing sockets

2018-11-12 Thread Ying Xue


On 11/11/2018 03:05 AM, Jon Maloy wrote:
>  
> +struct tipc_fin_net_work {
> + struct work_struct work;
> + struct net *net;
> + u32 addr;
> +};
> +

In my opinion, it's no necessary to define the name so specific to
reflect that it will be only used to finalize tipc net.

Instead, probably we can define a bit generic name: such as, tipc_net_work.


___
tipc-discussion mailing list
tipc-discussion@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/tipc-discussion


Re: [tipc-discussion] [net-next 1/2] tipc: fix lockdep warning when reinitilaizing sockets

2018-11-12 Thread Ying Xue


On 11/11/2018 03:05 AM, Jon Maloy wrote:
> + INIT_WORK(>work, tipc_exec_net_finalize);

The function name of tipc_exec_net_finalize doesn't match the
traditional naming rule about work function. It's better that it can be
named as tipc_net_finalize_work or tipc_net_finalize_fn.

Other changes are fine to me.

Acked-by: Ying Xue 


___
tipc-discussion mailing list
tipc-discussion@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/tipc-discussion