Using constants instead of anonymous numbers increases code readability.

Fixes: 704df6aa0a28 ("fs: fat: refactor write interface for a file offset")
Signed-off-by: Heinrich Schuchardt <xypron.g...@gmx.de>
---
 fs/fat/fat_write.c | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/fs/fat/fat_write.c b/fs/fat/fat_write.c
index fc932df953..7afc8388b2 100644
--- a/fs/fat/fat_write.c
+++ b/fs/fat/fat_write.c
@@ -1191,7 +1191,8 @@ int file_fat_write_at(const char *filename, loff_t pos, 
void *buffer,
                }

                /* Set short name entry */
-               fill_dentry(itr->fsdata, itr->dent, filename, 0, size, 0x20);
+               fill_dentry(itr->fsdata, itr->dent, filename, 0, size,
+                           ATTR_ARCH);

                retdent = itr->dent;
        }
--
2.29.2

Reply via email to