Re: [U-Boot] [PATCH 5/5] lcd: refactor lcd console stuff into its own file

2014-11-21 Thread Nikita Kiryanov

Hi Simon,

On 11/20/2014 08:35 PM, Simon Glass wrote:

Hi Nikita,

On 20 November 2014 16:13, Nikita Kiryanov nik...@compulab.co.il wrote:

common/lcd.c is a mix of code portions that do different but related
things. To improve modularity, the various code portions should be split
into their own modules. Separate lcd console code into its own file.

In the process of making this move, some minor changes are introduced:
CONSOLE_ROWS and CONSOLE_COLS macros are replaced with variables which
are assigned using a new function lcd_init_console().

Minor changes were done to facilitate communication between lcd code
and lcd_console code, specifically in the introduction of lcd_console
functions set_console_col(), set_console_row(), lcd_get_screen_rows(),
lcd_get_screen_columns(), and lcd funcitons lcd_getbgcolor(),
lcd_getfgcolor().

Signed-off-by: Nikita Kiryanov nik...@compulab.co.il
Cc: Anatolij Gustschin ag...@denx.de
Cc: Wolfgang Denk w...@denx.de
Cc: Simon Glass s...@chromium.org


To my mind this patch should be split - one that changes the code and
another to move part of it into a separate file. Also how about adding
function comments to the header file (lcd_console.h and lcd.h)?


Sure, I can do that.
I also just noticed that I forgot the license headers in the new files,
so V2 coming up.



Regards,
Simon



--
Regards,
Nikita Kiryanov
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot


Re: [U-Boot] [PATCH 5/5] lcd: refactor lcd console stuff into its own file

2014-11-20 Thread Simon Glass
Hi Nikita,

On 20 November 2014 16:13, Nikita Kiryanov nik...@compulab.co.il wrote:
 common/lcd.c is a mix of code portions that do different but related
 things. To improve modularity, the various code portions should be split
 into their own modules. Separate lcd console code into its own file.

 In the process of making this move, some minor changes are introduced:
 CONSOLE_ROWS and CONSOLE_COLS macros are replaced with variables which
 are assigned using a new function lcd_init_console().

 Minor changes were done to facilitate communication between lcd code
 and lcd_console code, specifically in the introduction of lcd_console
 functions set_console_col(), set_console_row(), lcd_get_screen_rows(),
 lcd_get_screen_columns(), and lcd funcitons lcd_getbgcolor(),
 lcd_getfgcolor().

 Signed-off-by: Nikita Kiryanov nik...@compulab.co.il
 Cc: Anatolij Gustschin ag...@denx.de
 Cc: Wolfgang Denk w...@denx.de
 Cc: Simon Glass s...@chromium.org

To my mind this patch should be split - one that changes the code and
another to move part of it into a separate file. Also how about adding
function comments to the header file (lcd_console.h and lcd.h)?

Regards,
Simon
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot