Re: [webkit-dev] Kickstarting the migration of platform-specific WebCore source code to Source/Platform

2013-02-28 Thread Darin Adler
There may be a misunderstand of what the “platform layer” is.

We should not move all platform-specific files into the platform directory! 
Please do not make the changes in bug 110330 until we have discussed this.

The idea is not that all platform-specific code is in the WebCore/platform 
directory. Instead, the idea is that WebCore/platform contains code that the 
rest of WebCore is built on top of that creates a platform independent 
abstraction.

To do this, we need to eliminate dependencies from the platform directory to 
the rest of WebCore.

At this time, we are far from that. Many dependencies on the DOM and other such 
things have crept into the platform directory.

The real point of having a separate library for the platform directory is not 
to segregate all platform-specific code, but rather to have a coherent platform 
independence library that we can rely on for most platform-independence and 
minimize the need for platform-independent code.

-- Darin
___
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev


Re: [webkit-dev] Kickstarting the migration of platform-specific WebCore source code to Source/Platform

2013-02-28 Thread Darin Adler
On Feb 28, 2013, at 9:31 AM, Darin Adler da...@apple.com wrote:

 minimize the need for platform-independent code

minimize the need for platform-specific code

Moving all the platform-specific bits of various parts of WebCore away from the 
code they are tightly integrated with and into a “all platform-specific stuff 
goes here” directory would be counterproductive, unless there’s some real 
separation or abstraction that prevents things from having to be updated in 
lock step.

-- Darin
___
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev


Re: [webkit-dev] Kickstarting the migration of platform-specific WebCore source code to Source/Platform

2013-02-28 Thread Darin Adler
On Feb 28, 2013, at 10:23 AM, John Yani van...@gmail.com wrote:

 If I understood correctly, the idea is that WebCore should depend on 
 platform, not vice versa.
 
 Still, while platform provides platform independent API to WebCore, it has 
 platform-specific bits.
 
 Did I get the idea correctly?

That’s right.

And there are still some platform-specific bits in the rest of WebCore, but 
they can be kept to a minimum because of the rich set of platform-independent 
abstractions we provide in “platform”.

-- Darin
___
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev


[webkit-dev] Philip Rogers is now a Reviewer

2013-02-28 Thread Eric Seidel
Nice to have another hand for SVG reviews. :)

Grats to pdr!
___
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev


Re: [webkit-dev] Philip Rogers is now a Reviewer

2013-02-28 Thread Levi Weintraub
Congratulations, Mr. Rogers!


On Thu, Feb 28, 2013 at 12:09 PM, Eric Seidel e...@webkit.org wrote:

 Nice to have another hand for SVG reviews. :)

 Grats to pdr!

 ___
 webkit-dev mailing list
 webkit-dev@lists.webkit.org
 https://lists.webkit.org/mailman/listinfo/webkit-dev


___
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev


Re: [webkit-dev] Philip Rogers is now a Reviewer

2013-02-28 Thread Ryosuke Niwa
Congrats!

On the other hand, now you'll get my perf. test patches on your way :P

On Thu, Feb 28, 2013 at 12:11 PM, Levi Weintraub le...@chromium.org wrote:

 Congratulations, Mr. Rogers!


 On Thu, Feb 28, 2013 at 12:09 PM, Eric Seidel e...@webkit.org wrote:

 Nice to have another hand for SVG reviews. :)

 Grats to pdr!

 ___
 webkit-dev mailing list
 webkit-dev@lists.webkit.org
 https://lists.webkit.org/mailman/listinfo/webkit-dev



 ___
 webkit-dev mailing list
 webkit-dev@lists.webkit.org
 https://lists.webkit.org/mailman/listinfo/webkit-dev


___
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev


Re: [webkit-dev] Philip Rogers is now a Reviewer

2013-02-28 Thread Dirk Schulze
Congratulations Philip! :)

Greetings
Dirk

On Feb 28, 2013, at 12:11 PM, Levi Weintraub 
le...@chromium.orgmailto:le...@chromium.org wrote:

Congratulations, Mr. Rogers!


On Thu, Feb 28, 2013 at 12:09 PM, Eric Seidel 
e...@webkit.orgmailto:e...@webkit.org wrote:
Nice to have another hand for SVG reviews. :)

Grats to pdr!

___
webkit-dev mailing list
webkit-dev@lists.webkit.orgmailto:webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev


___
webkit-dev mailing list
webkit-dev@lists.webkit.orgmailto:webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev
___
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev


Re: [webkit-dev] Kickstarting the migration of platform-specific WebCore source code to Source/Platform

2013-02-28 Thread Žan Doberšek
On Thu, Feb 28, 2013 at 6:31 PM, Darin Adler da...@apple.com wrote:

 There may be a misunderstand of what the “platform layer” is.

 We should not move all platform-specific files into the platform
 directory! Please do not make the changes in bug 110330 until we have
 discussed this.

 The idea is not that all platform-specific code is in the WebCore/platform
 directory. Instead, the idea is that WebCore/platform contains code that
 the rest of WebCore is built on top of that creates a platform independent
 abstraction.

 To do this, we need to eliminate dependencies from the platform directory
 to the rest of WebCore.

 At this time, we are far from that. Many dependencies on the DOM and other
 such things have crept into the platform directory.

 The real point of having a separate library for the platform directory is
 not to segregate all platform-specific code, but rather to have a coherent
 platform independence library that we can rely on for most
 platform-independence and minimize the need for platform-independent code.

 -- Darin


Understood. Thanks for the explanation, much appreciated. Will held off the
work for the GTK-specific files until appropriate.

For the sake of clarity and if in anyone's interest, I'm linking two more
bugs:
https://bugs.webkit.org/show_bug.cgi?id=21354 - meta bug for platform
layering violations
https://bugs.webkit.org/show_bug.cgi?id=75664 - meta bug for the platform
layer migration

Regards,
-Z
___
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev


Re: [webkit-dev] Kickstarting the migration of platform-specific WebCore source code to Source/Platform

2013-02-28 Thread Maciej Stachowiak

I think Adam's old plan for the Platform directory was to migrate from 
WebCore/platform piece-by-piece, starting with related groups of classes that 
are already free of layering violations. That seems like a sensible approach to 
me as it allows the work to happen incrementally.

 - Maciej

On Feb 28, 2013, at 12:41 PM, Žan Doberšek zandober...@gmail.com wrote:

 On Thu, Feb 28, 2013 at 6:31 PM, Darin Adler da...@apple.com wrote:
 There may be a misunderstand of what the “platform layer” is.
 
 We should not move all platform-specific files into the platform directory! 
 Please do not make the changes in bug 110330 until we have discussed this.
 
 The idea is not that all platform-specific code is in the WebCore/platform 
 directory. Instead, the idea is that WebCore/platform contains code that the 
 rest of WebCore is built on top of that creates a platform independent 
 abstraction.
 
 To do this, we need to eliminate dependencies from the platform directory to 
 the rest of WebCore.
 
 At this time, we are far from that. Many dependencies on the DOM and other 
 such things have crept into the platform directory.
 
 The real point of having a separate library for the platform directory is not 
 to segregate all platform-specific code, but rather to have a coherent 
 platform independence library that we can rely on for most 
 platform-independence and minimize the need for platform-independent code.
 
 -- Darin
 
 Understood. Thanks for the explanation, much appreciated. Will held off the 
 work for the GTK-specific files until appropriate.
 
 For the sake of clarity and if in anyone's interest, I'm linking two more 
 bugs:
 https://bugs.webkit.org/show_bug.cgi?id=21354 - meta bug for platform 
 layering violations
 https://bugs.webkit.org/show_bug.cgi?id=75664 - meta bug for the platform 
 layer migration
 
 Regards,
 -Z
 ___
 webkit-dev mailing list
 webkit-dev@lists.webkit.org
 https://lists.webkit.org/mailman/listinfo/webkit-dev

___
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev


Re: [webkit-dev] Kickstarting the migration of platform-specific WebCore source code to Source/Platform

2013-02-28 Thread Darin Adler
On Feb 28, 2013, at 1:02 PM, Maciej Stachowiak m...@apple.com wrote:

 I think Adam's old plan for the Platform directory was to migrate from 
 WebCore/platform piece-by-piece, starting with related groups of classes that 
 are already free of layering violations. That seems like a sensible approach 
 to me as it allows the work to happen incrementally.

I agree!

-- Darin
___
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev


Re: [webkit-dev] WebKit Perf Monitor (perf.webkit.org) has been launched

2013-02-28 Thread Ryosuke Niwa
Note that the released version of Safari has a bug where it doesn't load
JSON properly. To work around this issue, open Inspector and reload. It
works just fine on WebKit nightly builds.

On Sun, Feb 24, 2013 at 7:24 PM, Ryosuke Niwa rn...@webkit.org wrote:

 Hi all,

 We've replaced webkit-perf.appspot.com by perf.webkit.org.
 webkit-perf.appspot.com will be phased-out in the coming weeks.

 I'm going to check in the source code of perf.webkit.org into WebKit
 repository in coming months.

 - R. Niwa


___
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev


[webkit-dev] -khtml- and -apple- CSS prefixes

2013-02-28 Thread Adam Barth
I noticed this comment on the Hacker News thread about Paul Irish's
recent blog post:

---8---
CSS parsing is the same, though. Slurping up your CSS and turning it
into CSSOM’s pretty standard. Yeah, though Chrome accepts just the
-webkit- prefix whereas Apple and other ports accept legacy prefixes
like -khtml- and -apple-.

Using this information, can you target Chrome with the webkit- prefix
and Safari with the apple- prefix? Specifying the apple- prefix after
webkit- will ensure that Safari uses that one, right?
---8---

http://news.ycombinator.com/item?id=5302150

If developers start using this technique, it might be harder to remove
these prefixes in the future.  Chromium's experience removing these
prefixes has been quite positive.  We ran into one compatibility
problem on apple.com, which Apple was gracious enough to fix.

I'd recommend that the rest of the ports disable
ENABLE(LEGACY_CSS_VENDOR_PREFIXES) to remove support for the -khtml-
and -apple- CSS prefixes before it's too late.

Adam
___
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev