Re: [webkit-dev] New Feature Flag Proposal: TIME_INPUT_FIELDS

2012-06-27 Thread Brady Eidson
Are there bugs tracking this work yet?

Thanks,
~Brady

On Jun 26, 2012, at 8:47 PM, Yoshifumi Inoue yo...@google.com wrote:

 Hi WebKit!
 
 I would like to notify adding new feature flag ENABLE_TIME_INPUT_FIELDS.
 
 This flag will enable multiple fields input UI for input type time.
 
 Looking is as same as input type number (including spin button), but each 
 time component, hour, minute, second, millisecond, period(AM/PM), is fixed 
 and handles keyboard input as overwriting rather than inserting, like Mac 
 OSX's DateTime control.
 
 This feature will be enable for desktop version of Chrome (== excluding 
 Android).
 
 This flag also introduce following class and functions:
 * DateTimeFormat class
 * localizedDecimalSeparator()
 * localizedTimeFormat()
 * localizedShortTimeFormat()
 * DateTimeFIeldElement (for shadow DOM)
 * DateTimeEditElement (for shadow DOM)
 
 Thanks!
 -yosi
 ___
 webkit-dev mailing list
 webkit-dev@lists.webkit.org
 http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev

___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev


Re: [webkit-dev] New Feature Flag Proposal: TIME_INPUT_FIELDS

2012-06-27 Thread Yoshifumi Inoue
Tracked by:
https://bugs.webkit.org/show_bug.cgi?id=88970

Thanks.
-yosi


On Thu, Jun 28, 2012 at 12:44 AM, Brady Eidson beid...@apple.com wrote:

 Are there bugs tracking this work yet?

 Thanks,
 ~Brady

 On Jun 26, 2012, at 8:47 PM, Yoshifumi Inoue yo...@google.com wrote:

 Hi WebKit!

 I would like to notify adding new feature flag ENABLE_TIME_INPUT_FIELDS.

 This flag will enable multiple fields input UI for input type time.

 Looking is as same as input type number (including spin button), but
 each time component, hour, minute, second, millisecond, period(AM/PM), is
 fixed and handles keyboard input as overwriting rather than inserting, like
 Mac OSX's DateTime control.

 This feature will be enable for desktop version of Chrome (== excluding
 Android).

 This flag also introduce following class and functions:
 * DateTimeFormat class
 * localizedDecimalSeparator()
 * localizedTimeFormat()
 * localizedShortTimeFormat()
 * DateTimeFIeldElement (for shadow DOM)
 * DateTimeEditElement (for shadow DOM)

 Thanks!
 -yosi
 ___
 webkit-dev mailing list
 webkit-dev@lists.webkit.org
 http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev



___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev


Re: [webkit-dev] New Feature Flag Proposal: TIME_INPUT_FIELDS

2012-06-27 Thread Yoshifumi Inoue
I got feedback that the flag name is unclear.
So, I rename it to
ENABLE_INPUT_TYPE_MULTIPLE_FIELDS

Thanks!
-yosi

On Thu, Jun 28, 2012 at 10:16 AM, Yoshifumi Inoue yo...@google.com wrote:

 Tracked by:
 https://bugs.webkit.org/show_bug.cgi?id=88970

 Thanks.
 -yosi


 On Thu, Jun 28, 2012 at 12:44 AM, Brady Eidson beid...@apple.com wrote:

 Are there bugs tracking this work yet?

 Thanks,
 ~Brady

 On Jun 26, 2012, at 8:47 PM, Yoshifumi Inoue yo...@google.com wrote:

 Hi WebKit!

 I would like to notify adding new feature flag ENABLE_TIME_INPUT_FIELDS.

 This flag will enable multiple fields input UI for input type time.

 Looking is as same as input type number (including spin button), but
 each time component, hour, minute, second, millisecond, period(AM/PM), is
 fixed and handles keyboard input as overwriting rather than inserting, like
 Mac OSX's DateTime control.

 This feature will be enable for desktop version of Chrome (== excluding
 Android).

 This flag also introduce following class and functions:
 * DateTimeFormat class
 * localizedDecimalSeparator()
 * localizedTimeFormat()
 * localizedShortTimeFormat()
 * DateTimeFIeldElement (for shadow DOM)
 * DateTimeEditElement (for shadow DOM)

 Thanks!
 -yosi
 ___
 webkit-dev mailing list
 webkit-dev@lists.webkit.org
 http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev




___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev


Re: [webkit-dev] New Feature Flag Proposal: TIME_INPUT_FIELDS

2012-06-27 Thread Yoshifumi Inoue
Oops, correction

ENABLE_INPUT_TYPE_TIME_MULTIPLE_FIELDS

This flag affects only input type time only.
-yosi


On Thu, Jun 28, 2012 at 11:25 AM, Yoshifumi Inoue yo...@google.com wrote:

 I got feedback that the flag name is unclear.
 So, I rename it to
 ENABLE_INPUT_TYPE_MULTIPLE_FIELDS

 Thanks!
 -yosi


 On Thu, Jun 28, 2012 at 10:16 AM, Yoshifumi Inoue yo...@google.comwrote:

 Tracked by:
 https://bugs.webkit.org/show_bug.cgi?id=88970

 Thanks.
 -yosi


 On Thu, Jun 28, 2012 at 12:44 AM, Brady Eidson beid...@apple.com wrote:

 Are there bugs tracking this work yet?

 Thanks,
 ~Brady

 On Jun 26, 2012, at 8:47 PM, Yoshifumi Inoue yo...@google.com wrote:

 Hi WebKit!

 I would like to notify adding new feature flag ENABLE_TIME_INPUT_FIELDS.

 This flag will enable multiple fields input UI for input type time.

 Looking is as same as input type number (including spin button), but
 each time component, hour, minute, second, millisecond, period(AM/PM), is
 fixed and handles keyboard input as overwriting rather than inserting, like
 Mac OSX's DateTime control.

 This feature will be enable for desktop version of Chrome (== excluding
 Android).

 This flag also introduce following class and functions:
 * DateTimeFormat class
 * localizedDecimalSeparator()
 * localizedTimeFormat()
 * localizedShortTimeFormat()
 * DateTimeFIeldElement (for shadow DOM)
 * DateTimeEditElement (for shadow DOM)

 Thanks!
 -yosi
 ___
 webkit-dev mailing list
 webkit-dev@lists.webkit.org
 http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev





___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev


[webkit-dev] New Feature Flag Proposal: TIME_INPUT_FIELDS

2012-06-26 Thread Yoshifumi Inoue
Hi WebKit!

I would like to notify adding new feature flag ENABLE_TIME_INPUT_FIELDS.

This flag will enable multiple fields input UI for input type time.

Looking is as same as input type number (including spin button), but each
time component, hour, minute, second, millisecond, period(AM/PM), is fixed
and handles keyboard input as overwriting rather than inserting, like Mac
OSX's DateTime control.

This feature will be enable for desktop version of Chrome (== excluding
Android).

This flag also introduce following class and functions:
* DateTimeFormat class
* localizedDecimalSeparator()
* localizedTimeFormat()
* localizedShortTimeFormat()
* DateTimeFIeldElement (for shadow DOM)
* DateTimeEditElement (for shadow DOM)

Thanks!
-yosi
___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev


[webkit-dev] New Feature Flag Proposal: TIME_INPUT_FIELDS

2012-06-26 Thread Yosi Inoue
Hi WebKit!

I would like to notify adding new feature flag ENABLE_TIME_INPUT_FIELDS.

This flag will enable multiple fields input UI for input type time.

Looking is as same as input type number (including spin button), but each
time component, hour, minute, second, millisecond, period(AM/PM), is fixed
and handles keyboard input as overwriting rather than inserting, like Mac
OSX's DateTime control.

This feature will be enable for desktop version of Chrome (== excluding
Android).

This flag also introduce following class and functions:
* DateTimeFormat class
* localizedDecimalSeparator()
* localizedTimeFormat()
* localizedShortTimeFormat()
* DateTimeFIeldElement (for shadow DOM)
* DateTimeEditElement (for shadow DOM)

Thanks!
___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev


Re: [webkit-dev] New Feature Flag Proposal: TIME_INPUT_FIELDS

2012-06-26 Thread Peter Beverloo
On Tue, Jun 26, 2012 at 9:20 PM, Yosi Inoue yo...@chromium.org wrote:

 Hi WebKit!

 I would like to notify adding new feature flag ENABLE_TIME_INPUT_FIELDS.

 This flag will enable multiple fields input UI for input type time.

 Looking is as same as input type number (including spin button), but
 each time component, hour, minute, second, millisecond, period(AM/PM), is
 fixed and handles keyboard input as overwriting rather than inserting, like
 Mac OSX's DateTime control.

 This feature will be enable for desktop version of Chrome (== excluding
 Android).


Android already enables time (and date) inputs, and defers to the
platform's input mechanisms. Will the appearances of the controls be
consolidated?

Peter

This flag also introduce following class and functions:
 * DateTimeFormat class
 * localizedDecimalSeparator()
 * localizedTimeFormat()
 * localizedShortTimeFormat()
 * DateTimeFIeldElement (for shadow DOM)
 * DateTimeEditElement (for shadow DOM)

 Thanks!

 ___
 webkit-dev mailing list
 webkit-dev@lists.webkit.org
 http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev


___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev


Re: [webkit-dev] New Feature Flag Proposal: TIME_INPUT_FIELDS

2012-06-26 Thread Yoshifumi Inoue
Will the appearances of the controls be consolidated?
No. In other words, to use different appearances among platforms, I
introduced this flag in addition to ENABLE_INPUT_TYPE_TIME.

ENABLE_TIME_INPUT_FIELDS is child flag of ENABLE_INPUT_TYPE_TIME.

When ENABLE_INPUT_TYPE_TIME w/o TIME_INPUT_FIELDS, input type time uses
single text field and doesn't change current behavior.

-yosi

On Wed, Jun 27, 2012 at 2:19 PM, Peter Beverloo pe...@chromium.org wrote:

 On Tue, Jun 26, 2012 at 9:20 PM, Yosi Inoue yo...@chromium.org wrote:

 Hi WebKit!

 I would like to notify adding new feature flag ENABLE_TIME_INPUT_FIELDS.

 This flag will enable multiple fields input UI for input type time.

 Looking is as same as input type number (including spin button), but
 each time component, hour, minute, second, millisecond, period(AM/PM), is
 fixed and handles keyboard input as overwriting rather than inserting, like
 Mac OSX's DateTime control.

 This feature will be enable for desktop version of Chrome (== excluding
 Android).


 Android already enables time (and date) inputs, and defers to the
 platform's input mechanisms. Will the appearances of the controls be
 consolidated?

 Peter

 This flag also introduce following class and functions:
 * DateTimeFormat class
 * localizedDecimalSeparator()
 * localizedTimeFormat()
 * localizedShortTimeFormat()
 * DateTimeFIeldElement (for shadow DOM)
 * DateTimeEditElement (for shadow DOM)

 Thanks!

 ___
 webkit-dev mailing list
 webkit-dev@lists.webkit.org
 http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev



___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev