Re: [Xen-devel] [PATCH v4 0/4] libxl: add HVM USB passthrough capability

2016-09-20 Thread Wei Liu
On Tue, Sep 20, 2016 at 04:18:06PM +0200, Juergen Gross wrote:
> Add the capability to pass USB devices to HVM domains by using the
> emulation of USB controllers of qemu.
> 
> The user interface via xl is the same as for pvusb passthrough, only
> the type of the usbctrl is different: instead of "qusb" (qemu-based
> pvusb backend) or "vusb" (kernel-based pvusb backend) the type
> "devicemodel" is used.
> 
> Especially the communication with qemu via qmp commands is based on
> the patches of George Dunlap sent in 2014:
> 
> https://lists.xen.org/archives/html/xen-devel/2014-06/msg00085.html
> 
> Changes in V4:
> - patch 2: corrected libxl__device_destroy() to not use be_path being NULL
> 
> Changes in V3:
> - patch 3: rename pvusb_get_port_path() to vusb_get_port_path()
>   as requested by George Dunlap
> - patch 4: wording adjusted as requested by Ian Jackson
> 
> Changes in V2:
> - patches 1-3 removed as already pushed
> - split out (new) patch 1 from patch 3 (was 5) as requested by Wei Liu
> - addressed code style issues in patch 3 (was 5) as requested by Wei Liu
> - added some assert()s n patch 3 (was 5) as requested by Wei Liu
> 
> Juergen Gross (4):
>   libxl: add function to remove usb controller xenstore entries
>   libxl: add basic support for devices without backend
>   libxl: add HVM usb passthrough support
>   docs: add HVM USB passthrough documentation
> 
>  docs/man/xl.cfg.pod.5.in |  12 +-
>  tools/libxl/libxl_device.c   |  73 --
>  tools/libxl/libxl_types_internal.idl |   1 +
>  tools/libxl/libxl_usb.c  | 435 
> +++
>  tools/libxl/libxl_xshelp.c   |   6 +-
>  tools/libxl/xl_cmdimpl.c |   4 +-
>  6 files changed, 409 insertions(+), 122 deletions(-)
> 

Series pushed.

> -- 
> 2.6.6
> 

___
Xen-devel mailing list
Xen-devel@lists.xen.org
https://lists.xen.org/xen-devel


[Xen-devel] [PATCH v4 0/4] libxl: add HVM USB passthrough capability

2016-09-20 Thread Juergen Gross
Add the capability to pass USB devices to HVM domains by using the
emulation of USB controllers of qemu.

The user interface via xl is the same as for pvusb passthrough, only
the type of the usbctrl is different: instead of "qusb" (qemu-based
pvusb backend) or "vusb" (kernel-based pvusb backend) the type
"devicemodel" is used.

Especially the communication with qemu via qmp commands is based on
the patches of George Dunlap sent in 2014:

https://lists.xen.org/archives/html/xen-devel/2014-06/msg00085.html

Changes in V4:
- patch 2: corrected libxl__device_destroy() to not use be_path being NULL

Changes in V3:
- patch 3: rename pvusb_get_port_path() to vusb_get_port_path()
  as requested by George Dunlap
- patch 4: wording adjusted as requested by Ian Jackson

Changes in V2:
- patches 1-3 removed as already pushed
- split out (new) patch 1 from patch 3 (was 5) as requested by Wei Liu
- addressed code style issues in patch 3 (was 5) as requested by Wei Liu
- added some assert()s n patch 3 (was 5) as requested by Wei Liu

Juergen Gross (4):
  libxl: add function to remove usb controller xenstore entries
  libxl: add basic support for devices without backend
  libxl: add HVM usb passthrough support
  docs: add HVM USB passthrough documentation

 docs/man/xl.cfg.pod.5.in |  12 +-
 tools/libxl/libxl_device.c   |  73 --
 tools/libxl/libxl_types_internal.idl |   1 +
 tools/libxl/libxl_usb.c  | 435 +++
 tools/libxl/libxl_xshelp.c   |   6 +-
 tools/libxl/xl_cmdimpl.c |   4 +-
 6 files changed, 409 insertions(+), 122 deletions(-)

-- 
2.6.6


___
Xen-devel mailing list
Xen-devel@lists.xen.org
https://lists.xen.org/xen-devel