[jira] [Updated] (YARN-10355) Refactor NM ContainerLaunch.java#orderEnvByDependencies

2024-01-25 Thread Shilun Fan (Jira)


 [ 
https://issues.apache.org/jira/browse/YARN-10355?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Shilun Fan updated YARN-10355:
--
Affects Version/s: 3.4.0

> Refactor NM ContainerLaunch.java#orderEnvByDependencies
> ---
>
> Key: YARN-10355
> URL: https://issues.apache.org/jira/browse/YARN-10355
> Project: Hadoop YARN
>  Issue Type: Improvement
>  Components: yarn
>Affects Versions: 3.4.0
>Reporter: Benjamin Teke
>Assignee: Tamas Domok
>Priority: Minor
>  Labels: pull-request-available
> Fix For: 3.4.0
>
>  Time Spent: 6h
>  Remaining Estimate: 0h
>
> The 
> {{org.apache.hadoop.yarn.server.nodemanager.containermanager.launcher.ContainerLaunch#orderEnvByDependencies}}
>  and it's helper method \{{getEnvDependencies }}(together with the overrides) 
> is hard to read. Some improvements could be made:
>  * use Pattern matching in the overrides of getEnvDependencies instead of 
> iterating through the environmental variable strings char by char
>  * the unit tests contains a lot of repeated code and generally the test 
> methods are long - they could be separated into different setup/helper and 
> assertion methods



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

-
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org



[jira] [Updated] (YARN-10355) Refactor NM ContainerLaunch.java#orderEnvByDependencies

2021-08-10 Thread Tamas Domok (Jira)


 [ 
https://issues.apache.org/jira/browse/YARN-10355?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Tamas Domok updated YARN-10355:
---
Attachment: (was: YARN-10814-branch-3.3.patch)

> Refactor NM ContainerLaunch.java#orderEnvByDependencies
> ---
>
> Key: YARN-10355
> URL: https://issues.apache.org/jira/browse/YARN-10355
> Project: Hadoop YARN
>  Issue Type: Improvement
>  Components: yarn
>Reporter: Benjamin Teke
>Assignee: Tamas Domok
>Priority: Minor
>  Labels: pull-request-available
> Fix For: 3.4.0
>
>  Time Spent: 6h
>  Remaining Estimate: 0h
>
> The 
> {{org.apache.hadoop.yarn.server.nodemanager.containermanager.launcher.ContainerLaunch#orderEnvByDependencies}}
>  and it's helper method \{{getEnvDependencies }}(together with the overrides) 
> is hard to read. Some improvements could be made:
>  * use Pattern matching in the overrides of getEnvDependencies instead of 
> iterating through the environmental variable strings char by char
>  * the unit tests contains a lot of repeated code and generally the test 
> methods are long - they could be separated into different setup/helper and 
> assertion methods



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org



[jira] [Updated] (YARN-10355) Refactor NM ContainerLaunch.java#orderEnvByDependencies

2021-08-10 Thread Tamas Domok (Jira)


 [ 
https://issues.apache.org/jira/browse/YARN-10355?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Tamas Domok updated YARN-10355:
---
Attachment: YARN-10814-branch-3.3.patch

> Refactor NM ContainerLaunch.java#orderEnvByDependencies
> ---
>
> Key: YARN-10355
> URL: https://issues.apache.org/jira/browse/YARN-10355
> Project: Hadoop YARN
>  Issue Type: Improvement
>  Components: yarn
>Reporter: Benjamin Teke
>Assignee: Tamas Domok
>Priority: Minor
>  Labels: pull-request-available
> Fix For: 3.4.0
>
> Attachments: YARN-10814-branch-3.3.patch
>
>  Time Spent: 6h
>  Remaining Estimate: 0h
>
> The 
> {{org.apache.hadoop.yarn.server.nodemanager.containermanager.launcher.ContainerLaunch#orderEnvByDependencies}}
>  and it's helper method \{{getEnvDependencies }}(together with the overrides) 
> is hard to read. Some improvements could be made:
>  * use Pattern matching in the overrides of getEnvDependencies instead of 
> iterating through the environmental variable strings char by char
>  * the unit tests contains a lot of repeated code and generally the test 
> methods are long - they could be separated into different setup/helper and 
> assertion methods



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org



[jira] [Updated] (YARN-10355) Refactor NM ContainerLaunch.java#orderEnvByDependencies

2021-08-04 Thread Jira


 [ 
https://issues.apache.org/jira/browse/YARN-10355?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Gergely Pollák updated YARN-10355:
--
Fix Version/s: 3.4.0

> Refactor NM ContainerLaunch.java#orderEnvByDependencies
> ---
>
> Key: YARN-10355
> URL: https://issues.apache.org/jira/browse/YARN-10355
> Project: Hadoop YARN
>  Issue Type: Improvement
>  Components: yarn
>Reporter: Benjamin Teke
>Assignee: Tamas Domok
>Priority: Minor
>  Labels: pull-request-available
> Fix For: 3.4.0
>
>  Time Spent: 5h 20m
>  Remaining Estimate: 0h
>
> The 
> {{org.apache.hadoop.yarn.server.nodemanager.containermanager.launcher.ContainerLaunch#orderEnvByDependencies}}
>  and it's helper method \{{getEnvDependencies }}(together with the overrides) 
> is hard to read. Some improvements could be made:
>  * use Pattern matching in the overrides of getEnvDependencies instead of 
> iterating through the environmental variable strings char by char
>  * the unit tests contains a lot of repeated code and generally the test 
> methods are long - they could be separated into different setup/helper and 
> assertion methods



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org



[jira] [Updated] (YARN-10355) Refactor NM ContainerLaunch.java#orderEnvByDependencies

2021-07-20 Thread ASF GitHub Bot (Jira)


 [ 
https://issues.apache.org/jira/browse/YARN-10355?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

ASF GitHub Bot updated YARN-10355:
--
Labels: pull-request-available  (was: )

> Refactor NM ContainerLaunch.java#orderEnvByDependencies
> ---
>
> Key: YARN-10355
> URL: https://issues.apache.org/jira/browse/YARN-10355
> Project: Hadoop YARN
>  Issue Type: Improvement
>  Components: yarn
>Reporter: Benjamin Teke
>Assignee: Tamas Domok
>Priority: Minor
>  Labels: pull-request-available
>  Time Spent: 10m
>  Remaining Estimate: 0h
>
> The 
> {{org.apache.hadoop.yarn.server.nodemanager.containermanager.launcher.ContainerLaunch#orderEnvByDependencies}}
>  and it's helper method \{{getEnvDependencies }}(together with the overrides) 
> is hard to read. Some improvements could be made:
>  * use Pattern matching in the overrides of getEnvDependencies instead of 
> iterating through the environmental variable strings char by char
>  * the unit tests contains a lot of repeated code and generally the test 
> methods are long - they could be separated into different setup/helper and 
> assertion methods



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org



[jira] [Updated] (YARN-10355) Refactor NM ContainerLaunch.java#orderEnvByDependencies

2020-07-20 Thread Benjamin Teke (Jira)


 [ 
https://issues.apache.org/jira/browse/YARN-10355?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Benjamin Teke updated YARN-10355:
-
Description: 
The 
{{org.apache.hadoop.yarn.server.nodemanager.containermanager.launcher.ContainerLaunch#orderEnvByDependencies}}
 and it's helper method \{{getEnvDependencies }}(together with the overrides) 
is hard to read. Some improvements could be made:
 * use Pattern matching in the overrides of getEnvDependencies instead of 
iterating through the environmental variable strings char by char
 * the unit tests contains a lot of repeated code and generally the test 
methods are long - they could be separated into different setup/helper and 
assertion methods

  was:
The 
{{org.apache.hadoop.yarn.server.nodemanager.containermanager.launcher.ContainerLaunch#orderEnvByDependencies}}
 and it's helper method {{getEnvDependencies }}(together with the overrides) is 
hard to read. Some improvements could be made:
 * use Pattern matching in the overrides of getEnvDependencies instead of 
iterating through the environmental variable strings char by char
 * the unit tests contains a lot of repeated code and generally the test 
methods are long - it could be separated into different setup/helper and 
assertion methods


> Refactor NM ContainerLaunch.java#orderEnvByDependencies
> ---
>
> Key: YARN-10355
> URL: https://issues.apache.org/jira/browse/YARN-10355
> Project: Hadoop YARN
>  Issue Type: Improvement
>  Components: yarn
>Reporter: Benjamin Teke
>Priority: Minor
>
> The 
> {{org.apache.hadoop.yarn.server.nodemanager.containermanager.launcher.ContainerLaunch#orderEnvByDependencies}}
>  and it's helper method \{{getEnvDependencies }}(together with the overrides) 
> is hard to read. Some improvements could be made:
>  * use Pattern matching in the overrides of getEnvDependencies instead of 
> iterating through the environmental variable strings char by char
>  * the unit tests contains a lot of repeated code and generally the test 
> methods are long - they could be separated into different setup/helper and 
> assertion methods



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org