Re: OBJECT SET ENABLED

2017-05-10 Thread Keisuke Miyako via 4D_Tech
well, I can confirm that this does work: OBJECT SET ACTION(*;"Button";Object No standard action) OBJECT SET ENABLED(*;"Button";False) OBJECT SET ACTION(*;"Button";Object Next page action) OBJECT SET ENABLED(*;"Button";True) > 2017/05/11 9:39、Sujit Shah via 4D_Tech <4d_tech@lists.4d.com> のメール: >

What is 'Index Scanning'

2017-05-10 Thread Robert McKeever via 4D_Tech
4D v13.4 Server. Runs on an iMac. I access via Teamviewer as they are 4 time zones away. The entire machine froze today. Blamed on 4D of course, although there are a couple of other programs running, etc. 52.78Gb datafile, 2.43 Gb index file. When they restarted, it was rebuilding some

Re: POINTER TO ARRAY

2017-05-10 Thread Chuck Miller via 4D_Tech
Pointers to locals do work. I pass locals via pointer from method to method all of the time Regards Chuck Chuck Miller Voice: (617) 739-0306 Informed Solutions, Inc. Fax: (617) 232-1064

Re: OBJECT SET ENABLED

2017-05-10 Thread Sujit Shah via 4D_Tech
On Thu, May 11, 2017 at 10:02 AM, Keisuke Miyako via 4D_Tech < 4d_tech@lists.4d.com> wrote: > out of interest, > why would you want to over-ride the enabled/disabled state of an object > with standard action? > Next Page, Previous Page for example:

Re: Lost window cursor

2017-05-10 Thread Keith Goebel via 4D_Tech
That’s it! Many thanks. I know I looked there but didn’t see it (on Win7 anyway). Note to self - don’t look for icons when you’re tired! :-) > On 11/05/2017, at 12:01 pm, Keisuke Miyako wrote: > /4D.app/Contents/Resources/Cursors

Re: How to clear a webpage from a web area?

2017-05-10 Thread Keith Goebel via 4D_Tech
Cannon, Thanks - I will try that when I get back on-site. Cheers, Keith > On 11/05/2017, at 12:01 pm, Cannon Smith wrote: > No sure about using the variable, but I do this when I need to get a blank > web area: > > WA OPEN URL(*;"vtWebArea";"about:blank")

Re: OBJECT SET ENABLED

2017-05-10 Thread Keisuke Miyako via 4D_Tech
out of interest, why would you want to over-ride the enabled/disabled state of an object with standard action? B.T.W. until v13, automatic (a.k.a. standard action) objects needed to have an associated variable. since v14, they work with form-local variables, which implied that they now

Re: 4D_Pack Replacement commands in v16

2017-05-10 Thread Keisuke Miyako via 4D_Tech
EXPORT STRUCTURE gives all the information (and more) you could get for a table, field, relation or index. there is a nice demo on the official blog: http://blog.4d.com/detailed-analysis-database-structure/ > 2017/05/10 19:29、Jörg Knebel via 4D_Tech <4d_tech@lists.4d.com> のメール: > > Would

Re: Resources v14

2017-05-10 Thread Keisuke Miyako via 4D_Tech
your XLIFF file is already a resource, you don't have to load it explicitly. if the file is inside your current localisation folder (Resources/en.lproj) it is automatically loaded when you start your application, and automatically re-loaded each time you activate a window in design mode. to

Re: POINTER TO ARRAY

2017-05-10 Thread Keisuke Miyako via 4D_Tech
because local variable do not have a name in compile mode, Get pointer (which works on names) does not work for local variables. 2017/05/11 6:39、stardata.info via 4D_Tech <4d_tech@lists.4d.com> のメール: Someone know because?

Re: How to clear a webpage from a web area?

2017-05-10 Thread Cannon Smith via 4D_Tech
Hi Keith, No sure about using the variable, but I do this when I need to get a blank web area: WA OPEN URL(*;"vtWebArea";"about:blank") Maybe something similar for you? -- Cannon.Smith Synergy Farm Solutions Inc. Hill Spring, AB Canada 403-626-3236

Lost window cursor

2017-05-10 Thread Keith Goebel via 4D_Tech
Greetings. I have a need to document the "lost window" cursor you get when the active window is hidden behind another window. I know we should always prevent this happening but there is one situation I cannot avoid and need to document it and need a picture of that cursor. I am not in the

How to clear a webpage from a web area?

2017-05-10 Thread Keith Goebel via 4D_Tech
Hi all. Using 4D v15.2 Win7: In a dialog I have a web area that is displaying a webpage and I want to simply clear it to show nothing. I have tried - clearing the URL variable from a button - adding "WA REFRESH CURRENT URL(URL_t)" after clearing URL_t but after the button script finishes, 4D

Re: POINTER TO ARRAY

2017-05-10 Thread Keith Culotta via 4D_Tech
Try changing the line "c_pointer($vPoint->)" to "c_pointer($vPoint)", and make sure $X is set to "1" or "2". Keith - CDI > On May 10, 2017, at 4:39 PM, stardata.info via 4D_Tech <4d_tech@lists.4d.com> > wrote: > > Hi All, > > I use 4D V13 on windows. > This code in interpreted work, but in

POINTER TO ARRAY

2017-05-10 Thread stardata.info via 4D_Tech
Hi All, I use 4D V13 on windows. This code in interpreted work, but in compiled application give an error: c_pointer($vPoint->) ARRAY STRING(12;$aCodMat_1;0) ARRAY STRING(12;$aCodMat_2;0) DISTINCT VALUES([TABLE]Cod;$aCodMat_1) DISTINCT VALUES([TABLE]Cod_1;$aCodMat_2) $vPoint:=Get

Re: Resources v14

2017-05-10 Thread Julio Carneiro via 4D_Tech
Eduardo, Those ‘resources’ statements in 4D are old legacy stuff, that deal with really old Mac OS Resource files. Nothing to do with the Resources folder. In the Resources folder you can keep any files you want and you access them using regular file system commands (Open Document, Documento

Resources v14

2017-05-10 Thread Eduardo Souza via 4D_Tech
Hello! I will try to be objective and concise. The question concerns "Resources" and I would like to ask for help to make "MyArchive.xlf" file into a Resource that can be used by 4D v14 throughout the code. Using the command "Open Resource File", in the many attempts I made, nothing worked

RE: SMTP error 10113 Error with Authentication

2017-05-10 Thread David Ringsmuth via 4D_Tech
Tim, Great suggestion. At first I thought it did. The smtp auth password has only lowercase letters and numbers. It is using SSL (true) SMTP AUTH (true). I had that problem on another system. Special characters broke it. David Ringsmuth From: Timothy Penner via 4D_Tech Sent: Wednesday, May

Re: v13 - how to create a 'folder' in Explorer

2017-05-10 Thread Douglas von Roeder via 4D_Tech
Chip: Click the "Home" icon from the list of icons in the Explorer. The "+" button will display a triangle, indicating, in this case, that a hierarchical menu is available. If you're going to set up folders for "objects" in your application, you're well served by creating multiple levels of

Re: v13 - how to create a 'folder' in Explorer

2017-05-10 Thread Chip Scheide via 4D_Tech
Got it! have to be on the "home" tab first, otherwise.. Clicking the "+" gives me the "Create new method" dialog, with no option for new folder. Right clicking a blank area (all default folders collapsed) gives - nothing gear button gives "batch setting of properties, or Web services wizard"

Re: v13 - how to create a 'folder' in Explorer

2017-05-10 Thread Cannon Smith via 4D_Tech
Click the “+” button at the bottom of the Explorer and choose “New Folder”. Or right-click on an existing folder (or empty area in the Explorer) and choose New—>Folder to created a folder inside a folder. -- Cannon.Smith Synergy Farm Solutions Inc. Hill Spring, AB Canada 403-626-3236

v13 - how to create a 'folder' in Explorer

2017-05-10 Thread Chip Scheide via 4D_Tech
How do I create a folder in my project methods? Thanks Chip --- Gas is for washing parts Alcohol is for drinkin' Nitromethane is for racing ** 4D Internet Users Group (4D iNUG) FAQ: http://lists.4d.com/faqnug.html

Re: SMTP error 10113 Error with Authentication

2017-05-10 Thread Chuck Miller via 4D_Tech
Is the sending email a gmail account by any chance? Can you try with a different email address/ not gmail? Regards Chuck Chuck Miller Voice: (617) 739-0306 Informed Solutions, Inc. Fax: (617)

RE: SMTP error 10113 Error with Authentication

2017-05-10 Thread Timothy Penner via 4D_Tech
David, Just a wild guess - Is there a strange character in the password? If so, maybe the character is being handled differently on 4D Server? I don't know why this would be the case, I just thought it might give you something to investigate. -Tim

RE: SMTP error 10113 Error with Authentication

2017-05-10 Thread David Ringsmuth via 4D_Tech
I tested with plugin 15.0, both with 4D Server and 4D Remote. 4D Remote sends the message correctly. 4D Server does NOT correctly deliver the message, but I am no longer getting the error 10113 Error with authentication. The email is NOT delivered. David Ringsmuth From: Epperlein, Lutz

RE: SMTP error 10113 Error with Authentication

2017-05-10 Thread Epperlein, Lutz (agendo) via 4D_Tech
Try 4DIC Plugin 15.0 > -Original Message- > From: 4D_Tech [mailto:4d_tech-boun...@lists.4d.com] On Behalf Of David > Ringsmuth via 4D_Tech > Sent: Wednesday, May 10, 2017 5:41 PM > To: Timothy Penner via 4D_Tech <4d_tech@lists.4d.com> > Cc: davidi...@gmail.com > Subject: SMTP error 10113

Re: POST with Server Name Indication

2017-05-10 Thread Peter Bozek via 4D_Tech
On Wed, May 10, 2017 at 6:08 PM, Timothy Penner via 4D_Tech < 4d_tech@lists.4d.com> wrote: > > "The client software did not provide a hostname using Server Name > Indication (SNI), which is required to access this server" > > Did anybody run into this problem? > > Yes, here is a feature request

RE: POST with Server Name Indication

2017-05-10 Thread Timothy Penner via 4D_Tech
Hi Peter, > "The client software did not provide a hostname using Server Name Indication > (SNI), which is required to access this server" > Did anybody run into this problem? Yes, here is a feature request for "Support for TLS / SNI extension":

SMTP error 10113 Error with Authentication

2017-05-10 Thread David Ringsmuth via 4D_Tech
OSX 10.12.3 4D 15.3HF1 4D Server Compiled 4DIC Plugin 15.3 Also tested with: 15.4 (211153) with 4DIC plugin 15.4, Compiled When sending emails through 4D Server at this location fail with SMTP error 10113 Error with authentication. Same application sending email through 4D Remote or 4D Stand

[ANN] fun with colo(u)rs : now available on my blog

2017-05-10 Thread Herr Alexander Heintz via 4D_Tech
Hi folks, even after the overwhelming feedback (thanks you 2) for my last blog post, I have not been fazed and just published something new: http://blog.heintz.net/fun-with-colors/ It will help you fiddle with colors, convert to other color systems,

Re: Preemptive mode flaw

2017-05-10 Thread Jeffrey Kain via 4D_Tech
Weird that a market large enough for its own branch office doesn't use the same tools as the rest of the world. I have to say that the Taow system works really well, in my experience. If I had to email someone and then have no further contact about an issue until it showed up in a release note,

POST with Server Name Indication

2017-05-10 Thread Peter Bozek via 4D_Tech
I am sending data to web server using POST protocol. Recently, web server changed its URL and attempts to send data resulted in error -403 with reason "The client software did not provide a hostname using Server Name Indication (SNI), which is required to access this server" It seems that the

Zint Bar code

2017-05-10 Thread stardata.info via 4D_Tech
Hi All, I use ZINT plug in for make a bar code in code 128. Work well, but i need to reduce the bar dimension of bar code, because the label support i very short. Someone know how i can do? Thanks Ferdinando ** 4D Internet

Re: 4D_Pack Replacement commands in v16

2017-05-10 Thread Nigel Greenlee via 4D_Tech
> On 10 May 2017, at 11:29, Jörg Knebel via 4D_Tech <4d_tech@lists.4d.com> > wrote: > > Hi, > > Would someone please care to mention where one can find the replacement for > commands from the Pack like: > > > _o_AP Get table info > > > > And where the hell are the PDF-Manuals for v16?

Re: 4D_Pack Replacement commands in v16

2017-05-10 Thread Arnaud de Montard via 4D_Tech
> Le 10 mai 2017 à 12:29, Jörg Knebel via 4D_Tech <4d_tech@lists.4d.com> a > écrit : > > Hi, > > Would someone please care to mention where one can find the replacement for > commands from the Pack like: > > _o_AP Get table info GET TABLE PROPERTIES: "invisible" OK, "destruct" KO. I can

Re: 4D_Pack Replacement commands in v16

2017-05-10 Thread Jörg Knebel via 4D_Tech
> On 10 May 2017, at 20:29 AEST, Jörg Knebel via 4D_Tech <4d_tech@lists.4d.com> > wrote: > > Would someone please care to mention where one can find the replacement for > commands from the Pack like: > > > _o_AP Get table info OK, never mind this. BUT still waiting for the PDF-Manuals…

4D_Pack Replacement commands in v16

2017-05-10 Thread Jörg Knebel via 4D_Tech
Hi, Would someone please care to mention where one can find the replacement for commands from the Pack like: _o_AP Get table info And where the hell are the PDF-Manuals for v16? ** 4D Internet Users Group (4D iNUG) FAQ: