Re: Printing an existing PDF File in Windows 10

2019-05-06 Thread Julio Carneiro via 4D_Tech
@Tim, one problem with those non-Adobe solutions is compatibility. Depending on the type/contents of your PDF’s, those non-Adobe alternatives may not handle them well. In my case I'm dealing mostly with PDFs that contain images, and no text at all. In my experience those non-Adobe alternatives

Re: Printing an existing PDF File in Windows 10

2019-05-06 Thread Julio Carneiro via 4D_Tech
; > DKC > > >> On May 6, 2019, at 10:57 AM, Doug Cottrill via 4D_Tech >> <4d_tech@lists.4d.com> wrote: >> >> Thanks Julio! I will give that a try- sounds like exactly what I was hoping >> for. >> >>> On May 4, 2019, at 7:09 AM, Julio

Re: Printing an existing PDF File in Windows 10

2019-05-04 Thread Julio Carneiro via 4D_Tech
Try: “print xx.pdf”… simple as that :-) it tells Win 10 to just print the document using whatever app is set do print the type of document passed to the command. It’ll no open the app, will just print the document. hth julio > On May 2, 2019, at 5:15 PM, Doug Cottrill via 4D_Tech

Re: Printing to PDF (again)

2019-04-05 Thread Julio Carneiro via 4D_Tech
There’s another one there QPDF, have you looked at it? > On Apr 5, 2019, at 7:39 AM, Pat Bensky via 4D_Tech <4d_tech@lists.4d.com> > wrote: > > Hi Julio, > I'm a big fan of Rob's plugins, but PDFX Plugin doesn't do what we need. > Pat > > On Fri, 5 Apr 2019 at 03:

Re: Printing to PDF (again)

2019-04-04 Thread Julio Carneiro via 4D_Tech
Have you checked Rob Laveaux’s plugins at pluggers.nl ? Those are x-platform and might do the trick. What you want cannot be achieved with any print to pdf solution. You need a plugin that helps create, or manipulate, pdf documents. I’ve Myako also has something on the

Re: Problems with Microsoft Print to PDF

2019-04-03 Thread Julio Carneiro via 4D_Tech
Well, 4D 17.1 32 bit works fine with both PDF Creator and MS PDF. I’ve only seen problems with 64-bit Client/standalone. julio > On Apr 3, 2019, at 9:05 PM, Chuck Miller via 4D_Tech <4d_tech@lists.4d.com> > wrote: > > Yes when I upgraded to 17.1 using 32 bit client on windows > > Regards >

Re: Problems with Microsoft Print to PDF

2019-04-03 Thread Julio Carneiro via 4D_Tech
afaik, none of the PDF plugins for 4D give you the ability to print to PDF. They provide functionality for you to create and manipulate PDFs, but none gives you what you get with print to PDF Creator/MS PDF. > On Apr 2, 2019, at 10:09 PM, Keith Goebel via 4D_Tech <4d_tech@lists.4d.com> >

Re: Problems with Microsoft Print to PDF

2019-04-03 Thread Julio Carneiro via 4D_Tech
Keith, I’ve experienced issues with V17.1 and printing to pdf. V17.1 64-bit, Windows 10, does not support PDF Creator. You must use Microsoft PDF, as you’ve done. V17.1 32-bit though seems to work fine with PDF Creator, in Win 10. The issues I’ve had with V17.1 64-bit and Microsoft PDF, were

Re: Printing a PDF document from 4D

2019-03-19 Thread Julio Carneiro via 4D_Tech
ilto:4d_tech@lists.4d.com>> wrote: > > > >> On 19 Mar 2019, at 15:27, Julio Carneiro via 4D_Tech <4d_tech@lists.4d.com >> <mailto:4d_tech@lists.4d.com>> wrote: >> >> @Luc Devar, QPDF, also from pluggers.nl <http://pluggers.nl/> >

Re: Printing a PDF document from 4D

2019-03-19 Thread Julio Carneiro via 4D_Tech
Thanks to all that replied, Stephen J. Orth’s Win32API is the winning solution. That’s why this is is awesome. cheers, julio > On Mar 19, 2019, at 4:42 PM, ADeeg via 4D_Tech <4d_tech@lists.4d.com> wrote: > > 4D Tech mailing list wrote >> Has anyone here had the need to print a PDF document

Re: Printing a PDF document from 4D

2019-03-19 Thread Julio Carneiro via 4D_Tech
I do have PDF Viewer, but on Windows you can’t print from an off-screen area, which means yo have to display the pdf on a form before printing it. I forgot to mention that I need to just “print” and external PDF. Printing has to happen in background and in some cases for 4D Server. So, no user

Printing a PDF document from 4D

2019-03-19 Thread Julio Carneiro via 4D_Tech
Has anyone here had the need to print a PDF document from 4D, and found a solution? I am not talking about generating a PDF from 4D. I have an existing PDF document and I need 4D to print it for me! Exactly, user selects a PDF document and I have 4D command it to be printed. I can use LEP, a

Re: exe file that can launch 4D client as well as Chrome?

2019-02-26 Thread Julio Carneiro via 4D_Tech
One idea would be to start 4D Client (preferably a built server/client, so you have a specific .exe to use), and upon start up, use LEP to start Chrome. You can start Chrome using a specific URI in the format: "http://user:p...@yoursite.com/xxx ” (assuming

Re: AWS Experts - Need a little help

2019-01-15 Thread Julio Carneiro via 4D_Tech
Exactly. You need to assign your EC2 VM to a security group that enables the ports 4D requires. > On Jan 14, 2019, at 8:56 PM, Spencer Hinsdale via 4D_Tech > <4d_tech@lists.4d.com> wrote: > > > did you edit Security Groups to add 4D ports 19812 to 19814? > >> On Jan 14, 2019, at 2:15 PM,

Re: soap messages somehow not read by 4d

2018-12-26 Thread Julio Carneiro via 4D_Tech
Ernie, A couple of things to check: - in Database Settings-> Web: is web server enabled automatically? or if set to manual, are you sure web server is up and running on the exact Port your client expects? - in Database Settings -> Web -> Web Services: are Web Service Requests enabled? Do you

Having trouble with V16.4 and User Forms

2018-11-06 Thread Julio Carneiro via 4D_Tech
Is anyone here using User Forms and V16.4? I am having all sorts of issues with that in V16! Specially C/S. For example, I create a brand new User Form, via CREATE USER FORM, but if I try to edit that I get an error saying user form does not exist. But LIST USER FORMS does list it!! duh! Then

Re: Setting up an entity / collection listbox in code

2018-10-30 Thread Julio Carneiro via 4D_Tech
Jeremy, I have something similar to what you have, and I use entity selection. Except that I have a single column Listbox already set in the forms where I need them, The missing link for a completely dynamic Listbox is the ability to set the “Datasource” properties by code. As of V17r2, afaik,

Re: ORDA Entity From

2018-10-23 Thread Julio Carneiro via 4D_Tech
as I mentioned on an earlier post, I’ve put that as a request to 4D and the response I got was that ‘it may come in a future release” if you have access to the beta forum, go vote for it: http://forums.4d.com/Post/EN/25274556/1/25274557 may they get into the next release :-) > On Oct 23, 2018,

Re: DataClass Name from Entity

2018-10-23 Thread Julio Carneiro via 4D_Tech
Posted that as a feature request sometime ago, in the beta forum. 4D said it would come in the future. It is not in v17R2, afaik. > On Oct 22, 2018, at 7:10 PM, Douglas von Roeder via 4D_Tech > <4d_tech@lists.4d.com > wrote: > > When trying to save an entity, the

Re: Custom Object Libraries crash 4D V16.4

2018-10-16 Thread Julio Carneiro via 4D_Tech
, perhaps that will lead to something helpful > > Regards > Chuck > > On Tue, Oct 16, 2018 at 3:50 PM Julio Carneiro via 4D_Tech < > 4d_tech@lists.4d.com> wrote: > >> Does anyone here use, or have used, Custom Object Libraries? in V16? is >> that broken in

Custom Object Libraries crash 4D V16.4

2018-10-16 Thread Julio Carneiro via 4D_Tech
Does anyone here use, or have used, Custom Object Libraries? in V16? is that broken in V16? It works fine for me in V12! But in V16, 4D crashes whenever I try to use a item from Custom Object Library, while trying to edit a User Form. At first I thought it might be the fact that the Library

Re: v17R2

2018-10-15 Thread Julio Carneiro via 4D_Tech
Have you tried the “Refresh” button on the License Manager? That should refresh all your registered license, and I believe that’d ‘transfer’ your V17 to V17R2. > On Oct 15, 2018, at 4:50 AM, Jeremy Roussak via 4D_Tech > <4d_tech@lists.4d.com> wrote: > > My v17 licences show up in the “build

Re: Do I want to use SELECTION TO ARRAY instead of GOTO SELECTED RECORD server-side in V17?

2018-09-15 Thread Julio Carneiro via 4D_Tech
Following up on Jim’s and other responses I would venture to say that one good solution memory and performance wise would be: - loop thru records using NEXT RECORD, or GOTO SELECTED RECORD - preallocate a BLOB to build your text/json; say 5MB is your limit, or maybe 50Mb, or 500Mb, you pick your

Re: ORDA question: how do I add related fields to an entity selection?

2018-07-31 Thread Julio Carneiro via 4D_Tech
> > $kind:=ds.Table_1[$attribute].kind > > Case of > : ($kind="storage") > > > : ($kind="relatedEntity") > $one.push($attribute) > > : ($kind="relatedEntities") > $many.push($attribute) > > End case > > End for each &

Re: ORDA question: how do I add related fields to an entity selection?

2018-07-30 Thread Julio Carneiro via 4D_Tech
gt; Assuming a table named A and a relation to table B named My_B_Link, after > loading a selection of table A into collection My_Col, you can get your > related data from table B like this: > > My_Col.My_B_Link.AnyFieldYouLike > > Regards, > > Lahav > > -Origi

ORDA question: how do I add related fields to an entity selection?

2018-07-30 Thread Julio Carneiro via 4D_Tech
Let’s say I have 2 tables in my database, MANY and ONE, where MANY has a many to one relation to ONE. Using a MANY based SELECTION TO ARRAY I can populate arrays with fields from the MANY table, of course, but I can also include fields from the ONE table. If automatic relations is set to true

Re: Who’s the Gestapo?

2018-07-16 Thread Julio Carneiro via 4D_Tech
Yes Steve, that is a feature of most mail clients & lists, your own posts are not sent back to you, which makes sense. Your posts are on your “sent” list and do not appear on the incoming flow. You do not get a confirmation back, not on 4D list and almost any list I participate on. But you do

Re: Components and Execute Formula

2018-06-29 Thread Julio Carneiro via 4D_Tech
Chip, Your specific example would not work, because “My_execute” would not have access to the calling method’s local variables. That is not a component issue, that would not work even if My_execute were a local method :-( Now to answer your question, yes a Component method can issue an Execute

Re: 2 instances of 4D connected to different 4D Servers

2018-06-19 Thread Julio Carneiro via 4D_Tech
John, have you tried to duplicate the 4D folder under Programs (or ProgramsX86)? and then create aliases to each 4D.exe. Then try to run them. At least that’s how I do on OS X, have not tried on Windows, maybe it works there too. hth julio > On Jun 19, 2018, at 6:45 PM, JOHN BAUGHMAN via

Re: Moving Methods/Forms between structures seems disabled

2018-06-10 Thread Julio Carneiro via 4D_Tech
For me moving between structures only works if the target structure’s explorer is in Home. So, maybe in your case “B” explorer is not in the Home page, and that prevents moving into it… just an idea hth julio > On Jun 10, 2018, at 10:18 PM, Randy Engle via 4D_Tech <4d_tech@lists.4d.com >

Re: Testing for Null is superior to OB is defined

2018-05-01 Thread Julio Carneiro via 4D_Tech
Here is an example I’m using: C_COLLECTION($aOrderByCols) $aOrderByCols:=Split string($orderBy;"%";sk ignore empty strings+sk trim spaces) $orderBy is a text string with “%” separated terms, like “foo %bar%more %%data”. As a result of the statement above, $aOrderByCols

Re: Collection.orderBy()

2018-04-27 Thread Julio Carneiro via 4D_Tech
Cannon, If the statement in your code reads exactly as you posted then the error is in v16r6 syntax checker :-) The collection member function is ‘orderBy’, capital B. That’s why you get a runtime error, because ‘orderby’ does not exist. At this point 4D does not manage class typing properly,

Re: How do I get the type of a Collection element? (v16r6)

2018-04-26 Thread Julio Carneiro via 4D_Tech
anyway - always string. Frequently the same for dates. > > On Thu, Apr 26, 2018 at 11:47 AM Julio Carneiro via 4D_Tech < > 4d_tech@lists.4d.com> wrote: > > > You do have Value type, but neither work 100%. Both fail Time for > example. > > And I believe v16r6 fails D

Re: How do I get the type of a Collection element? (v16r6)

2018-04-26 Thread Julio Carneiro via 4D_Tech
You do have Value type, but neither work 100%. Both fail Time for example. And I believe v16r6 fails Date too (fixed in v17.0Beta). I reported that same issue to the beta forum. I hope that gets sorted out in the beta cycle. On Thu, Apr 26, 2018 at 12:36 PM Kirk Brooks via 4D_Tech <

Re: Errors in 4D Web Process

2018-04-24 Thread Julio Carneiro via 4D_Tech
eb I had put a call to Method called on > error, got back an empty string, and 4D continued to ignore my otherwise > forced errors. But after having 4D choke on the bad ON ERR CALL, it started > catching errors again. Go figure. > > John > >> On Apr 24, 2018, at 1

Re: Errors in 4D Web Process

2018-04-24 Thread Julio Carneiro via 4D_Tech
Hey John, have you by any chance added an ON ERR CALL() during your web process, and are thus trapping errors yourself? Because that would cause your process to continue on w/o throwing any 4D error. I don’t think there is a way t detect if you’re trapping errors, nothing I see in debug can

Re: Detecting 64-bit OS

2018-04-23 Thread Julio Carneiro via 4D_Tech
Cannon, I believe that code only works if the Regional Settings establish English as the main language. In other languages that folder name gets translated by Windows, so your code would fail. Was the computer that reported a failure set to French by any chance? hth julio > On Apr 23, 2018,

Re: Time in a c_object

2018-04-16 Thread Julio Carneiro via 4D_Tech
Miyako, I can confirm that there is a difference between V16.3 and V17.0 Beta, in how time is stored in an object property. In V16 it is stored in milliseconds, but in V17.0 it is stored in seconds. This code returns different values between versions: C_TIME($hh) C_OBJECT($o) $hh:=Current

Re: Time in a c_object

2018-04-16 Thread Julio Carneiro via 4D_Tech
is that different in V16 and V17? because in the code I posted I get the same result, but I am not dividing the time value by 1000!! > On Apr 16, 2018, at 10:59 PM, Keisuke Miyako via 4D_Tech > <4d_tech@lists.4d.com> wrote: > > time is stored in milliseconds, not seconds. > > you have to >

Re: Time in a c_object

2018-04-16 Thread Julio Carneiro via 4D_Tech
What version of 4D? The code below, in V17.0 Beta works fine here: C_TIME($hh) C_OBJECT($o) $hh:=Current time $o:=New object("time";$hh) ALERT("$hh:"+String($hh;HH MM AM PM)+”, $o.time:"+String(time($o.time);HH MM AM PM)) I get the exact same value. cheers, julio > On Apr 16, 2018, at 10:02

Re: ORDA query & pointers syntax question

2018-04-11 Thread Julio Carneiro via 4D_Tech
ooops, sorry I mixed up ‘classic 4D’ and ORDA :-) The query line should read: ds[$tableName].query($tableName+”.”+$fieldName+” = “+$aValue) or ds[$tableName].query($tableName+”.”+$fieldName+” = :1“;$aValue) hth julio > On Apr 11, 2018, at 5:00 PM, Julio Carneiro wrote: > >

Re: ORDA query & pointers syntax question

2018-04-11 Thread Julio Carneiro via 4D_Tech
Something like this might do the trick (did not try it yet): $tableName:=Table name(pTable) $fieldName:=Field name(pField) QUERY(ds[$tableName];ds[$tableName][$fieldName]=$aValue) When an object property name is on a variable, you can use the “object[property]” syntax. hth julio > On Apr 11,

Re: Web Service Call in 4Dv15

2018-04-11 Thread Julio Carneiro via 4D_Tech
4D WebServices license perhaps? > On Apr 11, 2018, at 2:57 AM, Ronnie Teo via 4D_Tech <4d_tech@lists.4d.com> > wrote: > > Hi All, > > I would like to seek some help/advise on an XML issue in 4Dv15 on Windows. > > I have an app that is currently running in v11. XML transmission via the >

Re: 4D Summit 2018 Comments - Import XML Structure

2018-04-10 Thread Julio Carneiro via 4D_Tech
I believe LR may have suggested importing XML into a new structure. That’ll give you what you want. You can then open the old structure with a 4D copy and drag methods & forms across. depending on the size (and age) of your structure, probably easier to manually rename the relations, I guess

Re: How can I get a windows Users list

2018-04-08 Thread Julio Carneiro via 4D_Tech
Try this: C_TEXT($cmd;$in;$out;$err) $cmd:="net user" LAUNCH EXTERNAL PROCESS($cmd;$in;$out;$err) $out should get the result from ‘net user’. All you have to do is parse it to get the user list. Abraço, julio > On Apr 8, 2018, at 4:15 PM, John Baughman via 4D_Tech

Re: 4D data on the web - what do you use?

2018-03-14 Thread Julio Carneiro via 4D_Tech
Keith, you may take a look at my presentation on 4D Methods, where I explain how I do what you’re asking for. https://4dmethod.com/2017/12/31/january-17th-meeting-4d-web-access-and-angular2-components-julio-carneiro/#more-822

Re: [SAD NEWS] legendary developer and 4D base-rock Ortwin Zillgen

2018-02-27 Thread Julio Carneiro via 4D_Tech
Really sad news :-( Please pass on my condolences to his family. Unexpected for sure as he posted on just 2 weeks ago about going to the Summit in Paris. His posts here and on will surely be missed. > On Feb 27, 2018, at 8:22 AM, Herr Alexander Heintz via 4D_Tech >

Re: REST server component?

2018-02-13 Thread Julio Carneiro via 4D_Tech
On Feb 12, 2018, at 6:16 PM, Jeffrey Kain via 4D_Tech <4d_tech@lists.4d.com> wrote: > > Anyone have a full-featured, debugged REST server component for 4D? > ** There is the FourDRESTApi V16 component I presented on 4D Methods

Re: Javascript Calendar in Web Area

2018-02-10 Thread Julio Carneiro via 4D_Tech
I agree with Tom’s recommendations, try to pick a framework of your choice that does include a Calendar widget. I’m also a big fan of Kendo UI. I’ve been using their jQuery version but I’m now in the process of migrating to their Angular version. > On Feb 10, 2018, at 1:50 PM, Tom DeMeo via

Re: Unable to start Web Server 4D 16.3 on OSX 10.11 [solved]

2018-02-07 Thread Julio Carneiro via 4D_Tech
Fixed it…. it was the 443 port that was taken by OSX Server… After I disabled TLS or changed that port Web server started w/o issues. What got me was that V12 does not complain and starts web server fine. Maybe it does not check if port 443 is taken But apparently V16 does check. It’d be

Re: Unable to start Web Server 4D 16.3 on OSX 10.11

2018-02-07 Thread Julio Carneiro via 4D_Tech
Port is free for sure… as I said before, I can start web server with 4D V12 fine, no problem. It is only V16 that has an issue :-( > On Feb 7, 2018, at 5:16 PM, William Swann via 4D_Tech <4d_tech@lists.4d.com> > wrote: > > Hi Julio, > > Do the following test: telnet machinename.com 80 or

Re: Unable to start Web Server 4D 16.3 on OSX 10.11

2018-02-07 Thread Julio Carneiro via 4D_Tech
So, tried both V16.3HotFix 1 and the latest Nightly build, same result… Any idea/suggestions what to try next? > On Feb 7, 2018, at 4:14 PM, Julio Carneiro wrote: > > Not trying a compiled DB. > > I simply create a new database and then try Run->Start Web Server, and then I

Re: Unable to start Web Server 4D 16.3 on OSX 10.11

2018-02-07 Thread Julio Carneiro via 4D_Tech
Not trying a compiled DB. I simply create a new database and then try Run->Start Web Server, and then I get “The database cannot be published”. That’s it, no error code, nothing. Now I’ve downloaded and installed V16R5 and the result is the same. I’ll try the hotfix to see if anything changes.

Re: Unable to start Web Server 4D 16.3 on OSX 10.11

2018-02-07 Thread Julio Carneiro via 4D_Tech
This was not my case. This is a fresh 4D v16.3 install, which I’ve just downloaded from 4D.com. Here is what I tried, based on suggestions here: - OSX restart, did not help - trashed "Library/Application Support/4D” folder, launched 4D, re-entered my partner license, refresh all my licenses,

Unable to start Web Server 4D 16.3 on OSX 10.11

2018-02-06 Thread Julio Carneiro via 4D_Tech
Something weird on my old MacPro server running 10.11. I cannot start web server on 4D v16.3. Web server does start OK on V12.4, same box. I did try to create new apps on both versions, to eliminate any issues with my app. With V12, Start Web & Test Web work fine. Same thing on V16.3 gives me

Re: The writing is on the wall

2018-01-25 Thread Julio Carneiro via 4D_Tech
On Jan 25, 2018, at 9:21 PM, Jeffrey Kain via 4D_Tech <4d_tech@lists.4d.com> wrote: > > We all need to be testing the new network layer and getting our feedback to > 4D... > > https://arstechnica.com/gadgets/2018/01/apple-prepares-macos-users-for-discontinuation-of-32-bit-app-support/ > Well,

Re: Document capture

2018-01-25 Thread Julio Carneiro via 4D_Tech
Hi Kenneth, I’ve also implemented something similar to what others have done. But in my case, instead of having a folder for each client, I have one folder per clientID\1000 (client ID mod 1000), so a maximum of 1000 folders. Then I have a second folder level for document classes/categories.

Re: Can I use METHOD GET NAMES in the Host to get methods from a component?

2018-01-18 Thread Julio Carneiro via 4D_Tech
Try this: - Add a new method to host, call it “ProxyMethodGetNames" and make it ‘shared between host and components’, with the following code: > C_Pointer($1;$arrNames) > > $arrNames:=$1 > METHOD GET NAMES($arrNames->) - on your component, replace METHOD GET NAMES call by: > ARRAY

Re: Data from 4D to a webpage

2018-01-05 Thread Julio Carneiro via 4D_Tech
Carl, Assuming 4D webserver is indeed up and running, then On Web Connection will be called whenever a non-existing page is requested. Then you can handle it yourself, load the file from anywhere, do Process 4D Tags and Web Send Blob/HTML to serve the page. hth julio > On Jan 5, 2018, at

Re: Does 4D View not work on Windows Server in v16?

2017-12-14 Thread Julio Carneiro via 4D_Tech
Ignore this thread please. Yes Tim, I did have the 4D View.bundle in the Plugins folder near the structure, and it was not recognized by the Server. Then, after this email exchange I decided to copy all 4D plugins again, from the 4D-32bit install folder and to my Plugins folder. Now everything

Does 4D View not work on Windows Server in v16?

2017-12-14 Thread Julio Carneiro via 4D_Tech
Did I miss the announcement or something? or am I wrong? I just noticed that 4D View does not work with 4D Server Windows anymore! Works fine with 4D-32 standalone, but if you open the exact same structure with 4D Server Windows (64-bit only), then it does not work, even if using 4D-32 bit to

Re: LEP - and Batch files

2017-11-08 Thread Julio Carneiro via 4D_Tech
Chip, have you tried to change the .bat file to eliminate the ‘cmd’ call and run xcopy directly, so that .bat would read just: "xcopy 2>> ” And then call the .bat directly in your LEP statement? Why do you need that “cmd.exe” for? julio ' > On Nov 8, 2017, at 10:06 PM, Chip Scheide via

Re: QUERY into variable vs. Records in Table

2017-10-19 Thread Julio Carneiro via 4D_Tech
Jeffrey, I did not quite get your question. Records in Table does not relate to QUERY in any way, because you are comparing a sort of static number, total records in a table, to the result of a dynamic operation. Did you mean compare: Set Query Destination(into variable;$nrecs)

Re: How do workers die?

2017-10-06 Thread Julio Carneiro via 4D_Tech
Well, documentation says Workers don’t die. You have to kill them, or quit 4D. From 4D 16.2 Docs, About Workers page: "Unlike the New process command, a worker process remains alive after the execution of the process method ends.” Web process stay dormant for awhile and then die if no new

Re: Fastest way to get text into a BLOB?

2017-08-01 Thread Julio Carneiro via 4D_Tech
I see only 2 alternatives there, either append text to a blob directly, or append to a text variable and then move it to a blob. I ran a quick test using both alternatives, and a series of TEXT TO BLOB is more than 10x faster then appending to a text variable and then moving it to a blob.

Re: Thinking about optional parameters and optional object elements

2017-07-31 Thread Julio Carneiro via 4D_Tech
Well, I might hate you less ;-) if instead of: > > MyMediocreMethod(->[Table];5;Current date;"";"";0;5) We coud write something like: > MyMediocreMethod(->[Table];5;Current date;{numofdays:5}) or > MyMediocreMethod(->[Table];5;Current date;{startDay:0; numofdays:5}) If the optional parameters

Re: Thinking about optional parameters and optional object elements

2017-07-31 Thread Julio Carneiro via 4D_Tech
David, If I understood your thoughts right, which is no guarantee at all ;), I believe you are proposing replacing a method call like: MyMethodWithOptionals(p1, p2, p3, p4) or MyMethodWithOptionals(p1, p2, p3, p4, p5, p6,p7) where parameters 1-3 are mandatory and 4-7 optional, by

Re: Trace buttons disappeared (OS X 11.12, 4D v14.6)

2017-07-18 Thread Julio Carneiro via 4D_Tech
I had the same issue this week. - open your user Library folder in Finder (option-Go->Library) - go to Application Support -> 4D - delete folder "4D Window Bounds v16” That’ll reset all window bounds to a default setting. hth julio > On Jul 18, 2017, at 2:19 PM, Claudio Braga via 4D_Tech

Re: Set_Exists() function: Simple version

2017-07-17 Thread Julio Carneiro via 4D_Tech
Robert, Just out of curiosity, what happens if there is no current record to add to the set? - do you get an error, which might only indicate no record exists to add to an existing set? - nothing happens, even if set does not exist? > On Jul 17, 2017, at 8:48 AM, Robert Livingston via 4D_Tech

Re: Thinking through object/text fields: Findings summarized, advice solicited

2017-07-16 Thread Julio Carneiro via 4D_Tech
Correct, David, you got the gist of my comment. Jim Hays gave a great example where I can see object fields excel. If your app requires user defined fields, then an object field is just perfect for that. I’ve had similar situations in the past and used tab-separated text fields first, and then

Re: Thinking through object/text fields: Findings summarized, advice solicited

2017-07-14 Thread Julio Carneiro via 4D_Tech
On Jul 14, 2017, at 4:21 AM, David Adams via 4D_Tech <4d_tech@lists.4d.com> wrote: > > Does that all sound about right? Am I missing reasons why I would want to > use object fields. vs. text fields? Any other technical details that people > have learned or figured out? I’d add that using an

Re: Resources v14

2017-05-10 Thread Julio Carneiro via 4D_Tech
Eduardo, Those ‘resources’ statements in 4D are old legacy stuff, that deal with really old Mac OS Resource files. Nothing to do with the Resources folder. In the Resources folder you can keep any files you want and you access them using regular file system commands (Open Document, Documento

Re: Converting Little Endian Byte Representation To a String

2017-04-17 Thread Julio Carneiro via 4D_Tech
Cannon, Forgive my stupid question: why do you need to convert the hex string to number? Can’t you simply use it as your RFID? (of course you’d have to increase your key field to 16 chars). You’re already handling it as a string, why change? > On Apr 17, 2017, at 6:36 PM, Cannon Smith via

Re: 4D V16 fails to launch external programs asynchronously

2017-03-21 Thread Julio Carneiro via 4D_Tech
Aha, I am not the only one. Checking V16R2 release notes there is a bug fix for that same issue: ACI0096092 'LAUNCH EXTERNAL PROCESS' doesn't work correctly if using the environment variable '4D_OPTION_BLOCKING_EXTERNAL_PROCESS'. Downloading V16R2 to confirm that it is fixed. On Tue, Mar 21, 2017

4D V16 fails to launch external programs asynchronously

2017-03-21 Thread Julio Carneiro via 4D_Tech
Running 4D v16, on Windows 10, and running a converted application. That 4D app relies on a bunch of external apps that are launched asynchronously, but I cannot get anyone of those to start! The following code fails (not exactly the app I need to launch, but just an illustration): > SET

4D V12.5 fails to open in latest Win 10

2017-03-20 Thread Julio Carneiro via 4D_Tech
All of a sudden, probably after a recent Windows 10 update, 4D V12.5 fails to open some of my structures. Everything works fine on other versions of Windows. On that Win10, 4D app takes a long time to start. Then, when I open one of my structures it shows 4D login dialog and then enters into a