Re: v17 conundrum in design

2019-02-11 Thread Jim Hays via 4D_Tech
Chuck, I've seen some cases where I put a break point in a method that was called repeatedly. I would click on the break point to remove it in the debugger, but it would still stop there. I solved it by: - click to remove the break point - click again, adding it back - click again to remove it

4D Write Pro-Creating Paragraphs

2019-02-11 Thread Mitchell Shiller via 4D_Tech
Hi, Banging my head against the wall on this one. Obviously a simple answer but it seems to be eluding me. I want to programmatically create a series of paragraphs in WP, Different paragraphs would have different attributes - e.g. font and margins etc. I cannot find any examples in the KB or

Document-Management Solution for 4D

2019-02-11 Thread Klaus Droeder via 4D_Tech
Although I have used 4th Dimension for the last 25 years for my projects, this is my first post (but hopefully not my last) in this forum. My company specializes in medical database applications. In addition to several 4D apps (mostly combined with SQL databases), we have developed a professional

Error 30 When Using HTTP Get or HTTP Request

2019-02-11 Thread 4dinug via 4D_Tech
I am using v17R3 on Windows 10, and attempting to retrieve some resources from the web using HTTP Get() and HTTP Request() functions. Every attempt fails with an Error 30. Here is the contents of the arrays returned by GET LAST ERROR STACK: *Code* *Int Comp** * *Error description** *

Re: How to display read-only input form

2019-02-11 Thread Jim Crate via 4D_Tech
On Feb 7, 2019, at 1:19 AM, Koen Van Hooreweghe via 4D_Tech <4d_tech@lists.4d.com> wrote: > > Have you tried MODIFY SELECTION instead of MODIFY RECORD? > Set the table in read only mode, make sure only the requested record is in > the current selection and then open the record using MODIFY

Re: v17 conundrum in design

2019-02-11 Thread Chuck Miller via 4D_Tech
Been there done that Regards Chuck Chuck Miller Voice: (617) 739-0306 Informed Solutions, Inc. Fax: (617) 232-1064 mailto:cjmillerinformed-solutions.com Brookline, MA 02446 USA

Re: Error 30 When Using HTTP Get or HTTP Request

2019-02-11 Thread Bruno LEGAY via 4D_Tech
Hi, Could be there that the SSL/TLS version of your server is not supported (too old or too new). You can use nmap or online tools to check the configuration of the server... https://www.ssllabs.com/ssltest/ This will give you a list of ciphers HTH Bruno LEGAY signature.asc Description:

Re: Error 30 When Using HTTP Get or HTTP Request

2019-02-11 Thread 4dinug via 4D_Tech
Thanks, Tim and Bruno. You are both correct. This particular organization's server uses SSL3 and supports only TLS 1.0. Given that the site in question belongs to one of the five largest museums in the world, I would rate my chances at getting them to re-deploy their server platform at my

RE: Error 30 When Using HTTP Get or HTTP Request

2019-02-11 Thread Timothy Penner via 4D_Tech
I agree with Bruno; the most likely answer is that the server does not support TLS 1,2 - use the site Bruno mentioned in order to test the server to see what TLS versions it supports. Check out the blog post from October 2017 describing the change in 4D where we no longer allow connections to

[off] Project Request

2019-02-11 Thread Tom DeMeo via 4D_Tech
Hi David, I've worked extensively with Active4D for over a decade, and also did a 2 year full time stint building an app with Wakanda, so I should have the skills your client is looking for. Let me know if they have any interest in discussing this project. Regards, Tom DeMeo

[off] Project Request

2019-02-11 Thread David Ringsmuth via 4D_Tech
A customer of mine asked me to post this. He has a project request using 4D’s REST API or Wakanda in front of 4D, creating a web-site that can replace an existing web site that is partially generated from Active4D. If you are interested, and familiar with these tools, please contact me.

Re: Error 30 When Using HTTP Get or HTTP Request

2019-02-11 Thread Keisuke Miyako via 4D_Tech
in case you missed it, the blog link that Tim posted does explain how you can lower your TLS threshold on the 4D side with SET DATABASE PARAMETER. 2019/02/12 8:15、4dinug via 4D_Tech <4d_tech@lists.4d.com>のメール: I would rate my chances at getting them to re-deploy

4D server 12.6 as a service on a windows server 2016

2019-02-11 Thread Miguel Gonzalez via 4D_Tech
Hi All, Has anyone is running 4D server12.6 as a service on a windows server 2016 machine? When I start the service it tells me that the start parameter is wrong. I've never used start parameters before. Which parameter I need to supply to the service? Thank you very much in advance. --