[Alsa-user] ALSA PCM plugin lifetime

2020-05-18 Thread Robert Bielik
Hi all, I have a system setup where I need a post-processing ALSA PCM plugin. But how is the lifetime managed by the ALSA server? Will the plugin only be instantiated whilst there is an audio stream running? Is it possible to setup an ALSA configuration that keeps the PCM plugin instantiated,

Re: [Alsa-user] RME HDSPe AIO + RME AO4S 192 AIO

2020-05-18 Thread Ralf Mardorf
Hi Maurizio, thank you for reporting back. Take a look at the attached pic. You only made step 1, but you need to do step 2 and step 3, too. CCing, since the attached png might not make it through the mailing list. Regards, Ralf ___ Alsa-user

Re: [Alsa-user] RME HDSPe AIO + RME AO4S 192 AIO

2020-05-18 Thread Ralf Mardorf
On Mon, 18 May 2020 18:30:08 +0200, Ralf Mardorf wrote: >Take a look at the attached pic. You only made step 1, but you need to >do step 2 and step 3, too. It seems you made step 1 and step 2, but you are missing step 3, "Make current file default". If you already made step 2, you don't need to

Re: [Alsa-user] Android Pixel C in MIDI mode not creating a alsa seq port

2020-05-18 Thread Stefan Sauer
On 18.05.20 17:25, Clemens Ladisch via Alsa-user wrote: > Stefan Sauer wrote: >> If I use my pixel c tablet, the alsa device is recognized (it shows >> up in /proc/asound/ and also creates a midi0 entry) > Does it show up in the output of "amidi -l"? > > Is the ID 5209 or 520a? Your logs show

[Alsa-user] Out AO4S 192 AIO

2020-05-18 Thread Maurizio M
Hi Ralph, yes I was missing the third part in fact you are absolutely right. I did step 3 and already saved 2 presets thank you very much. I wanted to ask you for more information then if possible, I have 2 more outputs from the expansion card that I have just installed, the AO4S-192-AIO,

Re: [Alsa-user] Out AO4S 192 AIO

2020-05-18 Thread Ralf Mardorf
On Mon, 2020-05-18 at 19:54 +0200, Maurizio M wrote: > Hi Ralph, yes I was missing the third part in fact you are absolutely > right. I did step 3 and already saved 2 presets thank you very much. I > wanted to ask you for more information then if possible, I have 2 more > outputs from the

Re: [Alsa-user] Android Pixel C in MIDI mode not creating a alsa seq port

2020-05-18 Thread Clemens Ladisch via Alsa-user
Stefan Sauer wrote: > If I use my pixel c tablet, the alsa device is recognized (it shows > up in /proc/asound/ and also creates a midi0 entry) Does it show up in the output of "amidi -l"? Is the ID 5209 or 520a? Your logs show both. Regards, Clemens

[Alsa-user] RME HDSPe AIO + RME AO4S 192 AIO

2020-05-18 Thread Maurizio Mileto Principale
Ralph, the AO4S expansion card for HDSPe AIO also works well, adds 4 monophonic outputs that become 2 stereo and does it totally independently of the main AIO card. It has an analog section and a DAC dedicated only to you and its outputs so the quility is at the top. What I don't understand is