Re: [Alsa-user] alsactl sometimes fails to restore mixer settings at boot

2018-02-04 Thread Ralf Mardorf
On Sun, 4 Feb 2018 13:22:43 +0100, Clemens Ladisch via Alsa-user wrote:
>Nikos Chantziaras wrote:
>> How do I assign numbers?  
>
>With a line
>
>  options snd slots=snd-virtuoso,snd-usb-audio
>
>in some .conf file in /etc/modprobe.d/.

FWIW "some .conf file" means you could name it as you want, a common
used name is "alsa-base.conf".

[rocketmouse@archlinux ~]$ cat /etc/modprobe.d/alsa-base.conf 
# ALSA module ordering
options snd slots=snd_hdspm,snd_ice1712,snd_ice1712

--
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
___
Alsa-user mailing list
Alsa-user@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/alsa-user


Re: [Alsa-user] alsactl sometimes fails to restore mixer settings at boot

2018-02-04 Thread Clemens Ladisch via Alsa-user
Nikos Chantziaras wrote:
> How do I assign numbers?

With a line

  options snd slots=snd-virtuoso,snd-usb-audio

in some .conf file in /etc/modprobe.d/.


Regards,
Clemens

--
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
___
Alsa-user mailing list
Alsa-user@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/alsa-user


Re: [Alsa-user] alsactl sometimes fails to restore mixer settings at boot

2018-01-29 Thread Nikos Chantziaras

On 29/01/18 14:25, Clemens Ladisch via Alsa-user wrote:

Nikos Chantziaras wrote:

alsactl sometimes fails to restore the mixer settings at system boot. Failure 
rate is about 50/50.

systemd-udevd[151]: Process '/usr/sbin/alsactl restore 1' failed with exit code 
99.
systemd-udevd[149]: Process '/usr/sbin/alsactl restore 0' failed with exit code 
99.


This sounds as if the card numbers might be mixed up.  How do you control
which card gets which index?


I don't. I didn't even know this is possible (or needed.) I just assumed 
everything is "plug" How do I assign numbers?


(Note that this only happens with systemd. OpenRC never had this issue.)


--
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
___
Alsa-user mailing list
Alsa-user@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/alsa-user


Re: [Alsa-user] alsactl sometimes fails to restore mixer settings at boot

2018-01-29 Thread Clemens Ladisch via Alsa-user
Nikos Chantziaras wrote:
> alsactl sometimes fails to restore the mixer settings at system boot. Failure 
> rate is about 50/50.
>
> systemd-udevd[151]: Process '/usr/sbin/alsactl restore 1' failed with exit 
> code 99.
> systemd-udevd[149]: Process '/usr/sbin/alsactl restore 0' failed with exit 
> code 99.

This sounds as if the card numbers might be mixed up.  How do you control
which card gets which index?


Regards,
Clemens

--
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
___
Alsa-user mailing list
Alsa-user@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/alsa-user