答复: [PATCH] drm/amdgpu/virt: fix double kfree on bo_va

2017-02-03 Thread Liu, Monk
thanks for this catch! Reviewed-by: Monk Liu 发件人: Colin King 发送时间: 2017年2月4日 4:23:42 收件人: Deucher, Alexander; Koenig, Christian; David Airlie; Liu, Monk; Yu, Xiangliang; amd-gfx@lists.freedesktop.org;

[PATCH 13/13] drm/amdgpu: new queue policy, take first 2 queues of each pipe

2017-02-03 Thread Andres Rodriguez
Instead of taking the first pipe and givint the rest to kfd, take the first 2 queues of each pipe. Effectively, amdgpu and amdkfd own the same number of queues. But because the queues are spread over multiple pipes the hardware will be able to better handle concurrent compute workloads. amdgpu

[PATCH 04/13] drm/amdgpu: remove duplicate definition of cik_mqd

2017-02-03 Thread Andres Rodriguez
The gfxv7 contains a slightly different version of cik_mqd called bonaire_mqd. This can introduce subtle bugs if fixes are not applied in both places. Signed-off-by: Andres Rodriguez --- drivers/gpu/drm/amd/amdgpu/gfx_v7_0.c | 135 ++ 1 file

[PATCH 08/13] drm/radeon: take ownership of pipe initialization

2017-02-03 Thread Andres Rodriguez
Take ownership of pipe initialization away from KFD. Note that hpd_eop_gpu_addr was already large enough to accomodate all pipes. Signed-off-by: Andres Rodriguez --- drivers/gpu/drm/radeon/cik.c| 27 ++- drivers/gpu/drm/radeon/radeon_kfd.c |

[PATCH 05/13] drm/amdgpu: unify MQD programming sequence for kfd and amdgpu

2017-02-03 Thread Andres Rodriguez
Use the same gfx_*_mqd_commit function for kfd and amdgpu codepaths. This removes the last duplicates of this programming sequence. Signed-off-by: Andres Rodriguez --- drivers/gpu/drm/amd/amdgpu/amdgpu_amdkfd_gfx_v7.c | 51 ++-

[PATCH 12/13] drm/amdgpu: allocate queues horizontally across pipes

2017-02-03 Thread Andres Rodriguez
Pipes provide better concurrency than queues, therefore we want to make sure that apps use queues from different pipes whenever possible. Optimize for the trivial case where an app will consume rings in order, therefore we don't want adjacent rings to belong to the same pipe. Signed-off-by:

[PATCH 10/13] drm/amdkfd: allow split HQD split on per-queue granularity

2017-02-03 Thread Andres Rodriguez
Update the KGD to KFD interface to allow sharing pipes with queue granularity instead of pipe granularity. This allows for more interesting pipe/queue splits. Signed-off-by: Andres Rodriguez --- drivers/gpu/drm/amd/amdgpu/amdgpu_amdkfd.c | 22 -

[PATCH 06/13] drm/amdgpu: rename rdev to adev

2017-02-03 Thread Andres Rodriguez
Rename straggler instances of r(adeon)dev to a(mdgpu)dev Signed-off-by: Andres Rodriguez --- drivers/gpu/drm/amd/amdgpu/amdgpu_amdkfd.c | 70 +++--- drivers/gpu/drm/amd/amdgpu/amdgpu_amdkfd.h | 14 +++--- drivers/gpu/drm/amd/amdgpu/gfx_v7_0.c |

[PATCH 11/13] drm/amdgpu: remove duplicate magic constants from amdgpu_amdkfd_gfx*.c

2017-02-03 Thread Andres Rodriguez
This information is already available in adev. Signed-off-by: Andres Rodriguez --- drivers/gpu/drm/amd/amdgpu/amdgpu_amdkfd_gfx_v7.c | 12 ++-- drivers/gpu/drm/amd/amdgpu/amdgpu_amdkfd_gfx_v8.c | 12 ++-- 2 files changed, 12 insertions(+), 12 deletions(-)

[PATCH 09/13] drm/amdgpu: allow split of queues with kfd at queue granularity

2017-02-03 Thread Andres Rodriguez
Previously the queue/pipe split with kfd operated with pipe granularity. This patch allows amdgpu to take ownership of an arbitrary set of queues. It also consolidates the last few magic numbers in the compute initialization process into mec_init. Signed-off-by: Andres Rodriguez

Change queue/pipe split between amdkfd and amdgpu

2017-02-03 Thread Andres Rodriguez
The current queue/pipe split policy is for amdgpu to take the first pipe of MEC0 and leave the rest for amdkfd to use. This policy is taken as an assumption in a few areas of the implementation. This patch series aims to allow for flexible/tunable queue/pipe split policies between kgd and kfd. It

[PATCH 02/13] drm/amdgpu: doorbell registers need only be set once

2017-02-03 Thread Andres Rodriguez
The CP_MEC_DOORBELL_RANGE_* and CP_PQ_STATUS.DOORBELL_ENABLE registers are not HQD specific. They only need to be set once if at least 1 pipe requested doorbell support. Signed-off-by: Andres Rodriguez --- drivers/gpu/drm/amd/amdgpu/amdgpu.h | 1 +

[PATCH] drm/amdgpu/virt: fix double kfree on bo_va

2017-02-03 Thread Colin King
From: Colin Ian King bo_va is being kfree'd twice, once in the call to amdgpu_vm_bo_rmv and then a short while later. Fix this double free by removing the 2nd kfree. Detected by CoverityScan, CID#1399524 ("Double Free") Signed-off-by: Colin Ian King

Re: [PATCH v5 0/3] Allow ASYNC flip with atomic helpers.

2017-02-03 Thread Alex Deucher
On Thu, Feb 2, 2017 at 4:56 PM, Andrey Grodzovsky wrote: > This series is a folow-up on > https://patchwork.kernel.org/patch/9501787/ > > The first patch makes changes to atomic helpers to allow for drives with > ASYNC flip support to use them. > Patch 2 is to use this

Re: drm/ttm: Fix unused variable warning

2017-02-03 Thread Alex Deucher
On Fri, Feb 3, 2017 at 12:23 PM, Kent Russell wrote: > This cleans up a remnant from Christian's patch (drm/ttm: revert "add > optional LRU removal callback v2") > > Kent > FWIW, I already squashed the same fix into the patch when it went upstream. Feel free to apply to

drm/ttm: Fix unused variable warning

2017-02-03 Thread Kent Russell
This cleans up a remnant from Christian's patch (drm/ttm: revert "add optional LRU removal callback v2") Kent >From dfdf89a8dff0e378db6fa9578f75b02eec02ca0e Mon Sep 17 00:00:00 2001 From: Kent Russell Date: Tue, 31 Jan 2017 06:44:10 -0500 Subject: [PATCH] drm/ttm: Fix

drm/ttm: Fix unused variable warning

2017-02-03 Thread Kent Russell
This cleans up a remnant from Christian's patch (drm/ttm: revert "add optional LRU removal callback v2") Kent >From dfdf89a8dff0e378db6fa9578f75b02eec02ca0e Mon Sep 17 00:00:00 2001 From: Kent Russell Date: Tue, 31 Jan 2017 06:44:10 -0500 Subject: [PATCH] drm/ttm: Fix

[PATCH] drm/amdgpu: fix warning on older gcc releases

2017-02-03 Thread Arnd Bergmann
gcc-4.8 warns about '{0}' being used an an initializer for nested structures: drivers/gpu/drm/amd/amdgpu/gfx_v8_0.c: In function ‘gfx_v8_0_ring_emit_ce_meta_init’: drivers/gpu/drm/amd/amdgpu/gfx_v8_0.c:7263:2: warning: missing braces around initializer [-Wmissing-braces] } ce_payload = {0};

RE: [PATCH 00/12] mise patch related uvd/vce cg and pg.

2017-02-03 Thread Deucher, Alexander
Reviewed-by: Alex Deucher From: amd-gfx [mailto:amd-gfx-boun...@lists.freedesktop.org] On Behalf Of Zhu, Rex Sent: Friday, February 03, 2017 7:10 AM To: Christian König; amd-gfx@lists.freedesktop.org Cc: Alex Deucher Subject: Re: [PATCH 00/12] mise patch related

Re: [PATCH] drm/amdgpu: shut up #warning for compile testing

2017-02-03 Thread Michel Dänzer
On 02/02/17 06:36 PM, Christian König wrote: > Am 02.02.2017 um 07:09 schrieb Michel Dänzer: >> [SNIP] >> OTOH the people running the kernel aren't always the same people >> building it, so the downside is that this would potentially delay >> getting X86_PAT enabled. > > And exactly for this

Re: [PATCH 4/6] drm/amdgpu: implement PRT for GFX6 v2

2017-02-03 Thread Nicolai Hähnle
On 02.02.2017 11:25, Christian König wrote: From: Christian König Enable/disable the handling globally for now and print a warning when we enable it for the first time. v2: write to the correct register, adjust bits to that hw generation Signed-off-by: Christian

Re: [PATCH 00/12] mise patch related uvd/vce cg and pg.

2017-02-03 Thread Zhu, Rex
Thanks Alex and Christian. Patch7 is just a workaround for issue: when dpm disabled, can't initialize uvd on Ci. Now I have found the root cause. so no need to add timeout time. Please review the attached patch. Best Regards Rex From: amd-gfx