Re: [PATCH] Add GPU_POWER sensors

2017-02-10 Thread Tom St Denis
On 02/10/2017 07:25 PM, Edward O'Callaghan wrote: Hey Tom, On 02/11/2017 05:10 AM, Tom St Denis wrote: Add the ability to sample GPU_POWER sensors. Because the sensors have a high latency we read them from a background thread which means we've added the requirement for pthreads.

Re: [PATCH] Add GPU_POWER sensors

2017-02-10 Thread Edward O'Callaghan
Hey Tom, On 02/11/2017 05:10 AM, Tom St Denis wrote: > Add the ability to sample GPU_POWER sensors. Because > the sensors have a high latency we read them from a background > thread which means we've added the requirement for pthreads. > > Signed-off-by: Tom St Denis > ---

[PATCH] drm/amdgpu/pm: check for headless before calling compute_clocks

2017-02-10 Thread Alex Deucher
Don't update display bandwidth on headless asics. bug: https://bugs.freedesktop.org/show_bug.cgi?id=99387 Signed-off-by: Alex Deucher Cc: sta...@vger.kernel.org --- drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff

RE: [PATCH] drm/amd/amdgpu: post card if there is real hw resetting performed

2017-02-10 Thread Deucher, Alexander
> -Original Message- > From: amd-gfx [mailto:amd-gfx-boun...@lists.freedesktop.org] On Behalf > Of Jim Qu > Sent: Friday, February 10, 2017 3:06 AM > To: amd-gfx@lists.freedesktop.org > Cc: Qu, Jim > Subject: [PATCH] drm/amd/amdgpu: post card if there is real hw resetting > performed > >

[PATCH] Add GPU_POWER sensors

2017-02-10 Thread Tom St Denis
Add the ability to sample GPU_POWER sensors. Because the sensors have a high latency we read them from a background thread which means we've added the requirement for pthreads. Signed-off-by: Tom St Denis --- CMakeLists.txt | 5 ++- README | 6

[UMR] Add GPU_POWER Sensors

2017-02-10 Thread Tom St Denis
This patch adds the ability to read GPU_POWER sensors on smu7 hardware. Because there is an incredibly high latency on reading them I've added a pthread to handle that. Hence the project now requires pthreads to build. ___ amd-gfx mailing list

RE: [PATCH] drm/amd/amdgpu: Update read_sensor calls to have size parameter (v2)

2017-02-10 Thread Deucher, Alexander
> -Original Message- > From: amd-gfx [mailto:amd-gfx-boun...@lists.freedesktop.org] On Behalf > Of Tom St Denis > Sent: Friday, February 10, 2017 7:18 AM > To: amd-gfx@lists.freedesktop.org > Cc: StDenis, Tom > Subject: [PATCH] drm/amd/amdgpu: Update read_sensor calls to have size >

Re: [PATCH 2/2] drm/amdgpu: use amdgpu_gem_va_check() in amdgpu_gem_va_update_vm()

2017-02-10 Thread Alex Deucher
On Thu, Feb 9, 2017 at 5:28 PM, Samuel Pitoiset wrote: > This removes code duplication. > > Signed-off-by: Samuel Pitoiset Applied. thanks! Alex > --- > drivers/gpu/drm/amd/amdgpu/amdgpu_gem.c | 8 +--- > 1 file changed, 1

[PATCH 8/8] Revert "drm/amdgpu: Refactor flip into prepare submit and submit. (v3)"

2017-02-10 Thread Harry Wentland
This reverts commit cb341a319f7e66f879d69af929c3dadfc1a8f31e. --- drivers/gpu/drm/amd/amdgpu/amdgpu_display.c | 136 ++-- drivers/gpu/drm/amd/amdgpu/amdgpu_mode.h| 15 --- 2 files changed, 28 insertions(+), 123 deletions(-) diff --git

Re: Change queue/pipe split between amdkfd and amdgpu

2017-02-10 Thread Andres Rodriguez
Hey Oded, Where can I find a repo with kfdtest? I tried looking here bit couldn't find it: https://cgit.freedesktop.org/~gabbayo/ -Andres On 2017-02-10 05:35 AM, Oded Gabbay wrote: So the warning in dmesg is gone of course, but the test (that I mentioned in previous email) still fails, and

[PATCH 7/8] drm/amd/display: Refactor headless to use atomic commit.

2017-02-10 Thread Harry Wentland
From: Andrey Grodzovsky Headless mode set needs to be synchronized against outstanding nonblocking commits. This achieved by building atomic state and commiting it. Change-Id: Ie5e778afb33dd5c303a169216a7bb8c2d857037e Signed-off-by: Andrey Grodzovsky

[PATCH 5/8] drm/amdgpu: Add a few members to support DAL atomic refactor.

2017-02-10 Thread Harry Wentland
From: Andrey Grodzovsky Signed-off-by: Andrey Grodzovsky --- drivers/gpu/drm/amd/amdgpu/amdgpu_mode.h | 4 1 file changed, 4 insertions(+) diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_mode.h

[PATCH 6/8] drm/amd/display: Refactor atomic commit implementation.

2017-02-10 Thread Harry Wentland
From: Andrey Grodzovsky Modify amdgpu_dm_atomic_comit to implement atomic_comit_tail hook. Unify Buffer objects allocation and dealocation for surface updates and page flips. Simplify wait for fences and target_vbank logic for non blockiing commit. Remove hacky update

[PATCH 3/8] drm/amd/display: Use atomic helpers for gamma

2017-02-10 Thread Harry Wentland
We were using set_properties and gamma in a weird way. This change aligns the properties with other drivers and allows us to remove a private gamma flag and reuse atomic helpers for most of this. Change-Id: Ic74b692ee6c6d3e4fd938c6226e65b54075ff983 Signed-off-by: Harry Wentland

[PATCH 1/8] drm/amdgpu: Expose mode_config functions for DM

2017-02-10 Thread Harry Wentland
Signed-off-by: Harry Wentland --- drivers/gpu/drm/amd/amdgpu/amdgpu_display.c | 4 ++-- drivers/gpu/drm/amd/amdgpu/amdgpu_display.h | 33 + 2 files changed, 35 insertions(+), 2 deletions(-) create mode 100644

[PATCH 4/8] drm/amd/display: Remove unused define from amdgpu_dm_types

2017-02-10 Thread Harry Wentland
Change-Id: Idfd0d0d6e537eddbc75378ba394b0f36bd89dd50 Signed-off-by: Harry Wentland --- drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm_types.h | 5 - 1 file changed, 5 deletions(-) diff --git a/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm_types.h

[PATCH 2/8] drm/amd/display: Use amdgpu mode funcs statically

2017-02-10 Thread Harry Wentland
No need to assign them dynamically. This is much more readable. Change-Id: I2d8a356e8d916800c4553c4e9b19ce42f7f1c391 Signed-off-by: Harry Wentland --- drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c | 8 +++- 1 file changed, 3 insertions(+), 5 deletions(-) diff

[PATCH 0/8] Refactor DC atomic commit and gamma

2017-02-10 Thread Harry Wentland
Resending with CC to dri-devel as per Alex's suggestions. This might be of interest to a wider audience. These patches are first steps of addressing some of the problems in DC's atomic implementation. Please take a look and provide feedback if possible. Our hope is that we can start setting a

[no subject]

2017-02-10 Thread Tom St Denis
Fix bug where GPU_POWER wasn't accessible because we wrote to *size early... ___ amd-gfx mailing list amd-gfx@lists.freedesktop.org https://lists.freedesktop.org/mailman/listinfo/amd-gfx

[PATCH] drm/amd/amdgpu: Update read_sensor calls to have size parameter (v2)

2017-02-10 Thread Tom St Denis
This update allows sensors to return more than 1 value and indicates to the caller how many bytes are written. The debugfs interface has been updated to handle reading all of the values. Simply seek to the enum value (multiplied by 4) and then read as many bytes as the sensor provides. (v2):

Re: [PATCH 1/2] drm/amdgpu: drop multiple bo_unreserve() calls in amdgpu_gem_op_ioctl()

2017-02-10 Thread Samuel Pitoiset
On 02/10/2017 11:37 AM, Christian König wrote: Am 10.02.2017 um 11:22 schrieb Samuel Pitoiset: On 02/10/2017 11:19 AM, Christian König wrote: Am 10.02.2017 um 11:11 schrieb Samuel Pitoiset: On 02/10/2017 03:55 AM, zhoucm1 wrote: On 2017年02月10日 06:28, Samuel Pitoiset wrote: Move

Re: [PATCH 1/2] drm/amdgpu: drop multiple bo_unreserve() calls in amdgpu_gem_op_ioctl()

2017-02-10 Thread Samuel Pitoiset
On 02/10/2017 11:19 AM, Christian König wrote: Am 10.02.2017 um 11:11 schrieb Samuel Pitoiset: On 02/10/2017 03:55 AM, zhoucm1 wrote: On 2017年02月10日 06:28, Samuel Pitoiset wrote: Move amdgpu_bo_unreserve() outside of the switch. While we are at it, add a missing break in the default

Re: [PATCH 1/2] drm/amdgpu: drop multiple bo_unreserve() calls in amdgpu_gem_op_ioctl()

2017-02-10 Thread Christian König
Am 10.02.2017 um 11:11 schrieb Samuel Pitoiset: On 02/10/2017 03:55 AM, zhoucm1 wrote: On 2017年02月10日 06:28, Samuel Pitoiset wrote: Move amdgpu_bo_unreserve() outside of the switch. While we are at it, add a missing break in the default case. Signed-off-by: Samuel Pitoiset

Re: [PATCH 1/2] drm/amdgpu: drop multiple bo_unreserve() calls in amdgpu_gem_op_ioctl()

2017-02-10 Thread Samuel Pitoiset
On 02/10/2017 11:02 AM, Christian König wrote: NAK, we need to drop the reservation before calling copy_to_user(). Otherwise you run into a double locking error when copy_to_user() is trying to copy to the BO in question. Okay, I trust you but this seems tricky. copy_to_user() doesn't even

Re: [PATCH] drm/amdgpu: add more cases to DCE11 possible crtc mask setup

2017-02-10 Thread Christian König
Am 10.02.2017 um 06:02 schrieb Alex Deucher: Add cases for asics with 3 and 5 crtcs. Fixes an artificial limitation on asics with 3 or 5 crtcs. Fixes: https://bugs.freedesktop.org/show_bug.cgi?id=99744 Signed-off-by: Alex Deucher Cc: sta...@vger.kernel.org

Re: [PATCH 3/6] drm/amdgpu: IOCTL interface for PRT support v4

2017-02-10 Thread Nicolai Hähnle
On 08.02.2017 16:04, Christian König wrote: From: Junwei Zhang Till GFX8 we can only enable PRT support globally, but with the next hardware generation we can do this on a per page basis. Keep the interface consistent by adding PRT mappings and enable support globally on

Re: [PATCH 1/2] drm/amdgpu: drop multiple bo_unreserve() calls in amdgpu_gem_op_ioctl()

2017-02-10 Thread Samuel Pitoiset
On 02/10/2017 03:55 AM, zhoucm1 wrote: On 2017年02月10日 06:28, Samuel Pitoiset wrote: Move amdgpu_bo_unreserve() outside of the switch. While we are at it, add a missing break in the default case. Signed-off-by: Samuel Pitoiset ---

Re: [PATCH 2/2] drm/amdgpu: use amdgpu_gem_va_check() in amdgpu_gem_va_update_vm()

2017-02-10 Thread Christian König
Am 09.02.2017 um 23:28 schrieb Samuel Pitoiset: This removes code duplication. Signed-off-by: Samuel Pitoiset Reviewed-by: Christian König . --- drivers/gpu/drm/amd/amdgpu/amdgpu_gem.c | 8 +--- 1 file changed, 1 insertion(+), 7

Re: [PATCH 1/2] drm/amdgpu: drop multiple bo_unreserve() calls in amdgpu_gem_op_ioctl()

2017-02-10 Thread Christian König
NAK, we need to drop the reservation before calling copy_to_user(). Otherwise you run into a double locking error when copy_to_user() is trying to copy to the BO in question. Regards, Christian. Am 09.02.2017 um 23:28 schrieb Samuel Pitoiset: Move amdgpu_bo_unreserve() outside of the

Re: [PATCH libdrm 1/2] amdgpu: add AMDGPU_VM_PAGE_PRT

2017-02-10 Thread Nicolai Hähnle
On 09.02.2017 17:24, Emil Velikov wrote: On 8 February 2017 at 12:34, Nicolai Hähnle wrote: From: Nicolai Hähnle This is a new kernel interface. Signed-off-by: Nicolai Hähnle --- include/drm/amdgpu_drm.h | 2 ++ Hi