Re: [PATCH v2] drm/amd/display: Fix Apple dongle cannot be successfully detected

2019-11-21 Thread Louis Li
On Thu, Nov 21, 2019 at 08:47:50AM -0500, Kazlauskas, Nicholas wrote: > On 2019-11-21 8:40 a.m., Kazlauskas, Nicholas wrote: > >On 2019-11-21 3:31 a.m., Li, Ching-shih (Louis) wrote: > >>Hi reviewers, > >> > >>What is the review result for this patch? Customer is pushing on this > >>change to

[PATCH v2 2/2] drm: share address space for dma bufs

2019-11-21 Thread Gerd Hoffmann
Use the shared address space of the drm device (see drm_open() in drm_file.c) for dma-bufs too. That removes a difference betweem drm device mmap vmas and dma-buf mmap vmas and fixes corner cases like dropping ptes (using madvise(DONTNEED) for example) not working properly. Also remove amdgpu

RE: [PATCH] drm/amdkfd: Remove duplicate functions update_mqd_hiq()

2019-11-21 Thread Liu, Zhan
Looks good to me. Reviewed-by: Zhan Liu > -Original Message- > From: amd-gfx On Behalf Of > Yong Zhao > Sent: 2019/November/21, Thursday 4:25 PM > To: amd-gfx@lists.freedesktop.org > Cc: Zhao, Yong > Subject: [PATCH] drm/amdkfd: Remove duplicate functions > update_mqd_hiq() > > The

Re: [PATCH] drm/amdgpu: move pci handling out of pm ops

2019-11-21 Thread Alex Deucher
On Thu, Nov 21, 2019 at 5:13 PM Dave Airlie wrote: > > On Fri, 22 Nov 2019 at 06:05, Alex Deucher wrote: > > > > On Thu, Nov 21, 2019 at 2:53 PM Dave Airlie wrote: > > > > > > On Fri, 22 Nov 2019 at 02:55, Alex Deucher wrote: > > > > > > > > The documentation says the that PCI core handles

Re: [PATCH] drm/amdgpu: move pci handling out of pm ops

2019-11-21 Thread Dave Airlie
On Fri, 22 Nov 2019 at 06:05, Alex Deucher wrote: > > On Thu, Nov 21, 2019 at 2:53 PM Dave Airlie wrote: > > > > On Fri, 22 Nov 2019 at 02:55, Alex Deucher wrote: > > > > > > The documentation says the that PCI core handles this > > > for you unless you choose to implement it. Just rely > > >

[PATCH 1/2] drm/amdkfd: Rename pm_release_ib() to pm_destroy_runlist_ib()

2019-11-21 Thread Yong Zhao
Its counterparty is called pm_create_runlist_ib(). The new name makes it easier to navigate in the code. Accordingly, Add rl_ to the variable names to indicate it is runlist. Change-Id: Id63bfebeb8a5ed6aaefbebe98858d84724fd26be Signed-off-by: Yong Zhao ---

[PATCH 2/2] drm/amdkfd: Move pm_create_runlist_ib() out of pm_send_runlist()

2019-11-21 Thread Yong Zhao
This is consistent with the calling sequence in unmap_queues_cpsch(). Change-Id: Ieb6714422c812d4f6ebbece34e339871471e4b5e Signed-off-by: Yong Zhao --- .../drm/amd/amdkfd/kfd_device_queue_manager.c | 18 +++-- .../gpu/drm/amd/amdkfd/kfd_packet_manager.c | 20 +--

[PATCH] drm/amdkfd: Remove duplicate functions update_mqd_hiq()

2019-11-21 Thread Yong Zhao
The functions are the same as update_mqd(). Change-Id: Ic8d8f23cdde6b7806ab766ddf3d71fa668cca5fb Signed-off-by: Yong Zhao --- drivers/gpu/drm/amd/amdkfd/kfd_mqd_manager_v10.c | 16 ++-- drivers/gpu/drm/amd/amdkfd/kfd_mqd_manager_v9.c | 16 ++--

Re: GFX[6-9] unconditionaly "allocate" the max of sgprs and vgprs to align on GFX10?

2019-11-21 Thread sylvain . bertrand
On Thu, Nov 21, 2019 at 03:17:12PM -0500, Alex Deucher wrote: > Not sure I understand the question. What are you asking about? On GFX[6-9], maybe it could be a could idea to freeze the number of allocated sgprs and number of allocated vgprs, a bit like what we have on GFX10. Then we could remove

Re: GFX[6-9] unconditionaly "allocate" the max of sgprs and vgprs to align on GFX10?

2019-11-21 Thread Alex Deucher
Not sure I understand the question. What are you asking about? Alex On Thu, Nov 21, 2019 at 3:12 PM wrote: > > Hi, > > Is this a good idea? (see the email subject). > > regards, > > -- > Sylvain > ___ > amd-gfx mailing list >

GFX[6-9] unconditionaly "allocate" the max of sgprs and vgprs to align on GFX10?

2019-11-21 Thread sylvain . bertrand
Hi, Is this a good idea? (see the email subject). regards, -- Sylvain ___ amd-gfx mailing list amd-gfx@lists.freedesktop.org https://lists.freedesktop.org/mailman/listinfo/amd-gfx

Re: [PATCH] drm/amdgpu: move pci handling out of pm ops

2019-11-21 Thread Alex Deucher
On Thu, Nov 21, 2019 at 2:53 PM Dave Airlie wrote: > > On Fri, 22 Nov 2019 at 02:55, Alex Deucher wrote: > > > > The documentation says the that PCI core handles this > > for you unless you choose to implement it. Just rely > > on the PCI core to handle the pci specific bits. > > > >

Re: [PATCH] drm/amdgpu: move pci handling out of pm ops

2019-11-21 Thread Dave Airlie
On Fri, 22 Nov 2019 at 02:55, Alex Deucher wrote: > > The documentation says the that PCI core handles this > for you unless you choose to implement it. Just rely > on the PCI core to handle the pci specific bits. > > Signed-off-by: Alex Deucher > --- > drivers/gpu/drm/amd/amdgpu/amdgpu.h

Re: [PATCH][next] drm/amdgpu: remove redundant assignment to pointer write_frame

2019-11-21 Thread Alex Deucher
Applied. thanks! Alex On Thu, Nov 21, 2019 at 11:54 AM Colin King wrote: > > From: Colin Ian King > > The pointer write_frame is being initialized with a value that is > never read and it is being updated later with a new value. The > initialization is redundant and can be removed. > >

[PATCH][next] drm/amdgpu: remove redundant assignment to pointer write_frame

2019-11-21 Thread Colin King
From: Colin Ian King The pointer write_frame is being initialized with a value that is never read and it is being updated later with a new value. The initialization is redundant and can be removed. Addresses-Coverity: ("Unused value") Signed-off-by: Colin Ian King ---

[PATCH] drm/amdgpu: move pci handling out of pm ops

2019-11-21 Thread Alex Deucher
The documentation says the that PCI core handles this for you unless you choose to implement it. Just rely on the PCI core to handle the pci specific bits. Signed-off-by: Alex Deucher --- drivers/gpu/drm/amd/amdgpu/amdgpu.h| 4 +-- drivers/gpu/drm/amd/amdgpu/amdgpu_device.c | 33

RE: [PATCH v2 0/7] PCI: Prefer pcie_capability_read_word()

2019-11-21 Thread Deucher, Alexander
> -Original Message- > From: amd-gfx On Behalf Of > Bjorn Helgaas > Sent: Thursday, November 21, 2019 9:02 AM > To: linux-...@vger.kernel.org > Cc: Zhou, David(ChunMing) ; Frederick Lawler > ; Dave Airlie ; linux- > ker...@vger.kernel.org; dri-de...@lists.freedesktop.org; Bjorn Helgaas >

Re: [PATCH] drm/amd: Fix Kconfig indentation

2019-11-21 Thread Deucher, Alexander
Reviewed-by: Alex Deucher From: Krzysztof Kozlowski Sent: Thursday, November 21, 2019 8:29 AM To: linux-ker...@vger.kernel.org Cc: Krzysztof Kozlowski ; Deucher, Alexander ; Koenig, Christian ; Zhou, David(ChunMing) ; David Airlie ; Daniel Vetter ;

Re: [PATCH 2/2] drm/amd/amdgpu/sriov skip RLCG s/r list for arcturus VF.

2019-11-21 Thread Zhang, Jack (Jian)
Sure,will do that! Thanks, Jack Outlook for Android From: Deucher, Alexander Sent: Friday, November 22, 2019 12:00:04 AM To: Zhang, Jack (Jian) ; Alex Deucher Cc: amd-gfx list Subject: Re: [PATCH 2/2] drm/amd/amdgpu/sriov skip RLCG s/r

Re: [PATCH 2/2] drm/amd/amdgpu/sriov skip RLCG s/r list for arcturus VF.

2019-11-21 Thread Deucher, Alexander
You can have my RB on the first patch if you fix the compiler warnings. Alex From: amd-gfx on behalf of Zhang, Jack (Jian) Sent: Thursday, November 21, 2019 10:58 AM To: Alex Deucher Cc: amd-gfx list Subject: Re: [PATCH 2/2] drm/amd/amdgpu/sriov skip RLCG s/r

Re: [PATCH 2/2] drm/amd/amdgpu/sriov skip RLCG s/r list for arcturus VF.

2019-11-21 Thread Zhang, Jack (Jian)
Thanks Alex for this review. Both of the two patches will not influence bare-metal code path. B. R. Jack Outlook for Android From: Alex Deucher Sent: Thursday, November 21, 2019 11:26:37 PM To: Zhang, Jack (Jian) Cc: amd-gfx list

RE: [PATCH 2/2] drm/amdgpu: invalidate mmhub semphore workaround in gmc9/gmc10

2019-11-21 Thread Zhu, Changfeng
Hi Chris, I have removed DRM_WARN_ONCE. I think we can write mmhub patch firstly. And It's for ticket: http://ontrack-internal.amd.com/browse/SWDEV-201459 According to Yang,Zilong's comments on this issue, GFXHUB is not applicable to the bug thus doesn't need the w/a. I'll see gfxhub hang root

[PATCH] drm/amdgpu: invalidate mmhub semphore workaround in gmc9/gmc10

2019-11-21 Thread Changfeng.Zhu
From: changzhu It may lose gpuvm invalidate acknowldege state across power-gating off cycle. To avoid this issue in gmc9/gmc10 invalidation, add semaphore acquire before invalidation and semaphore release after invalidation. After adding semaphore acquire before invalidation, the semaphore

Re: [PATCH 2/2] drm/amd/amdgpu/sriov skip RLCG s/r list for arcturus VF.

2019-11-21 Thread Alex Deucher
Nevermind. I missed the sr-iov check. Patch is: Acked-by: Alex Deucher On Thu, Nov 21, 2019 at 10:25 AM Alex Deucher wrote: > > Won't this impact bare metal hw that needs this? > > Alex > > On Thu, Nov 21, 2019 at 1:17 AM Jack Zhang wrote: > > > > After rlcg fw 2.1, kmd driver starts to load

Re: [PATCH 2/2] drm/amd/amdgpu/sriov skip RLCG s/r list for arcturus VF.

2019-11-21 Thread Alex Deucher
Won't this impact bare metal hw that needs this? Alex On Thu, Nov 21, 2019 at 1:17 AM Jack Zhang wrote: > > After rlcg fw 2.1, kmd driver starts to load extra fw for > LIST_CNTL,GPM_MEM,SRM_MEM. We needs to skip the three fw > because all rlcg related fw have been loaded by host driver. > Guest

Re: [PATCH 1/2] drm/amd/amdgpu/sriov temporarily skip ras, dtm, hdcp for arcturus VF

2019-11-21 Thread Alex Deucher
On Thu, Nov 21, 2019 at 1:17 AM Jack Zhang wrote: > > Temporarily skip ras,dtm,hdcp initialize and terminate for arcturus VF > Currently the three features haven't been enabled at SRIOV, it would > trigger guest driver load fail with the bare-metal path of the three > features. > > Signed-off-by:

[PATCH 5/7] drm/radeon: Correct Transmit Margin masks

2019-11-21 Thread Bjorn Helgaas
From: Bjorn Helgaas Previously we masked PCIe Link Control 2 register values with "7 << 9", which was apparently intended to be the Transmit Margin field, but instead was the high order bit of Transmit Margin, the Enter Modified Compliance bit, and the Compliance SOS bit. Correct the mask to "7

[PATCH 1/7] PCI: Add #defines for Enter Compliance, Transmit Margin

2019-11-21 Thread Bjorn Helgaas
From: Bjorn Helgaas Add definitions for the Enter Compliance and Transmit Margin fields of the PCIe Link Control 2 register. Link: https://lore.kernel.org/r/20191112173503.176611-2-helg...@kernel.org Signed-off-by: Bjorn Helgaas Reviewed-by: Alex Deucher --- include/uapi/linux/pci_regs.h | 2

[PATCH 3/7] drm/amdgpu: Replace numbers with PCI_EXP_LNKCTL2 definitions

2019-11-21 Thread Bjorn Helgaas
From: Bjorn Helgaas Replace hard-coded magic numbers with the descriptive PCI_EXP_LNKCTL2 definitions. No functional change intended. Link: https://lore.kernel.org/r/20191112173503.176611-4-helg...@kernel.org Signed-off-by: Bjorn Helgaas Reviewed-by: Alex Deucher ---

[PATCH 4/7] drm/amdgpu: Prefer pcie_capability_read_word()

2019-11-21 Thread Bjorn Helgaas
From: Frederick Lawler Commit 8c0d3a02c130 ("PCI: Add accessors for PCI Express Capability") added accessors for the PCI Express Capability so that drivers didn't need to be aware of differences between v1 and v2 of the PCI Express Capability. Replace pci_read_config_word() and

[PATCH v2 0/7] PCI: Prefer pcie_capability_read_word()

2019-11-21 Thread Bjorn Helgaas
From: Bjorn Helgaas Use pcie_capability_read_word() and similar instead of using pci_read_config_word() directly. Add #defines to replace some magic numbers. Fix typos in use of Transmit Margin field. These are currently on my pci/misc branch for v5.5. Let me know if you see any issues.

[PATCH 2/7] drm/amdgpu: Correct Transmit Margin masks

2019-11-21 Thread Bjorn Helgaas
From: Bjorn Helgaas Previously we masked PCIe Link Control 2 register values with "7 << 9", which was apparently intended to be the Transmit Margin field, but instead was the high order bit of Transmit Margin, the Enter Modified Compliance bit, and the Compliance SOS bit. Correct the mask to "7

[PATCH 7/7] drm/radeon: Prefer pcie_capability_read_word()

2019-11-21 Thread Bjorn Helgaas
From: Frederick Lawler Commit 8c0d3a02c130 ("PCI: Add accessors for PCI Express Capability") added accessors for the PCI Express Capability so that drivers didn't need to be aware of differences between v1 and v2 of the PCI Express Capability. Replace pci_read_config_word() and

[PATCH 6/7] drm/radeon: Replace numbers with PCI_EXP_LNKCTL2 definitions

2019-11-21 Thread Bjorn Helgaas
From: Bjorn Helgaas Replace hard-coded magic numbers with the descriptive PCI_EXP_LNKCTL2 definitions. No functional change intended. Link: https://lore.kernel.org/r/20191112173503.176611-4-helg...@kernel.org Signed-off-by: Bjorn Helgaas Reviewed-by: Alex Deucher ---

Re: [PATCH v2 1/1] drm: Prefer pcie_capability_read_word()

2019-11-21 Thread Bjorn Helgaas
On Mon, Nov 18, 2019 at 12:42:25PM -0500, Alex Deucher wrote: > On Mon, Nov 18, 2019 at 3:37 AM Frederick Lawler wrote: > > > > Commit 8c0d3a02c130 ("PCI: Add accessors for PCI Express Capability") > > added accessors for the PCI Express Capability so that drivers didn't > > need to be aware of

Re: [PATCH v2] drm/amd/display: Fix Apple dongle cannot be successfully detected

2019-11-21 Thread Kazlauskas, Nicholas
On 2019-11-21 8:40 a.m., Kazlauskas, Nicholas wrote: On 2019-11-21 3:31 a.m., Li, Ching-shih (Louis) wrote: Hi reviewers, What is the review result for this patch? Customer is pushing on this change to merge. TKS for your attention. BR, Louis -Original Message- From: Louis Li

Re: [PATCH v2] drm/amd/display: Fix Apple dongle cannot be successfully detected

2019-11-21 Thread Kazlauskas, Nicholas
On 2019-11-21 3:31 a.m., Li, Ching-shih (Louis) wrote: Hi reviewers, What is the review result for this patch? Customer is pushing on this change to merge. TKS for your attention. BR, Louis -Original Message- From: Louis Li Sent: Thursday, November 14, 2019 11:42 AM To:

[PATCH] drm/amd: Fix Kconfig indentation

2019-11-21 Thread Krzysztof Kozlowski
Adjust indentation from spaces to tab (+optional two spaces) as in coding style with command like: $ sed -e 's/^/\t/' -i */Kconfig Signed-off-by: Krzysztof Kozlowski --- drivers/gpu/drm/amd/acp/Kconfig | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git

RE: [PATCH v2] drm/amd/display: Fix Apple dongle cannot be successfully detected

2019-11-21 Thread Li, Ching-shih (Louis)
Hi reviewers, What is the review result for this patch? Customer is pushing on this change to merge. TKS for your attention. BR, Louis -Original Message- From: Louis Li Sent: Thursday, November 14, 2019 11:42 AM To: amd-gfx@lists.freedesktop.org Cc: Kazlauskas, Nicholas ; Wentland,