[PATCH 5/6] drm/amdkfd: Unify multiple calls to pr_debug() into one

2016-09-16 Thread Edward O'Callaghan
Signed-off-by: Edward O'Callaghan --- drivers/gpu/drm/amd/amdkfd/kfd_doorbell.c | 16 +--- 1 file changed, 9 insertions(+), 7 deletions(-) diff --git a/drivers/gpu/drm/amd/amdkfd/kfd_doorbell.c b/drivers/gpu/drm/amd/amdkfd/kfd_doorbell.c index

[PATCH 4/6] drm/amdkfd: Fix possible infinite loop

2016-09-16 Thread Edward O'Callaghan
When the loop predicating timeout parameter passed happens to not be a multiple of 20 the unsigned integer will overflow and the loop will become unbounded. Signed-off-by: Edward O'Callaghan Reviewed-by: Oded Gabbay ---

[PATCH 1/6] drm/amdkfd: Tidy up kfd_generate_gpu_id() uint64_t bitshift unpack

2016-09-16 Thread Edward O'Callaghan
Dereference the one time and unpack the lower and upper 32bit portions with the proper kernel helper macros. Signed-off-by: Edward O'Callaghan Reviewed-by: Oded Gabbay --- drivers/gpu/drm/amd/amdkfd/kfd_topology.c | 8 +--- 1 file

[PATCH 2/6] drm/amdkfd: Add some missing memset zero'ing in queue init func

2016-09-16 Thread Edward O'Callaghan
Signed-off-by: Edward O'Callaghan Reviewed-by: Oded Gabbay --- drivers/gpu/drm/amd/amdkfd/kfd_kernel_queue.c | 3 +++ 1 file changed, 3 insertions(+) diff --git a/drivers/gpu/drm/amd/amdkfd/kfd_kernel_queue.c

drm/amdkfd: Misc patchset lineup for drm-next-4.9

2016-09-16 Thread Edward O'Callaghan
Hi, Most of these have already been reviewed and some of the more invasive patches have been dropped from the orginal series. As I wish to get the low hanging fruit out the way as quickly as possible. I shall try to find the time this weekend to prepare the second more interesting set but don't

[PATCH 6/6] drm/amdkfd: Pass 'struct queue_propertices' by reference

2016-09-16 Thread Edward O'Callaghan
Allow init_queue() to take 'struct queue_properties' by reference. Signed-off-by: Edward O'Callaghan --- drivers/gpu/drm/amd/amdkfd/kfd_kernel_queue.c | 2 +- drivers/gpu/drm/amd/amdkfd/kfd_priv.h | 2 +-

Re: [pull] radeon and amdgpu drm-next-4.9

2016-09-16 Thread Alex Deucher
On Fri, Sep 16, 2016 at 5:38 PM, Lukas Wunner wrote: > On Fri, Sep 16, 2016 at 04:42:43PM -0400, Alex Deucher wrote: >> drm/amdgpu: skip suspend/resume on DRM_SWITCH_POWER_DYNAMIC_OFF >> drm/radeon: skip suspend/resume on DRM_SWITCH_POWER_DYNAMIC_OFF > > Those two are

Re: [pull] radeon and amdgpu drm-next-4.9

2016-09-16 Thread Lukas Wunner
On Fri, Sep 16, 2016 at 04:42:43PM -0400, Alex Deucher wrote: > drm/amdgpu: skip suspend/resume on DRM_SWITCH_POWER_DYNAMIC_OFF > drm/radeon: skip suspend/resume on DRM_SWITCH_POWER_DYNAMIC_OFF Those two are unnecessary, it can't happen that the ->suspend hook is executed with the

[pull] radeon and amdgpu drm-next-4.9

2016-09-16 Thread Alex Deucher
Hi Dave, More radeon and amdgpu changes for 4.9. Highlights: - Initial SI support for amdgpu (controlled by a Kconfig option) - misc ttm cleanups - runtimepm fixes - S3/S4 fixes - power improvements - lots of code cleanups and optimizations The following changes since commit

Re: [PATCH 15/15] drm/amdgpu: use the new ring ib and dma frame size callbacks

2016-09-16 Thread Christian König
Am 16.09.2016 um 18:05 schrieb Alex Deucher: Use them to more accurately determine the ring size required for ib submission. Signed-off-by: Alex Deucher --- drivers/gpu/drm/amd/amdgpu/amdgpu_ib.c | 8 ++-- 1 file changed, 6 insertions(+), 2 deletions(-) diff

[PATCH 12/15] drm/amdgpu/vce: add common ring callbacks for ib and dma frame size

2016-09-16 Thread Alex Deucher
Signed-off-by: Alex Deucher --- drivers/gpu/drm/amd/amdgpu/amdgpu_vce.c | 12 drivers/gpu/drm/amd/amdgpu/amdgpu_vce.h | 2 ++ 2 files changed, 14 insertions(+) diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_vce.c

[PATCH 13/15] drm/amdgpu/vce2: add ring callbacks for ib and dma frame size

2016-09-16 Thread Alex Deucher
Signed-off-by: Alex Deucher --- drivers/gpu/drm/amd/amdgpu/vce_v2_0.c | 2 ++ 1 file changed, 2 insertions(+) diff --git a/drivers/gpu/drm/amd/amdgpu/vce_v2_0.c b/drivers/gpu/drm/amd/amdgpu/vce_v2_0.c index 58af0da..76e64ad 100644 ---

[PATCH 14/15] drm/amdgpu/vce3: add ring callbacks for ib and dma frame size

2016-09-16 Thread Alex Deucher
Signed-off-by: Alex Deucher --- drivers/gpu/drm/amd/amdgpu/vce_v3_0.c | 25 + 1 file changed, 25 insertions(+) diff --git a/drivers/gpu/drm/amd/amdgpu/vce_v3_0.c b/drivers/gpu/drm/amd/amdgpu/vce_v3_0.c index a55ddc0..a6b4e27 100644 ---

[PATCH 02/15] drm/amdgpu/gfx6: add ring callbacks for ib and dma frame size

2016-09-16 Thread Alex Deucher
Signed-off-by: Alex Deucher --- drivers/gpu/drm/amd/amdgpu/gfx_v6_0.c | 31 +++ 1 file changed, 31 insertions(+) diff --git a/drivers/gpu/drm/amd/amdgpu/gfx_v6_0.c b/drivers/gpu/drm/amd/amdgpu/gfx_v6_0.c index e7293f6..410b29c 100644 ---

[PATCH 04/15] drm/amdgpu/gfx8: add ring callbacks for ib and dma frame size

2016-09-16 Thread Alex Deucher
Signed-off-by: Alex Deucher --- drivers/gpu/drm/amd/amdgpu/gfx_v8_0.c | 40 +++ 1 file changed, 40 insertions(+) diff --git a/drivers/gpu/drm/amd/amdgpu/gfx_v8_0.c b/drivers/gpu/drm/amd/amdgpu/gfx_v8_0.c index e2ed71d..1e7c615 100644

[PATCH 11/15] drm/amdgpu/uvd6: add ring callbacks for ib and dma frame size

2016-09-16 Thread Alex Deucher
Signed-off-by: Alex Deucher --- drivers/gpu/drm/amd/amdgpu/uvd_v6_0.c | 29 + 1 file changed, 29 insertions(+) diff --git a/drivers/gpu/drm/amd/amdgpu/uvd_v6_0.c b/drivers/gpu/drm/amd/amdgpu/uvd_v6_0.c index 2abe8a9..e0fd9f2 100644 ---

[PATCH 10/15] drm/amdgpu/uvd5: add ring callbacks for ib and dma frame size

2016-09-16 Thread Alex Deucher
Signed-off-by: Alex Deucher --- drivers/gpu/drm/amd/amdgpu/uvd_v5_0.c | 16 1 file changed, 16 insertions(+) diff --git a/drivers/gpu/drm/amd/amdgpu/uvd_v5_0.c b/drivers/gpu/drm/amd/amdgpu/uvd_v5_0.c index 8513376..400c16f 100644 ---

[PATCH 09/15] drm/amdgpu/uvd4.2: add ring callbacks for ib and dma frame size

2016-09-16 Thread Alex Deucher
Signed-off-by: Alex Deucher --- drivers/gpu/drm/amd/amdgpu/uvd_v4_2.c | 16 1 file changed, 16 insertions(+) diff --git a/drivers/gpu/drm/amd/amdgpu/uvd_v4_2.c b/drivers/gpu/drm/amd/amdgpu/uvd_v4_2.c index 10c0407..f6c9415 100644 ---

[PATCH 06/15] drm/amdgpu/cik_sdma: add ring callbacks for ib and dma frame size

2016-09-16 Thread Alex Deucher
Signed-off-by: Alex Deucher --- drivers/gpu/drm/amd/amdgpu/cik_sdma.c | 18 ++ 1 file changed, 18 insertions(+) diff --git a/drivers/gpu/drm/amd/amdgpu/cik_sdma.c b/drivers/gpu/drm/amd/amdgpu/cik_sdma.c index e71cd12..e6d7bf9 100644 ---

[PATCH 08/15] drm/amdgpu/sdma3: add ring callbacks for ib and dma frame size

2016-09-16 Thread Alex Deucher
Signed-off-by: Alex Deucher --- drivers/gpu/drm/amd/amdgpu/sdma_v3_0.c | 18 ++ 1 file changed, 18 insertions(+) diff --git a/drivers/gpu/drm/amd/amdgpu/sdma_v3_0.c b/drivers/gpu/drm/amd/amdgpu/sdma_v3_0.c index cabb9fe..62e2f4c 100644 ---

[PATCH 03/15] drm/amdgpu/gfx7: add ring callbacks for ib and dma frame size

2016-09-16 Thread Alex Deucher
Signed-off-by: Alex Deucher --- drivers/gpu/drm/amd/amdgpu/gfx_v7_0.c | 39 +++ 1 file changed, 39 insertions(+) diff --git a/drivers/gpu/drm/amd/amdgpu/gfx_v7_0.c b/drivers/gpu/drm/amd/amdgpu/gfx_v7_0.c index 8c780f6..90102f1 100644

[PATCH 07/15] drm/amdgpu/sdma2.4: add ring callbacks for ib and dma frame size

2016-09-16 Thread Alex Deucher
Signed-off-by: Alex Deucher --- drivers/gpu/drm/amd/amdgpu/sdma_v2_4.c | 18 ++ 1 file changed, 18 insertions(+) diff --git a/drivers/gpu/drm/amd/amdgpu/sdma_v2_4.c b/drivers/gpu/drm/amd/amdgpu/sdma_v2_4.c index e822296..82c731b 100644 ---

[PATCH] drm/amdgpu: update the shadow PD together with the real one

2016-09-16 Thread Christian König
From: Christian König Far less CPU cycles needed for this approach. Signed-off-by: Christian König --- drivers/gpu/drm/amd/amdgpu/amdgpu.h| 1 - drivers/gpu/drm/amd/amdgpu/amdgpu_vm.c | 134 + 2 files

Re: Powerplay sensors (v2.5)

2016-09-16 Thread Edward O'Callaghan
This series is, Reviewed-by: Edward O'Callaghan On 09/16/2016 10:44 PM, Tom St Denis wrote: > I've rebased the backend to squash the carrizo + rest patches together > and then touched up the debugfs entry per Edwards suggestions. > > Tested on Tonga, Carrizo, and

[PATCH 1/2] drm/amd/powerplay: Add read_sensor() callback to hwmgr (v2)

2016-09-16 Thread Tom St Denis
Provides standardized interface to read various sensors. The API is extensible (by adding to the end of the amd_pp_sensors enumeration list. Support has been added to Carrizo/Tonga/Fiji/Polaris/Iceland (v2) Squashed the two sensor patches into one. Signed-off-by: Tom St Denis

[PATCH 2/2] drm/amd/amdgpu: Hook up read_sensor() to debugfs (v2)

2016-09-16 Thread Tom St Denis
(v2) Tidy'ed up read function. Signed-off-by: Tom St Denis --- drivers/gpu/drm/amd/amdgpu/amdgpu_device.c | 31 ++ 1 file changed, 31 insertions(+) diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_device.c

Powerplay sensors (v2.5)

2016-09-16 Thread Tom St Denis
I've rebased the backend to squash the carrizo + rest patches together and then touched up the debugfs entry per Edwards suggestions. Tested on Tonga, Carrizo, and Stoney. ___ amd-gfx mailing list amd-gfx@lists.freedesktop.org

Re: [PATCH 1/3] drm/amdgpu: cleanup VM shadow BO unreferencing

2016-09-16 Thread Edward O'Callaghan
Series is, Acked-by: Edward O'Callaghan On 09/16/2016 10:12 PM, Christian König wrote: > From: Christian König > > Unreference the shadow BOs in the error path as well and drop the NULL checks. > > Signed-off-by: Christian König

[PATCH 1/3] drm/amdgpu: cleanup VM shadow BO unreferencing

2016-09-16 Thread Christian König
From: Christian König Unreference the shadow BOs in the error path as well and drop the NULL checks. Signed-off-by: Christian König --- drivers/gpu/drm/amd/amdgpu/amdgpu_vm.c | 16 ++-- 1 file changed, 10 insertions(+), 6

[PATCH 2/3] drm/amdgpu: fix initializing the VM last eviction counter

2016-09-16 Thread Christian König
From: Christian König Close a very small window where something can go wrong. Signed-off-by: Christian König --- drivers/gpu/drm/amd/amdgpu/amdgpu_vm.c | 8 ++-- 1 file changed, 6 insertions(+), 2 deletions(-) diff --git

Re: Add read_sensor() support for fiji/tonga/iceland/polaris10

2016-09-16 Thread StDenis, Tom
Thanks. I'm thinking I might merge this with Patch #1 from the other series just to make life easier for everyone. Tom From: amd-gfx on behalf of Edward O'Callaghan Sent: Friday, September

Re: [PATCH] drm/amdgpu: allocate GTT space for shadow VM page tables

2016-09-16 Thread Christian König
Could be, but possible that I've missed a few other places where GTT is used as well. What issues where you seeing and are there any backtraces logged? I have a WARN_ON() in the code path which should trigger whenever I missed something. Christian. Am 16.09.2016 um 11:55 schrieb Mike

Re: [PATCH] drm/amdgpu: allocate GTT space for shadow VM page tables

2016-09-16 Thread Mike Lothian
Does this fix the issue I was seeing since the new memory manager went into thr 4.9-wip branch? On Fri, 16 Sep 2016, 10:48 am Christian König, wrote: > From: Christian König > > We need to access those with the system domain. > > Fixes fallout

[PATCH] drm/amdgpu: allocate GTT space for shadow VM page tables

2016-09-16 Thread Christian König
From: Christian König We need to access those with the system domain. Fixes fallout from only allocating GTT space on demand. Signed-off-by: Christian König --- drivers/gpu/drm/amd/amdgpu/amdgpu_vm.c | 17 + 1 file changed,

[ANNOUNCE] xf86-video-amdgpu 1.1.2

2016-09-16 Thread Michel Dänzer
This is the 1.1.2 release of xf86-video-amdgpu, the Xorg driver for AMD Radeon GPUs supported by the amdgpu kernel driver. The only change in this release is a fix for issues with the configure option --with-xorg-conf-dir which slipped into the 1.1.1 release. Everybody is advised to use this

Re: libdrm/amdgpu - Fixup typedef not to hide pointer type

2016-09-16 Thread Christian König
Am 16.09.2016 um 11:02 schrieb Edward O'Callaghan: Hi Christian, On 09/16/2016 06:49 PM, Christian König wrote: NAK, that is clearly an API breakage. It should have never been typedef'ed in the first place. Does that mean we would have to bump version for API change? What is the procedure

Re: libdrm/amdgpu - Fixup typedef not to hide pointer type

2016-09-16 Thread Edward O'Callaghan
Hi Christian, On 09/16/2016 06:49 PM, Christian König wrote: > NAK, that is clearly an API breakage. It should have never been typedef'ed in the first place. Does that mean we would have to bump version for API change? What is the procedure there? > > BTW: Why would we want to stop hiding the

Re: libdrm/amdgpu - Fixup typedef not to hide pointer type

2016-09-16 Thread Christian König
NAK, that is clearly an API breakage. BTW: Why would we want to stop hiding the type? Christian. Am 16.09.2016 um 10:46 schrieb Edward O'Callaghan: Oops, turns out I mailed to dri-devel by mistake so resending here. The following series fixes up libdrm/amdgpu such that to not hide a pointer

[PATCH 2/3] amdgpu: Fix amdgpu_semaphore_handle typedef not to hide pointer type

2016-09-16 Thread Edward O'Callaghan
Signed-off-by: Edward O'Callaghan --- amdgpu/amdgpu.h| 10 +- amdgpu/amdgpu_cs.c | 20 ++-- tests/amdgpu/basic_tests.c | 2 +- 3 files changed, 16 insertions(+), 16 deletions(-) diff --git a/amdgpu/amdgpu.h

[PATCH 3/3] amdgpu: Fix amdgpu_bo_list_handle typedef not to hide pointer type

2016-09-16 Thread Edward O'Callaghan
Signed-off-by: Edward O'Callaghan --- amdgpu/amdgpu.h| 10 +- amdgpu/amdgpu_bo.c | 6 +++--- tests/amdgpu/amdgpu_test.h | 2 +- tests/amdgpu/basic_tests.c | 8 4 files changed, 13 insertions(+), 13 deletions(-) diff --git

libdrm/amdgpu - Fixup typedef not to hide pointer type

2016-09-16 Thread Edward O'Callaghan
Oops, turns out I mailed to dri-devel by mistake so resending here. The following series fixes up libdrm/amdgpu such that to not hide a pointer type behind a typedef. Please Review, Edward O'Callaghan (3): [PATCH 1/3] amdgpu: Fix amdgpu_va_handle typedef not to hide pointer [PATCH 2/3]

[PATCH 1/3] amdgpu: Fix amdgpu_va_handle typedef not to hide pointer type

2016-09-16 Thread Edward O'Callaghan
Fundamentally this change stops us hiding the following pointer type behind a typedef: -typedef struct amdgpu_va *amdgpu_va_handle; +typedef struct amdgpu_va amdgpu_va_handle_t; Signed-off-by: Edward O'Callaghan --- amdgpu/amdgpu.h| 6 +++---

Re: [PATCH 2/5] drm/amdgpu: fix a bunch of coding style issues in amdgpu_ttm.c

2016-09-16 Thread Christian König
Am 16.09.2016 um 04:17 schrieb Michel Dänzer: On 15/09/16 10:10 PM, Christian König wrote: From: Christian König No intented functional change. Signed-off-by: Christian König --- drivers/gpu/drm/amd/amdgpu/amdgpu_ttm.c | 65

Re: [PATCH 1/3] drm/amdgpu/gfx6: drop duplicate code

2016-09-16 Thread Edward O'Callaghan
This series is, Reviewed-by: Edward O'Callaghan P.S., keep these hedge cuttings coming! On 09/16/2016 05:55 AM, Alex Deucher wrote: > The compute functions just called the gfx functions, drop > the wrapper. > > Signed-off-by: Alex Deucher

[PATCH xf86-video-amdgpu] Untangle HAS_XORG_CONF_DIR / --with-xorg-conf-dir lines in configure.ac

2016-09-16 Thread Michel Dänzer
From: Michel Dänzer $sysconfigdir used to be part of the default --with-xorg-conf-dir value, but it no longer is. Signed-off-by: Michel Dänzer --- configure.ac | 5 +++-- 1 file changed, 3 insertions(+), 2 deletions(-) diff --git a/configure.ac

Re: [PATCH] drm/amdgpu/sdma3: drop unused functions

2016-09-16 Thread Christian König
Am 15.09.2016 um 22:30 schrieb Alex Deucher: These are not used yet. Signed-off-by: Alex Deucher Reviewed-by: Christian König . --- drivers/gpu/drm/amd/amdgpu/sdma_v3_0.c | 25 - 1 file changed, 25 deletions(-)

Re: [PATCH 1/3] drm/amdgpu/gfx6: drop duplicate code

2016-09-16 Thread Christian König
Am 15.09.2016 um 21:55 schrieb Alex Deucher: The compute functions just called the gfx functions, drop the wrapper. Signed-off-by: Alex Deucher Reviewed-by: Christian König for the whole series. ---

[PATCH] Fix handling of configure option --with-xorg-conf-dir

2016-09-16 Thread Michel Dänzer
From: Michel Dänzer There were two problems: I accidentally changed the variable name in the AC_ARG_WITH stanza from configdir to xorgconfigdir, so specifying --with-xorg-conf-dir wouldn't work correctly. Fix this back to configdir. If neither --with-xorg-conf-dir nor