Re: [PATCH 13/15] drm/amdgpu/display: split dp connector registration (v3)

2020-02-13 Thread Daniel Vetter
On Fri, Feb 07, 2020 at 04:17:13PM -0500, Alex Deucher wrote: > Split into init and register functions to avoid a segfault > in some configs when the load/unload callbacks are removed. > > v2: > - add back accidently dropped has_aux setting > - set dev in late_register > > v3: > - fix dp cec

[PATCH] drm/amdgpu: add is_raven_kicker judgement for raven1

2020-02-13 Thread Changfeng.Zhu
From: changzhu The rlc version of raven_kicer_rlc is different from the legacy rlc version of raven_rlc. So it needs to add a judgement function for raven_kicer_rlc and avoid disable GFXOFF when loading raven_kicer_rlc. Change-Id: I00d726cc39eae4ea788c1d5faeb8ce75ec0b884d Signed-off-by:

[PATCH] drm/amdgpu: add is_raven_kicker judgement for raven1

2020-02-13 Thread Changfeng.Zhu
From: changzhu The rlc version of raven_kicer_rlc is different from the legacy rlc version of raven_rlc. So it needs to add a judgement function for raven_kicer_rlc and avoid disable GFXOFF when loading raven_kicer_rlc. Change-Id: I00d726cc39eae4ea788c1d5faeb8ce75ec0b884d Signed-off-by:

Re: [PATCH] drm/amdgpu: Move to a per-IB secure flag (TMZ)

2020-02-13 Thread Luben Tuikov
On 2020-02-13 09:57, Huang Rui wrote: > On Thu, Feb 13, 2020 at 11:30:43AM +0100, Christian König wrote: >> Am 13.02.20 um 01:54 schrieb Luben Tuikov: >>> Move from a per-CS secure flag (TMZ) to a per-IB >>> secure flag. >> >> Well that seems to make a lot of sense to me, but need to bit of time

Re: [PATCH] drm/amdgpu: Move to a per-IB secure flag (TMZ)

2020-02-13 Thread Luben Tuikov
On 2020-02-13 05:30, Christian König wrote: > Am 13.02.20 um 01:54 schrieb Luben Tuikov: >> Move from a per-CS secure flag (TMZ) to a per-IB >> secure flag. > > Well that seems to make a lot of sense to me, but need to bit of time to > read into the PM4 handling of TMZ. Note that this patch is

Re: [PATCH 14/15] drm/amdgpu/ring: move debugfs init into core amdgpu debugfs

2020-02-13 Thread Alex Deucher
On Thu, Feb 13, 2020 at 12:28 PM Christian König wrote: > > Am 13.02.20 um 15:32 schrieb Alex Deucher: > > On Thu, Feb 13, 2020 at 5:17 AM Christian König > > wrote: > >> Am 13.02.20 um 10:54 schrieb Daniel Vetter: > >>> On Fri, Feb 07, 2020 at 02:50:57PM -0500, Alex Deucher wrote: > In

Re: [PATCH 14/15] drm/amdgpu/ring: move debugfs init into core amdgpu debugfs

2020-02-13 Thread Christian König
Am 13.02.20 um 15:32 schrieb Alex Deucher: On Thu, Feb 13, 2020 at 5:17 AM Christian König wrote: Am 13.02.20 um 10:54 schrieb Daniel Vetter: On Fri, Feb 07, 2020 at 02:50:57PM -0500, Alex Deucher wrote: In order to remove the load and unload drm callbacks, we need to reorder the init

Re: [RFC PATCH 5/6] drm/qxl: don't use ttm bo->offset

2020-02-13 Thread Christian König
Am 13.02.20 um 15:30 schrieb Gerd Hoffmann: @@ -311,10 +311,8 @@ qxl_bo_physical_address(struct qxl_device *qdev, struct qxl_bo *bo, (bo->tbo.mem.mem_type == TTM_PL_VRAM) ? >main_slot : >surfaces_slot; - WARN_ON_ONCE((bo->tbo.offset & slot->gpu_offset) !=

Re: [PATCH 13/15] drm/amdgpu/display: split dp connector registration (v3)

2020-02-13 Thread Alex Deucher
Anyone want to take a shot at this one? Alex On Fri, Feb 7, 2020 at 4:17 PM Alex Deucher wrote: > > Split into init and register functions to avoid a segfault > in some configs when the load/unload callbacks are removed. > > v2: > - add back accidently dropped has_aux setting > - set dev in

[PATCH 4/4] drm/radeon: align short build log

2020-02-13 Thread Masahiro Yamada
This beautifies the build log. [Before] HOSTCC drivers/gpu/drm/radeon/mkregtable MKREGTABLE drivers/gpu/drm/radeon/r100_reg_safe.h MKREGTABLE drivers/gpu/drm/radeon/rn50_reg_safe.h CC [M] drivers/gpu/drm/radeon/r100.o MKREGTABLE drivers/gpu/drm/radeon/r300_reg_safe.h CC [M]

[PATCH 3/4] drm/radeon: use pattern rule to avoid code duplication in Makefile

2020-02-13 Thread Masahiro Yamada
This Makefile repeats similar build rules. Use a pattern rule. Signed-off-by: Masahiro Yamada --- drivers/gpu/drm/radeon/Makefile | 29 + 1 file changed, 1 insertion(+), 28 deletions(-) diff --git a/drivers/gpu/drm/radeon/Makefile b/drivers/gpu/drm/radeon/Makefile

[PATCH 2/4] drm/radeon: fix build rules of *_reg_safe.h

2020-02-13 Thread Masahiro Yamada
if_changed must have FORCE as a prerequisite, and the targets must be added to 'targets'. Signed-off-by: Masahiro Yamada --- drivers/gpu/drm/radeon/Makefile | 22 +++--- 1 file changed, 11 insertions(+), 11 deletions(-) diff --git a/drivers/gpu/drm/radeon/Makefile

Re: [PATCH] drm/amdgpu: Move to a per-IB secure flag (TMZ)

2020-02-13 Thread Huang Rui
On Thu, Feb 13, 2020 at 11:30:43AM +0100, Christian König wrote: > Am 13.02.20 um 01:54 schrieb Luben Tuikov: > > Move from a per-CS secure flag (TMZ) to a per-IB > > secure flag. > > Well that seems to make a lot of sense to me, but need to bit of time to > read into the PM4 handling of TMZ. >

Re: [RFC PATCH 0/6] do not store GPU address in TTM

2020-02-13 Thread Huang Rui
On Thu, Feb 13, 2020 at 01:01:57PM +0100, Nirmoy Das wrote: > With this patch series I am trying to remove GPU address dependency in > TTM and moving GPU address calculation to individual drm drivers. > This is required[1] to continue the work started by Brian Welty to create > struct

Re: [PATCH 14/15] drm/amdgpu/ring: move debugfs init into core amdgpu debugfs

2020-02-13 Thread Alex Deucher
On Thu, Feb 13, 2020 at 5:17 AM Christian König wrote: > > Am 13.02.20 um 10:54 schrieb Daniel Vetter: > > On Fri, Feb 07, 2020 at 02:50:57PM -0500, Alex Deucher wrote: > >> In order to remove the load and unload drm callbacks, > >> we need to reorder the init sequence to move all the drm > >>

Re: [RFC PATCH 5/6] drm/qxl: don't use ttm bo->offset

2020-02-13 Thread Gerd Hoffmann
> @@ -311,10 +311,8 @@ qxl_bo_physical_address(struct qxl_device *qdev, struct > qxl_bo *bo, > (bo->tbo.mem.mem_type == TTM_PL_VRAM) > ? >main_slot : >surfaces_slot; > > - WARN_ON_ONCE((bo->tbo.offset & slot->gpu_offset) != slot->gpu_offset); > - > - /* TODO

Re: [RFC PATCH 2/6] drm/radeon: don't use ttm bo->offset

2020-02-13 Thread Christian König
Am 13.02.20 um 13:31 schrieb Nirmoy: On 2/13/20 1:18 PM, Christian König wrote: Looks like most of the patch is missing? We should have quite a number of uses of the BO offset in radeon or do all of those go through radeon_bo_gpu_offset? Compilation worked so I think all those(bo->offset)

Re: [RFC PATCH 2/6] drm/radeon: don't use ttm bo->offset

2020-02-13 Thread Nirmoy
On 2/13/20 1:18 PM, Christian König wrote: Looks like most of the patch is missing? We should have quite a number of uses of the BO offset in radeon or do all of those go through radeon_bo_gpu_offset? Compilation worked so I think all those(bo->offset) accesses went through

Re: [RFC PATCH 0/6] do not store GPU address in TTM

2020-02-13 Thread Christian König
Am 13.02.20 um 13:01 schrieb Nirmoy Das: With this patch series I am trying to remove GPU address dependency in TTM and moving GPU address calculation to individual drm drivers. This is required[1] to continue the work started by Brian Welty to create struct drm_mem_region which can be leverage

Re: [RFC PATCH 2/6] drm/radeon: don't use ttm bo->offset

2020-02-13 Thread Christian König
Looks like most of the patch is missing? We should have quite a number of uses of the BO offset in radeon or do all of those go through radeon_bo_gpu_offset? If yes then the change is much smaller than I thought i needs to be. Christian. Am 13.02.20 um 13:01 schrieb Nirmoy Das:

[RFC PATCH 6/6] drm/ttm: do not keep GPU dependent addresses

2020-02-13 Thread Nirmoy Das
GPU address handling is device specific and should be handle by its device driver. Signed-off-by: Nirmoy Das --- drivers/gpu/drm/ttm/ttm_bo.c| 7 --- include/drm/ttm/ttm_bo_api.h| 2 -- include/drm/ttm/ttm_bo_driver.h | 1 - 3 files changed, 10 deletions(-) diff --git

[RFC PATCH 0/6] do not store GPU address in TTM

2020-02-13 Thread Nirmoy Das
With this patch series I am trying to remove GPU address dependency in TTM and moving GPU address calculation to individual drm drivers. This is required[1] to continue the work started by Brian Welty to create struct drm_mem_region which can be leverage by DRM cgroup controller to manage memory

[RFC PATCH 5/6] drm/qxl: don't use ttm bo->offset

2020-02-13 Thread Nirmoy Das
Signed-off-by: Nirmoy Das --- drivers/gpu/drm/qxl/qxl_drv.h| 6 ++ drivers/gpu/drm/qxl/qxl_kms.c| 3 +++ drivers/gpu/drm/qxl/qxl_object.h | 5 - drivers/gpu/drm/qxl/qxl_ttm.c| 9 - 4 files changed, 5 insertions(+), 18 deletions(-) diff --git

[RFC PATCH 4/6] drm/nouveau: don't use ttm bo->offset

2020-02-13 Thread Nirmoy Das
Signed-off-by: Nirmoy Das --- drivers/gpu/drm/nouveau/dispnv04/crtc.c | 6 +++--- drivers/gpu/drm/nouveau/dispnv04/disp.c | 2 +- drivers/gpu/drm/nouveau/dispnv04/overlay.c | 6 +++--- drivers/gpu/drm/nouveau/dispnv50/base507c.c | 2 +- drivers/gpu/drm/nouveau/dispnv50/core507d.c |

[RFC PATCH 1/6] drm/amdgpu: move ttm bo->offset to amdgpu_bo

2020-02-13 Thread Nirmoy Das
GPU address should belong to driver not in memory management. This patch moves ttm bo.offset and gpu_offset calculation to amdgpu driver. Signed-off-by: Nirmoy Das --- drivers/gpu/drm/amd/amdgpu/amdgpu_object.c | 22 ++-- drivers/gpu/drm/amd/amdgpu/amdgpu_object.h | 1 +

[RFC PATCH 3/6] drm/vmwgfx: don't use ttm bo->offset

2020-02-13 Thread Nirmoy Das
Signed-off-by: Nirmoy Das --- drivers/gpu/drm/vmwgfx/vmwgfx_bo.c | 4 ++-- drivers/gpu/drm/vmwgfx/vmwgfx_execbuf.c| 2 +- drivers/gpu/drm/vmwgfx/vmwgfx_fifo.c | 2 +- drivers/gpu/drm/vmwgfx/vmwgfx_ttm_buffer.c | 2 -- 4 files changed, 4 insertions(+), 6 deletions(-) diff --git

[RFC PATCH 2/6] drm/radeon: don't use ttm bo->offset

2020-02-13 Thread Nirmoy Das
Signed-off-by: Nirmoy Das --- drivers/gpu/drm/radeon/radeon.h| 1 + drivers/gpu/drm/radeon/radeon_object.h | 16 +++- drivers/gpu/drm/radeon/radeon_ttm.c| 4 +--- 3 files changed, 17 insertions(+), 4 deletions(-) diff --git a/drivers/gpu/drm/radeon/radeon.h

Re: [PATCH] drm/ttm: replace dma_resv object on deleted BOs v3

2020-02-13 Thread Pan, Xinhui
> 2020年2月13日 18:01,Koenig, Christian 写道: > > Am 13.02.20 um 05:11 schrieb Pan, Xinhui: >> >> >>> 2020年2月12日 19:53,Christian König 写道: >>> >>> Am 12.02.20 um 07:23 schrieb Pan, Xinhui: > 2020年2月11日 23:43,Christian König 写道: > > When non-imported BOs are resurrected for delayed

Re: [PATCH] drm/amdgpu: Move to a per-IB secure flag (TMZ)

2020-02-13 Thread Christian König
Am 13.02.20 um 01:54 schrieb Luben Tuikov: Move from a per-CS secure flag (TMZ) to a per-IB secure flag. Well that seems to make a lot of sense to me, but need to bit of time to read into the PM4 handling of TMZ. Especially what is the "start" parameter good for? Regards, Christian.

Re: [PATCH 14/15] drm/amdgpu/ring: move debugfs init into core amdgpu debugfs

2020-02-13 Thread Christian König
Am 13.02.20 um 10:54 schrieb Daniel Vetter: On Fri, Feb 07, 2020 at 02:50:57PM -0500, Alex Deucher wrote: In order to remove the load and unload drm callbacks, we need to reorder the init sequence to move all the drm debugfs file handling. Do this for rings. Acked-by: Christian König

Re: [PATCH] drm/ttm: replace dma_resv object on deleted BOs v3

2020-02-13 Thread Christian König
Am 13.02.20 um 05:11 schrieb Pan, Xinhui: 2020年2月12日 19:53,Christian König 写道: Am 12.02.20 um 07:23 schrieb Pan, Xinhui: 2020年2月11日 23:43,Christian König 写道: When non-imported BOs are resurrected for delayed delete we replace the dma_resv object to allow for easy reclaiming of the