[PATCH] drm/amdgpu/powerplay: using the FCLK DPM table to set the MCLK

2020-03-31 Thread Yuxian Dai
From: "yuxia...@amd.com" 1,Using the FCLK DPM table to set the MCLK for DPM states consist of three entities: FCLK UCLK MEMCLK All these three clk change together, MEMCLK from FCLK, so use the fclk frequency. 2,we should show the current working clock freqency from clock table metric

RE: [PATCH] drm/amdgpu/powerplay: using the FCLK DPM table to set the MCLK for DPM states consist of three entities :FCLK, UCLK, MEMCLK all these three clk change together , MEMCLK from FCLK.

2020-03-31 Thread Dai, Yuxian (David)
[AMD Official Use Only - Internal Distribution Only] On Tue, Mar 31, 2020 at 09:41:44AM -0400, Alex Deucher wrote: > On Tue, Mar 31, 2020 at 6:10 AM Yuxian Dai wrote: > > > > From: "yuxia...@amd.com" > > Your patch title is too long; it is basically the whole patch > description rather than

Re: [PATCH] drm/amdgpu/powerplay: using the FCLK DPM table to set the MCLK for DPM states consist of three entities :FCLK, UCLK, MEMCLK all these three clk change together , MEMCLK from FCLK.

2020-03-31 Thread Huang Rui
On Tue, Mar 31, 2020 at 09:41:44AM -0400, Alex Deucher wrote: > On Tue, Mar 31, 2020 at 6:10 AM Yuxian Dai wrote: > > > > From: "yuxia...@amd.com" > > Your patch title is too long; it is basically the whole patch > description rather than just a title. Please split it up between the > title

Re: [PATCH 1/6] dma-buf: add peer2peer flag

2020-03-31 Thread Sumit Semwal
Hi Christian, On Tue, 31 Mar 2020, 14:16 Daniel Vetter, wrote: > On Mon, Mar 30, 2020 at 03:55:31PM +0200, Christian König wrote: > > Add a peer2peer flag noting that the importer can deal with device > > resources which are not backed by pages. > > > > Signed-off-by: Christian König > > On

[PATCH 0/2] drm/amdgpu: Remove duplicated DPCD logging

2020-03-31 Thread Lyude Paul
There's a bunch of messy DPCD tracing code in amdgpu that isn't needed since we already support this in DRM. Plus, it's really spammy. So, just get rid of it. Lyude Paul (2): drm/amd/amdgpu_dm/mst: Remove useless sideband tracing drm/amd/dc: Kill dc_conn_log_hex_linux()

[PATCH 1/2] drm/amd/amdgpu_dm/mst: Remove useless sideband tracing

2020-03-31 Thread Lyude Paul
We already trace DPCD reads/writes on both MST and SST, there's no reason to have this code here (plus, toggling these things with a define at the top of the file isn't how we do things in the kernel). Signed-off-by: Lyude Paul --- .../display/amdgpu_dm/amdgpu_dm_mst_types.c | 43

[PATCH 2/2] drm/amd/dc: Kill dc_conn_log_hex_linux()

2020-03-31 Thread Lyude Paul
DRM already supports tracing DPCD transactions, there's no reason for the existence of this function. Also, it prints one byte per-line which is way too loud. So, just remove it. Signed-off-by: Lyude Paul --- .../gpu/drm/amd/display/dc/basics/Makefile| 3 +-

[PATCH 0/4] drm/dp_mst: Remove ->destroy_connector() callback

2020-03-31 Thread Lyude Paul
This finishes up the work that Pankaj Bharadiya started in: https://patchwork.freedesktop.org/series/74412/ And allows us to entirely remove ->destroy_connector() Lyude Paul (4): drm/amd/amdgpu_dm/mst: Remove unneeded edid assignment when destroying connectors drm/amd/amdgpu_dm/mst:

[PATCH 2/4] drm/amd/amdgpu_dm/mst: Remove ->destroy_connector() callback

2020-03-31 Thread Lyude Paul
Pankaj Bharadiya started cleaning up the MST connector callbacks a while ago, as I pointed out that they are the same across every driver and don't serve much purpose. There was one callback that was left over though from amdgpu, that we delayed removing due to not being completely sure as to

[PATCH 1/4] drm/amd/amdgpu_dm/mst: Remove unneeded edid assignment when destroying connectors

2020-03-31 Thread Lyude Paul
Doesn't do anything, noticed this while cleaning up some unrelated stuff. Signed-off-by: Lyude Paul --- drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm_mst_types.c | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm_mst_types.c

[PATCH 4/4] drm/dp_mst: Remove drm_dp_mst_topology_cbs.destroy_connector

2020-03-31 Thread Lyude Paul
Now that we've removed the last user of this callback, get rid of it and drm_dp_destroy_connector(). Signed-off-by: Lyude Paul Cc: Pankaj Bharadiya --- drivers/gpu/drm/drm_dp_mst_topology.c | 16 +++- include/drm/drm_dp_mst_helper.h | 2 -- 2 files changed, 3 insertions(+),

[PATCH 3/4] drm/amd/amdgpu_dm/mst: Stop printing extra messages in dm_dp_add_mst_connector()

2020-03-31 Thread Lyude Paul
You can already trace the creation and destruction of connectors using DRM, and we definitely don't need to be printing info messages on connector hotplugs as well. So, get rid of these. Signed-off-by: Lyude Paul --- drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm_mst_types.c | 5 - 1 file

Re: [PATCH] drm/amd/display: Guard calls to hdcp_ta and dtm_ta

2020-03-31 Thread Lakha, Bhawanpreet
[AMD Official Use Only - Internal Distribution Only] mod_hdcp_hdcp2_get_link_encryption_status() isn't being used, should probably remove it in a followup patch From: Kazlauskas, Nicholas Sent: March 31, 2020 2:03 PM To: Alex Deucher ; Lakha, Bhawanpreet Cc:

Re: [PATCH] drm/amd/display: Guard calls to hdcp_ta and dtm_ta

2020-03-31 Thread Kazlauskas, Nicholas
On 2020-03-31 1:37 p.m., Alex Deucher wrote: On Mon, Mar 30, 2020 at 6:36 PM Bhawanpreet Lakha wrote: [Why] The buffer used when calling psp is a shared buffer. If we have multiple calls at the same time we can overwrite the buffer. [How] Add mutex to guard the shared buffer. Signed-off-by:

Re: [PATCH] drm/amd/display: Guard calls to hdcp_ta and dtm_ta

2020-03-31 Thread Alex Deucher
On Mon, Mar 30, 2020 at 6:36 PM Bhawanpreet Lakha wrote: > > [Why] > The buffer used when calling psp is a shared buffer. If we have multiple calls > at the same time we can overwrite the buffer. > > [How] > Add mutex to guard the shared buffer. > > Signed-off-by: Bhawanpreet Lakha Acked-by:

Re: mmotm 2020-03-30-18-46 uploaded (freesync)

2020-03-31 Thread Randy Dunlap
On 3/31/20 12:39 AM, Nathan Chancellor wrote: > On Mon, Mar 30, 2020 at 11:18:26PM -0700, Randy Dunlap wrote: >> On 3/30/20 6:47 PM, a...@linux-foundation.org wrote: >>> The mm-of-the-moment snapshot 2020-03-30-18-46 has been uploaded to >>> >>>http://www.ozlabs.org/~akpm/mmotm/ >>> >>>

Re: [PATCH 0/4] drm/amd/display: more code cleanup in the dc_link file

2020-03-31 Thread Alex Deucher
On Tue, Mar 31, 2020 at 6:55 AM Melissa Wen wrote: > > These patches address many code style issues on dc_link for readability > and cleaning up warnings. Change suggested by checkpatch.pl. > Some issues remain and need some minor code refactoring for proper handling. > > Melissa Wen (4): >

Re: [PATCH] drm/amdgpu: fix fence handling in amdgpu_gem_object_close

2020-03-31 Thread Pan, Xinhui
Reviewed-by: xinhui pan > 2020年3月31日 22:25,Christian König 写道: > > The exclusive fence is only optional. > > Signed-off-by: Christian König > --- > drivers/gpu/drm/amd/amdgpu/amdgpu_gem.c | 6 -- > 1 file changed, 4 insertions(+), 2 deletions(-) > > diff --git

Re: [PATCH] drm/amd/display: Fix 64-bit division error on 32-bit platforms in mod_freesync_build_vrr_params

2020-03-31 Thread Alex Deucher
On Tue, Mar 31, 2020 at 3:38 AM Nathan Chancellor wrote: > > When building arm32 allyesconfig, > > ld.lld: error: undefined symbol: __aeabi_uldivmod > >>> referenced by freesync.c > >>> > >>> gpu/drm/amd/display/modules/freesync/freesync.o:(mod_freesync_build_vrr_params) > >>> in

Re: [PATCH] drm/amdgpu/sdma5: silence a warning

2020-03-31 Thread Nirmoy
On 3/31/20 4:32 PM, Alex Deucher wrote: This isn't actually a valid warning, but initialize the variable to silence the compiler. Signed-off-by: Alex Deucher Acked-by: Nirmoy Das --- drivers/gpu/drm/amd/amdgpu/sdma_v5_0.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff

[PATCH] drm/amdgpu/sdma5: silence a warning

2020-03-31 Thread Alex Deucher
This isn't actually a valid warning, but initialize the variable to silence the compiler. Signed-off-by: Alex Deucher --- drivers/gpu/drm/amd/amdgpu/sdma_v5_0.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/gpu/drm/amd/amdgpu/sdma_v5_0.c

[PATCH] drm/amdgpu: fix fence handling in amdgpu_gem_object_close

2020-03-31 Thread Christian König
The exclusive fence is only optional. Signed-off-by: Christian König --- drivers/gpu/drm/amd/amdgpu/amdgpu_gem.c | 6 -- 1 file changed, 4 insertions(+), 2 deletions(-) diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_gem.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_gem.c index

Re: mmotm 2020-03-30-18-46 uploaded (freesync)

2020-03-31 Thread Nathan Chancellor
On Mon, Mar 30, 2020 at 11:18:26PM -0700, Randy Dunlap wrote: > On 3/30/20 6:47 PM, a...@linux-foundation.org wrote: > > The mm-of-the-moment snapshot 2020-03-30-18-46 has been uploaded to > > > >http://www.ozlabs.org/~akpm/mmotm/ > > > > mmotm-readme.txt says > > > > README for

Re: [PATCH v2 1/2] drm/amdgpu: sync ring type and drm hw_ip type

2020-03-31 Thread Christian König
Am 31.03.20 um 15:59 schrieb Nirmoy Das: Use AMDGPU_HW_IP_* to set amdgpu_ring_type enum values Signed-off-by: Nirmoy Das Reviewed-by: Christian König --- drivers/gpu/drm/amd/amdgpu/amdgpu_ring.h | 20 ++-- 1 file changed, 10 insertions(+), 10 deletions(-) diff --git

[PATCH v5 2/2] drm/amdgpu: rework sched_list generation

2020-03-31 Thread Nirmoy Das
Generate HW IP's sched_list in amdgpu_ring_init() instead of amdgpu_ctx.c. This makes amdgpu_ctx_init_compute_sched(), ring.has_high_prio and amdgpu_ctx_init_sched() unnecessary. This patch also stores sched_list for all HW IPs in one big array in struct amdgpu_device which makes

[PATCH v2 1/2] drm/amdgpu: sync ring type and drm hw_ip type

2020-03-31 Thread Nirmoy Das
Use AMDGPU_HW_IP_* to set amdgpu_ring_type enum values Signed-off-by: Nirmoy Das --- drivers/gpu/drm/amd/amdgpu/amdgpu_ring.h | 20 ++-- 1 file changed, 10 insertions(+), 10 deletions(-) diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_ring.h

Re: [PATCH] drm/amdgpu/powerplay: using the FCLK DPM table to set the MCLK for DPM states consist of three entities :FCLK, UCLK, MEMCLK all these three clk change together , MEMCLK from FCLK.

2020-03-31 Thread Alex Deucher
On Tue, Mar 31, 2020 at 6:10 AM Yuxian Dai wrote: > > From: "yuxia...@amd.com" Your patch title is too long; it is basically the whole patch description rather than just a title. Please split it up between the title and descriptions. E.g., drm/amdgpu/powerplay: fix MCLK DPM handling for

Re: [PATCH v4 2/2] drm/amdgpu: rework sched_list generation

2020-03-31 Thread Christian König
Am 31.03.20 um 14:54 schrieb Nirmoy Das: Generate HW IP's sched_list in amdgpu_ring_init() instead of amdgpu_ctx.c. This makes amdgpu_ctx_init_compute_sched(), ring.has_high_prio and amdgpu_ctx_init_sched() unnecessary. This patch also stores sched_list for all HW IPs in one big array in struct

Re: [PATCH 1/2] drm/amdgpu: sync ring type with drm hw_ip type

2020-03-31 Thread Christian König
Am 31.03.20 um 14:54 schrieb Nirmoy Das: Move AMDGPU_RING_TYPE_KIQ at the end of amdgpu_ring_type enum to sync amdgpu_ring_type values with AMDGPU_HW_IP_* Signed-off-by: Nirmoy Das --- drivers/gpu/drm/amd/amdgpu/amdgpu_ring.h | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff

[PATCH v4 2/2] drm/amdgpu: rework sched_list generation

2020-03-31 Thread Nirmoy Das
Generate HW IP's sched_list in amdgpu_ring_init() instead of amdgpu_ctx.c. This makes amdgpu_ctx_init_compute_sched(), ring.has_high_prio and amdgpu_ctx_init_sched() unnecessary. This patch also stores sched_list for all HW IPs in one big array in struct amdgpu_device which makes

[PATCH 1/2] drm/amdgpu: sync ring type with drm hw_ip type

2020-03-31 Thread Nirmoy Das
Move AMDGPU_RING_TYPE_KIQ at the end of amdgpu_ring_type enum to sync amdgpu_ring_type values with AMDGPU_HW_IP_* Signed-off-by: Nirmoy Das --- drivers/gpu/drm/amd/amdgpu/amdgpu_ring.h | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git

Re: [PATCH v3 1/1] drm/amdgpu: rework sched_list generation

2020-03-31 Thread Nirmoy
On 3/31/20 3:01 AM, Luben Tuikov wrote: This patch seems to be using DOS line-endings. Strange, I don't see that in my local patch file. After converting it to UNIX line-endings, the output of "git am" using "scripts/checkpatch.pl" via the pre-commit hook is appended last to my thoughts

[PATCH 4/4] drm/amd/display: code cleanup of dc_link file on func dc_link_construct

2020-03-31 Thread Melissa Wen
Removes codestyle issues in dc_link file, on dc_link_construct and translate_encoder_to_transmitter as suggested by checkpatch.pl. Types covered: CHECK: Lines should not end with a '(' WARNING: Missing a blank line after declarations CHECK: Alignment should match open parenthesis CHECK:

[PATCH 2/4] drm/amd/display: codestyle cleanup on dc_link file until detect_dp func

2020-03-31 Thread Melissa Wen
Removes codestyle issues on the file dc_link until detect_dp func as suggested by checkpatch.pl. Types covered: CHECK: Please don't use multiple blank lines CHECK: Comparison to NULL could be written ERROR: space required before the open parenthesis '(' CHECK: Alignment should match open

[PATCH 3/4] drm/amd/display: code cleanup on dc_link from is_same_edid to get_ddc_line

2020-03-31 Thread Melissa Wen
Removes codestyle issues on the file dc_link between is_same_edid and get_ddc_line as suggested by checkpatch.pl. Types covered: CHECK: Blank lines aren't necessary after an open brace '{' CHECK: Blank lines aren't necessary before a close brace '}' WARNING: braces {} are not necessary for

[PATCH 1/4] drm/amd/display: cleanup codestyle type BLOCK_COMMENT_STYLE on dc_link

2020-03-31 Thread Melissa Wen
Solve comments alignment problems on dc_link file Signed-off-by: Melissa Wen --- drivers/gpu/drm/amd/display/dc/core/dc_link.c | 25 +++ 1 file changed, 15 insertions(+), 10 deletions(-) diff --git a/drivers/gpu/drm/amd/display/dc/core/dc_link.c

[PATCH 0/4] drm/amd/display: more code cleanup in the dc_link file

2020-03-31 Thread Melissa Wen
These patches address many code style issues on dc_link for readability and cleaning up warnings. Change suggested by checkpatch.pl. Some issues remain and need some minor code refactoring for proper handling. Melissa Wen (4): drm/amd/display: cleanup codestyle type BLOCK_COMMENT_STYLE on

[PATCH] drm/amdgpu/powerplay: using the FCLK DPM table to set the MCLK for DPM states consist of three entities :FCLK, UCLK, MEMCLK all these three clk change together , MEMCLK from FCLK.

2020-03-31 Thread Yuxian Dai
From: "yuxia...@amd.com" Change-Id: Ia45f3069fc7ae56db495cb5a3865e2c50c550774 Signed-off-by: Yuxian Dai --- drivers/gpu/drm/amd/powerplay/renoir_ppt.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/gpu/drm/amd/powerplay/renoir_ppt.h

Re: [PATCH 1/6] dma-buf: add peer2peer flag

2020-03-31 Thread Daniel Vetter
On Mon, Mar 30, 2020 at 03:55:31PM +0200, Christian König wrote: > Add a peer2peer flag noting that the importer can deal with device > resources which are not backed by pages. > > Signed-off-by: Christian König On the series: Acked-by: Daniel Vetter > --- > drivers/dma-buf/dma-buf.c | 2 ++

Re: [PATCH v3 1/1] drm/amdgpu: rework sched_list generation

2020-03-31 Thread Christian König
Am 31.03.20 um 10:24 schrieb Nirmoy: [SNIP] +const unsigned int amdgpu_ring_type_to_drm_hw_ip[AMDGPU_HW_IP_NUM] = { +    [AMDGPU_RING_TYPE_GFX]  = AMDGPU_HW_IP_GFX, +    [AMDGPU_RING_TYPE_COMPUTE]  = AMDGPU_HW_IP_COMPUTE, +    [AMDGPU_RING_TYPE_SDMA] = AMDGPU_HW_IP_DMA, +   

Re: [PATCH v3 1/1] drm/amdgpu: rework sched_list generation

2020-03-31 Thread Nirmoy
On 3/31/20 9:56 AM, Christian König wrote: Am 30.03.20 um 17:49 schrieb Nirmoy Das: Generate HW IP's sched_list in amdgpu_ring_init() instead of amdgpu_ctx.c. This makes amdgpu_ctx_init_compute_sched(), ring.has_high_prio and amdgpu_ctx_init_sched() unnecessary. This patch also stores

Re: [PATCH v3 1/1] drm/amdgpu: rework sched_list generation

2020-03-31 Thread Christian König
Am 30.03.20 um 17:49 schrieb Nirmoy Das: Generate HW IP's sched_list in amdgpu_ring_init() instead of amdgpu_ctx.c. This makes amdgpu_ctx_init_compute_sched(), ring.has_high_prio and amdgpu_ctx_init_sched() unnecessary. This patch also stores sched_list for all HW IPs in one big array in struct

[PATCH] drm/amd/display: Fix 64-bit division error on 32-bit platforms in mod_freesync_build_vrr_params

2020-03-31 Thread Nathan Chancellor
When building arm32 allyesconfig, ld.lld: error: undefined symbol: __aeabi_uldivmod >>> referenced by freesync.c >>> >>> gpu/drm/amd/display/modules/freesync/freesync.o:(mod_freesync_build_vrr_params) >>> in archive drivers/built-in.a >>> did you mean: __aeabi_uidivmod >>> defined